Icon disappears from favorites in gnome-shell 3.32 (upstream dock, not the ubuntu-dock)

Bug #1822846 reported by Julian Andres Klode on 2019-04-02
66
This bug affects 14 people
Affects Status Importance Assigned to Milestone
GNOME Shell
Fix Released
Unknown
gnome-shell (Ubuntu)
Status tracked in Eoan
Disco
High
Marco Trevisan (Treviño)
Eoan
High
Marco Trevisan (Treviño)

Bug Description

[ Impact ]

From time to time, my chrome icon disappears in gnome shell 3.32, leaving only the "open window indicator" below it. It's the first of my icons, and this is running a vanilla gnome session.

[ QA ]

No further verification as this is a fix coming with a GNOME micro release update that is covered by this exception https://wiki.ubuntu.com/StableReleaseUpdates/GNOME

---

ProblemType: BugDistroRelease: Ubuntu 19.04
Package: gnome-shell 3.32.0-1ubuntu1
ProcVersionSignature: Ubuntu 5.0.0-7.8-generic 5.0.0
Uname: Linux 5.0.0-7-generic x86_64
ApportVersion: 2.20.10-0ubuntu23
Architecture: amd64
CurrentDesktop: GNOME
Date: Tue Apr 2 17:44:52 2019
DisplayManager: gdm3
InstallationDate: Installed on 2018-03-14 (383 days ago)
InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Alpha amd64 (20180313)SourcePackage: gnome-shell
UpgradeStatus: Upgraded to disco on 2018-11-20 (133 days ago)

Related branches

Julian Andres Klode (juliank) wrote :
Julian Andres Klode (juliank) wrote :

See attached screenshots. Not sure if upstream bug or Ubuntu bug, hence reporting here first.

Daniel van Vugt (vanvugt) wrote :

Confirmed. This week (when using gnome-shell upstream, not the Ubuntu Dock) I've been seeing the same bug (occasionally) with my Files icon.

summary: - Chrome icon disappears from dash
+ Icon disappears from dash

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Changed in gnome-shell (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
summary: - Icon disappears from dash
+ Icon disappears from dash in gnome-shell 3.32
Changed in gnome-shell:
status: Unknown → New
tags: added: rls-dd-incoming
Changed in gnome-shell (Ubuntu):
importance: Medium → High
summary: - Icon disappears from dash in gnome-shell 3.32
+ Icon disappears from dash/launcher in gnome-shell 3.32
summary: - Icon disappears from dash/launcher in gnome-shell 3.32
+ Icon disappears from favorites bar/launcher in gnome-shell 3.32
summary: - Icon disappears from favorites bar/launcher in gnome-shell 3.32
+ Icon disappears from favorites in gnome-shell 3.32
tags: removed: rls-dd-incoming

This also survived across a reboot, which was odd (or the bug triggered directly after boot).

Changed in gnome-shell:
status: New → Fix Released
tags: added: fixed-in-3.32.1 fixed-upstream
summary: - Icon disappears from favorites in gnome-shell 3.32
+ Icon disappears from favorites in gnome-shell 3.32 (upstream dock, not
+ the ubuntu-dock)
Daniel van Vugt (vanvugt) wrote :

Unfortunately it seems the fix for this bug landed just hours/days slightly too late to be included in gnome-shell 3.32.0+git20190410

Giacomo Graziosi (g.graziosi) wrote :

Does anyone know a workaround for this bug?

Daniel van Vugt (vanvugt) wrote :

I also expect/hope gnome-shell 3.32.1 will reach Ubuntu 19.04 updates soon enough. So you may not need to do anything other than wait :/

Changed in gnome-shell (Ubuntu):
status: Triaged → In Progress
importance: High → Medium
importance: Medium → High
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in gnome-shell (Ubuntu Disco):
status: New → In Progress
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
importance: Undecided → High
description: updated
Launchpad Janitor (janitor) wrote :
Download full text (3.8 KiB)

This bug was fixed in the package gnome-shell - 3.32.1-1ubuntu1

---------------
gnome-shell (3.32.1-1ubuntu1) eoan; urgency=medium

  [ Marco Trevisan (Treviño) ]
  * Merge with debian
    - Update to 3.32.1 upstream version (LP: #1826936)
    - Fixes Icon disappears from favorites (LP: #1822846)
    - Fix applications aren't focused in Wayland session (LP: #1826176)
    remaining changes:
    + Replace gnome-backgrounds dep with ubuntu-wallpapers and Suggests
      gnome-themes-standard-data, gnome-backgrounds
    + Add some Recommends:
      - ubuntu-session (| gnome-session) to have the ubuntu session available
      - xserver-xorg-legacy
      - yaru-theme-gnome-shell for the default ubuntu theming
    + Update debian/gbp.conf with Ubuntu settings
    + gnome-shell-common.install: Install Ubuntu mode
    + gnome-shell-common.prerm: Remove deprecated ubuntu theme alternative
    + ubuntu/desktop_detect.patch:
      - add caching for desktop detection to avoid querying the current
        desktop env variable as iterate through the list each time. For the
        time of the Shell process, we can expect this env variable to stay
        stable.
    + ubuntu/smarter_alt_tab.patch:
      - quick alt-tab (without showing up the switcher) switch only between
        the last window of the last 2 applications to be focused instead of
        raising all windows of those apps.
    + ubuntu/lightdm-user-switching.patch:
      - Allow user switching when using LightDM.
    + ubuntu/lock_on_suspend.patch
      - Respect Ubuntu's lock-on-suspend setting.
    + ubuntu/gdm.patch
      - as gdm is system-wide and not session-wide, ensure gdm has an ubuntu
        styling by default, not impacting the gnome user session though.
    + ubuntu/background_login.patch
      - Change default background color as we modified the default GDM color
        for our ubuntu session. Change it as well here, still applying the
        background noise loading.
    + ubuntu/gdm_alternatives.patch
      - Add support for GDM3 theme alternatives
    + ubuntu/block_mode_extension_update.patch
      - Don't allow ubuntu mode extension to update
    + optional-hot-corner.patch
      - enable patch proposed by upstream developer already in package (but
        not in series) to add a settings for optional hot corner activation.
    + volume-Add-back-sound-feedback-on-scroll.patch
      - Fix regression causing missing feedback on volume slider scroll
    + main-show-an-error-message-on-gnome-shell-crash.patch,
      global-make-possible-to-set-debug-flags-dynamically.patch,
      main-increase-the-granularity-of-backtraces-in-SHELL_DEBU.patch,
      main-add-backtrace-crashes-all-and-backtrace-all.patch,
      sessionMode-add-support-for-debugFlags-parameter.patch:
      - Improve debug JS tracing for crash reports
    + st-scroll-view-Handle-the-case-where-scrollbars-are-NULL.patch,
      st-scroll-view-Remove-scrollbars-references-on-dispose.patch:
      - Fix crash on theme changes
    + ubuntu/search-call-XUbuntuCancel-method-on-providers-when-no-dat.patch:
      - stop searches when requested from UI
    + magnifier-Show-cursor-when-magnifier-is-enabled-and-scale.patch:...

Read more...

Changed in gnome-shell (Ubuntu):
status: In Progress → Fix Released

Hello Julian, or anyone else affected,

Accepted gnome-shell into disco-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-shell/3.32.1-1ubuntu1~19.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-disco to verification-done-disco. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-disco. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in gnome-shell (Ubuntu Disco):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-disco

looks ok in initial testing on 3.32.1-1ubuntu1~19.04.1

On Mon, May 6, 2019 at 5:41 AM Łukasz Zemczak <email address hidden>
wrote:

> Hello Julian, or anyone else affected,
>
> Accepted gnome-shell into disco-proposed. The package will build now and
> be available at https://launchpad.net/ubuntu/+source/gnome-
> shell/3.32.1-1ubuntu1~19.04.1 in a few hours, and then in the -proposed
> repository.
>
> Please help us by testing this new package. See
> https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how
> to enable and use -proposed. Your feedback will aid us getting this
> update out to other Ubuntu users.
>
> If this package fixes the bug for you, please add a comment to this bug,
> mentioning the version of the package you tested and change the tag from
> verification-needed-disco to verification-done-disco. If it does not fix
> the bug for you, please add a comment stating that, and change the tag
> to verification-failed-disco. In either case, without details of your
> testing we will not be able to proceed.
>
> Further information regarding the verification process can be found at
> https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in
> advance for helping!
>
> N.B. The updated package will be released to -updates after the bug(s)
> fixed by this package have been verified and the package has been in
> -proposed for a minimum of 7 days.
>
> ** Changed in: gnome-shell (Ubuntu Disco)
> Status: In Progress => Fix Committed
>
> ** Tags added: verification-needed verification-needed-disco
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1822846
>
> Title:
> Icon disappears from favorites in gnome-shell 3.32 (upstream dock, not
> the ubuntu-dock)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gnome-shell/+bug/1822846/+subscriptions
>

tags: added: verification-done-disco
removed: verification-needed-disco
Launchpad Janitor (janitor) wrote :
Download full text (3.9 KiB)

This bug was fixed in the package gnome-shell - 3.32.1-1ubuntu1~19.04.1

---------------
gnome-shell (3.32.1-1ubuntu1~19.04.1) disco; urgency=medium

  * Backport from eoan to disco
  * Update VCS metadata

gnome-shell (3.32.1-1ubuntu1) eoan; urgency=medium

  [ Marco Trevisan (Treviño) ]
  * Merge with debian
    - Update to 3.32.1 upstream version (LP: #1826936)
    - Fixes Icon disappears from favorites (LP: #1822846)
    - Fix applications aren't focused in Wayland session (LP: #1826176)
    remaining changes:
    + Replace gnome-backgrounds dep with ubuntu-wallpapers and Suggests
      gnome-themes-standard-data, gnome-backgrounds
    + Add some Recommends:
      - ubuntu-session (| gnome-session) to have the ubuntu session available
      - xserver-xorg-legacy
      - yaru-theme-gnome-shell for the default ubuntu theming
    + Update debian/gbp.conf with Ubuntu settings
    + gnome-shell-common.install: Install Ubuntu mode
    + gnome-shell-common.prerm: Remove deprecated ubuntu theme alternative
    + ubuntu/desktop_detect.patch:
      - add caching for desktop detection to avoid querying the current
        desktop env variable as iterate through the list each time. For the
        time of the Shell process, we can expect this env variable to stay
        stable.
    + ubuntu/smarter_alt_tab.patch:
      - quick alt-tab (without showing up the switcher) switch only between
        the last window of the last 2 applications to be focused instead of
        raising all windows of those apps.
    + ubuntu/lightdm-user-switching.patch:
      - Allow user switching when using LightDM.
    + ubuntu/lock_on_suspend.patch
      - Respect Ubuntu's lock-on-suspend setting.
    + ubuntu/gdm.patch
      - as gdm is system-wide and not session-wide, ensure gdm has an ubuntu
        styling by default, not impacting the gnome user session though.
    + ubuntu/background_login.patch
      - Change default background color as we modified the default GDM color
        for our ubuntu session. Change it as well here, still applying the
        background noise loading.
    + ubuntu/gdm_alternatives.patch
      - Add support for GDM3 theme alternatives
    + ubuntu/block_mode_extension_update.patch
      - Don't allow ubuntu mode extension to update
    + optional-hot-corner.patch
      - enable patch proposed by upstream developer already in package (but
        not in series) to add a settings for optional hot corner activation.
    + volume-Add-back-sound-feedback-on-scroll.patch
      - Fix regression causing missing feedback on volume slider scroll
    + main-show-an-error-message-on-gnome-shell-crash.patch,
      global-make-possible-to-set-debug-flags-dynamically.patch,
      main-increase-the-granularity-of-backtraces-in-SHELL_DEBU.patch,
      main-add-backtrace-crashes-all-and-backtrace-all.patch,
      sessionMode-add-support-for-debugFlags-parameter.patch:
      - Improve debug JS tracing for crash reports
    + st-scroll-view-Handle-the-case-where-scrollbars-are-NULL.patch,
      st-scroll-view-Remove-scrollbars-references-on-dispose.patch:
      - Fix crash on theme changes
    + ubuntu/search-call-XUbuntuCancel-method-on-providers-when-no-...

Read more...

Changed in gnome-shell (Ubuntu Disco):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gnome-shell has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.