Comment 49 for bug 1748450

Mine does EVERYTHING EXACTLY as you just mentioned.

Sent from my iPhone

> On Jan 4, 2019, at 3:25 AM, Benjamin Schmid <email address hidden> wrote:
>
> @vanvugt Seeing this VERY regularly in cosmic, too. Just came back here
> to re-check the status of this long-term annoying issue.
>
> The fact is, that gnome shell provides me a VERY poor UX experience:
>
> Logged out for the session more than 10mins? Type your password and go
> get take a coffee, because it literally takes 1-2 minutes until the
> session finally crashes and restarts. Before my PC it literally
> unusable. Sometimes I also switch to the login screen and re-login into
> my running session to somehow provoke the crash to get it usable.
>
> Ah – and by the way: On some occassions lockscreen does not work and
> expose the clickable (!) left sidebar. In this case I only can unlock
> via the login-screen way to crash the session.
>
> Also commonly in normal operation the left sidebar looks strangely
> sized. Then I need to type "r" to restart the shell to resume normal
> operation.
>
> Feels really like an old, nearly dying device …
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1755163).
> https://bugs.launchpad.net/bugs/1748450
>
> Title:
> gnome-shell crashed with SIGTRAP in _g_log_abort() from
> g_log_default_handler() from default_log_handler(message="Connection
> to xwayland lost") from g_logv() from g_log() from <bug 1505409>
>
> Status in gnome-shell package in Ubuntu:
> Invalid
> Status in mutter package in Ubuntu:
> Fix Released
> Status in gnome-shell source package in Bionic:
> Invalid
> Status in mutter source package in Bionic:
> Fix Released
>
> Bug description:
> [Impact]
>
> * Xwayland is failing frequently (not crashing), which triggers a
> crash in gnome-shell because gnome-shell doesn't know how to survive
> after Xwayland has reset itself.
>
> * The frequent gnome-shell crashes create frequent problem reports and
> annoying dialogs for users, after they log in to an apparently working
> gnome-shell.
>
> * This affects Xorg sessions too, because the gdm login screen itself
> is a Wayland session. And Xorg users will see the problem dialog after
> they have logged into a Xorg session.
>
> * The fix simply converts the crash into a silent exit (as decided by
> Gnome upstream). This avoids the mountain of crash reports and
> annoying error dialogs at least. It does not fix the root causes that
> remain in Xwayland, but this is considered acceptable because there
> really isn't a bug in gnome-shell here other than it doesn't know how
> to survive without a connection to Xwayland.
>
> * For users of Xorg sessions, like bionic default, this is a full fix
> as Xorg users will never get an Xwayland instance after logging in.
> And hence the Xwayland bugs are irrelevant.
>
> [Test Case]
>
> * Just install bionic, use it lightly and reboot a few times.
>
> * Observe crash files are left in /var/crash and problem report
> dialogs after logging in.
>
> [Regression Potential]
>
> Medium. The fix does not really change the structure of the existing
> error handling, only changes it from a core dump into a silent exit.
> For Xorg users this should be invisible as the affected login screen
> restarts automatically.
>
> [Other Info]
>
> This is a whole class of gnome-shell crash which includes bug 1505409, bug 1748450 and bug 1556601. All three should be considered the same crash for the sake of this SRU. Just don't mark them as duplicates of each other
> because they are all still collecting duplicates of their own.
>
> ---------
>
> *** This is a duplicate of bug 1505409, but is being kept separate so
> as to automatically collect duplicate reports since the stacktrace
> signature has changed recently. Any resolution and discussion should
> occur in bug 1505409. ***
>
> See also:
> https://errors.ubuntu.com/problem/8ef857b2fe07d60742cd02d7d8f988f78ecd0f95
>
> ProblemType: Crash
> DistroRelease: Ubuntu 18.04
> Package: gnome-shell 3.26.2-0ubuntu2
> ProcVersionSignature: Ubuntu 4.13.0-33.36-generic 4.13.13
> Uname: Linux 4.13.0-33-generic x86_64
> ApportVersion: 2.20.8-0ubuntu8
> Architecture: amd64
> CurrentDesktop: GNOME-Greeter:GNOME
> Date: Thu Feb 8 23:50:23 2018
> DisplayManager: gdm3
> ExecutablePath: /usr/bin/gnome-shell
> GsettingsChanges:
>
> InstallationDate: Installed on 2016-03-21 (690 days ago)
> InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Alpha amd64 (20160307)
> ProcCmdline: /usr/bin/gnome-shell
> ProcEnviron:
> PATH=(custom, no user)
> XDG_RUNTIME_DIR=<set>
> LANG=en_US.UTF-8
> SHELL=/bin/false
> Signal: 5
> SourcePackage: gnome-shell
> StacktraceTop:
> () at /usr/lib/x86_64-linux-gnu/libmutter-1.so.0
> _XIOError () at /usr/lib/x86_64-linux-gnu/libX11.so.6
> _XEventsQueued () at /usr/lib/x86_64-linux-gnu/libX11.so.6
> XPending () at /usr/lib/x86_64-linux-gnu/libX11.so.6
> () at /usr/lib/x86_64-linux-gnu/libgdk-3.so.0
> Title: gnome-shell crashed with signal 5
> UpgradeStatus: Upgraded to bionic on 2018-02-08 (0 days ago)
> UserGroups:
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1748450/+subscriptions