gnome-shell crashed with SIGSEGV in _gdk_window_has_impl() from gdk_x11_window_get_xid() from shell_gtk_embed_window_created_cb()

Bug #1743442 reported by fcole90 on 2018-01-15
36
This bug affects 4 people
Affects Status Importance Assigned to Milestone
gnome-shell (Ubuntu)
Medium
Unassigned
Nominated for Xenial by Daniel van Vugt

Bug Description

https://errors.ubuntu.com/problem/3434d7489f159ba504e522fe386cf086f71fd18d

---

After running a program which filled my RAM memory, the shell started behaving in an unresponsive way, until it crashed. After it restarted it worked well.

ProblemType: Crash
DistroRelease: Ubuntu 16.04
Package: gnome-shell 3.18.5-0ubuntu0.3
ProcVersionSignature: Ubuntu 4.10.0-42.46~16.04.1-generic 4.10.17
Uname: Linux 4.10.0-42-generic x86_64
NonfreeKernelModules: nvidia_uvm nvidia_drm nvidia_modeset nvidia
ApportVersion: 2.20.1-0ubuntu2.15
Architecture: amd64
CrashCounter: 1
CurrentDesktop: GNOME
Date: Mon Jan 15 20:26:41 2018
DisplayManager: gdm3
ExecutablePath: /usr/bin/gnome-shell
InstallationDate: Installed on 2016-09-09 (493 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
JournalErrors:
 Error: command ['journalctl', '-b', '--priority=warning', '--lines=1000'] failed with exit code 1: Hint: You are currently not seeing messages from other users and the system.
       Users in the 'systemd-journal' group can see all messages. Pass -q to
       turn off this notice.
 No journal files were opened due to insufficient permissions.
ProcCmdline: /usr/bin/gnome-shell
SegvAnalysis:
 Segfault happened at: 0x7f566db886a2: cmp %rdi,0xe8(%rdi)
 PC (0x7f566db886a2) ok
 source "%rdi" ok
 destination "0xe8(%rdi)" (0x000000e8) not located in a known VMA region (needed writable region)!
SegvReason: writing NULL VMA
Signal: 11
SourcePackage: gnome-shell
StacktraceTop:
 ?? () from /usr/lib/x86_64-linux-gnu/libgdk-3.so.0
 gdk_x11_window_get_xid () from /usr/lib/x86_64-linux-gnu/libgdk-3.so.0
 ?? () from /usr/lib/gnome-shell/libgnome-shell.so
 g_closure_invoke () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: gnome-shell crashed with SIGSEGV in gdk_x11_window_get_xid()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: lxd sudo

fcole90 (fcole90) wrote :

StacktraceTop:
 _gdk_window_has_impl (window=window@entry=0x0) at /build/gtk+3.0-2Ut_nl/gtk+3.0-3.18.9/./gdk/gdkwindow.c:626
 gdk_x11_window_get_xid (window=window@entry=0x0) at /build/gtk+3.0-2Ut_nl/gtk+3.0-3.18.9/./gdk/x11/gdkwindow-x11.c:5527
 shell_gtk_embed_window_created_cb (display=0x1f0ff20, window=0x4eb4bd0, embed=0x3aa53f0) at shell-gtk-embed.c:67
 g_closure_invoke (closure=0x344b290, return_value=return_value@entry=0x0, n_param_values=2, param_values=param_values@entry=0x7ffeefc39030, invocation_hint=invocation_hint@entry=0x7ffeefc38fb0) at /build/glib2.0-prJhLS/glib2.0-2.48.2/./gobject/gclosure.c:804
 signal_emit_unlocked_R (node=node@entry=0x1e54af0, detail=detail@entry=0, instance=instance@entry=0x1f0ff20, emission_return=emission_return@entry=0x0, instance_and_params=instance_and_params@entry=0x7ffeefc39030) at /build/glib2.0-prJhLS/glib2.0-2.48.2/./gobject/gsignal.c:3629

Changed in gnome-shell (Ubuntu):
importance: Undecided → Medium
summary: - gnome-shell crashed with SIGSEGV in gdk_x11_window_get_xid()
+ gnome-shell crashed with SIGSEGV in _gdk_window_has_impl()
tags: removed: need-amd64-retrace
summary: - gnome-shell crashed with SIGSEGV in _gdk_window_has_impl()
+ gnome-shell crashed with SIGSEGV in _gdk_window_has_impl() from
+ gdk_x11_window_get_xid() from shell_gtk_embed_window_created_cb()
information type: Private → Public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Daniel van Vugt (vanvugt) wrote :

Also tracking in:
https://errors.ubuntu.com/problem/3434d7489f159ba504e522fe386cf086f71fd18d

Although it appears the problem stopped happening after Ubuntu 16.10.

description: updated
Changed in gnome-shell (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers