Keyboard Layout switches back to EN indicator shows DE

Bug #1303005 reported by Michael Flaig on 2014-04-05
38
This bug affects 8 people
Affects Status Importance Assigned to Milestone
gnome-shell (Ubuntu)
Undecided
Unassigned

Bug Description

I just noticed that a bug I already have for some time now on my other machne with 3.12 and on a virtual machine. Now it also happens to be there with 3.10 in ubuntugnome trusty lts. Which is a fresh install and therefore I am now reporting as it is most probably not a screwup by me :)

My language is set to English but my keyboard layout is german (de)

After first login the keyboard indicator showed de as the keyboard layout. When I opened a terminal and typed a dash on my keyboard a slash was printed (which is what happens when selecting en as keyboard layout). Keyboard layout still set to de according to the indicator in gnome-shell.

This also happens from time to time on my other machines where I work. I have yet to find out why or by what it is triggered.
Usually after starting a new application I notice. It also happens if de is the only keyboard layout configured. And it is fixed by switching keyboard layouts- which is why I keep EN as a keyboard layout in the list. The default is DE.

What can I do to provide more information?

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: gnome-shell 3.10.4-0ubuntu5
ProcVersionSignature: Ubuntu 3.13.0-22.44-generic 3.13.8
Uname: Linux 3.13.0-22-generic x86_64
ApportVersion: 2.14-0ubuntu1
Architecture: amd64
CurrentDesktop: GNOME
Date: Sat Apr 5 12:11:47 2014
DisplayManager: gdm
EcryptfsInUse: Yes
GsettingsChanges: b'org.gnome.desktop.interface' b'gtk-im-module' b"'gtk-im-context-simple'"
InstallationDate: Installed on 2014-04-05 (0 days ago)
InstallationMedia: Ubuntu-GNOME 14.04 LTS "Trusty Tahr" - Daily amd64 (20140404)
SourcePackage: gnome-shell
UpgradeStatus: No upgrade log present (probably fresh install)

Michael Flaig (mflaig) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Tommaso Fonda (fondatommaso2) wrote :

This bug affects me too. I have Ubuntu Gnome 14.04 and I noticed that keyboard layout is set to "en" each time I restart gnome-shell by pressing ALT+F2 and typing "r". The applet still shows "it" (Italian layout), but actually it works like an English keyboard. In order to set it back to "it", I have to switch to "en" and then back to "it".
Thanks

Take a look at this bug-discussion: https://bugs.launchpad.net/ubuntu/+source/ibus/+bug/1240198 One attempt for a workaround is opening "ibus-setup" an selecting "use system keyboard layout".

Ketil (ketil-froyn) wrote :

Me too!

I reported this as https://bugs.launchpad.net/ubuntu/+source/indicator-keyboard/+bug/1315122, I didn't find this issue at the time. This is still a problem for me on Ubuntu 14.04, and happens fairly regularly. To fix it, I don't need to first select "En" and then "No" layout. I simply select "No" (which is already selected), and then the layout is as it should be.

#4 works for me. Language indication is good after that. Also fixes an issue of occasional slight delay in the language switch: sometimes while having switched languages and continue to type, first few chars remain in old language.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers