Windows maximise underneath dock after monitor sleep

Bug #1917939 reported by Alan Pope 🍺🐧🐱 🦄 on 2021-03-05
56
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Dash to dock
New
Unknown
Mutter
Unknown
Unknown
gnome-shell (Ubuntu)
Undecided
Daniel van Vugt
gnome-shell-extension-ubuntu-dock (Ubuntu)
Medium
Unassigned
mutter (Ubuntu)
Medium
Unassigned

Bug Description

Under wayland on 21.04 windows keep maximising underneath the dock. So I can see icons "through" the dock, when I shouldn't. In the attached screenshot you can see Telegram showing through the dock.

If I switch to the application in question, unmaximise and re-maximise, it goes back to maximising inside the usable area of my desktop.

But when I suspend and resume, then login, I'm left with windows under the dock again. Never seen this under xorg. I only discovered I was in wayland when I tried to ALT+F2, R to restart.

ProblemType: Bug
DistroRelease: Ubuntu 21.04
Package: gnome-shell 3.38.3-2ubuntu2
ProcVersionSignature: Ubuntu 5.10.0-14.15-generic 5.10.11
Uname: Linux 5.10.0-14-generic x86_64
NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
ApportVersion: 2.20.11-0ubuntu59
Architecture: amd64
CasperMD5CheckResult: unknown
CurrentDesktop: ubuntu:GNOME
Date: Fri Mar 5 19:21:39 2021
DisplayManager: gdm3
InstallationDate: Installed on 2020-06-11 (267 days ago)
InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
RelatedPackageVersions: mutter-common 3.38.3-2ubuntu1
SourcePackage: gnome-shell
UpgradeStatus: Upgraded to hirsute on 2020-12-14 (81 days ago)

Revision history for this message
Alan Pope 🍺🐧🐱 🦄 (popey) wrote :
Revision history for this message
Alan Pope 🍺🐧🐱 🦄 (popey) wrote :
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Assigning to Ubuntu Dock for now, because nobody is going to notice the bug without it. Although the eventual fix might end up being in some other package.

affects: gnome-shell (Ubuntu) → gnome-shell-extension-ubuntu-dock (Ubuntu)
Changed in gnome-shell-extension-ubuntu-dock (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Revision history for this message
Daniel van Vugt (vanvugt) wrote :
Changed in dash-to-dock:
status: Unknown → New
tags: added: fixed-in-40 fixed-upstream
Changed in mutter (Ubuntu):
status: New → Fix Committed
importance: Undecided → Medium
Changed in gnome-shell-extension-ubuntu-dock (Ubuntu):
status: Triaged → Invalid
summary: - windows maximise underneath dock
+ Windows maximise underneath dock after monitor sleep
tags: added: rls-hh-incoming
Revision history for this message
Daniel van Vugt (vanvugt) wrote :
Changed in gnome-shell (Ubuntu):
status: New → Invalid
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Looks like the fix is 8dd1e26d051 in salsa, so that will be released in:

https://launchpad.net/ubuntu/+source/mutter/3.38.4-1ubuntu1

(there's a typo in the changelog but it is this bug)

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Oh. There's also a gnome-shell fix coming in https://launchpad.net/ubuntu/+source/gnome-shell/3.38.4-1ubuntu1

Changed in gnome-shell (Ubuntu):
status: Invalid → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :
Download full text (3.9 KiB)

This bug was fixed in the package gnome-shell - 3.38.4-1ubuntu1

---------------
gnome-shell (3.38.4-1ubuntu1) hirsute; urgency=medium

  * Merge with debian, containing a new upstream release
  * debian/control: (Build-)Depends on mutter 3.38.4
  * debian/patches:
    - Refresh
    - Remove input-thread related patches
    - Fix handling of OSK codes in keyboard (LP: #1918738)
    - Ensure Cancel button uses proper arguments (LP: #1918666)
    - Allow updating struts in Overview (LP: #1917939)
    - Configure Login Scree: cleanup code to match shell's JS
  * Remaining changes with debian:
    - Replace gnome-backgrounds dep with ubuntu-wallpapers and Suggests
      gnome-themes-standard-data, gnome-backgrounds
    - Add some Recommends:
      + ubuntu-session (| gnome-session) to have the ubuntu session available
      + xserver-xorg-legacy
      + yaru-theme-gnome-shell for the default ubuntu theming
    - Update debian/gbp.conf with Ubuntu settings
    - gnome-shell-common.prerm: Remove deprecated ubuntu theme alternative
    - ubuntu/desktop_detect.patch:
      + add caching for desktop detection to avoid querying the current
        desktop env variable as iterate through the list each time. For the
        time of the Shell process, we can expect this env variable to stay
        stable.
    - ubuntu/smarter_alt_tab.patch:
      + quick alt-tab (without showing up the switcher) switch only between
        the last window of the last 2 applications to be focused instead of
        raising all windows of those apps.
    - ubuntu/lightdm-user-switching.patch:
      + Allow user switching when using LightDM.
    - ubuntu/lock_on_suspend.patch
      + Respect Ubuntu's lock-on-suspend setting.
    - ubuntu/background_login.patch
      + Change default background color as we modified the default GDM color
        for our ubuntu session.
    - ubuntu/gdm_alternatives.patch
      + Add support for GDM3 theme alternatives
    - optional-hot-corner.patch
      + enable patch proposed by upstream developer already in package (but
        not in series) to add a settings for optional hot corner activation.
    - main-show-an-error-message-on-gnome-shell-crash.patch,
      global-make-possible-to-set-debug-flags-dynamically.patch,
      main-increase-the-granularity-of-backtraces-in-SHELL_DEBU.patch,
      main-add-backtrace-crashes-all-and-backtrace-all.patch,
      sessionMode-add-support-for-debugFlags-parameter.patch:
      + Improve debug JS tracing for crash reports
    - st-scroll-view-Handle-the-case-where-scrollbars-are-NULL.patch:
      + Fix crash on theme changes
    - ubuntu/search-call-XUbuntuCancel-method-on-providers-when-no-dat.patch:
      + stop searches when requested from UI
    - magnifier-Show-cursor-when-magnifier-is-enabled-and-scale.patch:
      + Show monitor scaled cursor when magnifier is enabled
    - Break gnome-shell-extension-desktop-icons (<< 19.01.3+git20190814)

gnome-shell (3.38.4-1) unstable; urgency=medium

  * Team upload
  * New upstream release
    - Fix missing X11 fallback icons (particularly for games and other
      programs not installed system-wide), a regression in 3.37.3
    - Fix a Shell crash when a...

Read more...

Changed in gnome-shell (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

mutter (3.38.4-1ubuntu1) hirsute; urgency=medium

Changed in mutter (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Bug 1922795 seems to suggest this regression has crept into focal-updates now.

tags: added: focal
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Confirmed you only need the mutter fix. The gnome-shell fix was in error.

Changed in gnome-shell (Ubuntu):
status: Fix Released → Invalid
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Turns out I wrote a new fix for this bug by accident, proposed in https://gitlab.gnome.org/GNOME/gnome-shell/-/merge_requests/1785

Changed in gnome-shell (Ubuntu):
assignee: nobody → Daniel van Vugt (vanvugt)
status: Invalid → In Progress
Revision history for this message
Daniel van Vugt (vanvugt) wrote :
Changed in gnome-shell (Ubuntu):
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell - 3.38.4-1ubuntu2

---------------
gnome-shell (3.38.4-1ubuntu2) hirsute; urgency=medium

  [ Daniel van Vugt ]
  * Add layout-Try-to-allocate-before-getting-size-of-tracke.patch.
    To fix LP: #1919979 and also to re-fix LP: #1917939
    (LP: #1919979, #1917939)
  * Drop layout-Allow-updating-struts-in-Overview.patch.
    Because it caused a regression and doesn't seem to have been necessary
    anyway. (LP: #1922772)

  [ Marco Trevisan (Treviño) ]
  * debian/patches: Fix suggestions box actor population in non-latin languages
    (LP: #1914230)
  * debian/patches: Enable to use Escape to cancel auth requests (with limits)
    (LP: #1921929)
  * debian/patches: Refresh

 -- Marco Trevisan (Treviño) <email address hidden> Thu, 15 Apr 2021 06:20:27 +0200

Changed in gnome-shell (Ubuntu):
status: Fix Committed → Fix Released
Changed in mutter (Ubuntu):
status: Fix Released → Won't Fix
status: Won't Fix → Invalid
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Sorry for the confusion but it is confusing...

* The first gnome-shell fix in comment #8 is bogus. It never worked and was removed in comment #14 because it had also caused regression bug 1922772.

* The first mutter fix included in 3.38.4-1ubuntu1 (comment #6) did work but also caused regression bug 1922034. So the mutter fix has now been removed.

* The second gnome-shell fix in comment #14 is the only fix we are now using.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.