[xsettings]: gnome-settings-daemon crashed with SIGSEGV in g_cclosure_marshal_VOID__STRINGv()

Bug #988580 reported by Fabio Marconi on 2012-04-25
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OEM Priority Project
High
James M. Leddy
Precise
High
Unassigned
gnome-settings-daemon (Ubuntu)
High
Unassigned

Bug Description

Hello
this happens at the first boot of a fresh installation in OEM mode from usb+persistence
Thanks
Fabio

ProblemType: BugDistroRelease: Ubuntu 12.04
Package: gnome-settings-daemon 3.4.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic 3.2.14
Uname: Linux 3.2.0-23-generic x86_64
ApportVersion: 2.0.1-0ubuntu5
Architecture: amd64
Date: Wed Apr 25 23:40:59 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=it_IT.UTF-8
 SHELL=/bin/bashSourcePackage: gnome-settings-daemon
UpgradeStatus: No upgrade log present (probably fresh install)

#0 0x00007f4be968d98c in ?? () from /usr/lib/gnome-settings-daemon-3.0/libxsettings.so
 No symbol table info available.
 #1 0x00007f4c01af4c30 in g_cclosure_marshal_VOID__STRINGv () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 No symbol table info available.
 #2 0x00007f4c01af1eca in ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 No symbol table info available.
 #3 0x00007f4c01b0a741 in g_signal_emit_valist () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 No symbol table info available.
 #4 0x00007f4c01b0b242 in g_signal_emit () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 No symbol table info available.
 #5 0x00007f4c01dd9401 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
 No symbol table info available.
 #6 0x00007f4bfe319a14 in ffi_call_unix64 () from /usr/lib/x86_64-linux-gnu/libffi.so.6
 No symbol table info available.
 #7 0x00007f4bfe319435 in ffi_call () from /usr/lib/x86_64-linux-gnu/libffi.so.6
 No symbol table info available.
 #8 0x00007f4c01af2b16 in g_cclosure_marshal_generic_va () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 No symbol table info available.
 #9 0x00007f4c01af1eca in ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 No symbol table info available.
 #10 0x00007f4c01b0a741 in g_signal_emit_valist () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 No symbol table info available.
 #11 0x00007f4c01b0b242 in g_signal_emit () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 No symbol table info available.
 #12 0x00007f4c01dd9ed8 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
 No symbol table info available.
 #13 0x00007f4c01dd5a9a in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
 No symbol table info available.
 #14 0x00007f4c01834c9a in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 No symbol table info available.
 #15 0x00007f4c01835060 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 No symbol table info available.
 #16 0x00007f4c0183545a in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 No symbol table info available.
 #17 0x00007f4c021fa25d in gtk_main () from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
 No symbol table info available.
 #18 0x0000000000403801 in main ()
 No symbol table info available.
Title: [xsettings]: gnome-settings-daemon crashed with SIGSEGV in g_cclosure_marshal_VOID__STRINGv()
UpgradeStatus: No upgrade log present (probably fresh install)

Fabio Marconi (fabiomarconi) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-settings-daemon (Ubuntu):
status: New → Confirmed
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/988580

tags: added: iso-testing
description: updated
Changed in oem-priority:
importance: Undecided → High
Kent Lin (kent-jclin) wrote :

/var/crash/_usr_lib_gnome-settings-daemon_gnome-settings-daemon.104.crash is attached

Kent Lin (kent-jclin) wrote :
Changed in gnome-settings-daemon (Ubuntu):
importance: Undecided → High
Changed in oem-priority:
assignee: nobody → James M. Leddy (jm-leddy)
James M. Leddy (jm-leddy) wrote :

Hi Fabio,

I've not seen this yet. Does it have to be usb+persistence for the bug to trigger?

Fabio Marconi (fabiomarconi) wrote :

Hallo
I cannot remember and I'm ready to do all the needed tests, but as oem config influence definitively (without possibility to revert back) persistence I think that is better to evaluate it with and without.
Tomorrow I try to reproduce it with debug symbols installed in both ways.
Regards.
Fabio.
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Fabio Marconi (fabiomarconi) wrote :

Hello
I'm sorry but I cannot reproduce it again, from usb with persistence.
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Changed in oem-priority:
status: New → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers