[xsettings]: gnome-settings-daemon crashed with SIGSEGV in xft_settings_set_xsettings()

Bug #948347 reported by Scott Lewin on 2012-03-06
348
This bug affects 85 people
Affects Status Importance Assigned to Milestone
OEM Priority Project
High
James M. Leddy
Precise
High
Unassigned
gnome-settings-daemon (Ubuntu)
Low
Unassigned
Quantal
Low
Unassigned

Bug Description

This error happened on a fairly new install of Beta 1. Fully updated.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: gnome-settings-daemon 3.3.91-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-18.28-generic-pae 3.2.9
Uname: Linux 3.2.0-18-generic-pae i686
NonfreeKernelModules: nvidia
ApportVersion: 1.94-0ubuntu2
Architecture: i386
Date: Tue Mar 6 14:04:32 2012
ExecutablePath: /usr/lib/gnome-settings-daemon/gnome-settings-daemon
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta i386 (20120301)
ProcCmdline: /usr/lib/gnome-settings-daemon/gnome-settings-daemon
ProcEnviron:
 SHELL=/bin/false
 PATH=(custom, no user)
 LANGUAGE=en_CA:en
 LANG=en_CA.UTF-8
SegvAnalysis:
 Segfault happened at: 0xb3fad7a0: mov (%eax),%eax
 PC (0xb3fad7a0) ok
 source "(%eax)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: gnome-settings-daemon
StacktraceTop:
 ?? () from /usr/lib/gnome-settings-daemon-3.0/libxsettings.so
 ?? () from /usr/lib/gnome-settings-daemon-3.0/libxsettings.so
 g_cclosure_marshal_VOID__STRINGv () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
 ?? () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
 g_signal_emit_valist () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
Title: [xsettings]: gnome-settings-daemon crashed with SIGSEGV in g_cclosure_marshal_VOID__STRINGv()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

Scott Lewin (sclewin) wrote :
visibility: private → public

StacktraceTop:
 xft_settings_set_xsettings (settings=<optimized out>, manager=<optimized out>) at gsd-xsettings-manager.c:470
 update_xft_settings (manager=0x97c8000) at gsd-xsettings-manager.c:564
 xft_callback (manager=0x97c8000, settings=<optimized out>, key=<optimized out>) at gsd-xsettings-manager.c:577
 g_cclosure_marshal_VOID__STRINGv (closure=0x97fd7d0, return_value=0x0, instance=0x97ef4c8, args=0xbfc6eb3c "\277Pm\t\001", marshal_data=0x0, n_params=1, param_types=0x970d3c8) at /build/buildd/glib2.0-2.31.20/./gobject/gmarshal.c:1004
 _g_closure_invoke_va (closure=0x97fd7d0, return_value=0x0, instance=0x97ef4c8, args=0xbfc6eb3c "\277Pm\t\001", n_params=1, param_types=0x970d3c8) at /build/buildd/glib2.0-2.31.20/./gobject/gclosure.c:840

Changed in gnome-settings-daemon (Ubuntu):
importance: Undecided → Medium
summary: [xsettings]: gnome-settings-daemon crashed with SIGSEGV in
- g_cclosure_marshal_VOID__STRINGv()
+ xft_settings_set_xsettings()
tags: removed: need-i386-retrace
BertN45 (lammert-nijhof) wrote :

logged in using xrdp and remmina remote desktop, 2when the crash occured

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-settings-daemon (Ubuntu):
status: New → Confirmed
Changed in gnome-settings-daemon (Ubuntu):
importance: Medium → High
no longer affects: gnome-settings-daemon (Ubuntu Precise)
tags: added: apport-request-retrace

Package: gnome-settings-daemon 3.4.1-0ubuntu1
ProcCmdline: /usr/lib/gnome-settings-daemon/gnome-settings-daemon

tags: removed: apport-request-retrace
marco python (marco-python-x) wrote :

Error happened on a fresh installed 12.04-release w/o any related user activity (only firefox where running).

Robert Ancell (robert-ancell) wrote :

Stack trace indicates this seems to be related to XFT settings changing. Changing these from dconf-editor [1] doesn't trigger the problem for me.

[1] Open dconf-editor, change settings in /org/gnome/settings-daemon/plugins/xsettings

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-settings-daemon - 3.4.2-0ubuntu2

---------------
gnome-settings-daemon (3.4.2-0ubuntu2) quantal; urgency=low

  * debian/patches/xsettings_signal_handling.patch:
    - upstream bugzilla patch, fix segfaults in the xsettings code which
      seem to happen at logout
      (lp: #946295, #948347, #963704)
 -- Sebastien Bacher <email address hidden> Wed, 23 May 2012 21:50:41 +0200

Changed in gnome-settings-daemon (Ubuntu):
status: Confirmed → Fix Released
Clint Byrum (clint-fewbar) wrote :

Hello! This bug is attached to an upload in the queue for precise-proposed. However, it does not contain the requisite fields for the SRU team to process the upload. Please add them per the process outlined here. To be more succinct, make sure the bug description lists these fields: "Impact, Dev Fix, Stable Fix, Regression Potential, Test case".

https://wiki.ubuntu.com/StableReleaseUpdates#Procedure

The upload will likely not be looked at by the SRU team until these fields are present.

Thank you!

Sebastien Bacher (seb128) wrote :

see bug #946295 for the SRU summary

Hello Scott, or anyone else affected,

Accepted gnome-settings-daemon into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Tammy Yang (wanchingy) wrote :

Tried gnome-settings-daemon (3.4.2-0ubuntu2) from precise-proposed on a HP cedar-trail model, the error message remains.

Kent Lin (kent-jclin) on 2012-06-01
Changed in oem-priority:
importance: Undecided → High
James M. Leddy (jm-leddy) wrote :

Setting back to In-Progress verification-failed based on comment #18

Changed in gnome-settings-daemon (Ubuntu):
status: Fix Released → Confirmed
tags: added: verification-failed
removed: verification-needed
Changed in gnome-settings-daemon (Ubuntu):
status: Confirmed → In Progress
Sebastien Bacher (seb128) wrote :

it's unclear that "the error message remains." is the same issue, could you give details on what error message you get exactly and where?

Changed in gnome-settings-daemon (Ubuntu):
status: In Progress → Incomplete
tags: added: quantal
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/948347

tags: added: iso-testing
Kent Lin (kent-jclin) wrote :

@Sebastien

The error message is attached.

Changed in oem-priority:
assignee: nobody → James M. Leddy (jm-leddy)
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

does anyone has a regression with the fix? it seems to work for some people and failing the SRU on it if there is no regression seems unnecessary

Tammy Yang (wanchingy) wrote :

After installing the package in -proposed, the same error box still pop up in first boot due to gnome-settings-daemon
Steps to reproduce:
1. Boot from USB installer and install system on a Cedar Trail machine
2. Complete OOBE and boot into system
3. Wait for 5-10 minutes and observe

./kern.log:Jun 5 10:18:41 ubuntu-desktop kernel: [ 362.707513] gnome-settings-[24692]: segfault at 6 ip b47b76b3 sp bfd25760 error 4 in libxsettings.so[b47b2000+9000]

Sebastien Bacher (seb128) wrote :

is the timestamp the one from after installation or is that coming from the liveCD system? did you restart g-s-d after installing it?

tags: added: blocks-hwcert-enablement
tags: added: rls-mgr-p-tracking
tags: added: rls-q-incoming
Tammy Yang (wanchingy) wrote :

@ ebastien Bacher, the timestamp was after OOBE.
No manually stop/restart was done.

Tammy Yang (wanchingy) wrote :

Sorry, the previous message was for Sebastien Bacher (S of the first name was missing).

Sebastien Bacher (seb128) wrote :

ok, somebody having the issue will need to debug it I guess then...

Tammy Yang (wanchingy) wrote :

We made some further checks. When OOBE ends and lightdm starts, the gnome-setting-daemon is invoked via lightdm, and soon crashed.

Sebastien Bacher (seb128) wrote :

settings to verification-done to unblock the SRU, the update has no regression and fixes some other bugs, we will reopen the bug once the SRU moves to -updates

tags: added: verification-done
removed: verification-failed
tags: removed: rls-q-incoming
Chris Van Hoof (vanhoof) wrote :

@Tammy -- How much memory is this machine configured with?

no longer affects: oem-priority/precise
Changed in oem-priority:
status: Confirmed → Won't Fix
tags: removed: blocks-hwcert-enablement
Adrián (jaksi) wrote :

This error happened Ubuntu 12.10 Alpha 3 64 bit, when logged in Ubuntu 2D.

jerrylamos (jerrylamos) wrote :

12.10 Alpha 3 Ubuntu 2D i386 32 bit new install Unity 2D, referring to post #31, 2 GB.

.iso as of August 4
Linux Compaq 3.5.0-7-generic #7-Ubuntu SMP Tue Jul 31 07:23:07 UTC 2012 i686 i686 i686 GNU/Linux

Does "won't fix" mean 12.10 will release with this bug?

Jerry

Fabio Marconi (fabiomarconi) wrote :

Hallo
Reproducible in real hardware (nvidia) with ubuntu 20120915 desktop testing oem install.
See bug 1051415
This pc is also affected by:
Sep 15 22:59:15 oem-K8NF4G-SATA2 kernel: [ 1449.572931] [drm] nouveau 0000:00:05.0: fail ttm_validate
Sep 15 22:59:15 oem-K8NF4G-SATA2 kernel: [ 1449.572942] [drm] nouveau 0000:00:05.0: validate vram_list
Sep 15 22:59:15 oem-K8NF4G-SATA2 kernel: [ 1449.580132] [drm] nouveau 0000:00:05.0: validate: -12

Changed in gnome-settings-daemon (Ubuntu Quantal):
status: Incomplete → Confirmed
Didier Roche (didrocks) wrote :

downgrade to medium: not a quantal release blocker (already shipped quantal with it. Ensuring that someone still continue to work on it though

Changed in gnome-settings-daemon (Ubuntu Quantal):
importance: High → Medium
Changed in gnome-settings-daemon (Ubuntu Quantal):
importance: Medium → Low
milestone: none → quantal-updates
Steve Magoun (smagoun) wrote :

Reopened oem-priority task, this affects some of our 32-bit 12.04 OEM builds.

Changed in oem-priority:
status: Won't Fix → Confirmed
tags: added: rls-r-tracking
Changed in oem-priority:
status: Confirmed → Won't Fix
Rolf Leggewie (r0lf) wrote :

quantal has seen the end of its life and is no longer receiving any updates. Marking the quantal task for this ticket as "Won't Fix".

Changed in gnome-settings-daemon (Ubuntu Quantal):
status: Confirmed → Won't Fix
To post a comment you must log in.