Ubuntu

gnome-settings-daemon crashed with SIGSEGV in idle_set_mode()

Reported by Jim Read on 2012-01-18
32
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gnome-settings-daemon
Invalid
High
gnome-settings-daemon (Fedora)
Unknown
Unknown
gnome-settings-daemon (Ubuntu)
Medium
Unassigned

Bug Description

The settings enforcer will crash randomly. When I run it through a terminal, it gives me a varying amount of text for varying purposes, followed by Segmentation Fault (core dumped)

After restarting it more than once, my mouse pointer doesn't work through my synaptics touchpad. Don't know if it's related, but it seems to be.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: gnome-settings-daemon 3.2.2-0ubuntu10
ProcVersionSignature: Ubuntu 3.2.0-9.16-generic 3.2.1
Uname: Linux 3.2.0-9-generic x86_64
ApportVersion: 1.90-0ubuntu2
Architecture: amd64
CrashCounter: 1
Date: Wed Jan 18 08:47:31 2012
ExecutablePath: /usr/lib/gnome-settings-daemon/gnome-settings-daemon
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
ProcCmdline: /usr/lib/gnome-settings-daemon/gnome-settings-daemon
SegvAnalysis:
 Segfault happened at: 0x7f8245ddc727: mov 0x8(%rax),%rcx
 PC (0x7f8245ddc727) ok
 source "0x8(%rax)" (0x00000008) not located in a known VMA region (needed readable region)!
 destination "%rcx" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: gnome-settings-daemon
StacktraceTop:
 ?? () from /usr/lib/gnome-settings-daemon-3.0/libpower.so
 ?? () from /usr/lib/gnome-settings-daemon-3.0/libpower.so
 g_closure_invoke () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_signal_emit_valist () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: gnome-settings-daemon crashed with SIGSEGV in g_closure_invoke()
UpgradeStatus: Upgraded to precise on 2012-01-12 (6 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Jim Read (jcr20jm) wrote :

StacktraceTop:
 idle_set_mode (manager=0x192d090, mode=<optimized out>) at gsd-power-manager.c:2675
 idle_evaluate (manager=0x192d090) at gsd-power-manager.c:2918
 idle_evaluate (manager=0x192d090) at gsd-power-manager.c:2876
 g_closure_invoke (closure=0x195bde0, return_value=0x0, n_param_values=2, param_values=0x1a82750, invocation_hint=<optimized out>) at /build/buildd/glib2.0-2.31.10/./gobject/gclosure.c:774
 signal_emit_unlocked_R (node=<optimized out>, detail=0, instance=<optimized out>, emission_return=0x0, instance_and_params=0x1a82750) at /build/buildd/glib2.0-2.31.10/./gobject/gsignal.c:3302

Changed in gnome-settings-daemon (Ubuntu):
importance: Undecided → Medium
summary: - gnome-settings-daemon crashed with SIGSEGV in g_closure_invoke()
+ gnome-settings-daemon crashed with SIGSEGV in idle_set_mode()
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-settings-daemon (Ubuntu):
status: New → Confirmed
visibility: private → public
adnan2a (chaudry-adnan-akbar) wrote :

Hi,

I am new to this , so dont know if it would help.

I was facing the same issue but on ubuntu 12.04 precise [Kernel 3.2.04] and gnome-settings-daemon version 3.2.2 . My system is toshiba sattellite L305-D .

After looking into the issue i found out the the whenever i leave the system Idle for around a minute there was a crash only when i login with out pluging in the power cable.

I did the following to fix the segmentation fault.

File: plugins/power/gsd-power-manager.c
Adding the following at line 2264 backlight_helper_get_value
// after getting the long value should be checked for lesser than 0 value also
// Line: 2319
  if (value > G_MAXINT || value < 0 ) {

// this will fix the seg fault

For some reason I always get -5 value in /sys/class/backlight/toshiba/brightness irrespective of logging on with power cable plugged or without it.

I will look into it later.

Hope it helps.

LRN (lrn1986) wrote :

Debian unstable, gnome-settings-daemon-3.2.2-2 on Toshiba Satellite m100:

Program received signal SIGSEGV, Segmentation fault.
0x00007f552b521e35 in idle_set_mode (manager=0xc81040, mode=GSD_POWER_IDLE_MODE_DIM) at gsd-power-manager.c:2674
2674 g_warning ("failed to get existing backlight: %s",
(gdb) bt
#0 0x00007f552b521e35 in idle_set_mode (manager=0xc81040, mode=GSD_POWER_IDLE_MODE_DIM) at gsd-power-manager.c:2674
#1 0x00007f552b5226e9 in idle_evaluate (manager=0xc81040) at gsd-power-manager.c:2917
#2 0x00007f552b5232d1 in idle_idletime_alarm_expired_cb (idletime=0xc15d80, alarm_id=1, manager=0xc81040) at gsd-power-manager.c:3255
#3 0x00007f55332d5804 in g_closure_invoke () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#4 0x00007f55332e778a in ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#5 0x00007f55332f0e11 in g_signal_emit_valist () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#6 0x00007f55332f0fb2 in g_signal_emit () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#7 0x00007f552b51c7c7 in gpm_idletime_event_filter_cb (gdkxevent=0x7fff19f792c0, event=0xce7000, data=0xc15d80) at gpm-idletime.c:281
#8 0x00007f553260a851 in ?? () from /usr/lib/x86_64-linux-gnu/libgdk-3.so.0
#9 0x00007f553260a9ab in ?? () from /usr/lib/x86_64-linux-gnu/libgdk-3.so.0
#10 0x00007f55325e28d1 in gdk_display_get_event () from /usr/lib/x86_64-linux-gnu/libgdk-3.so.0
#11 0x00007f553260a6f2 in ?? () from /usr/lib/x86_64-linux-gnu/libgdk-3.so.0
#12 0x00007f5532c0d0cf in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#13 0x00007f5532c0d8c8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#14 0x00007f5532c0de02 in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#15 0x00007f5533dd6fdd in gtk_main () from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
#16 0x0000000000404e40 in main (argc=1, argv=0x7fff19f79638) at main.c:459
(gdb) c
Continuing.
[Thread 0x7f552bf2f700 (LWP 7525) exited]
[Thread 0x7f55234a7700 (LWP 7526) exited]

Program terminated with signal SIGSEGV, Segmentation fault.
The program no longer exists.

Arnoques (arnoques) wrote :

This also happened to me. Since it seems that it still isn't fixed, I created a bug upstream:
https://bugzilla.gnome.org/show_bug.cgi?id=675048

Changed in gnome-settings-daemon (Ubuntu):
status: Confirmed → Triaged
Changed in gnome-settings-daemon:
importance: Unknown → High
status: Unknown → Invalid
Arnoques (arnoques) wrote :

Bug fixed in gnome-settings-daemon version 3.4.2 (at least, I'm not sure). The fix was http://git.gnome.org/browse/gnome-settings-daemon/commit?id=0fc947c590ec40f492af16cef5e3de7775ba08ab

Changed in gnome-settings-daemon (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.