Ubuntu

Brightness

Reported by faceless on 2011-10-12
40
This bug affects 7 people
Affects Status Importance Assigned to Milestone
gnome-settings-daemon (Ubuntu)
Medium
Abhishek kumar singh

Bug Description

Brightness will not maintain its settings. Keeps reverting to a dim display. Constantly have to function up ( increase screen brightness) on dell latitude D610. was stable on releases prior to 11.10

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: xorg 1:7.6+7ubuntu7
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic i686
.tmp.unity.support.test.0:

ApportVersion: 1.23-0ubuntu3
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,decor,regex,compiztoolbox,mousepoll,vpswitch,imgpng,wall,resize,unitymtgrabhandles,move,grid,snap,gnomecompat,place,animation,workarounds,fade,session,expo,scale,ezoom,unityshell]
CompositorRunning: compiz
Date: Wed Oct 12 10:34:39 2011
DistUpgraded: Log time: 2011-09-19 12:23:14.212126
DistroCodename: oneiric
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes, if not too technical
GraphicsCard:
 Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller [8086:2592] (rev 03) (prog-if 00 [VGA controller])
   Subsystem: Dell Device [1028:0182]
   Subsystem: Dell Device [1028:0182]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
MachineType: Dell Inc. Latitude D610
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-12-generic root=UUID=e3f817e0-cde5-462b-abaf-f6dc6a84604e ro quiet splash vt.handoff=7
SourcePackage: xorg
UpgradeStatus: Upgraded to oneiric on 2011-09-30 (12 days ago)
dmi.bios.date: 08/11/2005
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A05
dmi.board.name: 0U8082
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA05:bd08/11/2005:svnDellInc.:pnLatitudeD610:pvr:rvnDellInc.:rn0U8082:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: Latitude D610
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.6+bzr20110929-0ubuntu3
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

faceless (geelhoed) wrote :
bugbot (bugbot) on 2011-10-16
affects: xorg (Ubuntu) → xserver-xorg-video-intel (Ubuntu)
bugbot (bugbot) on 2011-10-16
tags: added: backlight
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed
Bryce Harrington (bryce) on 2011-10-25
Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → Medium
Bryce Harrington (bryce) wrote :

The X driver doesn't control brightness. Might be an issue in the userspace daemon. Or some ACPI quirkiness.

affects: xserver-xorg-video-intel (Ubuntu) → gnome-settings-daemon (Ubuntu)
Changed in gnome-settings-daemon (Ubuntu):
status: Confirmed → New
Bryce Harrington (bryce) wrote :

Sarvatt suggested this patch went in around that time and might be relevant:
http://git.gnome.org/browse/gnome-settings-daemon/commit/?id=67785fa2b1043bd5397669f92abbd210dbf23f24

Also:
<Sarvatt> * debian/patches/50_add_dell_backlight.patch:
<Sarvatt> - Add 'dell_backlight' module to gsd-backlight-helper (LP: #862474)

Santiago M. Mola (smola) wrote :

Anything we can do to help debug the issue?

A possibly dupe bug:
https://bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/873191

Changed in gnome-settings-daemon (Ubuntu):
assignee: nobody → Abhishek kumar singh (abhishekkumarsingh-cse)
status: New → In Progress
Paul Kilian (paul-kilian) wrote :

I too am having this problem on a Dell D430. In addition, the stepping on the brightness keys is wrong. It seems to step from the bottom, then from the top etc. etc. So when increasing the brightness, it goes dim, halfbright, dim+1, halfbright+1, dim+2, halfbright+2..........etc.

osprey (theosprey) wrote :

This bug affects mee to on a Dell D430, and I confirm that the brightness values keeps to alternate when trying to restore the original brigtness.

Marco Parillo (marco-parillo) wrote :

I can confirm both the alternating behavior with Fn Up Arrow as well as the not restoring full brightness when I swipe across my Dell Latitude D620 trackpad.
https://answers.launchpad.net/ubuntu/+source/acpi/+question/174296

I think it is in Gnome upstream of Ubuntu as this occurs on Fedora 16 (but not F15) Gnome:
http://ask.fedoraproject.org/question/121/laptop-screen-dims-on-f16-unlike-f15
And not on Kubuntu or SuSE 12.1 KDE.

osprey (theosprey) wrote :

I've installed the testing kernel from Kamal Mostafa's ppa and it solved the issue.
Now the alternating brightness problem disappeared from my Dell Latitude D430.
More details about the patch can be found at the following address
 https://launchpad.net/~kamalmostafa/+archive/inverted-backlight

osprey (theosprey) wrote :

The kernel version Ubuntu 3.0.0-16.29-generic 3.0.20 is still affected by this problem.

Bug also present on IBM/Lenovo ThinkPad X60s.

madbiologist (me-again) wrote :

Jan - as you have different hardware you most likely have a different bug which requires a different fix. Please file a new bug report.

osprey - are you able to test with the Ubuntu 12.04 "Precise Pangolin" Beta 1 LiveCD?

madbiologist - done (bug 947442).

osprey (theosprey) wrote :

The bug is still present in kernel version 3.0.0-18-generic #31-Ubuntu. Package linux-image-3.0.0-18-generic 3.0.0-18.31.

Madbiologist, I'll try as soon as time permits.

Marco Parillo (marco-parillo) wrote :

@Paul Kilian (paul-kilian):
I was able to resolve the exact same behavior as you noted on 2011-10-28, first by switching to Kubuntu, and now by a upgrading to 12.04 LTS. https://answers.launchpad.net/ubuntu/+source/acpi/+question/174296

osprey (theosprey) wrote :

Switched to 12.04. Confirmed that the problem of the brigthness is solved

Also gone on Intel hardware (bug 947442).

Am 29.05.2012 21:25, schrieb osprey:
> Switched to 12.04. Confirmed that the problem of the brigthness is
> solved
>

madbiologist (me-again) on 2012-05-31
Changed in gnome-settings-daemon (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.