Keyboard menu title needlessly has both icon and label

Bug #620331 reported by Martin Pitt on 2010-08-19
290
This bug affects 58 people
Affects Status Importance Assigned to Milestone
Ubuntu network, Bluetooth, keyboard menus
Fix Released
Undecided
Unassigned
gnome-settings-daemon (Ubuntu)
Low
Karl Lattimer

Bug Description

Binary package hint: gnome-settings-daemon

With the indicator-fied keyboard layout we now got an extra icon to the left of the layout name. This is redundant and takes away precious panel real estate, and it also looks confusing: They look like two separate indicators (all others just have an icon or just text).

Martin Pitt (pitti) on 2010-08-19
Changed in gnome-settings-daemon (Ubuntu):
assignee: nobody → Karl Lattimer (karl-qdh)
importance: Undecided → Low
Sebastien Bacher (seb128) wrote :

I'm subscribing mpt and ted to the bug as well since I guess they will have an opinion about it

Martin Pitt (pitti) wrote :

Ah, actually the me-menu also has an icon plus text. But it's still redundant IMHO.

Sebastien Bacher (seb128) wrote :

The spacing on the left and right of the applet seem also different but that's probably another bug? Or do you want to handle that discussion there as well?

Matthew Paul Thomas (mpt) wrote :

My design specified that each layout should have an icon composed of its abbreviation, and that this icon should be used both as the entire menu title, and in the individual menu items. <https://wiki.ubuntu.com/KeyboardMenu#Use%20cases> Unfortunately Karl did not have time to implement that icon generation code for Maverick, so he had to use a generic icon plus text for the title, and no icons at all for the menu items.

Matthew Paul Thomas (mpt) wrote :

It wasn't clear from my previous comment, so: The only way for the menu title to have just text would be to change the appindicator API. And it would be a temporary change, because the goal is eventually for this menu to have, as its title, the same icons as it will use for the individual layout items.

However, there are two possible ways to improve the situation for Maverick before the UI freeze next Wednesday.

One would be for an SVG guru to write that icon generation code, so that the menu title *can* be just an icon, rather than icon+text.

The other would be for someone to implement the "Show keyboard menu in the menu bar" checkbox, so that even people using multiple layouts can turn off the menu if they don't need it. <https://wiki.ubuntu.com/KeyboardMenu#5.%20User%20switches%20the%20keyboard%20menu%20on%20or%20off>

Martin Pitt (pitti) wrote :

Matthew, thanks for the heads-up. I don't consider it a big deal, so please feel free to close as "wontfix" if it's too complicated.

David Barth (dbarth) wrote :

Proposing to add a gconf key (at least) to be able to hide the indicator even if multiple layouts are installed/registered. That should bring us closer to mpt's design https://wiki.ubuntu.com/KeyboardMenu#5.%20User%20switches%20the%20keyboard%20menu%20on%20or%20off

And in a second step (if time still permits) adding the corresponding checkbox to the gnome-control-center applet.

Changed in gnome-settings-daemon (Ubuntu):
milestone: none → ubuntu-10.10-beta
Changed in ayatana-ubuntu:
importance: Undecided → Low
assignee: nobody → Karl Lattimer (karl-qdh)
milestone: none → ubuntu-10.10-beta
Sebastien Bacher (seb128) wrote :

could you clarify what you call keyboard menu exactly? is that just turning off the indicator? because most users don't need the indicator to have a menu but still want the layout to be indicated because otherwise they would not know where they are cycling or which one they are using

Chris Coulson (chrisccoulson) wrote :

gnome-settings-daemon already has a gconf key for switching off the indicator (/desktop/gnome/peripherals/keyboard/general/disable_indicator)

Karl Lattimer (karl-qdh) on 2010-08-25
Changed in gnome-settings-daemon (Ubuntu):
status: New → In Progress
Karl Lattimer (karl-qdh) wrote :

I have a working patch which I'll be uploading to bug https://bugs.launchpad.net/ayatana-ubuntu/+bug/599844 soon.

This will show the flags adjacent to the full label. It's a workaround to the "ugly" keyboard icon described.

Changed in gnome-settings-daemon (Ubuntu):
status: In Progress → Fix Committed
Karl Lattimer (karl-qdh) on 2010-08-31
Changed in ayatana-ubuntu:
status: New → Fix Committed

I don't think we want the icon at all - just the keyboard designator
text/image.

Mark

Ok, well, I'll try to implement the second option suggested by MPT which is to have the option in the control centre to hide the indicator as we can't really hide the icon and leave the label without breaking ABI atm.

Changed in gnome-settings-daemon (Ubuntu):
status: Fix Committed → In Progress
Karl Lattimer (karl-qdh) wrote :

Oh, there is one other option, we have SVG/PNG icons created and drop the label instead?

This would fit more with MPT's plan, although some complication could arise with the numbering of multiple layouts from the same country.

David Barth (dbarth) on 2010-09-01
Changed in ayatana-ubuntu:
milestone: ubuntu-10.10-beta → ubuntu-10.10
Changed in gnome-settings-daemon (Ubuntu):
milestone: ubuntu-10.10-beta → ubuntu-10.10
Extender (msveshnikov) wrote :

Not fixed in release, why??

majesty (majesty-nashemisto) wrote :

Remove an icon, please. That people,who use xneur or scroll lock LED for indication, not need nonfunctional icon.

Extender (msveshnikov) wrote :

This icon (keyboard) is not needed for any people. It's a bug.
But in 10.04 I was able to remove indicator completely with gconf (yes I use xneur) , but now it not working too... So I have 2 unnecessary icons wasting my screen :(

Yura Tolstik (yltsrc) wrote :

please remove this stupid and useless keyboard icon

Karl Lattimer (karl-qdh) wrote :

The keyboard icon is because of we hit the API freeze before the original bug of showing which is the current layout was fixed, we can't change the API now therefore the icon is there to stay.

You can, turn on "show_flags" in gconf, and get a pack of flag files extracted into ~/.icons/flags this will make turn the indicator into just an icon, which indicates the current layout.

majesty (majesty-nashemisto) wrote :

Thank you for answer, Karl. Why change the API to pick the icon? Simply implement the key "Do not display the icon and become happy".

Karl Lattimer (karl-qdh) wrote :

There are two issues here, firstly that the gconf key for *completely hiding* the icon, should in fact work. I was assured so, and haven't touched that part of the code - If in fact it doesn't work, that's a bug, I'll happily fix.

Secondly, the icon beside the layout label is because we couldn't change the api in the application indicators to hide the flag and show the label, this would have led to a messy changes in the code and probable ABI breakage. (binary interface, you change this and lots of horrible things happen, unicorns die etc...)

Yura Tolstik (yltsrc) wrote :

@Karl, in native gnome, when you turn on "show_flags" in gconf you can see only flag, but when you turn off, you can see only letters without image, and i am not sure that you had to change API to fix it

Karl Lattimer (karl-qdh) wrote :

@Yura, that *must* be a bug in the app indicators

Yura Tolstik (yltsrc) wrote :

@Karl, but now, as I can see, there no bug in the app indicators
and I haven't permissions to nominate or reassign this bug to app indicators, please do it
Thanks

Extender (msveshnikov) wrote :

@Karl, may I set 2 empty icons in flags for now (1x1 pixel size) ?

Turbid (turbidit) wrote :

I confirm this ugly bug

Matthew Paul Thomas (mpt) wrote :

Yura, you're talking about a notification area item. The new menu does not use a notification area item.

There's no point in "confirming" the bug yet again, or expressing surprise that it's not fixed, when I explained seven weeks ago why it couldn't be fixed for 10.10. All going according to plan, it will be fixed in Ubuntu 11.04.

summary: - please drop icon from keyboard indicator
+ Keyboard menu icon needlessly has both icon and label
summary: - Keyboard menu icon needlessly has both icon and label
+ Keyboard menu title needlessly has both icon and label
Karl Lattimer (karl-qdh) wrote :

@Extender, as I said, the gconf key for this *should* work to hide the indicator, and setting 1x1 pixel icons will only affect the GSD keyboard flag, the label will still be shown.

lumbricus (lumbricus) wrote :

@Karl Which gconf key do you mean?
I tried to enable the icons (although I just wanted to get rid of the other icon, not enable even more of them ;) ), but I didn't manage to change anything.

lumbricus (lumbricus) wrote :

Sorry, wrong alarm for the show_flags switch. This one worked after changing the theme. But I don't know which other switch should work.

Extender (msveshnikov) wrote :

@Karl, @lumbricus
1. /apps/gnome_settings_daemon/plugins/keyboard/active - worked, completely hides icon anв text (after logout of course) . But has some drawbacks (slow repeat keys, non-working PrtScr and more)

2. /desktop/gnome/peripherals/keyboard/general/disable_indicator - not working at all.

Matvei Fisenko (2matvei) wrote :

@Karl
I confirm that /desktop/gnome/peripherals/keyboard/general/disable_indicator do not work on fresh install of 10.10 (with apt-get update).
If you have a workaround to remove indicators at all - please provide.

Changed in gnome-settings-daemon (Ubuntu Natty):
milestone: ubuntu-10.10 → none
Karl Lattimer (karl-qdh) wrote :

@Matvei - Read omment #31

Seems to work?

Karl Lattimer (karl-qdh) wrote :

Extender, does that disable layout switching?

Elias K Gardner (zorkerz) wrote :

The workaround in comment #31 from Extender disables layout switching from keyboard shortcuts for me.

Actually I can't seem to switch the layout at all. Even when I delete the dvorak layout from
system->preferences->keyboard >layout tab it does not switch to standard USA (my other layout).

I can print screen with the PrtSc button and repeating keys seems to be fine.

So in effect it is easier to just have one layout because this also removes the keyboard icons.

Extender (msveshnikov) wrote :

@Karl - yes, /apps/gnome_settings_daemon/plugins/keyboard/active=false disables layout switching also, but I use xneur for that

Ian W Scott (iscott) wrote :

My solution to the problem of the duplicate icon/text was to create SVG language flags. If anyone else would like them they are posted at http://gnome-look.org/content/show.php/Language+Flags+for+Faenza+Dark+Panel?content=133910 (for dark panels) and http://gnome-look.org/content/show.php/Language+Flags+for+Faenza+and+Elementary?content=133726 (for light panels). The light-panel version looks best with Faenza or Elementary iconsets, but is also not bad with ubuntu-mono-light. The dark panel version is really best suited for Faenza. If there's enough interest, I can create another set to match ubuntu-mono-dark. The gnome-look.org pages include instructions for installing the sets. And if I've missed your language, let me know the code and I'll add it to the set.

Extender (msveshnikov) wrote :

@Ian, but those language flags are usually so huge (I mean width)... Can you make it more square? :)

Matvei Fisenko (2matvei) wrote :

@Karl solution from #31 disable indicators and layout switching as well (and that's bad)!

I assume than this is again one of those bugs which will be NOT fixed in this release. (10.10)
So users which do not want to have KB icon beside keyboard layout text are out of luck...

Karl Lattimer (karl-qdh) wrote :

In order to 'fix' this please follow the instructions here;

https://bugs.launchpad.net/ayatana-ubuntu/+bug/628015/comments/9

this will leave you with just a single icon e.g. [GB]

Alexander Fomichev (alfonder) wrote :

Thanks, Karl, this workaround helps me.

jorge (xxopxe) wrote :

I confirm that Karl's workaround in #41 works (after logging out and in again).

Alejandro (aleoliva) wrote :

I can also confirm that Karl's workaround works. I want to add a comment. I use 2 layouts, one for Japanese and one for Spanish. When I first tried the workaround the Japanese layout showed the JP icon and then for Spanish language did not show an icon. Instead it showed a red icon (probably indicating that no icon was available). For Spanish language the keyboad layout that is usually setup is LATAM (latin america) not an individual country (in my case Guatemala). The way I fixed it was to make a copy of the GT (Guatemala) icon and renamed it to use it as LATAM keyboard layout.

In the end my comment is just to let you know that maybe the icons do not have to be one for every country but only for every keyboard layout.

Thanks for the workaround. I apreciate it a lot.

pablomme (pablomme) wrote :

This continues being an issue in natty.

majesty (majesty-nashemisto) wrote :

Replacing keybord icon did not fix issue, because want to disable icon, keyboard indicators is on LED panel.

Adolfo Jayme (fitojb) wrote :

Any ideas to possibly implement comment #37 solution? I mean, temporarily until no-icon config is released.

I hope it will be fixed in oneiric

I think, icons can be generated on air, because text looks ugly

Adolfo Jayme (fitojb) on 2011-09-10
Changed in gnome-settings-daemon (Ubuntu):
status: In Progress → Confirmed
Changed in gnome-settings-daemon (Ubuntu Natty):
status: In Progress → Confirmed
Stas Sușcov (sushkov) wrote :

Still present in daily Oneiric.
More than that, the `showFlags` trick with gconf is not working anymore.
Big disappointment!

pablomme (pablomme) wrote :

The trick still works, but the parent key has been removed (probably migrated to gsettings). You need to create the Boolean key /desktop/gnome/peripherals/keyboard/indicator/showFlags and set it to true.

Dmitry Shachnev (mitya57) wrote :

In upstream Gnome it moved to org.gnome.libgnomekbd.indicator/show-flags, so maybe Ubuntu will use this key also?

Adolfo Jayme (fitojb) wrote :

This problem is more annoying since the update to make the indicator icons more readable (bug 828862). Now the keyboard icon is a white rectangle when the Dash is open. The importance of this bug should be raised a bit.

Alejandro (aleoliva) wrote :

I also keep having this same problem over and over. After Oneiric new install, the solution from Karl on #41 did not work this time. I also use ibus for Japanese Language input which has the same keyboard icon, so I had 2 identical keyboard icons.

 I looked for another fix and I found it on: http://www.webupd8.org/2011/05/how-to-remove-keyboard-indicator-icon.html It looks like a quick finx. The result is that instead of having a keyboard icon with a name, I have only have two letters: "jp" for Japanese and "es" for spanish. It looks nice and narrow and clean. So I hope it helps to find a final solution to the bug in future releases.

Alejandro (aleoliva) wrote :

Please disregard last comment. After clean install i only get the new keyboard layout button.

Olli Ries (ories) wrote :

thanks for your report - please reopen if this issue still exists in 12.04

Changed in ubuntu-indicator-mods:
status: New → Incomplete
Dmitry Shachnev (mitya57) wrote :

This still exists in precise.

Changed in ubuntu-indicator-mods:
status: Incomplete → Confirmed
affects: ayatana-ubuntu → null
Changed in null:
milestone: ubuntu-10.10 → none
Curtis Hovey (sinzui) on 2012-07-15
no longer affects: null
Adolfo Jayme (fitojb) on 2013-02-27
no longer affects: gnome-settings-daemon (Ubuntu Natty)
Adolfo Jayme (fitojb) wrote :

This has been fixed in Saucy with the introduction of indicator-keyboard.

Changed in ubuntu-indicator-mods:
status: Confirmed → Fix Released
Changed in gnome-settings-daemon (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers