[xsettings]: gnome-settings-daemon crashed with SIGSEGV in on_shell_disappeared()

Bug #1225243 reported by ariel sandoval on 2013-09-14
252
This bug affects 58 people
Affects Status Importance Assigned to Milestone
gnome-settings-daemon (Ubuntu)
High
Tim Lunn

Bug Description

ni idea

ProblemType: Crash
DistroRelease: Ubuntu 13.10
Package: gnome-settings-daemon 3.8.5-0ubuntu2
ProcVersionSignature: Ubuntu 3.10.0-3.12-generic 3.10.1
Uname: Linux 3.10.0-3-generic x86_64
ApportVersion: 2.12.1-0ubuntu4
Architecture: amd64
CrashCounter: 1
Date: Fri Sep 13 18:58:14 2013
ExecutablePath: /usr/lib/gnome-settings-daemon/gnome-settings-daemon
InstallationDate: Installed on 2013-05-30 (106 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
MarkForUpload: True
ProcCmdline: /usr/lib/gnome-settings-daemon/gnome-settings-daemon
ProcEnviron:
 LANGUAGE=es_CO:es
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=es_CO.UTF-8
 SHELL=/bin/false
SegvAnalysis:
 Segfault happened at: 0x7fe1814f4877: movl $0x0,0x38(%rax)
 PC (0x7fe1814f4877) ok
 source "$0x0" ok
 destination "0x38(%rax)" (0xaaaaaaaaaaaaaae2) not located in a known VMA region (needed writable region)!
SegvReason: writing unknown VMA
Signal: 11
SourcePackage: gnome-settings-daemon
StacktraceTop:
 ?? () from /usr/lib/gnome-settings-daemon-3.0/libxsettings.so
 ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
 ffi_call_unix64 () from /usr/lib/x86_64-linux-gnu/libffi.so.6
 ffi_call () from /usr/lib/x86_64-linux-gnu/libffi.so.6
 g_cclosure_marshal_generic () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: [xsettings]: gnome-settings-daemon crashed with SIGSEGV in ffi_call_unix64()
UpgradeStatus: Upgraded to saucy on 2013-06-03 (102 days ago)
UserGroups:

ariel sandoval (arielsanflo) wrote :

StacktraceTop:
 on_shell_disappeared (connection=<optimized out>, name=0x8d8ff0 "org.gnome.Shell", user_data=0x875320) at gsd-xsettings-manager.c:748
 g_bus_watch_name (bus_type=738733152, name=0x8bd260 "\001", flags=(unknown: 738733424), name_appeared_handler=0x7fff2c082da0, name_vanished_handler=0x856dd0, user_data=0x0, user_data_free_func=0x7fff2c082cf8) at /build/buildd/glib2.0-2.37.93/./gio/gdbusnamewatching.c:587
 ffi_call (cif=0x0, fn=0x0, rvalue=0x883090, avalue=0x7fff2c082d60) at ../src/x86/ffi64.c:522

Changed in gnome-settings-daemon (Ubuntu):
importance: Undecided → Medium
summary: [xsettings]: gnome-settings-daemon crashed with SIGSEGV in
- ffi_call_unix64()
+ on_shell_disappeared()
tags: removed: need-amd64-retrace
information type: Private Security → Public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-settings-daemon (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Thank you for your bug report

Tim, that seems to be a new issue in the 3.8 update, could you have a look to it?

Changed in gnome-settings-daemon (Ubuntu):
assignee: nobody → Tim (darkxst)
importance: Medium → High
status: Confirmed → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-settings-daemon (Ubuntu):
status: New → Confirmed
Isiah Meadows (impinball) wrote :

I found that replacing it with the one from GNOME's PPA actually rectifies the issue entirely. Comparing the sources of theirs and Ubuntu Gnome's may help a lot in triaging this bug.

Isiah Meadows (impinball) wrote :

I take that back...that definitely did not change on a consistent basis for the better.

biggc (1being) on 2017-08-30
Changed in gnome-settings-daemon (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers