Disabling user switching doesn't disable it completely

Bug #363871 reported by JS on 2009-04-19
52
This bug affects 8 people
Affects Status Importance Assigned to Milestone
gnome-session
Fix Released
Medium
gnome-session (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gconf-editor

Due to errors in the ATI driver, I need to disable fast user switching

As root I launch gconf-editor and set /desktop/gnome/lockdown/disable_user_switching = True as mandatory

I verify that this setting is propagated to the user level by running gconf-editor as a standard user and verifying the setting.

The system=>Logout... menu still gives a "Switch User" option.

js@ccsn-bw2:~$ lsb_release -rd
Description: Ubuntu 8.10
Release: 8.10

Thanks.

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 8.10
ExecutablePath: /usr/bin/gconf-editor
Package: gconf-editor 2.24.1-0ubuntu1
ProcEnviron:
 SHELL=/bin/bash
 PATH=/usr/local/bin:/usr/bin:/bin:/opt/bin:/usr/x86_64-pc-linux-gnu/gcc-bin/3.4.3:/opt/blackdown-jdk-1.4.2.02/bin:/opt/blackdown-jdk-1.4.2.02/jre/bin:/usr/qt/3/bin:/usr/kde/3.4/bin:/home/username/workspace/whatIs/whatIs:/home/username/workspace/whatIs/:/usr/local/afni/linux_gcc33_64/:/usr/kde/3.5/bin/:/opt/swift/bin
 LANG=en_US.UTF-8
SourcePackage: gconf-editor
Uname: Linux 2.6.27-11-generic i686

There's a bounty on this bug at:
http://www.fossfactory.org/project/p186

JS (hundredpercentjuice) wrote :
Chris Coulson (chrisccoulson) wrote :

This looks more like a gnome-session issue actually

affects: gconf-editor (Ubuntu) → gnome-session (Ubuntu)
Changed in gnome-session (Ubuntu):
importance: Undecided → Low
Shahar Or (mightyiam) wrote :

I'm also experiencing this. Reporting upstream.

Changed in gnome-session (Ubuntu):
status: New → Triaged
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
Shahar Or (mightyiam) wrote :

Perhaps the System => Logout was in a previous version; here in jaunty there's no such menu item.

But the problem is still there, that disabling user switching does not disable it completely.

summary: - Ubuntu ignores /desktop/gnome/lockdown/disable_user_switching
+ Disabling user switching doesn't disable it completely
Philip (philip-webb-99) wrote :

I was using this feature fine in 9.04, from the "system, Administration, lockdown editor" program.

In 9.10 it seems broken and the User switcher menu is displayed after it has been disabled.

Roberto C. Morano (rcmorano) wrote :

I can confirm that it doesn't works in 9.10 either...

Menu options are displayed in FUSA (in 9.10 indicator-session) applet and in the gnome-panel built-in applet "logout". They do not only are shown in the applets, they will let you switch user having set "/desktop/gnome/lockdown/disable_user_switching" to "True".

I have been looking into indicator-session's code and it directly spawns a new session without checking any config (gconf). I have tried to disallow normal users via policykit to access "org.gnome.displaymanager.localdisplayfactory" dbus resource, since, I've seen that, that's what indicator-session calls to instace a new sessión, but I haven't been able to do it, I don't know if it has been because of my ignorance or because some problem related with the transition from policykit to policykit-1 (the resource wasn't defined in "/usr/share/polkit-1/actions/gdm.policy")...

Im reviewing gnome-panel's code right now, I need those options disabled in the distro I'm developing (Guadalinex Guadalinfo V6).

Shahar Or (mightyiam) wrote :

There's a bounty on this bug at:
http://www.fossfactory.org/project/p186

tags: added: bounty
Shahar Or (mightyiam) on 2009-11-29
description: updated
Joel Ebel (jbebel) on 2010-02-26
tags: added: glucid
Changed in gnome-session:
importance: Unknown → Medium
status: Unknown → New
Changed in gnome-session:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.