gnome-session hangs when "lo" is not correctly configured

Bug #26419 reported by Carlos F. on 2005-11-30
84
Affects Status Importance Assigned to Milestone
gnome-session
Expired
Medium
gnome-session (Ubuntu)
Medium
Unassigned

Bug Description

I admit that this is a strange bug. Some day, as usual, I clicked on
System->Exit to halt the computer, but after clicking on "Exit", the panel
hanged. The shutdown dialog didn't appear and the panel just died, but it didn't
either reload or segfault, the "report a bug" window didn't appear.

I can't provide a backtrace as it is a hang and not a segfault. I opened
gnome-panel from a terminal (killing the previous one) and after the hang, no
message appears on the console.

If you tell me some flags to run gnome-panel with in order to debug the problem,
I'll be happy to help here.

http://bugzilla.gnome.org/show_bug.cgi?id=318584: http://bugzilla.gnome.org/show_bug.cgi?id=318584

Daniel Holbach (dholbach) wrote :

Thanks for the bug report. To me this sounds a lot like
http://bugzilla.ubuntu.com/show_bug.cgi?id=18163 - could you have a look, if
this matches your symptoms and if so, tell us?

Ok, more info.

This morning I tried again to shutdown with System->Exit and it WORKED.
Interestingly enough, a few hours later the same day it hanged again. I'm
starting to imagine that it has something to do with the running processes or
the hardware. No configuration was changed and no packages were updated.

About bug 24307, it seems similar but gnome doesn't hang, only the panel. And if
I open a console and run "killall -HUP gnome-panel", it reloads and I can
continue working (but the logout dialog doesn't appear either).

Sebastien Bacher (seb128) wrote :

Do you automatically store your session? Do you use dhclient? Is your loopback
correctly configured (ping localhost)?

Yes to the first two questions, but you're right, loopback wasn't properly
configured.

I have new information... if I wait about 5 minutes, the panel "ressurects" and
the logout window is shown at last. In the window list appears a new button
"gnome-session" which corresponds to the logout window, but I don't remember
there was any button associated to this dialog.

If you want a screenshot I can post some.

It seems that it was a problem of the loopback device. Some of my /etc/init.d
scripts was screwed up.

Thanks for the help. I suppose that we can close the bug now.

Sebastien Bacher (seb128) wrote :

That's a known gnome-session issue, you need a properly configured loopback to
not have to wait a few minutes before getting the dialog by example:
http://bugzilla.gnome.org/show_bug.cgi?id=318584

Sebastien Bacher (seb128) wrote :

*** Bug 20638 has been marked as a duplicate of this bug. ***

Carthik Sharma (carthik) wrote :

Confirmed by others.

Thanks.

Changed in gnome-session:
status: Unconfirmed → Confirmed
Martin Albisetti (beuno) wrote :

Shouldn't this be a higher priority considering this is the default configuration in Feisty?

Conn O Griofa (psyke83) wrote :

Sebastien,

You marked my bug at https://launchpad.net/bugs/94048 as a duplicate of this. However, I haven't noticed any logout bugs; my original bug deals with gnome applications being slow to start.

The root problem and solution may be the same (lo interface, and the 127.0.1.1 hostname split), but perhaps the priority of the bug should be reconsidered due to the performance impact system-wide in Feisty's default configuration (see my bug for details, there's no need to spam this one with descriptions of a different symptom).

Thanks. :)

Sebastien Bacher (seb128) wrote :

what is the default configuration? having an "lo" interface not correctly configured? that's not likely. That's not a GNOME bug if you deconfigured the loopback interface. If the configuration is created with a graphical tool you should rather open a bug on that tool

Martin Albisetti (beuno) wrote :

Sebastien, I think you should take a look at this forum thread: http://ubuntuforums.org/showthread.php?t=388765

It's what the previous bug was reported on.

Sebastien Bacher (seb128) wrote :

unduping to no send extra comments on the other bug

Changed in gnome-session:
status: Confirmed → Triaged
Nicolas Stouff (nico-stouff) wrote :

Same problem, or at least, it seems so.
Clicking in System -> Quit works well, but the fast-quit applet does not bring the shutdown window, instead, only panels and desktop freezes, but my keyboard and mouse are still active.

My loopback is properly configured.
Only changes in Gnome-Panel Config: removed fast-user-switch applet, added tomboy and OOo quickstart, remove NetworkManager...

Tht's all!

kailden (kailden) wrote :

I had a similar problem (upon upgrade from feisty to gutsy) and I think it was a problem with gnome-power-manager.
When I ran gnome-power-manager in a terminal, it couldn't find /usr/lib/libwnck-1.so-18.

I made a symbolic link as follows:

sudo ln -s /usr/lib/libwnck-1.so.22 /usr/lib/libwnck-1.so.18

and made sure that gnome-power-manager was running in my gnome session,

(System->Preferences->Sessions and check Power Manager)

and now there is no hang.

Sebastien Bacher (seb128) wrote :

looks like your issue is a different one and due to a local build, the ubuntu packages have correct libwnck depends

kailden (kailden) wrote :

That may be the case..I think at one point I was looking for a way to stop charging a battery at 40% (optimal) when it was on the AC and I may have downloaded the newest gnome-power-manager code,

I ran into someone on the ubuntu forums who had a similar problem, and the solution for them was JUST the latter step, adding gnome-power-manager to the session. (http://ubuntuforums.org/showthread.php?t=595247&goto=newpost).

I'm sorry neither step fixes your problem...even if the symptoms are similar!

Chris Coulson (chrisccoulson) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue for you. Can you try with the latest Ubuntu release? Thanks in advance.

Changed in gnome-session (Ubuntu):
status: Triaged → Incomplete
Changed in gnome-session (Ubuntu):
assignee: Sebastien Bacher (seb128) → nobody
Vish (vish) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future.
To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New".

Changed in gnome-session (Ubuntu):
status: Incomplete → Invalid
Changed in gnome-session:
importance: Unknown → Medium
Changed in gnome-session:
status: New → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.