[Intrepid]gnome-screensaver-gl-helper crashed with SIGSEGV

Bug #185704 reported by fragro on 2008-01-24
510
This bug affects 16 people
Affects Status Importance Assigned to Milestone
gnome-screensaver (Ubuntu)
Medium
Unassigned
Declined for Intrepid by Steve Langasek
Declined for Jaunty by Steve Langasek

Bug Description

Binary package hint: gnome-screensaver

ProblemType: Crash
Architecture: i386
Date: Thu Jan 24 17:43:20 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/lib/gnome-screensaver/gnome-screensaver-gl-helper
NonfreeKernelModules: cdrom
Package: gnome-screensaver 2.20.0-2ubuntu1
PackageArchitecture: i386
ProcCmdline: /usr/lib/gnome-screensaver/gnome-screensaver-gl-helper
ProcCwd: /
ProcEnviron:
 PATH=/home/fragro/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/lib/gnome-screensaver/gnome-screensaver:/usr/lib/xscreensaver:/usr/lib/xscreensaver
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: gnome-screensaver
StacktraceTop:
 ?? () from /lib/ld-linux.so.2
 ?? ()
 ?? () from /lib/ld-linux.so.2
 ?? ()
 ?? ()
Title: gnome-screensaver-gl-helper crashed with SIGSEGV
Uname: Linux fragro-laptop 2.6.24-4-generic #1 SMP Mon Jan 14 17:30:39 UTC 2008 i686 GNU/Linux
UserGroups: adm admin audio cdrom dialout dip floppy lpadmin netdev plugdev powerdev sambashare scanner video

fragro (frank-grossmann) wrote :

StacktraceTop:_dl_close () from /lib/ld-linux.so.2
dlclose_doit () from /lib/tls/i686/cmov/libdl.so.2
_dl_catch_error () from /lib/ld-linux.so.2
_dlerror_run () from /lib/tls/i686/cmov/libdl.so.2
dlclose () from /lib/tls/i686/cmov/libdl.so.2

Changed in gnome-screensaver:
importance: Undecided → Medium
Changed in gnome-screensaver:
status: New → Confirmed

Get this bug when i return to use the pc after screensaver has been active.

tdflanders (thomasdelbeke) wrote :

thomas@thomas-laptop:~$ lsb_release -rd ; uname -a ; apt-cache policy linux gvfs gnome-screensaver deluge-torrent
Description: Ubuntu intrepid (development branch)
Release: 8.10
Linux thomas-laptop 2.6.27-3-generic #1 SMP Wed Sep 10 16:02:00 UTC 2008 i686 GNU/Linux
linux:
  Installed: 2.6.27.3.3
  Candidate: 2.6.27.3.3
  Version table:
 *** 2.6.27.3.3 0
        500 cdrom://Ubuntu 8.10 _Intrepid Ibex_ - Alpha i386 (20080917.1) intrepid/restricted Packages
        500 http://gb.archive.ubuntu.com intrepid/restricted Packages
        100 /var/lib/dpkg/status
gvfs:
  Installed: 0.99.8-0ubuntu1
  Candidate: 0.99.8-0ubuntu1
  Version table:
 *** 0.99.8-0ubuntu1 0
        500 cdrom://Ubuntu 8.10 _Intrepid Ibex_ - Alpha i386 (20080917.1) intrepid/main Packages
        500 http://gb.archive.ubuntu.com intrepid/main Packages
        100 /var/lib/dpkg/status
gnome-screensaver:
  Installed: 2.23.90-0ubuntu1
  Candidate: 2.23.90-0ubuntu1
  Version table:
 *** 2.23.90-0ubuntu1 0
        500 http://gb.archive.ubuntu.com intrepid/main Packages
        100 /var/lib/dpkg/status
     2.23.3-0ubuntu2 0
        500 cdrom://Ubuntu 8.10 _Intrepid Ibex_ - Alpha i386 (20080917.1) intrepid/main Packages
deluge-torrent:
  Installed: 0.5.9.3-1
  Candidate: 0.5.9.3-1
  Version table:
 *** 0.5.9.3-1 0
        500 http://gb.archive.ubuntu.com intrepid/universe Packages
        100 /var/lib/dpkg/status
thomas@thomas-laptop:~$

Just using a black screen as screen saver...

Get this bug when i return to use the pc after screensaver (just black screen) has been active.

mlaverdiere (mlaverdiere) wrote :

I've just upgraded to Intrepid Beta and I'm experiencing this bug when I resume from suspend or from active screensaver. It was not present on my previous Hardy installation.

James Clemence (jvc26) wrote :

Same on my Intrepid beta install.

Typhoe (spamistrash) wrote :

Same problem also here.

I use a blank screen as my screen saver.

when I lock my session and try to log back, I can't (not seeing the dialog box. The mouse cursor is there, and disappear on the dialog box position).

Killing the screen saver from terminal let me get back in my session.

Léa GRIS (lea-gris) wrote :

Problem apperead just after upgrade to Intrepid

Still happens in most recent Jaunty release as well

Christophe Pierret (cpierret) wrote :

Happened on Jaunty after upgrade from intrepid

Thanks for contacting <email address hidden>. Due to a breathtakingly high
volume of spam, I ask that you first contact me via my contact form:

http://www.boutell.com/contact/

Once you have contacted me once via the form, you will immediately be
whitelisted to contact me via email as well. If you need to send an
attachment you can do so via email after first saying hello via the form.

I recognize that this is inconvenient, and I apologize for the necessity.
I can only say that nothing in the universe collects more spam than an
email address that has been published all over the Internet since 1994!

The subject of your message was:

[Bug 185704] Re: gnome-screensaver-gl-helper crashed with SIGSEGV

With my sincere apologies for the inconvenience,

Tom Boutell

P.S. Again, that link is:

http://www.boutell.com/contact/

Once you've used it once you will be whitelisted to contact me via email
as well.

Webform posted at: http://www.boutell.com/contact/:

Please whitelist:

<email address hidden> ; www.canonical.com ; https://bugs.launchpad.net/ubuntu

It seems that you or one of your employees (@boutell.com) has reported a bug in a Ubuntu OS he/she may be using, at bugs.launchpad.net. This is off course very much appreciated.

Launchpad is the bug tracking system for many Linux OS's. As the default mode when subscribing to launchpad is: you receive all messages related to your bug, this user will now get a very large amount of emails.

As the previous domains/addresses are blocked by your email client, the user who posted this will not get a notification. We will however, as we always will receive your automated reply.

Please whitelist these previous addresses/domains, so the original user will be notified. There are an enormous amount of duplicates of these bug, and the original user who posted the duplicate is not required to make his own email address public.

Therefore our alternatives are:

* Contact the server admin of bugs.launchpad.net
* Send a private message to everyone who ever posted a duplicate of this bug and hope they respond

Neither of these alternatives are preferred. Therefore please help us out instead, as we will get a duplicate of your bounce message for every new duplicate/comment that is posted. If you would like the domain: @boutell.com to be blocked, you may contact me and I will pass it on to the launchpad server admin.

For your reference:

https://bugs.launchpad.net/ubuntu/+source/gnome-screensaver/+bug/185704

Please Note:

It is not necessary to whitelist my email address, as I have no need to contact you ever again (not that I do not like you naturally).

Shadow (nathangrave3000) wrote :

Get this bug when i return to use the pc after screensaver (just black screen) has been active. Happened on Jaunty after upgrade from intrepid

I don't want to use zhe screensaver, I have it disabled, nervertheless, this is one of the more regular crashes ( Jaunty Alpha3, AMD64,)

jan (jan-ubuntu-h-i-s) wrote :

This bug appeared on my PC just after the upgrade to Intrepid.
I have never seen it in hardy before the upgrade. Clear case of a regression problem.

Jean.c.h (slug71) on 2009-07-17
Changed in gnome-screensaver (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.