Notifications when switching between AC/battery power should be improved

Bug #399492 reported by Steve Dodier-Lazaro on 2009-07-14
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Medium
Unassigned
gnome-power
Fix Released
Low
gnome-power-manager (Ubuntu)
Wishlist
Unassigned
notify-osd (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: gnome-power-manager

Hello,

I'm writing this feature request because I believe power notifications can be greatly improved by being simplified to the strict necessary.

I began a discussion about this subject, that you can find on the Ayatana ML ( https://lists.launchpad.net/ayatana/msg00146.html ), and I ended up drafting new triggered and non-triggered notifications, as follows (preview of the result here : http://www.youtube.com/watch?v=fkdaiXXcv8w ) :

Icon info
Title "Power information"
Body "Computer is running on battery power
 Laptop battery 1 hour 45 minutes remaining (72.0%)"

Becomes

Icon notification-battery-070
Title "1:45 hours remaining"

I'll include a file (the shell script used for the video above) with many more examples, and proposals of improvement for the "battery low" notifications too. The icons are created and uploaded into the Human icon theme. If needed, they can be put in notify-osd. They basically convey the % left and plugged / not plugged information to make the text part lighter (images can hold much more meaning than words in some cases).

Obviously I think this is implementable only as an Ubuntu patch (at least till the notification-* icons get some recognition outside of notify-osd / ubuntu), but I still think it's worth a try as it makes notifications _really_ easier to read.

Voilà. If you need any other information about this feature request, please let me know ASAP. I really hope this can be done for Karmic.

Scott Howard (showard314) wrote :

Great presentation and idea. I can see on the mailing list that there is lots of support and feedback for this proposal. I'm marking as triaged/wishlist. Steve, are you working on the patch? If not I'll try to get a developer to look at this (or I'd take a crack at it).

Changed in gnome-power-manager (Ubuntu):
importance: Undecided → Wishlist
status: New → Triaged
tags: added: bitesize
Steve Dodier-Lazaro (sidi) wrote :

I would really love someone to take care of it, i currently have a few more important things to work on and i fear i won't be able to produce a decent patch for it before a while.

No problem, I'll try to find someone or take care of it.

On Wed, Jul 15, 2009 at 11:14 AM, Steve Dodier<email address hidden> wrote:
> I would really love someone to take care of it, i currently have a few
> more important things to work on and i fear i won't be able to produce a
> decent patch for it before a while.
>
> --
> Feature request : Possible improvements for notifications
> https://bugs.launchpad.net/bugs/399492
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “gnome-power-manager” package in Ubuntu: Triaged
>
> Bug description:
> Binary package hint: gnome-power-manager
>
> Hello,
>
> I'm writing this feature request because I believe power notifications can be greatly improved by being simplified to the strict necessary.
>
> I began a discussion about this subject, that you can find on the Ayatana ML ( https://lists.launchpad.net/ayatana/msg00146.html ), and I ended up drafting new triggered and non-triggered notifications, as follows (preview of the result here : http://www.youtube.com/watch?v=fkdaiXXcv8w ) :
>
> Icon info
> Title "Power information"
> Body "Computer is running on battery power
>  Laptop battery 1 hour 45 minutes remaining (72.0%)"
>
> Becomes
>
> Icon notification-battery-070
> Title "1:45 hours remaining"
>
> I'll include a file (the shell script used for the video above) with many more examples, and proposals of improvement for the "battery low" notifications too. The icons are created and uploaded into the Human icon theme. If needed, they can be put in notify-osd. They basically convey the % left and plugged / not plugged information to make the text part lighter (images can hold much more meaning than words in some cases).
>
> Obviously I think this is implementable only as an Ubuntu patch (at least till the notification-* icons get some recognition outside of notify-osd / ubuntu), but I still think it's worth a try as it makes notifications _really_ easier to read.
>
> Voilà. If you need any other information about this feature request, please let me know ASAP. I really hope this can be done for Karmic.
>

Steve Dodier-Lazaro (sidi) wrote :

Thanks in advance then :)

I think I forgot to mention that there also are -plugged icons (they're not in the video). The complete list of icons is :

notification-battery-000
notification-battery-000-plugged
notification-battery-010
notification-battery-010-plugged
[...]
notification-battery-090
notification-battery-090-plugged
notification-battery-100
notification-battery-100-plugged

Thanks, I'm going to start working on this in two phases, first the
text then the icons. This is because I think we may be able to get the
text approved upstream in GPM, but the icons may be harder to get
approved in GNOME. I'll post the PPA and branch for the text changes
when I get to it.

On Sun, Jul 26, 2009 at 10:32 AM, Steve Dodier<email address hidden> wrote:
> I think I forgot to mention that there also are -plugged icons (they're
> not in the video). The complete list of icons is :
>
> notification-battery-000
> notification-battery-000-plugged
> notification-battery-010
> notification-battery-010-plugged
> [...]
> notification-battery-090
> notification-battery-090-plugged
> notification-battery-100
> notification-battery-100-plugged
>
> --
> Feature request : Possible improvements for notifications
> https://bugs.launchpad.net/bugs/399492
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “gnome-power-manager” package in Ubuntu: Triaged
>
> Bug description:
> Binary package hint: gnome-power-manager
>
> Hello,
>
> I'm writing this feature request because I believe power notifications can be greatly improved by being simplified to the strict necessary.
>
> I began a discussion about this subject, that you can find on the Ayatana ML ( https://lists.launchpad.net/ayatana/msg00146.html ), and I ended up drafting new triggered and non-triggered notifications, as follows (preview of the result here : http://www.youtube.com/watch?v=fkdaiXXcv8w ) :
>
> Icon info
> Title "Power information"
> Body "Computer is running on battery power
>  Laptop battery 1 hour 45 minutes remaining (72.0%)"
>
> Becomes
>
> Icon notification-battery-070
> Title "1:45 hours remaining"
>
> I'll include a file (the shell script used for the video above) with many more examples, and proposals of improvement for the "battery low" notifications too. The icons are created and uploaded into the Human icon theme. If needed, they can be put in notify-osd. They basically convey the % left and plugged / not plugged information to make the text part lighter (images can hold much more meaning than words in some cases).
>
> Obviously I think this is implementable only as an Ubuntu patch (at least till the notification-* icons get some recognition outside of notify-osd / ubuntu), but I still think it's worth a try as it makes notifications _really_ easier to read.
>
> Voilà. If you need any other information about this feature request, please let me know ASAP. I really hope this can be done for Karmic.
>

Steve Dodier-Lazaro (sidi) wrote :

Thanks. Indeed the icons are going to be a bit tough for upstream :)

Changed in gnome-power-manager (Ubuntu):
assignee: nobody → Scott Howard (showard314)
status: Triaged → In Progress

I really like the proposal, just watched the video. I suggest to open a bug at bugzilla.gnome.org to discuss these string changes; Richard is amazlingly responsive there, and translation-wise we absolutely need to get them upstream.

BTW, do we need the new icons to be approved by GNOME first? gnome-power-manager already ships its own icons, so it would just be about adding a few?

However, please do take care to make the text comprehensible without icons, to not ruin accessibility. The texts I saw in the video were fine, just pointing it out to keep it in mind.

Thanks for working on this!

Steve Dodier-Lazaro (sidi) wrote :

I am not sure that they would like the icons, as they're notification-* icons that afaik only exist in Ubuntu's Human theme right now. Replacing the current icons isn't possible either as these are specially designed for notifications (ie. color only for icons meant to be used in critical notifications, otherwise grey-scale, and not designed for use in a panel at all).

For the text comprehensibility in case of a lack of icon, every case should be ok except maybe the trigger of XF86Power while plugged, since one would not know how filled his/her battery is at the moment, only how long till it is full. Is it possible to easily detect the presence of an icon ? If they are absent, maybe g-p-m could be (a little) more verbose in some cases. If this isn't possible, the only other option would be to add a setting for more verbose notifications (which I think is not great), or make them more verbose by default (which I think isn't very great either).

I really don't know anyone in upstream GNOME, and they might be more receptive to someone they already know. ;)

Steve Dodier [2009-07-29 22:52 -0000]:
> I am not sure that they would like the icons, as they're notification-*
> icons that afaik only exist in Ubuntu's Human theme right now. Replacing
> the current icons isn't possible either as these are specially designed
> for notifications (ie. color only for icons meant to be used in critical
> notifications, otherwise grey-scale, and not designed for use in a panel
> at all).

Would it be totally bad to use another icon color theme with
notify-osd? Most colors should go along well with the dark gray
background?

> For the text comprehensibility in case of a lack of icon, every case
> should be ok except maybe the trigger of XF86Power while plugged, since
> one would not know how filled his/her battery is at the moment, only how
> long till it is full. Is it possible to easily detect the presence of an
> icon ?

Yes, but that wasn't my only concern. If you use a11y technologies,
and a blind person is in front of the computer, you do have the icon,
but it's not of any value to the user.

The other texts were self-contained, can't we just make this last
string, too?

Thanks for the input Martin. I sent this upstream: http://bugzilla.gnome.org/show_bug.cgi?id=590259 . Steve, could you add yourself to the cc: list for that one?

Changed in gnome-power:
status: Unknown → Confirmed

From Richard Hughes, author of GPM, in response to our bug request:

> For example, right now GPM gives the following notification:
> title = "Power Information"
> message = "Laptop battery fully charged (100%). Provides 2 hours 5 minutes
> battery runtime."
>
> Can be made:
> title = "Battery full"
> message = "2 hours 5 minutes battery runtime available"

Sure, agreed.

> Some more information:
> 1) Usually the strings are constructed as follows:
> "<DEVICE NAME> <event> <time>. ( <percentage> )"
> <DEVICE NAME> is chosen to be the verbose "Laptop battery" to distinguish
> between phone, keyboard, laptop, etc. However, on systems without any
> peripherals, it could be just "Battery." Additionally, even systmes with
> peripherals "Battery" would be inferred to mean "Laptop battery," so it may not
> be necessary.

No, I just had battery there before, and I got bugs about _which_ battery it
was referring to... If there are no other battery type devices present, I guess
this makes sense.

> 2) having both <time> and ( <percentage> ) may be redundant.

Only if the time is accurate -- which on some systems it's not.

> 3) the title "Power Information" could be dropped for something more
> descriptive for each event (such as "Battery full" or "AC unplugged")

I agree with this.

> On launchpad I started developing a mock-up patch to test some of these ideas
> to get user feedback when Martin Pitt suggested we send this upstream since we
> would also need translation support and feedback from GNOME.

Totally, there's no point developing this in sekret just for Ubuntu.

> The specification also includes new icons, which is discussed on both the ML
> and launchpad site.

I think the new icons could be harder to swallow -- but you could raise this
topic on desktop development list and see what the feedback is.

Anyway, patches welcomed with open arms. Please do patches against git master.
Thanks.

Richard.

@Scott Howard :
Could you take a look at this?
https://bugs.launchpad.net/ubuntu/+source/gnome-power-manager/+bug/404525

Its somewhat similar , all it needs it a second *simultaneous* notification sending the info about the battery / AC state

Scott Howard (showard314) wrote :
Download full text (4.2 KiB)

The first package is ready for testing.
This is my first time packaging, patching, using ppas, and bzr - so please bear with the extra commits and ppa versions while I figured out how to actually upload the files!

The ppa is here:
https://launchpad.net/~showard314/+archive/ppa

Could you please test it and check out why descriptions below (I'm running ~ppa3 now but don't have a good enough laptop with me to test it on)? Known bug: if you use this version with a latpop that has UPS, phone, wireless keyboard/mouse, or PDA attached to it, the peripheral battery information will be notified just as "battery" and not "phone battery" (this has to be fixed)

Also, if anyone knows quick ways to improve this or wants to work on the TO DOs below, please grab the bzr branch and work on the 09-concise-notification-osd patch!

Changes:

LOW BATTERY
[old]
title = "Laptop battery low"
message = "You have approximately 25 minutes of remaining battery life (10%)"
[new]
title = "Battery low"
message = "25 minutes remaining"
[TO DO]
-write a check to see if any other battery device peripherals(PDA, phone, wireless mouse/kb, UPS) exist on the system, if they do the title should remain "Laptop battery low" (does anyone know how to do that off the top of their head? I can figure it out but it may take a while...)
- we might need to make the message "25 minutes remaining (10%)" since the % is more accurate than the time

CRITICALLY LOW BATTERY
[old]
title = "Laptop battery critically low"
message = "You have approximately 25 minutes of remaining battery life (10%). This computer will <EVENT> in 15 minutes if the AC is not connected."
[new]
title = "Battery critically low"
message = "This computer will <EVENT> in 15 minutes."
[TO DO]
-write a check to see if any other device peripherals exist on the system, if they do the title should remain "Laptop battery critically low" to distinguish between the laptop battery and peripheral batteries
- we might need to make the message "This computer will <EVENT> in 15 minutes if the AC is not connected." to explicitly say what the alternative is (or is this intuitive?)

BATTERY FULL
[old]
title = "Power Information"
message = "Laptop battery fully charged (100%). Provides 2 hours 5 minutes of runtime."
[new]
title = "Power Information"
message = "Battery is full. Provides 2 hours 5 minutes runtime."
[TO DO]
- The "Power Information" title comes from one function, and the description string comes from another function. We would have to add a way to change the title depending on the event. Ideally the title = "Battery full" and the message = "Provides 2 hours 5 minutes of runtime"
- correct the bug where all batteries are labelled as "battery." this can be fixed by defining the string type_desc to be "Battery" if there are no peripherals and "Laptop battery" if there are peripherals.

BATTERY DISCHARGING
 [old]
title = "Power Information"
message = "Laptop battery 2 hours 5 minutes remaining (85%)."
[new]
title = "Power Information"
message = "2 hours 5 minutes remaining."
[TO DO]
- The "Power Information" title comes from one function, and the description string comes from another function. We would have to add a way to cha...

Read more...

Vish (vish) wrote :

Icon labels need *not* be requested, Gnome power manager already recognizes these 15 icons: [1]

The icon change can be done in the notify-osd ,
[ex: right now, the notify-osd wireless connect notification uses the notification-network-wireless-full.svg ,
whereas the signal sent by the nm-manager is to use nm-device-wireless ,
notify-osd changes the icon] similar change for gpm can be done in the notify-osd side.

There are already 15icons in gpm already ,We only need the 7 more icons , using the gpm label.That should be an easy request.
Or if gpm declines the request to have the 10,30,50,70,90 status icons we could just use these 15 in the gnome package
but have more increments in the ubuntu package

[1]
/usr/share/gnome-power-manager/icons/hicolor/scalable/status/gpm-ac-adapter.svg
/usr/share/gnome-power-manager/icons/hicolor/scalable/status/gpm-battery-000.svg
/usr/share/gnome-power-manager/icons/hicolor/scalable/status/gpm-battery-000-charging.svg
/usr/share/gnome-power-manager/icons/hicolor/scalable/status/gpm-battery-020.svg
/usr/share/gnome-power-manager/icons/hicolor/scalable/status/gpm-battery-020-charging.svg
/usr/share/gnome-power-manager/icons/hicolor/scalable/status/gpm-battery-040.svg
/usr/share/gnome-power-manager/icons/hicolor/scalable/status/gpm-battery-040-charging.svg
/usr/share/gnome-power-manager/icons/hicolor/scalable/status/gpm-battery-060.svg
/usr/share/gnome-power-manager/icons/hicolor/scalable/status/gpm-battery-060-charging.svg
/usr/share/gnome-power-manager/icons/hicolor/scalable/status/gpm-battery-080.svg
/usr/share/gnome-power-manager/icons/hicolor/scalable/status/gpm-battery-080-charging.svg
/usr/share/gnome-power-manager/icons/hicolor/scalable/status/gpm-battery-100.svg
/usr/share/gnome-power-manager/icons/hicolor/scalable/status/gpm-battery-100-charging.svg
/usr/share/gnome-power-manager/icons/hicolor/scalable/status/gpm-battery-charged.svg
/usr/share/gnome-power-manager/icons/hicolor/scalable/status/gpm-battery-empty.svg

@Martin
Notify-osd doesn't allow theming yet, but even if it did (i hope it will for
karmic), it's better to limitate to one color (grey) than allowing every
kind of colors, which would cause more contrast / different contrasts in the
bubbles and be more prone to grab the user's focus (which we want to avoid
for non critical notifications).

@Richard

If the remaining time information isn't accurate, how will the percentage
one be more accurate than it ? :/

@Scott

I'll test the PPA as soon as I boot on Karmic.

@Mac

No, they're not the same icons :) gpm-battery are planned for ~24px in
panels with colours. notification-battery icons are planned for ~40/48px in
black bubbles without colours.

But the icons could be only in Ubuntu if gnome doesn't want them till we can
make them "standard" in fd.o

@Steve Dodier :
The gpm-* *icons are all 48px* in the scalable folder these can be used, they have separate icons for panel.
The icons are in all sizes[16,22,24,32,48]

we dont have to use them , we use the icons for notifications from the human theme[that change can be done in the notify-osd] ,
gnome can use these gpm icons in their notification-daemon , they would prefer to have color icons.

Doing it this way[changing icons in notify-osd], we dont have to make constant changes in gpm-Ubuntu,
that way gnome-power-manager can be maintained upstream itself.

Oh ok, I misunderstood you, sorry. Indeed, G-p-m could use the gpm icons for
this since it's likely that the notification-* icons can't be used, and we
can push ours locally. Richard, is it possible to write a simple function
returning the correct icon with, as parameters :
 * guint percent_left
 * gboolean plugged

And possibly another parameter if you make a distinction between different
types of batteries for each icon ? This would considerably simplify the
maintenance of the ubuntu-side patch till someone makes the effort of
getting the icons in freedesktop.org.

@Martin, Scott
I'm not much of a fan of the % left information, as it is indeed redundant
with the time left information and can be transferred to the icon in most
cases. Isn't it possible in GTK+ to specify an alternative text to use if an
icon is missing ? Is it possible, from g-p-m, to know whether the user uses
a11y technologies, and whether or not they allow rendering of images ? I
think such an infrastructure should exist.

Scott Howard (showard314) wrote :

@Mac & Steve
thanks for working out the icons. I saw the icons in the source code
and am not familiar with notify-osd, so your help on this is great.
Let me know if there is anything you need in the code to make it work
(I'm working on the upstream project).

@ Steve
The percentages are more accurate since devicekit-power only receives
percentage information from the battery. GPM then does a quick
calculation based on past history of the battery to find how much time
is left. If batteries are broken or old, the time information can be
grossly inaccurate.

Also, I believe the function you request (returning the correct icon
with, as parameters: * guint percent_left * gboolean plugged) exists
and is currently in use with gnome-power-manager. With the patched
version, you may see it working since I believe Martin disabled the
notify-osd patches in it. The function is in:

src/gpm-devicekit.c

http://bazaar.launchpad.net/~vcs-imports/gnome-power/trunk/annotate/head%3A/src/gpm-devicekit.c
[or]
http://git.gnome.org/cgit/gnome-power-manager/tree/src/gpm-devicekit.c

function name: gpm_devicekit_get_object_icon [this file name is in
the format of comment #16]
Returns: filename as a gchar
Takes one argument (DkpDevice) [DkpDevice is laptop battery, phone
battery, wireless mouse battery, etc.]

The function will check the battery for it's percentage and return
with the correct filename.

In that case, we can make the argument to drop the % since it is
already included in the battery icon. And if they really want to see
it, a user can open power preferences. When it comes to notifications,
only the most important information should be shown - which is the
time remaining.

new ppa is up: https://launchpad.net/~showard314/+archive/ppa

Pretty much finalized low and critical battery notifications:

from the todo
- [DONE] write a check to see if any other battery device peripherals(PDA, phone, wireless mouse/kb, UPS) exist on the system, if they do the title should remain "Laptop battery low"

- [WON'T DO] we might need to make the message "25 minutes remaining (10%)" since the % is more accurate than the time -- if the battery is low/critically low, all that matters is the amount of time left, not the % left - so we don't need to tell users %. Same with "shut down in X minutes, you have Y minutes remaining" They don't need to know how much battery is left (Y) is their computer will be turned off in X minutes.

Vish (vish) wrote :

@Scott:
Just tested your ppa, there are some problems,
-the panel icon used doesnt change with the theme, it uses *only* the gpm hicolor icons
-the brightness notifications are now using the old notifications-daemon rather than notify-osd.

Also i dont know if this has been removed from gpm or just missing from the ppa, there is No "on battery" tab in the power preferences.

Vish (vish) wrote :

Ah... Found the error, themes label the icons for *panels* ,
/gpm-primary-***-charging.svg
/gpm-primary-***.svg

Seems you have it coded to use the gpm-battery-* ,
[i had suggested using the gpm-battery-* for the notifications only]

-Icons are not used in the power notifications.

-The notification for battery full uses the gtk-dialog-info icon. it needs to use the battery full icon.[or maybe battery-full-charging icon]

@Mac

Scott is writing a first patch without the notification-* icons for
inclusion upstream.

The problem with brightness notifications comes from global breakage of the
new g-p-m :P

Scott Howard (showard314) wrote :

I'm just working on the strings and not touching the icons yet. This
is because the strings patch will go upstream and the icons/notify-osd
patch should be done within Ubuntu. I'm getting close to finishing it
and sending it upstream.

Ubuntu used to have it's own notify-osd patch, but Martin Pitt has
disabled the notify-osd patch for GPM
(https://bugs.launchpad.net/ubuntu/+source/gnome-power-manager/+bug/406396)
since upstream has changed how they handle notifications.

The notify-osd patch needs to be rewritten, see bug #406396. Would
either of you be able to work on that side of it? I took a stab at it
here: bug 390669, but that patch was written against 2.27.1, I updated
it to 2.27.2, and soon we will have 2.27.3.

On Sun, Aug 2, 2009 at 4:07 PM, Steve Dodier<email address hidden> wrote:
> @Mac
>
> Scott is writing a first patch without the notification-* icons for
> inclusion upstream.
>
> The problem with brightness notifications comes from global breakage of the
> new g-p-m :P
>
> --
> Feature request : Possible improvements for notifications
> https://bugs.launchpad.net/bugs/399492
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Gnome Powermanager: Confirmed
> Status in “gnome-power-manager” package in Ubuntu: In Progress
>
> Bug description:
> Binary package hint: gnome-power-manager
>
> Hello,
>
> I'm writing this feature request because I believe power notifications can be greatly improved by being simplified to the strict necessary.
>
> I began a discussion about this subject, that you can find on the Ayatana ML ( https://lists.launchpad.net/ayatana/msg00146.html ), and I ended up drafting new triggered and non-triggered notifications, as follows (preview of the result here : http://www.youtube.com/watch?v=fkdaiXXcv8w ) :
>
> Icon info
> Title "Power information"
> Body "Computer is running on battery power
>  Laptop battery 1 hour 45 minutes remaining (72.0%)"
>
> Becomes
>
> Icon notification-battery-070
> Title "1:45 hours remaining"
>
> I'll include a file (the shell script used for the video above) with many more examples, and proposals of improvement for the "battery low" notifications too. The icons are created and uploaded into the Human icon theme. If needed, they can be put in notify-osd. They basically convey the % left and plugged / not plugged information to make the text part lighter (images can hold much more meaning than words in some cases).
>
> Obviously I think this is implementable only as an Ubuntu patch (at least till the notification-* icons get some recognition outside of notify-osd / ubuntu), but I still think it's worth a try as it makes notifications _really_ easier to read.
>
> Voilà. If you need any other information about this feature request, please let me know ASAP. I really hope this can be done for Karmic.
>

Oh... OK.
Since i'v upgraded to Karmic I'v been running only on AC mains, so i guess i didnt notice that change in the *panel* icons.

Scott Howard (showard314) wrote :

ppa updated, the string patch should be complete now. I'll test it for a couple more days before sending upstream. Here are the overall changes:

Battery charged:
title = "Battery Charged"
message = NONE
(message used to be: "Your laptop battery is now fully charged")
todo: change title from "battery charged" -> battery fully charged

Battery discharging (actually removed in Ubuntu, but in the upstream version):
title ="Battery Discharging"
message = "The AC power has been unplugged."
(message used to be "The AC power has been unplugged. The system is now using battery power.")

Critical and Low battery warnings:
If you have no peripheral batteries (pda, phone, kb, mouse, UPS):
title = "Battery low"
if you have peripherals:
title = "Laptop battery low"
message = "25 minutes remaining"
or in the case of critical battery
message = "25 minutes until shutdown"
(old message showed percentage remaining and had the warning "...if the AC is not connected.")
(Also removed the sentence You have approximately 25 minutes of remaining battery life (percent%). since the battery life remaining and % *beyond* the critical shutdown point doesn't matter since your computer will shutdown before you even see it.)

Mouse over notification bubbles:
title = NOTHING (used to be nondescript "Power Information")

When announcing the battery is full, it now does not show the percentage (since it would be redundant).

The other notifications should stay verbose since GPM doesn't just manage laptop batteries. This way you can see the power status of every peripheral in your system at once by mousing over the applet. Any comments regarding these changes? Try to plug in phones/pdas and make sure it's working properly.

Changed in hundredpapercuts:
milestone: none → round-5
status: New → Confirmed
Vish (vish) wrote :

Now that the specs are updated Bug #404525 would be a duplicate of this?
[its a report to display notification of the power status , which was previously disabled . But now that this is being fixed , its almost a dup]

Vish (vish) wrote :

Adding the notify-osd task due to the latest notify-osd specs.

Changed in notify-osd (Ubuntu):
status: New → Confirmed
Matthew Paul Thomas (mpt) wrote :

The Notify OSD spec covers changes to other software desired for compatibility with Notify OSD. No changes are needed to Notify OSD itself to fix this bug.

Changed in notify-osd (Ubuntu):
status: Confirmed → Invalid
Matthew Paul Thomas (mpt) wrote :

Thanks to mac_v for correcting me: since Notify OSD uses custom icons for volume, brightness, and wireless, it makes sense that Notify OSD should use custom icons for battery charge too.

Changed in notify-osd (Ubuntu):
status: Invalid → New
Mirco Müller (macslow) on 2009-08-06
Changed in notify-osd (Ubuntu):
importance: Undecided → Wishlist
status: New → Confirmed

The icons have to come from the application, though. We will just need a
ubuntu patch for g-p-m.

upstream now has the patch to improve the notification strings. The link bzr branch includes the patch. Feel free to grab it if anyone needs it.

Changed in gnome-power-manager (Ubuntu):
assignee: Scott Howard (showard314) → nobody
status: In Progress → Triaged
summary: - Feature request : Possible improvements for notifications
+ Notifications for switching between AC/battery power should be improved
summary: - Notifications for switching between AC/battery power should be improved
+ Notifications when switching between AC/battery power should be improved
Scott Howard (showard314) wrote :

upstream committed lots of string changes, including our string changes:
http://git.gnome.org/cgit/gnome-power-manager/commit/?id=0bfe44b903dc12512c7e99579c35bbd62a331d28

The change when switching between AC/battery power was accepted as follows:
title ="Battery Discharging"
message = "Laptop battery 2 hours 5 minutes remaining (80%)"
(message used to be "The AC power has been unplugged. The system is now using battery power.")

Changed in notify-osd (Ubuntu):
status: Confirmed → Triaged

Fixed upstream.

Changed in hundredpapercuts:
status: Confirmed → Fix Committed
Andrew (and471) on 2009-09-02
Changed in gnome-power:
status: Confirmed → Fix Committed
Mirco Müller (macslow) on 2009-09-30
Changed in notify-osd (Ubuntu):
status: Triaged → Invalid
Mat Tomaszewski (mat.t.) wrote :

This is still an issue in Karmic. The notification says "Battery Discharging" "Laptop battery discharging (%)". There is very little value in such information (especially if it's repeated twice).

Changed in hundredpapercuts:
status: Fix Committed → Triaged
importance: Undecided → Medium

It's repeated twice because Gnome Power Manager doesn't just manage
laptop batteries, but also manages phone, keyboard, mouse, UPS, and
PDA batteries. The string originally used to say:
"Laptop Battery Discharging" "Laptop battery discharging (%)"
(because the other options are "UPS battery discharging", etc.)

We changed it so that if you only have a laptop battery it would say:
"Battery Discharging" "Laptop battery discharging (%)"

If you have adequate power history or a battery that GPM could
identify the amount of time left, you should also see the time
remaining.

On Fri, Oct 2, 2009 at 5:25 AM, Mat Tomaszewski
<email address hidden> wrote:
> This is still an issue in Karmic. The notification says "Battery
> Discharging" "Laptop battery discharging (%)". There is very little
> value in such information (especially if it's repeated twice).
>
> ** Changed in: hundredpapercuts
>       Status: Fix Committed => Triaged
>
> ** Changed in: hundredpapercuts
>   Importance: Undecided => Medium
>
> --
> Notifications when switching between AC/battery power should be improved
> https://bugs.launchpad.net/bugs/399492
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Gnome Powermanager: Fix Committed
> Status in One Hundred Paper Cuts: Triaged
> Status in “gnome-power-manager” package in Ubuntu: Triaged
> Status in “notify-osd” package in Ubuntu: Invalid
>
> Bug description:
> Binary package hint: gnome-power-manager
>
> Hello,
>
> I'm writing this feature request because I believe power notifications can be greatly improved by being simplified to the strict necessary.
>
> I began a discussion about this subject, that you can find on the Ayatana ML ( https://lists.launchpad.net/ayatana/msg00146.html ), and I ended up drafting new triggered and non-triggered notifications, as follows (preview of the result here : http://www.youtube.com/watch?v=fkdaiXXcv8w ) :
>
> Icon info
> Title "Power information"
> Body "Computer is running on battery power
>  Laptop battery 1 hour 45 minutes remaining (72.0%)"
>
> Becomes
>
> Icon notification-battery-070
> Title "1:45 hours remaining"
>
> I'll include a file (the shell script used for the video above) with many more examples, and proposals of improvement for the "battery low" notifications too. The icons are created and uploaded into the Human icon theme. If needed, they can be put in notify-osd. They basically convey the % left and plugged / not plugged information to make the text part lighter (images can hold much more meaning than words in some cases).
>
> Obviously I think this is implementable only as an Ubuntu patch (at least till the notification-* icons get some recognition outside of notify-osd / ubuntu), but I still think it's worth a try as it makes notifications _really_ easier to read.
>
> Voilà. If you need any other information about this feature request, please let me know ASAP. I really hope this can be done for Karmic.
>

Vish (vish) wrote :

As per Scott's last comment.

Changed in hundredpapercuts:
status: Triaged → Fix Released
Vish (vish) wrote :

This bug was fixed a long time ago.
gnome-power-manager (2.27.91-0ubuntu2) UNRELEASED; urgency=low

  * debian/patches/03-remove-discharging-notify.patch:
    - Removed because of new notify OSD spec (LP: #419858)
      Upstream accepted our change so the notification matches Ubuntu's spec

 -- Scott Howard <email address hidden> Thu, 27 Aug 2009 20:37:29 -0400

Changed in gnome-power-manager (Ubuntu):
status: Triaged → Fix Released
Changed in gnome-power:
importance: Unknown → Low
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.