Hardy rhythmbox stops screen from blanking on laptop lid close

Bug #193617 reported by Booljayj on 2008-02-20
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-power-manager (Ubuntu)
High
Ted Gould

Bug Description

On a Dell e1505 Laptop with Hardy Heron Alpha 4, the laptop screen will not blank out on a lid close if rhythmbox is running. The power preferences are all perfectly set, and when rhythmbox is not running the screen blanks out perfectly, but if rhythmbox is running the screen will not shut off. A pop-up appears over the power icon in the notification area that says "Request to do policy action-- Music Player has stopped the policy action from taking place: playing." This bug also applies to pressing the power button (in order to lock the screen). If rhythmbox is running, the button does nothing, and the same pop-up appears.

When the screen remains on, it tends to heat up the laptop very quickly, which risks hardware overheating.

muszek (muszek) wrote :

I can confirm that. Running Dell Inspiron 1720.

Changed in gnome-power-manager:
status: New → Confirmed
Miguel Ruiz (mruiz) wrote :

I confirm this issue with Hardy Heron up to date.

Cheers!

jfestrada (jfestrada) wrote :

Hi, I think that these issue is due to version of Rhythmbox, because I have the same problem with Gutsy and Rhythmbox 0.11.4 which is the version of Rhythmbox on Hardy.

Oh sorry I forgot to say that my laptop is a apple MacBook C2D.

Best reegards.

Michael Rooney (mrooney) wrote :

This same issue prevents shutting down the computer when Rhythmbox is playing in an up-to-date Hardy Beta install. Is this actually gnome-power-manager or rhythmbox? Either way, pretty serious. This seems like a showstopper bug to me. People are going to want to shut down/restart/suspect/etc their computers without manually stopping their music.

Setting importance to High since it "has a moderate impact on a large portion of Ubuntu users (estimated)"

Changed in gnome-power-manager:
importance: Undecided → High
Michael Rooney (mrooney) wrote :

In related (if not duplicate) bug #78038, Sebastian offers the solution: "That is a new plugin, it should probably be listed by the interface though, you can stop it by changing the /apps/rhythmbox/plugins/power-manager/active gconf key to false."

This solution fixes the issue for me.

I found other mentions here (http://lists.alioth.debian.org/pipermail/pkg-gnome-maintainers/2007-April/033797.html) with the suggestion by Julien "I guess the correct behaviour of this plugin is to prevent the screensaver from starting (though I don't understand why this would be necessary with an audio player). I would thus recommand this plugin to be disabled by default, or at least not hidden."

Unless this plugin serves some useful purpose I am not aware of, I would agree strongly with the recommendation to disable it by default, and certainly at least not hide it! (/apps/rhythmbox/plugins/power-manager/hidden)

Can confirmers of the non-blanking screen issue change the key as per Sebastians solution and see if this fixes the issue? If someone could do it I would greatly appreciate it; then I can mark this as a duplicate of the other bug and merge the progress. Thanks!

Changed in gnome-power-manager:
assignee: nobody → ted-gould
Cory Dodt (corydodt) wrote :

This affects Banshee, too. Is there a similar workaround for banshee? I didn't see any power-related plugins or settings.

Ted Gould (ted) wrote :

I believe that I have a patch for this. Could you guys please try the patch that is included in gnome-power-manager_2.22.1-0ubuntu3~ppa2 in my PPA:

http://launchpad.net/~ted-gould/+archive

It should make it so that the screen always turns of when the lid is shut whether or not another app inhibits GPM.

Thanks. Ted.

Michael Rooney (mrooney) wrote :

Thanks for providing a PPA, Ted. Would you mind providing a few instructions on how to have that version replace my g-p-m without having the other packages in there replace anything else? What do I need to do past putting those two lines in my /etc/apt/sources.list?

On Sat, 2008-04-05 at 00:14 +0000, Mike Rooney wrote:
> Thanks for providing a PPA, Ted. Would you mind providing a few
> instructions on how to have that version replace my g-p-m without having
> the other packages in there replace anything else? What do I need to do
> past putting those two lines in my /etc/apt/sources.list?

Yes. If you put those two lines in your PPA you can then upgrade the
packages. You can do that using Synaptic which is in
System->Administration->Synaptic Package Manager which will show all the
packages in the system. You can then select gnome-power-manager, right
click on it to mark it for upgrade. Then you can click the check mark
in the toolbar to apply the changes.

Michael Rooney (mrooney) wrote :

Hi Ted,

The patched g-p-m seems to fix the issue of the screen not blanking and no policy action dialog appears! The strange thing is that if I set the laptop to do nothing on closing the lid, it correctly does nothing, but the policy action prevented dialog still appears. I wonder what it thinks it is preventing!

However, the user is still unable to shutdown/restart/etc with the Rhythmbox power plugin enabled. Should that be opened as a separate bug and perhaps this patch released to fix this issue?

Ted Gould (ted) wrote :

On Sun, 2008-04-06 at 14:41 +0000, Mike Rooney wrote:
> The patched g-p-m seems to fix the issue of the screen not blanking and
> no policy action dialog appears! The strange thing is that if I set the
> laptop to do nothing on closing the lid, it correctly does nothing, but
> the policy action prevented dialog still appears. I wonder what it
> thinks it is preventing!

Ah, oops. I'll fix that tomorrow, I don't have time today. Thank you
for catching that and I'm glad the majority works.

> However, the user is still unable to shutdown/restart/etc with the
> Rhythmbox power plugin enabled. Should that be opened as a separate bug
> and perhaps this patch released to fix this issue?

No, that's actually intended as part of the design. We don't block
users from shooting themselves in the foot, otherwise we'd have to
delete all Windows partitions on install! ;)

Cory Dodt (corydodt) wrote :

Will this patch to g-p-m also fix Banshee?

Cory Dodt (corydodt) wrote :

Actually here's a better question: will this patch allow *suspend* (not just screen blanking) when the laptop lid closes? I saw in another bug that several apps are getting dbus calls added for various reasons to prevent suspend.

This is a *really* bad idea.. it damages laptops! If the user has left headphones plugged in or muted the sound, it will prevent the laptop from suspending when the lid closes, which means overheating in the laptop and damaged components and shorter hardware lifespan.

Laptop lid close should trump all, for hardware safety if for no other reason.

Michael Rooney (mrooney) wrote :

You know Cory, if you are curious you could (and to improve the testing of this patch, should) just try it ;]

I want to add in here that I REALLY agree that whatever I select in my power settings should be what happens! I am really not liking this emerging trend of applications saying "well I know you have set your power settings to do A on lid close/power button press/timeout/etc, but actually I know better than you and instead am going to do B! ha ha ha!"

If I push the power button, I want the computer to do whatever I have it set to do. Not tell me it won't because music is playing.

However, I like the idea of a plugin to deny this, and I think it makes sense here, but not as default behavior. For users who set their laptop to suspend on close, I can see where they might want it to not suspend if music is playing, and a plugin for the music player seems like a good way to accomplish this. Because of that this sort of thing shouldn't be disallowed entirely as Cory suggested, just non-default. If a user wants it to not suspend, they should be able to enable the plugin and not have that be ignored.

Cory Dodt (corydodt) wrote :

I agree with you in principal actually, but I think the problem has been poorly-defined. We need a separate definition: call it "active" power management and "passive" power management.

In active PM, the user has taken an action to cause it to happen, i.e. press the power button, pick the shutdown menu item, or closed the lid.

In passive PM, the system is doing something power management related because a timeout has expired.

In my opinion apps should never be able to prevent the first kind without some kind of system-level setting changed. Perhaps label it "allow applications to override lid closing/power button". Default to "no". Then your plugins can work.

The second, passive kind is the kind I think these features are *intended* to block, and maybe they ought to be able to. As long as we're adding settings, make this one a setting too, but default to "yes".

Michael Rooney (mrooney) wrote :

Yes Cory, I think we agree. To summarize my points, the user's preference (in g-p-m) should correspond with what actually happens by default. Second, things should be able to override g-p-m (such as the rhythmbox plugin) but these behaviors should be non-default.

I think it is much better for users who want something to have to find out how to enable it, than to put the burden on people who do not want it, to have to research how to disable it.

Ted Gould (ted) wrote :

On Sun, 2008-04-06 at 14:41 +0000, Mike Rooney wrote:
> The patched g-p-m seems to fix the issue of the screen not blanking and
> no policy action dialog appears! The strange thing is that if I set the
> laptop to do nothing on closing the lid, it correctly does nothing, but
> the policy action prevented dialog still appears. I wonder what it
> thinks it is preventing!

Mike, please try 2.22.1-1ubuntu3~ppa3 and see if this if fixed.

Thanks. Ted.

Michael Rooney (mrooney) wrote :

Hi Ted. The latest patch works like a charm! Turns of the screen when it should, and doesn't display any g-p-m notices either way.

I think, as far as the other part of this bug is concerned (in regards to shutdown/suspect/etc), I will spin it off into a new bug, and this one can be fixed. They seem separate enough, as this one will fix the screen blanking for all apps, not just Rhythmbox, but my bug is more specific to Rhythmbox. Thanks!

Cory Dodt (corydodt) wrote :

Mike, please post the new bug here when it's open, as that's the one I'm more interested in following! :-)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-power-manager - 2.22.1-1ubuntu3

---------------
gnome-power-manager (2.22.1-1ubuntu3) hardy; urgency=low

  * Adding patch 09_lid_always_blanks.patch to make it so that a lid
    button will at least blank even when inhibitted. It also makes it so
    that inhibit can't block critical battery actions. LP: #193617

 -- Ted Gould <email address hidden> Tue, 08 Apr 2008 08:42:22 -0700

Changed in gnome-power-manager:
status: Confirmed → Fix Released
Michael Rooney (mrooney) wrote :

Cory, if I were to file a new bug I think it would be a duplicate of bug #78038, so I would recommend subscribing to that and adding some input there, and moving our discussion there. The importance should be Medium at least so lets do our parts in that bug.

And Ted, thanks for the great work here in this bug. I would like to think we saved some power and screen life with this one, which is great for an LTS.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers