Unplugging AC power when screen is dimmed interferes with brightness settings

Bug #163678 reported by Guido Conaldi on 2007-11-18
4
Affects Status Importance Assigned to Milestone
gnome-power-manager (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gnome-power-manager

In gutsy x86_64 on my dell xps m1330 unplugging the ac power when the screen is dimmed because the laptop is idle ruins the power management brightness options.

To reproduce:
select dim screen when idle both in ac and battery panel,
set ac brightness to 100%,
and decrease brightness by 20% when on battery.

Wait with the ac connected for the screen to go dim and then unplug ac: instead of decreasing by 20% brightness will go down considerably (80% less approximately). The dim when idle options won't work anymore.

The workaround is to deselect the dim when idle options, restore the brightness levels, log of, log on again and select the options again.

philsom (phil-somerville) wrote :

Similar experiences on Dell Inspiron 6000 using 8.04 x86_32

When "Dim display when Idle" was checked in power management, it would dim it but not return to the correct brightness when i continued to use the laptop.

Iulian Udrea (iulian) wrote :

Thank you for your report. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you?

Could you please attach the resulting log file of: gnome-power-bugreport.sh &> gpm.log to the report? You might also want to take a look to the Debugging instructions located at https://wiki.ubuntu.com/DebuggingGNOMEPowerManager for submit any other logs related to your problem.

Thank you.

Changed in gnome-power-manager:
importance: Undecided → Low
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

Closing this bug report as no further information has been provided. Please feel free to reopen this bug if you can provide the information asked for. Thanks!.

Changed in gnome-power-manager:
status: Incomplete → Invalid
Guido Conaldi (guido-conaldi) wrote :

I am reopening it as it is still and issue for me on a dell m1330 (both with ubuntu 8.04 x64 up-to-date and intrepid live alpha 3) with intel integrated graphics. Actually, the all brightness management is a bit broken, but here I report only about the issue when dimming on battery power:

1. brightness_reduced is on and brightness_battery set to 80.
2. Unplug the laptop
3. First time the brightness is dimmed by around 70%
3. Plug it in again and unplug
4. Brightness is now totally dimmed

Changing the brightness_battery value does not seem to make a difference.
All this is done after having blacklisted the video module. Otherwise since hardy brightness levels cannot be controlled properly on dell m1330.

I attach the requested log.

Guido Conaldi (guido-conaldi) wrote :

Still experiencing the issue and providing requested information

Changed in gnome-power-manager:
status: Invalid → New
Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Could you try to reproduce the same with Ubuntu 9.04 or 8.10? Thanks in advance.

Changed in gnome-power-manager (Ubuntu):
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to New. Thanks again!.

Changed in gnome-power-manager (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments