GNOME Power Manager installation problem

Bug #127617 reported by Matthew Nuzum on 2007-07-22
30
This bug affects 4 people
Affects Status Importance Assigned to Milestone
gnome-power-manager (Ubuntu)
Undecided
Ubuntu Desktop Bugs

Bug Description

After a fresh install of Gutsy tribe 3 I get a pop-up in the bottom right corner of the screen telling me that "the configuration defaults from GNOME Power Manager have not been installed correctly..." (see screenshot)

At the time of this screenshot I've not tried customizing anything. After this error I tried setting some of the settings and it appears something odd is happening... there is no option to change the settings for the computer when running on battery.

Before I did this install I wiped my home directory's dot files so that I'd get default settings.

Maybe related, but I'll open another bug for this, when I try to suspend my computer nothing happens.

Matthew Nuzum (newz) wrote :

Anything I can do to help get this problem resolved? There are some kernel bugs I need to work on and I need to get past this to rule it out as the cause of the other problems I'm having. (see Bug #128314 and Bug #128317)

Matthew Nuzum (newz) wrote :

Wow, you guys are FAST! I just did an update and now it works! I'm not sure what package fixed it, 16 were installed in the update.

Dean Sas (dsas) wrote :

Hmm, no g-p-m updates in that time, maybe it was a lower level problem? Marking as fix released, feel free to set back to 'New' if this reoccurs.

Changed in gnome-power-manager:
status: New → Fix Released
e-r-i-k-98 (erik98) wrote :

Hey, I've got also that problem (tribe 4) and I even have NO BATTERY

I have the same problem, I have just done an routine ubgrade on Ubuntu Intrepid Ibex 8.10.

Changed in gnome-power-manager:
status: Fix Released → New

To be clear this has rendered Gnome unusable on my system, just after this error message the screen goes blank, and can not be used further.

I simply did a routine upgrade of Ubuntu, and experienced this after my first reboot after the upgrade.

Lionel Dricot (ploum) wrote :

Confirmed as multiple users seem to have the problem, even in Intrepid. Could it be linked to some kind of hardware failure ?

Changed in gnome-power-manager:
status: New → Confirmed
Andrzej Kłapeć (solidslash) wrote :

I'm experiencing the problem as well on my Jaunty system.
I'm getting this error while VLC is playing a video.

See attachment.

corner-face-jones (paul281987) wrote :

I just got this so i went into fail safe terminal and got this.

corner-face-jones (paul281987) wrote :
Mario Alvisi (mario-alvisi) wrote :

I'm having same problem on Jaunty 9.04. Have the ame message and video is completely black... how can I get rid of this issue?Anyone able to help please?

Bret Kuhns (bkuhns) wrote :

I'm having the same issue after receiving updates for Karmic 9.10 Beta. I can still log into my Gnome desktop just fine, but now power manager is unaware of my laptop's battery.

Bret Kuhns (bkuhns) wrote :

Interesting, I was installing a game from a .deb package using gdebi on the command line and after installing the game, gdebi started configuring a ton of other packages. Once it was done, a graphical pop-up told me I should restart my computer to complete the update. I had already restarted after updating and posting my earlier comment, and I wasn't running Update Manager this time? I restarted again, and now everything is back to normal. Very strange...

Flying Kiwi (ubuntu-paradise) wrote :

I have been experiencing this problem for about two months now, I am on Karmic 9.10, and after a routine upgrade was asked to reboot, so being an absolute novice with Ubuntu I did what I was told and rebooted the computer and ever since then have been getting the message "the configuration defaults for gnome power manager have not been installed correctly . . ." exactly as described above by others. I have spo0ken to work colleagues about this and they have suggested that as it was caused by an upgrade to just wait for another upgrade to remedy it, but it has been several months now with no visible change.

When I switch on the computer, (Acer desktop, 2Gb RAM,), often I get the usual small circular icon, then I very briefly get a message appearing, I am unable to read it as (1) the letters are very compressed and almost indecipherable (2) the message is displayed for about 1 or 2 seconds, then the display compresses to a narrow band across the middle of the screen and nothing else happens, no hard drive activity etc. If I force a reboot at this point I again get most of the above, but then I get the user name / password, but this is not the log on box I used to have. I can then log on as usual and everything appears to be "normal".

Have checked System / Preferences / Power Management, but everything appears to be correct.

Being a very new Ubuntu user, I don't want to go "fiddling" and FUBAR everything.

If someone has the time to take pity on me and point me in the right direction, it would be greatly appreciated.

Help . . .

Andreas (andreas-kotowicz) wrote :

I just tumbled across this problem on a 10.04 updated machine. any solutions?

Andreas (andreas-kotowicz) wrote :

turned out my hard drive was full (both / and /home reside on the same partition). after freeing some disk space the error message went away.

trusktr (trusktr) wrote :

I'm also having this problem in Arch Linux!

I get to the login screen and the login box in the middle is there, but the background is black and that error pops up at the bottom like for most everyone above.

If attempt to log in, it simply returns to the screen with the same message. :(

What in the world is going on?

The last thing i did was install Cube2: sabeareuten and i was able to play it without rebooting, then on next boot the error appeared!

Nuphar C (ncpiano) wrote :

oooh, I thought I was alone there with this problem for a second!

For me though it made the access to linux denied altogether and I have to log on to windows instead...Every time I try to log in through the linux partition I get this "gnome power manager was installed incorrectly" small message at the top right side of the screen, and it doesn't allow me to log in.
I don't know what caused it since it worked fine and then it just happened, don't remember doing something differently...
Any advice?

Eric Ross (eric-ross) wrote :

This problem is now affecting both my Sony laptop and my Acer netbook.

A week or more ago, I started having trouble with my laptop disk being full. Every time I deleted files it would free space for a few minutes and then I'd start getting errors when launching programs because the disk was full again. I've manually cleaned files and looked for processes, like backup routines that might consume disk space but no joy.

I am able to get to root window with network so have autoremoved, and cleaned, and removed, and --reinstalled, and upgraded and have ended up with a message saying "configuration defaults for GNOME Power Manager have not been installed correctly". I'm quite sure this is related to startup with 0 disk available and whatever process is gobbling up free disk as soon as I create it. My laptop has not been useable for several days now so I've been getting by with my netbook until now.

My netbook ha been running without the sound card and in low-graphics mode for a week or more until this morning when it warned me about the disk being full. I deleted image files and lots of others, and yes, emptied the trash but file manager status bar showed 20+GB free but the file manager continued to show 0 free. Now my netbook gives me the GNOME Power Manager error on startup.

I've taken all of the steps suggested with no improvement.

What could be consuming my disk space? I don't see log files, so what is it??

tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions