Clicking on clock applet hangs gnome-panel

Bug #203527 reported by Jim Qode on 2008-03-18
92
This bug affects 8 people
Affects Status Importance Assigned to Milestone
GNOME Panel
Fix Released
Critical
gnome-panel (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Hardy

Left clicking on clock applet hangs gnome-panel. Gnome-panel won't come up again even after killing X. Only "killall -9 gnome-panel" works.

Right clicking on clock does show the expected behaviour. There are no locations in Clock Preferences / Locations. This seems to be the culprit as adding one location fixes the behaviour.

Pedro Villavicencio (pedro) wrote :

Thanks for your bug report. Please try to obtain a backtrace http://wiki.ubuntu.com/DebuggingProgramCrash and attach the file to the bug report. This will greatly help us in tracking down your problem.

Jim Qode (jimqode) wrote :

gnome-panel does not crash. It just hangs. Is it possible to get a dump from a hanged program?

Pedro Villavicencio (pedro) wrote :

Yes you need to attach to it with GDB, take a look to https://wiki.ubuntu.com/DebuggingGNOMEApplets which contains some information about how to do it, thanks.

Jim Qode (jimqode) wrote :

Thank you for the information. I tried removing the location to recreate the bug but it didn't hang this this. I don't know how to recreate this apart from reinstalling hardy. I'll try reinstalling if I have the time.

Rached B (benmur) wrote :

I'm seeing this hang from time to time, and this morning I attached to gnome-panel with gdb with debug symbols installed and got a backtrace.

It seems to hang while getting the appointments list to populate the calendar/appointments widget. Evolution-data-server is running and evolution is accessing the calendar just fine.

I launched "dates" and it gets stuck at the same place (backtrace coming). So I'd be inclined to say that the hang is in libecal ...

Jim Qode (jimqode) on 2008-03-29
Changed in gnome-panel:
status: Incomplete → Confirmed
Matthew Tighe (tighem) wrote :

Went to report this today and launchpad showed me this bug. You can put me in the "me too" category.

Matthew Tighe (tighem) wrote :

I think the medium classification for this is too low. This can really impact your system. If you don't have a terminal window open and no shortcut to one on the desktop you are effectively locked up. Alt+F2 fails me in this situation, too.

I also had a complete system hang sometime after leaving gnome-panel in this state without killall -1 gnome-panel, which corrects the problem.

Matthew Gregg (mcg) wrote :

I would like to see the priority higher as well. I used to frequently click the clock for a calendar, but now it hangs gnome-panel, each time I try it. If Hardy plans to ship with the clock enabled on the dock, it really needs to be fixed.

Pedro Villavicencio (pedro) wrote :

Known upstream you can track it here: http://bugzilla.gnome.org/show_bug.cgi?id=525198 ; and Medium is ok for now.

Changed in gnome-panel:
status: Confirmed → Triaged
levmatta (levmatta) wrote :

I have the problem also, just to comment: It seams to happen more when I am not connected to the internet.

Karunadheera (karunadheera) wrote :

I noticed that the problem comes when I have a location added to the clock. It hangs up the laptop. I use the Fn+F1 to sleep the computer, then during wake up Ctrl+Alt+Del to restart safely with cleanly unmounting hard disk.

Clicking on the Clock - Hanging up the whole desktop - Kills my time. :-(

Please fix.

ASUS F3E
4GB Ram
64-bit Ubuntu 8.04 Hardy Heron

Matthew Tighe (tighem) wrote :

This seems to have cleared up for me in the latest round of updates. However, it's slow so I'm not sure if the problem is really fixed or if the bug in applet is no longer causing gnome-panel to freeze because something else got fixed....

Daniel Cordeiro (dcordeiro) wrote :

The upstream bug blames a Google Calendar account in Evolution. I don't even use Evolution here and I'm having this very annoying problem.
I'm still having the problem with the latest upgrades.

I don't have evolution configured and the clock hangs the system everytime I left-click it. Hardy fully updated. Right-clicked and added another location and it started working again. A bit laggy on start, but working.

I have fully updated Hardy as of today but the problem is still there.

To "fix it", I have to stop X (/etc/init.d/gdm stop) and then kill -15 -1 as my user and then re-start X again.

Andrew Conkling (andrewski) wrote :

 Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 194505, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Feel free to continue to report any other bugs you may find.

Matthew Tighe (tighem) wrote :

Hi Andrew, the other bug talks of the clock not appearing when Google Calendar is running. Numerous users have reported here that gnome-panel freezes and it has nothing to do with Google Calendar. The upstream bug number is different, too.

Adam Niedling (krychek) wrote :

I'm removing the duplication marking because this bug has nothing to do with google calendar or evolution, I don't use either of them. The status of this bug was set to triaged, doesn't this mean that someone knows why this is happening?

Sebastien Bacher (seb128) wrote :

The upstream bug equivalent to this one has been marked duplicated and upstream is likely to know better if they have the same cause, either the bug watch is pointing to a wrong bug or you should mark the bug duplicated. Note that clear steps to trigger the issue and a debug stacktrace would make easier to figure what the issue is, and that's not because other people have an issue similar to one describe first there that they have the exact same bug

Claudiu Vlad (claudiu-vlad) wrote :

Same freeze here. Only difference is that I have 2 locations set.

bishoptf (bishoptf) wrote :

Same here, thought it was something else I had loaded, this really should be higher, it locks up your whole desktop and it does it every time you right click.

Sebastien Bacher (seb128) wrote :

Could the users who have the issue get stacktraces to make sure they have the same bug?

Adam Niedling (krychek) wrote :

How do we do that?

Sebastien Bacher (seb128) wrote :

That's explained on the wiki page pedro indicated

bishoptf (bishoptf) wrote :

Quote :"Known upstream you can track it here: http://bugzilla.gnome.org/show_bug.cgi?id=525198 ; and Medium is ok for now." Pedro Villavicencio

  I have gone and looked at what you are refferring too but as described it is not the same is, althought the lockup appears to be so. I do and have not set up evolution or anything to do with google calender. This is a bug that will effect anyone that is using just the straight calender, although i am running x86_64 not sure if it is happening in 32bit version. I think that is what most are trying to say and understand that the bug tracker you listed specifically refers to evolution and google calender and most here are nit using either. If you still need a backtrace let me know and I will provide an additional one.

Pedro Villavicencio (pedro) wrote :

bishoptf, did you read what Sebastien said in previous comments? Please get a stacktrace rather, there's a few comments of us asking for that information, thanks.

bishoptf (bishoptf) wrote :

Will try to upload one tonight......

bishoptf (bishoptf) wrote :

Pedro, I did an update (i should have tried the applet first) and now it doesn't happen. It was very consistent before and would do it every time. I'll reboot and see if I can reproduce it, if so I will post the traceback.

Pedro Villavicencio (pedro) wrote :

May someone else confirm that it's fixed? thanks.

Matthew Gregg (mcg) wrote :

I appears to be fixed for me.

Rached B (benmur) wrote :

I haven't seen the freeze in about 2 weeks, but I can't tell for sure that it's fixed.

Daniel Cordeiro (dcordeiro) wrote :

The frequency of the freezes decreased a lot after the last few days, but I still get then (just got one here with the latests upgrades). :-(

Sameer Morar (smorar) wrote :

I can confirm that this bug occurs every time I click on the clock applet.

Attached is a strace that I attached to my gnome-panel process before clicking on the clock applet. It seems to hang on a mutex, waiting for something.

(I tried doing a backtrace with gdb, but was unsuccessful)

marcgenou (marcgenou) wrote :

I still got some freezes when i clicking clock. Sometimes work as usual sometimes not.

Tomas 'tt' Krag (tt) wrote :

I had this same freeze on an updated system, today, but the problem went away when i removed the google calendar link from evolution.

Ron S (ronshere-people) wrote :

I had this problem every time I clicked on the applet. Just did an upgrade an hour ago that seems to have fixed the problem.
I have rebooted the machine several times and have not had had gnome freeze once.

marcgenou (marcgenou) wrote :

Seems solved when i disabled google calendar addon in evolution.

Stefan Lange (albundy) wrote :

It seems to be stable after disabling the Google calendar in Evolution (did an upgrade from 7.10 to 8.04 yesterday).

I had this problem on a fully updated upgrade of 8.04 LTS which I performed on 4/26 using the main server. The date/time applet did not display weather and left-clicking on it would freeze gnome. I do not use google calendar or evolution. The problem went away immediately when I set a location on the applet preferences - weather information is now displayed and left-clicking no longer freezes gnome. Initially the show weather/show temperature options were checked on the general tab of preferences, but nothing was set in the locations tab.

I can confirm the bug as well, and I can confirm that disabling Google Calendar in Evolution helps the problem!

Changed in gnome-panel:
status: Unknown → Invalid

I have the same problem with the clock applet (laptop with Hardy Heron 64 bit). I follow doubletruncation tip to add a location (and then I removed it) and gnome-panel didn't crash anymore (today I will try other tests). So I think it's confirmed that the bug is not directly related to the disabling of Google Calendar in Evolution (in fact I haven't still configured evolution).

Sebastien Bacher (seb128) wrote :

the google calendar issue is bug #194505, an another hang cause is an evolution-data-server issue described on bug #204775, is anybody having a different issue or should this bug be closed as duplicate?

Changed in gnome-panel:
status: Triaged → Incomplete
Andrea Grandi (andreagrandi) wrote :

I still have this bug with latest Ubuntu Hardy 8.04

Sebastien Bacher (seb128) wrote :

did you install the evolution-data-server update described in the other bug?

Andrea Grandi (andreagrandi) wrote :

Sebastien: I did:
apt-get update && apt-get upgrade
is it ok? Where can I find the other updated package?

I think Sebastien Bacher referred to hardy sru upload (http://launchpadlibrarian.net/13986760/eds.debdiff) posted in bug #204775.
I think we can follow the "building from a debdiff guide" (https://wiki.ubuntu.com/UbuntuPackagingGuide/BuildFromDebdiff) from the wiki documentation of ubuntu. I haven't tested the patch yet (nor I never used .debdiff as I am a new .deb user) but I think the steps are:
1) download build-essential fakeroot devscripts
2) download the source of evolution-data-server package (with its libraries)
3) apply the Bacher patch
4) rebuild the package
5) install the new .deb

Backer, can you confirm this?

Sebastien Bacher (seb128) wrote :

the update has been uploaded to hardy-proposed, you don't need to build anything just enable the source and try the version available there

Andrea Grandi (andreagrandi) wrote :

Sebastien: I've enabled hardy-proposed, installed all the updates available and rebooted my Ubuntu. I still have that bug: gnome-panel keeps freezing.

On Wed, Apr 30, 2008 at 9:51 AM, Andrea Grandi <email address hidden> wrote:

> Sebastien: I've enabled hardy-proposed, installed all the updates
> available and rebooted my Ubuntu. I still have that bug: gnome-panel
> keeps freezing.
>

You haven't mentioned this before, but are you using a Google Calendar in
Evolution?

Andrea Grandi (andreagrandi) wrote :

Yes, I do! Is this a problem?

Andrea Grandi (andreagrandi) wrote :

Removing Google Calendar settings from Evolution, it doesn't crash anymore...

Changed in gnome-panel:
status: Unknown → Confirmed
Andrew Conkling (andrewski) wrote :

On Wed, Apr 30, 2008 at 12:59 PM, Andrea Grandi <email address hidden> wrote:

> Yes, I do! Is this a problem?
>

No, not a problem, just a different issue. See the above comments, namely
this one:

On Tue, Apr 29, 2008 at 8:00 AM, Sebastien Bacher <email address hidden> wrote:
> the google calendar issue is bug #194505

Updating evolution-data-server from proposed has solved the problem for me.

Adam Niedling (krychek) wrote :

This just happened to me on another machine as well. I don't use evolution. Maybe uninstalling it will help this problem?

Sebastien Bacher (seb128) wrote :

does anybody still get the issue on hardy?

Rached B (benmur) wrote :

I haven't seen this bug happen for a while (it was happening often before).

Sebastien Bacher,

I upgraded my packages with sru update (In hardy proposed) one month ago and I had no more the issue. I have hardy Heron 64 bit on acer laptop, and for me the problem is resolved.

Sebastien Bacher (seb128) wrote :

closing the bug since that seems to work correctly now, feel free to reopen if you still get the issue though

Changed in gnome-panel:
status: Incomplete → Fix Released

This seems to have reared its head again after the last updates to evolution. Left clicking the clock once again hangs the panel. I do not have evolution/google calendar linked and do not use evolution. However evolution-data-server 2.22.2-0ubuntu1 is there for dependencies.

The strange thing is that it hangs for EXACTLY 100 seconds then it opens the calendar. This is repeatable.

I've changed ntp settings etc to no avail, but it does have the feel of a timer causing the delay.

Matthew Tighe (tighem) wrote :

There's a delay for me, but only about 3-5 seconds. Definitely not 100 seconds.

crivic (crivic) wrote :

hello,
I'm quite new about linux, but I had the same problem you are talking about.
Until yesterday no problems appear. But today I have worked on my hard disk partitions and, i don't know why, clock applet starts give me trouble. I'm sure befor work on my partitions, I didn't have any problem with this applet!
Reading this pages, i decided to try uninstal evolution. More over I was using thunderbird.
After that, the applet starts working corretly again.

Thanks

removing evolution and evolution-data-server cured the problem. It also removed ekiga. I reinstalled ekiga and it automatically reinstalled evolution-data-server and the problem has still gone.

Changed in gnome-panel:
status: Confirmed → Fix Released

I have found the same issue, however in my experience removing all locations (of which I had only one) solved the problem to some extent. There is still a short lag between clicking the clock and the calendar appearing, during which time the Window list is also frozen, but the calendar does appear, which was not the case before. I'm loathe to try uninstalling Evolution, as the calendar in the panel is useful to have easily at hand. I'm using Hardy and a fresh install from the 8.04 live CD did not exhibit this issue, an update appears to have caused it.

Adam Niedling (krychek) wrote :

I'm still having this issue. My Ubuntu laptop hasn't been connected to the internet since 10 days and maybe the clock applet is trying to get some information from the net. I have 4 locations setup in the clock. The whole panel is freezing when clicked on the clock. This happens every time i click on it.

Changed in gnome-panel:
status: Fix Released → New
description: updated
Adam Niedling (krychek) wrote :

I was more patient this time and waited more for the clock to come out. It took 3:50 minutes for the first time and 2:30 minutes for the second time for the clock to appear. This is unacceptable.

description: updated
Sebastien Bacher (seb128) wrote :

don't specify the versions in the title

Tomas Jonsson (tomas-jonsson) wrote :

Got the same problem with the clock/calendar.
Found that rename/remove the ~/.gnome2 folder was my solution to the problem.

Before I did that, I tried to reinstall evolution, remove everything under ~/.gconf/apps/evolution, disable weather reports, but the only thing that worked for me was renaming the ~/gnome2 folder.

I was able to affect a positive change by opening evolution and deleting some slow and or broken calendars.

Evolution with Exchange is broken (LP Bug: 207723), so I'm not too surprised that it mucks up the calendar.

Mike

Some additional items of interest:
1) Without evolution open I get the hang.
2) killall gnome-panel
3) run evolution from cli
4) click clock in panel and it works! Here's some cli ouput for your interest, it means nothing to me:

(evolution:23788): libecal-WARNING **: e-cal.c:319: Unexpected response

(evolution:23788): libecal-WARNING **: e-cal.c:319: Unexpected response

(evolution:23788): libecal-WARNING **: e-cal.c:319: Unexpected response

(evolution:23788): libecal-WARNING **: e-cal.c:319: Unexpected response

(evolution:23788): libecal-WARNING **: e-cal.c:319: Unexpected response

(evolution:23788): libecal-WARNING **: e-cal.c:319: Unexpected response

(evolution:23788): libecal-WARNING **: e-cal.c:319: Unexpected response
libecal-Message: e_cal_recur_generate_instances_of_rule(): bogus component, does not have DTSTART. Skipping...
libecal-Message: e_cal_recur_generate_instances_of_rule(): bogus component, does not have DTSTART. Skipping...
libecal-Message: e_cal_recur_generate_instances_of_rule(): bogus component, does not have DTSTART. Skipping...
libecal-Message: e_cal_recur_generate_instances_of_rule(): bogus component, does not have DTSTART. Skipping...

(evolution:23788): Gtk-CRITICAL **: gtk_widget_get_screen: assertion `GTK_IS_WIDGET (widget)' failed

(evolution:23788): Gdk-CRITICAL **: gdk_screen_is_composited: assertion `GDK_IS_SCREEN (screen)' failed

(evolution:23788): Gtk-CRITICAL **: gtk_widget_get_screen: assertion `GTK_IS_WIDGET (widget)' failed

(evolution:23788): Gdk-CRITICAL **: gdk_screen_is_composited: assertion `GDK_IS_SCREEN (screen)' failed
libecal-Message: e_cal_recur_generate_instances_of_rule(): bogus component, does not have DTSTART. Skipping...
libecal-Message: e_cal_recur_generate_instances_of_rule(): bogus component, does not have DTSTART. Skipping...
libecal-Message: e_cal_recur_generate_instances_of_rule(): bogus component, does not have DTSTART. Skipping...
libecal-Message: e_cal_recur_generate_instances_of_rule(): bogus component, does not have DTSTART. Skipping...

(evolution:23788): Gtk-CRITICAL **: gtk_widget_get_screen: assertion `GTK_IS_WIDGET (widget)' failed

(evolution:23788): Gdk-CRITICAL **: gdk_screen_is_composited: assertion `GDK_IS_SCREEN (screen)' failed

(evolution:23788): Gtk-CRITICAL **: gtk_widget_get_screen: assertion `GTK_IS_WIDGET (widget)' failed

(evolution:23788): Gdk-CRITICAL **: gdk_screen_is_composited: assertion `GDK_IS_SCREEN (screen)' failed

Changed in gnome-panel:
status: New → Triaged

I can't reproduce this in Ubuntu 9.04, so something somewhere has solved this for later versions.

Pedro Villavicencio (pedro) wrote :

Does anybody still see this with jaunty?

Changed in gnome-panel:
status: Triaged → Incomplete
Everthon Valadão (valadao) wrote :

I think it have something to do with my Google Calendar accounts in Evolution. To "unfreeze" the gnome-panel, I just run 'evolution --force-shutdown', but it's quite annoying. The (web) appointments fetch of evolution-alarm-notifier should run at background, or at least within it's own thread to not freeze the clock/calendar application...

@Everthon: Are you seeing this problem on 8.10 (Intrepid) or 9.04 (Jaunty)?

Everthon Valadão (valadao) wrote :

@Duncan: sorry, I forgot to specify my system configs :-)

Ubuntu 8.10 "Intrepid" [ Linux 2.6.27-9-generic i686 GNU/Linux ]
   |---Gnome 2.24.1
   |---Evolution 2.24.2

P.S.: I don't had this problem with Ubuntu 7.10 "Gutsy" ( I skip the pulse-bugged "Hardy" ).

This bug has gone away on Ubuntu 9.04 so I've marked it as fixed. Please reopen if you see this bug on Jaunty or request a backport if you want to see it fixed in earlier releases

Changed in gnome-panel:
status: Incomplete → Fix Released
Alex Bachmeier (cebalrai) wrote :

This bug still appears for me under 9.04.
'evolution --force-shutdown' does not work in my case. Killing the gnome panel does.

@Alex: Thanks for your bug report. Please try to obtain a backtrace http://wiki.ubuntu.com/DebuggingProgramCrash and attach the file to the bug report. This will greatly help us in tracking down your problem.

marmuta (marmuta) wrote :

I can see this happening on current Jaunty 9.04 too, but it started only some days ago. The panel just locks up when clicking the clock. 'evolution --force-shutdown' doesn't help here either and I'm not using google accounts.
What helps is starting evolution to the calendar page, ie evolution --component=calendar. I can open the clock just fine then. However evolution --component=contacts locks the panel and shows an error "Evolution Error, The Evolution address book has quit unexpectedly." and evolution-data-server-2.26 is gone. I'll attach a trace of evolution-data-server too, looks like it failed an assertion.

marmuta (marmuta) wrote :
Matthew Gregg (mcg) wrote :

Confirming that this bug is back in Jaunty.

same problem on my 9.04

Pedro Villavicencio (pedro) wrote :

may you please report a new one for the jaunty issue? that works fine for me here.

Dhruva Sagar (dhruva-sagar) wrote :

I have the same error. I have realized that the error is related to evolution data center.
I have found this solution to un-hang gnome-panel :

evolution --force-shutdown

Once you execute that command the gnome-panel comes back to normal.

erlguta (gonzalomarcote) wrote :

This bug affects to me in Karmic too. If for some reason,evolution calendar hangs up when i click in the clock applet it complety haungs up the upper and lower panel.
Maybe it is because i have configured syncronization with google calendar, and if it is inaccessible, it makes evolution calendar crash and this the clock applet and the panels.
This happens often when i resume form suspend.
I attach one screenshot where yo can see evolution hanged up and the clock panel clicked and hanged up too

I'm seeing the bug too in fully updated Lucid Lynx. You click on clock-applet, and it causes it to freeze. Kill the process, restart it, left click, and it freezes again.

Changed in gnome-panel:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.