Network Tools: Obstruction of Ping tab contents.

Bug #891852 reported by Derek White on 2011-11-17
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gnome-nettool (Ubuntu)
Undecided
Matt Fischer

Bug Description

The default window size (which is not remembered between launches) does not allow for the Ping tab's graph to be fully displayed - even the legend gets cut off, let alone the graph it self. The Details table also suffers the same issue as described in Bug #856387 (table on the "Devices" tab).

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: gnome-nettool 3.0.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 1.23-0ubuntu4
Architecture: amd64
CheckboxSubmission: 880f1cef728a67d1a58407cc143447d4
CheckboxSystem: 4ed15c40009aa6f7770f606350a390a2
Date: Thu Nov 17 17:44:06 2011
ExecutablePath: /usr/bin/gnome-nettool
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
SourcePackage: gnome-nettool
UpgradeStatus: Upgraded to oneiric on 2011-11-04 (13 days ago)

Derek White (d-man97) wrote :
Derek White (d-man97) wrote :
Derek White (d-man97) wrote :
Derek White (d-man97) wrote :

This last one is of the Ping tab, after 5 pings, with the Details expanded. As you can see, there is a TON of wasted space. The graph does expand with the window size; however, just like the IP Information table (Devices tab), the Details table does not expand.

Matt Fischer (mfisch) wrote :

Derek:

The first part of your bug is a duplicate of 891852, which has been reported by numerous people. It would probably be best for this defect to focus on the Ping tab since as far as I see, nobody else has reported that. Can you edit this bug if you agree?

Matt Fischer (mfisch) wrote :

Sorry, in my above comment I meant to say duplicate of 856387.

856387 Network tools IP information list is too small to see data

https://bugs.launchpad.net/ubuntu/+source/gnome-nettool/+bug/856387

Derek White (d-man97) wrote :

Bug has been updated.

In addition, I left a note on Bug #856387 to let them know the table on the Ping tab is affected too.

summary: - Unusable IP Information table and partial obstruction of Ping tab.
+ Network Tools: Obstruction of Ping tab contents.
description: updated
Matt Fischer (mfisch) on 2011-11-25
Changed in gnome-nettool (Ubuntu):
status: New → Confirmed
status: Confirmed → In Progress
assignee: nobody → Matt Fischer (mfisch)
Matt Fischer (mfisch) wrote :

Although it's not in the changelog, my patch I sent upstream fixed this. The fix is in 3.1.1-0ubuntu1.

Changed in gnome-nettool (Ubuntu):
status: In Progress → Fix Released
Phen Homen (phenhomen) wrote :

How do we get the fix?

Matt Fischer (mfisch) wrote :

Use my PPA listed in bug 806606 or install 12.04.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers