gnome-mplayer mplayer2 vdpau does not working

Bug #1005505 reported by Vorron on 2012-05-28
34
This bug affects 7 people
Affects Status Importance Assigned to Milestone
GNOME MPlayer
Unknown
Unknown
gnome-mplayer (Ubuntu)
Undecided
Unassigned

Bug Description

What you expected to happen: playing video with hardware acceleration.
What actually happened: grey screen instead of video, while audio is playing ok.
To reproduce:
1. Start the program
2. Select vdpau in settings.
3. Open random video file.

Also, mplayer2 with vdpau working ok. Smplayer+mplayer2 with vdpau working ok. Gnome-mplayer+mplayer2 with xv working ok.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: gnome-mplayer 1.0.5-1
ProcVersionSignature: Ubuntu 3.2.0-25.40-generic 3.2.18
Uname: Linux 3.2.0-25-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 2.0.1-0ubuntu8
Architecture: i386
Date: Mon May 28 15:40:31 2012
InstallationMedia: Xubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=ru_RU.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-mplayer
UpgradeStatus: Upgraded to precise on 2012-05-15 (13 days ago)

Vorron (worron) wrote :
Sebastian Ramacher (s-ramacher) wrote :

Could you please run gnome-mplayer -v and attach the output? This should also give you the exact line that is used to start mplayer2. Could you try to run mplayer2 with the same arguments and tell us if it works? Thanks.

Vorron (worron) wrote :

Ok, here it is. I got output for few second, while gnome-mplayer was playing audio with blank screen, then closed it. Mplayer2 arguments was found as

"-vo vdpau,gl,x11 -vc ffmpeg12vdpau,ffh264vdpau,ffwmv3vdpau,ffvc1vdpau,ffodivxvdpau, -channels 2 -af-add export=/tmp/mplayer-af_exportoorslh:512 -quiet -slave -noidle -noconsolecontrols -nostop-xscreensaver -identify -volume 100 -softvol -msglevel all=5 -osdlevel 0 -delay 0,000000 -subdelay 0,000000 -subpos 0 -sub-fuzziness 0 -wid 0x4400075 -brightness 0 -contrast 0 -hue 0 -saturation 0 -alang Zuni,zun -slang Zuni,zun -nomsgcolor -nomsgmodule -nokeepaspect -ass -embeddedfonts -ass-font-scale 1,00 -ass-color ffffff00"

When I tried start mplayer2 with same line, it was fault with some errors. Its output added to attached archive.

Also, mplayer2 with arguments "-vo vdpau -vc ffmpeg12vdpau,ffh264vdpau,ffwmv3vdpau,ffvc1vdpau,ffodivxvdpau" works fine. Its output and gnome-mplayer with xv output I added to archive too, may be it will helpful.

Sebastian Ramacher (s-ramacher) wrote :

I've been looking through the commit logs but can't find a commit that might fix your issue. Could you nevertheless try 1.0.6-1 which is available in quantal? If it doesn't work with 1.0.6-1 I'd report it upstream.

Vorron (worron) wrote :

I have tried version 1.0.6-1, but it has same problem.

Sebastian Ramacher (s-ramacher) wrote :

Silly me, should have spotted that earlier: Is it working if you start mplayer2 with the above arguments but exclude -af-add export=/tmp/mplayer-af_exportoorslh:512 and -wid 0x4400075?

I'll forward it upstream. Maybe he can spot what's wrong here.

Vorron (worron) wrote :

If it excluded "af-add export=/tmp/mplayer-af_exportoorslh:512 -wid 0x4400075" mplayer2 works right. So, mplayer2 playing video correctly with this argument line:

"-vo vdpau,gl,x11 -vc ffmpeg12vdpau,ffh264vdpau,ffwmv3vdpau,ffvc1vdpau,ffodivxvdpau, -channels 2 -quiet -slave -noidle -noconsolecontrols -nostop-xscreensaver -identify -volume 100 -softvol -msglevel all=5 -osdlevel 0 -delay 0,000000 -subdelay 0,000000 -subpos 0 -sub-fuzziness 0 -brightness 0 -contrast 0 -hue 0 -saturation 0 -alang Zuni,zun -slang Zuni,zun -nomsgcolor -nomsgmodule -nokeepaspect -ass -embeddedfonts -ass-font-scale 1,00 -ass-color ffffff00"

Kevin DeKorte (kdekorte-gmail) wrote :

Can you provide the output of vdpauinfo I think this might have something to do with the inital size of the window, but not entirely sure at this point. Also in gnome-mplayer do you get a picture if you disable "Hardware Acceleration" in Edit->Preferences (first tab)?

Kevin DeKorte (kdekorte-gmail) wrote :

One more question, does it work with mplayer (not mplayer2)?

Vorron (worron) wrote :

Enabling/disabling "Hardware Acceleration" doesn't change anything.
Unfortunately, I gave up using mplayer for some time ago. It was not ok with vdpau, since mplayer2 works fine.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-mplayer (Ubuntu):
status: New → Confirmed
Kevin DeKorte (kdekorte-gmail) wrote :

Can you post the full output of the mplayer2 command line that does not work, please omit the "-wid XXXXX" option as that changes from run to run.

bowser (bwbernard-wong1) wrote :

I think this is a manifestation of this bug https://bugs.launchpad.net/unity/+bug/993397 OP here doesn't specify which DE he is using but it seems that it only affects Unity (mplayer, mplayer2 and vdpau works in gnome-shell)

Please go over there and add an "affect me too" if you haven't done so already. Thanks.

CBrider (zaknafien13) wrote :

I have the same problem, so here is another datapoint for you. I am running
Ubuntu 12.04 x64
Nvidia 8800 GT with Nvidia driver 310.19
Gnome-3 Shell (lightdm display manager)

I have attached output for vdpauinfo and from mplayer when the video is playing.

Here are two new things I have discovered:
 1. The video playback is (mostly) fixed if I open the preferences menu, and close it. I do not need to change any settings. In the mplayer output, there is a string of repeating errors that stop when I close the preferences menu (mplayer is restarted).
 2. Once the video is working: In the main dvd menu, the interactive buttons do not render properly. There is a tranparent grey block where the button images should go (the ones that respond visually when you mouse-over and click).

I hope this helps. I will let you know if I find anything.

-Lee

CBrider (zaknafien13) wrote :

Adding vppauinfo output

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.