Ubuntu

gnome-mount crashed with SIGSEGV in g_datalist_id_set_data_full()

Reported by Barrius on 2007-06-27
586
Affects Status Importance Assigned to Milestone
gnome-mount
Fix Released
Critical
gnome-mount (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: gnome-mount

Had just booted Gutsy (using VirtualBox 1.3.8).

ProblemType: Crash
Architecture: i386
Date: Tue Jun 26 14:50:44 2007
DistroRelease: Ubuntu 7.10
ExecutablePath: /usr/bin/gnome-mount
NonfreeKernelModules: cdrom
Package: gnome-mount 0.6-1ubuntu2
PackageArchitecture: i386
ProcCmdline: /usr/bin/gnome-mount --hal-udi=/org/freedesktop/Hal/devices/volume_part_1_size_1073741312
ProcCwd: /home/barry
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: gnome-mount
StacktraceTop:
 g_datalist_id_set_data_full ()
 ?? () from /usr/lib/libgobject-2.0.so.0
 ?? ()
 ?? ()
 ?? ()
Title: gnome-mount crashed with SIGSEGV in g_datalist_id_set_data_full()
Uname: Linux L8TRALIG8TR 2.6.22-7-generic #1 SMP Mon Jun 25 17:33:14 GMT 2007 i686 GNU/Linux
UserGroups: adm admin audio cdrom dialout dip floppy lpadmin netdev plugdev powerdev scanner video

Related branches

Barrius (barrius) wrote :

StacktraceTop:IA__g_datalist_id_set_data_full (datalist=0x8097060, key_id=50, data=0x0, destroy_func=0) at /build/buildd/glib2.0-2.13.5/glib/gdataset.c:216
g_object_real_dispose (object=0x8097058) at /build/buildd/glib2.0-2.13.5/gobject/gobject.c:533
gtk_object_dispose (gobject=0x8097058) at /build/buildd/gtk+2.0-2.11.4/gtk/gtkobject.c:423
gtk_widget_dispose (object=0x8097058) at /build/buildd/gtk+2.0-2.11.4/gtk/gtkwidget.c:7439
gtk_window_dispose (object=0x8097058) at /build/buildd/gtk+2.0-2.11.4/gtk/gtkwindow.c:1966

Changed in gnome-mount:
importance: Undecided → Medium
Spyros Theodoritsis (madmetal) wrote :

just faced the same crash at a new gutsy tribe 2 installation while i was updating the system.
gutsy gibbon tribe 2 i386 on compaq armada E500 laptop.

Sebastien Bacher (seb128) wrote :

Thanks for your bug report. This bug has been reported to the developers of the software. You can track it and make comments here: http://bugzilla.gnome.org/show_bug.cgi?id=453361

Changed in gnome-mount:
status: New → Confirmed
Changed in gnome-mount:
status: Unknown → New
Mozg (andrei-arhont) wrote :

Had the same issue with gnome-mount crashing on Tribe3. The distro has been installed in vmware and the crash occurred after trying to install VMware tools.

Saul (creative-balm) wrote :

This bug report seemed to appeared when using Gimp 2.3.18 on gusty live CD when evaluating Tribe 4 issue.

DarkMageZ (darkmagez) wrote :

i just had this happen in ubuntu hardy (8.04) with latest updates as of now.

e-r-i-k-98 (erik98) wrote :

so do me!!

Erlend Larsen (erlend-larsen) wrote :

I just had this happen in Ubuntu Hardy Heron (8.04) Alpha 2 on a HP Pavilion ZE4417EA laptop.

Steve Langasek (vorlon) on 2008-01-24
Changed in gnome-mount:
milestone: none → ubuntu-8.04-beta
Chow Loong Jin (hyperair) wrote :

Same thing happens in Ubuntu Hardy Heron Alpha 3 with latest updates as of now.

Jesse Burt (avsa242) wrote :

Confirmed (with Hardy)

Kyubutsu (jf) wrote :

confirmed.
8.04 hardy x86.
upon insertion of usb portable drive, 2.0gigabytes.

Kyubutsu (jf) wrote :

also confirmed on 8.04 hardy x86_64. amd tk53 architecture.
upon usb drive insertion.
x86 system is a celeron 2.0ghz

A_User (paul-mcgregor) wrote :

confirmed on 8.04 hardy
insert of DVD-movie

Artyom Loenko (divenvrsk) wrote :

confirmed on 8.04 hardy. last updated today.
when insert DVD with autorun function.

mabovo (mabovo) wrote :

Confirmed Hardy 8.04, kernel 2.6.24-5, MacBook 2nd gen. crashed when attaching external hd on usb.

Konstigt (konstigt) wrote :

I just got this. I have the apport files if needed.

$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=8.04
DISTRIB_CODENAME=hardy
DISTRIB_DESCRIPTION="Ubuntu hardy (development branch)"
$ dpkg -l | grep gnome-mount
ii gnome-mount 0.7-1ubuntu1 wrapper for (un)mounting and ejecting storage devices

I solved. Thanks.

On mar, 2008-01-29 at 19:15 +0000, ThomasNovin wrote:
> I just got this. I have the apport files if needed.
>
> $ cat /etc/lsb-release
> DISTRIB_ID=Ubuntu
> DISTRIB_RELEASE=8.04
> DISTRIB_CODENAME=hardy
> DISTRIB_DESCRIPTION="Ubuntu hardy (development branch)"
> $ dpkg -l | grep gnome-mount
> ii gnome-mount 0.7-1ubuntu1 wrapper for (un)mounting and ejecting storage devices
>

Changed in gnome-mount:
status: Confirmed → Triaged

I can confirm this bug as well. It occurs every time I insert my Creative Muvo V100 mp3 player into the USB slot. The insertion causes two windows to open with the contents of the drive.

$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=8.04
DISTRIB_CODENAME=hardy
DISTRIB_DESCRIPTION="Ubuntu hardy (development branch)"
$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=8.04
DISTRIB_CODENAME=hardy
DISTRIB_DESCRIPTION="Ubuntu hardy (development branch)"
corey@frankenputer:~$ dpkg -l | grep gnome-mount
ii gnome-mount 0.7-1ubuntu1 wrapper for (un)mounting and ejecting storag

David S. (xxxxxx) wrote :

Hello!

Well, I've sent that report since I installed the new hardy alpha,
because I'll replace that box soon. I just wanted to see that new
version of ubuntu and send some bugreports.
I've got to admit that the new Kernel 2.6.25 is faster than the former
2.6.22. - even on my old Singel-core CPU.

greetings
David Schmaranzer

Mit freundlichen Grüßen
David Schmaranzer

0664 / 85 50 60 7
www.schmaranzer.eu <http://www.schmaranzer.eu/index.html>

Corey Thompson schrieb:
> I can confirm this bug as well. It occurs every time I insert my
> Creative Muvo V100 mp3 player into the USB slot. The insertion causes
> two windows to open with the contents of the drive.
>
> $ cat /etc/lsb-release
> DISTRIB_ID=Ubuntu
> DISTRIB_RELEASE=8.04
> DISTRIB_CODENAME=hardy
> DISTRIB_DESCRIPTION="Ubuntu hardy (development branch)"
> $ cat /etc/lsb-release
> DISTRIB_ID=Ubuntu
> DISTRIB_RELEASE=8.04
> DISTRIB_CODENAME=hardy
> DISTRIB_DESCRIPTION="Ubuntu hardy (development branch)"
> corey@frankenputer:~$ dpkg -l | grep gnome-mount
> ii gnome-mount 0.7-1ubuntu1 wrapper for (un)mounting and ejecting storag
>
>

Bruce R (bm007a0030) wrote :

Manual Install performed well, faster than Gutsy.

New kernel appears to be improving stability and speed.

After Reload Add/Remove lists, re-instated Gparted 0.3.3 to receive error message, but Gparted seems OK, causing
FAT32 and NTFS Drives to be displayed as Icons and mounted. (Including XP and Vista primary drives.)

Created NTFS data drive report folder and opened a log file with OpenOffice Writer 2.3

Now going on to see what else works, but it's Looking Good Folks !

robbak (robbak) wrote :

I just experienced this when inserting a sony memory stick. I also had this crash before, when using an sd(?) card. Incidentally, both had the DCIM virus on them.

Rich (rincebrain) wrote :

Given that I personally have filed bugs against two other programs which were marked as duplicates of this bug, in addition to a duplicate about gnome-mount, is it really appropriate to have gnome-mount marked as the source package for this problem any more?

Martin Pitt (pitti) wrote :

Rich, which duplicates do you mean? I think gnome-mount is exactly the right source package for this crash.

Rich (rincebrain) wrote :

Bugs 189121 and 188867 were filed by me against wxmaxima and eog, and they were both reported as duplicates of this.

I don't follow how gnome-mount is responsible for the crashes, as I wasn't changing the devices attached to my machine.

Rich (rincebrain) wrote :

My apologies, neither 189121 nor 188867 were marked duplicates of this, 189130 was, and that is gnome-mount.

It appears that my email client's threading of Launchpad bug reports is not trustworthy. =/ Too many bug reports.

perplexed (rooooooooooooooot) wrote :

заебло

Martin Pitt (pitti) wrote :

Got a patch now, and informed upstream about the cause and the patch.

Changed in gnome-mount:
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-mount - 0.7-2ubuntu1

---------------
gnome-mount (0.7-2ubuntu1) hardy; urgency=low

  * Merge with Debian unstable; see 0.7-1ubuntu1 for remaining changes.
  * Add debian/patches/01_missing_include.patch: Add missing #include
    <locale.h> to fix FTBFS. Forwarded to Gnome #514946.
  * Add debian/patches/02_msgbox_unref.patch: Fix/work around crash when
    destroying unused message box. (LP: #122673)

gnome-mount (0.7-2) unstable; urgency=low

  * debian/control
    - The Vcs-* fields are now officially supported, so remove the XS- prefix.
    - Bump Standards-Version to 3.7.3. No further changes required.
    - Use the "Homepage:" field to specify the upstream URL.
    - Fix a few capitalization errors in the package description.

 -- Martin Pitt <email address hidden> Thu, 07 Feb 2008 12:56:09 +0100

Changed in gnome-mount:
status: Fix Committed → Fix Released
randy noel (randy-noel) wrote :

At the time the error occurred I had just inserted a usb thumb drive and it mounted automatically and displayed the error message.

miked (miked11) wrote :

I was playing with /etc/fstab settings and restarting computer, in the process of repairing failing hard drive

Łukasz Jernaś (deejay1) wrote :

This is almost fixed - it still displays two nautilus windows for one drive here with 0.7-2ubuntu1

miked (miked11) wrote :

I was playing with /etc/fstab settings and restarting computer, in the process of repairing a failing hard drive.
root@2HewittRand-desktop:~# sudo fdisk -l

Disk /dev/sda: 4311 MB, 4311982080 bytes
255 heads, 63 sectors/track, 524 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x35b635b6

   Device Boot Start End Blocks Id System
/dev/sda1 * 1 494 3968023+ 83 Linux
/dev/sda2 495 524 240975 5 Extended
/dev/sda5 495 524 240943+ 82 Linux swap / Solaris

Disk /dev/sdb: 41.1 GB, 41110142976 bytes
255 heads, 63 sectors/track, 4998 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xc84cc84c

   Device Boot Start End Blocks Id System
/dev/sdb1 * 1 4905 39399381 83 Linux
/dev/sdb2 4906 4998 747022+ 5 Extended
/dev/sdb5 4906 4998 746991 82 Linux swap / Solaris
root@2HewittRand-desktop:~#

root@2HewittRand-desktop:~# cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=8.04
DISTRIB_CODENAME=hardy
DISTRIB_DESCRIPTION="Ubuntu hardy (development branch)"
root@2HewittRand-desktop:~#
Hardy Heron 8.04 Alpha 4

miked (miked11) wrote :
Changed in gnome-mount:
status: New → Confirmed
Changed in gnome-mount:
status: Confirmed → Fix Released
Changed in gnome-mount:
importance: Unknown → Critical
To post a comment you must log in.