doesn't add nvidia-settings to menu after installing

Bug #522969 reported by Erik B. Andersen on 2010-02-17
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
gnome-menus (Ubuntu)
Low
Martin Pitt
nvidia-graphics-drivers (Ubuntu)
Low
Alberto Milone
nvidia-graphics-drivers-173 (Ubuntu)
Low
Alberto Milone
nvidia-graphics-drivers-96 (Ubuntu)
Low
Alberto Milone

Bug Description

When you install the nvidia driver, Nvidia X Server Settings isn't added to the System -> Administration menu until you log out and back in. (And that's after you rebooted to install the driver, and therefore already logged in once)

Steps to reproduce:
Install a fresh install.
Use jockey to install the current nvidia driver.
Restart, as recomended by jockey.
Login.
Look under System -> Administration for Nvidia X Server Settings, and observe that it isn't there
Log out.
Log back in.
Look under System -> Administration for Nvidia X Server Settings, and Find it listed there.

I'm attaching two screenshots.

ProblemType: Bug
Architecture: amd64
Date: Tue Feb 16 17:22:17 2010
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha amd64 (20100215)
MachineType: System manufacturer System Product Name
NonfreeKernelModules: nvidia
Package: jockey-gtk 0.5.7-0ubuntu1
PackageArchitecture: all
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-13-generic root=UUID=7ffed213-2f5a-4ea2-9673-3d63ebe62efe ro quiet splash
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-13.18-generic
SourcePackage: jockey
Uname: Linux 2.6.32-13-generic x86_64
dmi.bios.date: 03/03/2008
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0903
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: P5B-VM SE
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0903:bd03/03/2008:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5B-VMSE:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer

Erik B. Andersen (azendale) wrote :
Alberto Milone (albertomilone) wrote :

This seems to me more like a bug in the gnome menu rather than a bug in Jockey

affects: jockey (Ubuntu) → gnome-menus (Ubuntu)
Changed in gnome-menus (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Martin Pitt (pitti) wrote :

I just checked the package, and the reason is that the nvidia driver does not actually ship the .desktop file in /usr/share/applications/, but in a different dir, and I suppose the postinst creates a link dynamically. This does not trigger a rebuild of the menu cache.

What we can do here is: nvidia-graphics-drivers call update-gnome-menus-cache directly after the alternative setup, or better, we add a named trigger "gmenucache" which n-g-d just needs to call in its postinst with "dpkg-trigger gmenucache".

Changed in gnome-menus (Ubuntu):
status: Confirmed → Triaged
assignee: nobody → Martin Pitt (pitti)
Changed in nvidia-graphics-drivers (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-menus - 2.29.6-0ubuntu2

---------------
gnome-menus (2.29.6-0ubuntu2) lucid; urgency=low

  * debian/python-gmenu.triggers: Add explicit trigger name "gmenucache",
    which can be called by other package's maintainer scripts if they do not
    ship .desktop files in the .deb, but only link it in their maintainer
    scripts. (LP: #522969)
 -- Martin Pitt <email address hidden> Fri, 19 Feb 2010 22:36:22 +0100

Changed in gnome-menus (Ubuntu):
status: Triaged → Fix Released
Erik B. Andersen (azendale) wrote :

So is this fixed, or does the nvidia-graphics-drivers package need updating too?

Jacopo Moronato (jmoronat) wrote :

It seems to be fixed.

description: updated
Bryce Harrington (bryce) on 2010-02-23
Changed in nvidia-graphics-drivers (Ubuntu):
status: New → Fix Released
Martin Pitt (pitti) wrote :

As I pointed out in comment 4, nvidia-graphics-drivers _also_ needs to be fixed to trigger gnome-menus in its postinst.

Changed in nvidia-graphics-drivers (Ubuntu):
status: Fix Released → Triaged
summary: - Jockey doesn't add nvidia-xconfig (Nvidia X Server Settings) to menu
- after installing nvidia driver until you re-login
+ doesn't add nvidia-xconfig to menu after installing

As of 2010-03-10, after installing the nvidia-current driver, I checked the menus. System -> Administration does contain the GUI tool immediately after installing drivers. Unfortunately, after following the hardware drivers tool instructions to restart, the tool disappears from the menu.

Alberto Milone (albertomilone) wrote :

What Martin said is correct. In the postinst script the nvidia packages create the link to the .desktop file, which explains why this doesn't trigger gnome-menus.

I'll set "dpkg-trigger gmenucache" in the postinst scripts so that the problem is solved.

Changed in nvidia-graphics-drivers-173 (Ubuntu):
status: New → Triaged
Changed in nvidia-graphics-drivers-96 (Ubuntu):
status: New → Triaged
Changed in nvidia-graphics-drivers-173 (Ubuntu):
importance: Undecided → Low
Changed in nvidia-graphics-drivers-96 (Ubuntu):
importance: Undecided → Low
Changed in nvidia-graphics-drivers (Ubuntu):
importance: Undecided → Low
Changed in nvidia-graphics-drivers-96 (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
Changed in nvidia-graphics-drivers-173 (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
summary: - doesn't add nvidia-xconfig to menu after installing
+ doesn't add nvidia-settings to menu after installing
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-graphics-drivers-96 - 96.43.14-0ubuntu11

---------------
nvidia-graphics-drivers-96 (96.43.14-0ubuntu11) lucid; urgency=low

  * debian/nvidia-$flavour.{postinst|prerm}.in:
    - Call gmenucache trigger so that the icon of nvidia-settings
      shows up in the menu (LP: #522969).
 -- Alberto Milone <email address hidden> Tue, 16 Mar 2010 17:38:42 +0100

Changed in nvidia-graphics-drivers-96 (Ubuntu):
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-graphics-drivers-173 - 173.14.22-0ubuntu10

---------------
nvidia-graphics-drivers-173 (173.14.22-0ubuntu10) lucid; urgency=low

  * debian/nvidia-$flavour.{postinst|prerm}.in:
    - Call gmenucache trigger so that the icon of nvidia-settings
      shows up in the menu (LP: #522969).
 -- Alberto Milone <email address hidden> Tue, 16 Mar 2010 17:39:22 +0100

Changed in nvidia-graphics-drivers-173 (Ubuntu):
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-graphics-drivers - 195.36.15-0ubuntu1

---------------
nvidia-graphics-drivers (195.36.15-0ubuntu1) lucid; urgency=low

  * New upstream release:
    - Fixed a bug that caused the X server to crash when rendering
      occurred while the X server was not on the active VT.
    - Fixed a regression that caused the driver to fail to properly
      adjust the GPU fan speed on some GPUs.
    - Fixed a bug that prevented performance level transitions on
      recent GPUs with SDDR3 and GDDR5 memory.
  * debian/nvidia-$flavour.{postinst|prerm}.in:
    - Call gmenucache trigger so that the icon of nvidia-settings
      shows up in the menu (LP: #522969).
  * debian/nvidia-current.links{32}.in:
    - Add link to libOpenCL.so in /usr/lib and in /usr/lib32.
 -- Alberto Milone <email address hidden> Wed, 17 Mar 2010 10:21:52 +0100

Changed in nvidia-graphics-drivers (Ubuntu):
status: Triaged → Fix Released

My bug, Missing Menu Entries - Lucid Beta 1 https://bugs.launchpad.net/ubuntu/+bug/542300 was marked a dupe of this? Why? This bug is about Nvidia Settings missing. My bug is "Control center", along with "Configuration Editor", "File Browser", "GDebi", "Report A Problem" and "Root Terminal" are still missing in system > preferences > main menu > system tools.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers