package gnome-menus 3.13.3-6ubuntu3.1 failed to install/upgrade: triggers looping, abandoned

Bug #1766890 reported by Taihsiang Ho on 2018-04-25
140
This bug affects 18 people
Affects Status Importance Assigned to Milestone
OEM Priority Project
Critical
Unassigned
gnome-menus (Ubuntu)
Critical
Julian Andres Klode
Xenial
Undecided
Julian Andres Klode
Bionic
Undecided
Julian Andres Klode
ubuntu-release-upgrader (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
Bionic
Undecided
Unassigned

Bug Description

[Impact]
Upgrades on some systems fail with trigger issues related to gnome-menus. Upgrading libc6 first fixes that, so we modified u-r-u to upgrade it first.

[Test case]
Restore apt-clone file from comment #20 and upgrade to bionic with u-r-u.

[Regression potential]
(1) Upgrade of libc6 fails, upgrade would revert
(2) If upgrade of libc6 succeeds, but we cannot find an ordering for the remaining upgrades, we are stuck with just libc6 upgraded. It seems unlikely that we find an ordering for all packages, but none for the set without libc6 though.

# Original bug report

Dell XPS 13 9360 (CID 201606-22338)
pre-installed (oem) image Xenial

[Description]

When I tried to perform 16.04 --> 18.04 update, the update process failed. The process guide me to file this bug report.

[Steps to reproduce]
1. Update the system to the latest stack by "sudo apt-get update; sudo apt-get dist-upgrade -y"
2. Reboot
3. Make sure /etc/update-manager/release-upgrades is able to update (The configuration value of "Prompt" should be "lts", namely "Prompt=lts", not "Prompt=never").
4. Perform the release update: "sudo apt-get update; sudo do-release-upgrade -d"
5. During the update process, it prompts for "Configuring gdm3". There are two choices "gdm3" and "lightdm". I picked up "gdm3". Please refer to the attachment for the prompt details as well.

We should use "-d" because bionic beaver has not been officially released yet.

[Expected Result]

The release update completed and I could start using Bionic instead of Xenial.

[Actual Result]

The update process failed. It shows the error message[1] and automatically asking for filing this bug report.

[1]

Preparing to unpack .../qml-module-qtquick-dialogs_5.9.5-0ubuntu1_amd64.deb ...
Unpacking qml-module-qtquick-dialogs:amd64 (5.9.5-0ubuntu1) over (5.5.1-1ubuntu1) ...
Preparing to unpack .../qml-module-qtquick-window2_5.9.5-0ubuntu1_amd64.deb ...
Unpacking qml-module-qtquick-window2:amd64 (5.9.5-0ubuntu1) over (5.5.1-2ubuntu6) ...
(Reading database ... 253705 files and directories currently installed.)
Removing unity-webapps-common (2.4.17+15.10.20150616-0ubuntu2) ...
Removing unity-webapps-service (2.5.0~+16.04.20160201-0ubuntu1) ...
Removing webapp-container (0.23+16.04.20161028-0ubuntu2) ...
Removing webbrowser-app (0.23+16.04.20161028-0ubuntu2) ...
dpkg: cycle found while processing triggers:
 chain of packages whose triggers are or may be responsible:
  bamfdaemon -> gnome-menus
 packages' pending triggers which are or may be unresolvable:
  gnome-menus: /usr/share/applications
  bamfdaemon: /usr/share/applications
  libglib2.0-0:amd64: /usr/share/glib-2.0/schemas
  desktop-file-utils: /usr/share/applications
  mime-support: /usr/share/applications
dpkg: error processing package gnome-menus (--remove):
 triggers looping, abandoned
Processing triggers for desktop-file-utils (0.22-1ubuntu5.1) ...
Processing triggers for mime-support (3.59ubuntu1) ...
Processing triggers for libglib2.0-0:amd64 (2.48.2-0ubuntu1) ...
Errors were encountered while processing:
 gnome-menus
ERROR: Cannot create report: [Errno 17] File exists: '/var/crash/gnome-menus.0.crash'
Exception during pm.DoInstall(): E:Sub-process /usr/bin/dpkg returned an error code (1)

*** Send problem report to the developers?

After the problem report has been sent, please fill out the form in the
automatically opened web browser.

What would you like to do? Your options are:
  S: Send report (376.4 KB)
  V: View report
  K: Keep report file for sending later or copying to somewhere else
  I: Cancel and ignore future crashes of this program version
  C: Cancel
Please choose (S/V/K/I/C):

...... (a lot of them)

 qml-module-qtquick-controls2:amd64
 qml-module-org-kde-kconfig:amd64
 libunity-control-center1
 libqt5quickcontrols2-5:amd64
 libglib2.0-bin
 libkf5plasma5:amd64
 locales
 qml-module-qtqml-models2:amd64
 libkf5coreaddons5:amd64
 gir1.2-goa-1.0:amd64
 libwebkit2gtk-4.0-37:amd64
Processing was halted because there were too many errors.

Upgrade complete

The upgrade has completed but there were errors during the upgrade
process.

To continue please press [ENTER]

ubuntu@201606-22338:~$

==========================================================================

ProblemType: Package
DistroRelease: Ubuntu 18.04
Package: gnome-menus 3.13.3-6ubuntu3.1
ProcVersionSignature: Ubuntu 4.4.0-121.145-generic 4.4.117
Uname: Linux 4.4.0-121-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.16
Architecture: amd64
Date: Wed Apr 25 22:00:01 2018
Dependencies:

DistributionChannelDescriptor:
 # This is a distribution channel descriptor
 # For more information see http://wiki.ubuntu.com/DistributionChannelDescriptor
 canonical-oem-somerville-xenial-amd64-20160624-2
ErrorMessage: triggers looping, abandoned
InstallationDate: Installed on 2018-04-25 (0 days ago)
InstallationMedia: Ubuntu 16.04 "Xenial" - Build amd64 LIVE Binary 20160624-10:47
RelatedPackageVersions:
 dpkg 1.18.4ubuntu1.4
 apt 1.2.26
SourcePackage: gnome-menus
Title: package gnome-menus 3.13.3-6ubuntu3.1 failed to install/upgrade: triggers looping, abandoned
UpgradeStatus: Upgraded to bionic on 2018-04-25 (0 days ago)

Related branches

Taihsiang Ho (taihsiangho) wrote :
description: updated
description: updated
tags: removed: need-duplicate-check
Taihsiang Ho (taihsiangho) wrote :
description: updated
Jean-Baptiste Lallement (jibel) wrote :

Thanks for your report.

Could you please attach a tarball of the directory /var/log/dist-upgrade to this bug report?

Changed in gnome-menus (Ubuntu):
status: New → Incomplete
Taihsiang Ho (taihsiangho) wrote :
Taihsiang Ho (taihsiangho) wrote :

Hi jibel, please refer to the attachment of comment #4. It is the tarball of /var/log/dist-upgrade

Changed in oem-priority:
importance: Undecided → Critical
Shih-Yuan Lee (fourdollars) wrote :

@Taihsiang,

Have you checked Ubuntu 16.04.0 and 16.04.1?
If not, could you check if they have the similar issues?

Pascal Morin (pcm689) on 2018-04-26
Changed in oem-priority:
assignee: nobody → Chen-Han Hsiao (Stanley) (swem)
Pascal Morin (pcm689) on 2018-04-26
description: updated
Jean-Baptiste Lallement (jibel) wrote :

Thanks for the logs

Changed in gnome-menus (Ubuntu):
status: Incomplete → Confirmed
Taihsiang Ho (taihsiangho) wrote :

This system Dell XPS 13 9360 (CID 201606-22338) could install stock ubuntu 18.04 daily build 49f7bfba24b829f39f8c6d64ee72dfb2 *bionic-desktop-amd64.iso

Jean-Baptiste Lallement (jibel) wrote :

I reproduced the issue with the clone attached.

Changed in gnome-menus (Ubuntu):
importance: Undecided → Critical
Chris Wayne (cwayne18) wrote :

I've reproduced this with an XPS13 9370, same errors and now X is completely broken

Chris Wayne (cwayne18) on 2018-04-26
Changed in oem-priority:
status: New → Confirmed
Chris Wayne (cwayne18) wrote :

After the initial reboot, x seems to keep crashing, but if you can get to a vt and run apt-get install -f, it seems to at least allow the system to boot

Adam Conrad (adconrad) wrote :

This trigger loop is almost certainly because bamfdaemon's trigger wasn't fixed to be interest-noawait until yakkety, and nothing forces it to deconfigure or upgrade early (ie: with a Breaks like we used in dpkg between trusty and xenial).

Jeff Lane (bladernr) wrote :

FWIW, this error (my bug was marked a duplicate) completely broke my Xenial - Bionic upgrade, leaving me with a nearly unbeatable system. I had to boot into Rescue Mode and do a lot of ctrl-C ing to get around this, and once I thought it had finally installed all the bionic packages, I rebooted into the OS proper, and STILL found it hadn't actually upgraded so I had to run 'apt-get -f install' again to finish the other 2400+ package updates.

I spent most of my morning just trying to get back to a bootable system that was only half-way upgraded (lsb-release told me I was in 18.04, name -a said I was still on 4.13 from 16.04.4, and apt said I still had 2400+ packages to update).

If I was not an experienced user who knew roughly how to manually kick this stuff to get around broken package updates, I'd have been considerably more upset than I already am.

Jeff Lane (bladernr) wrote :

Grr... autocorrect on OSX while I wait for Ubuntu to work again (finish upgrading). That should have said "leaving me with a nearly unbootable system."

Sebastien Bacher (seb128) wrote :

@Jeff, did you use apt instead of the dist-upgrader as well? Was your xenial uptodate before the upgrade?

Jeff Lane (bladernr) wrote :

@seb, per discussion via IRC, here are my logs from /var/log/dist-upgrade (upgrade started last night and finally wrapped up this morning after a lot of coffee and swearing).

To answer the questions:

I started off with 'do-release-upgrade -d' last night and ended up this morning with a reboot into rescue mode and a lot of 'apt-get -f install', 'dpkg --reconfigure -a' and finally an 'apt-get dist-upgrade' (or was it a -f install again?) to get the remaining held 2400+ packages updated.

NOW I believe I'm finally updated to Bionic and running again.

Also, will asked if I had manually modified anything in /etc/apt/sources.list and the answer is no, all that was handled by the upgrader.

Jeff Lane (bladernr) wrote :

FWIW, it's entirely possible I had other issues that just also included this one, or just exposed this one where I may not have seen it otherwise. This just happened to be the only one that Apport was able to create and submit.

Taihsiang Ho (taihsiangho) wrote :

Reproduced similar issue on different platform and SKU (will attach /var/log/dist-upgrade in this bug report):

https://bugs.launchpad.net/ubuntu/+source/gnome-menus/+bug/1767153
https://bugs.launchpad.net/ubuntu/+source/gnome-menus/+bug/1767154

Taihsiang Ho (taihsiangho) wrote :
Taihsiang Ho (taihsiangho) wrote :

201606-22355.dist-upgrade.tar.gz 201610-25144.dist-upgrade.tar.gz are attachments for comment#18

Taihsiang Ho (taihsiangho) wrote :

Dell-XPS-13-9350.tar is a tarball log containing 3 different SKU log of 9350. All of them could reproduce this issue.

Brian Murray (brian-murray) wrote :

I believe the issue is with the libglib2.0-0 triggers which were changed to interest-noawait in bionic but probably also need fixing in xenial.

Brian Murray (brian-murray) wrote :

I also think we have enough information to work on this and no further logs are necessary.

Brian Murray (brian-murray) wrote :

Regarding Adam's comment and bamfdaemon that was fixed in Ubuntu 16.04, see bug 1589097.

Fixing the triggers in libglib2.0-0 and desktop-file-utils did not resolve the issue for me. Additionally, both of those packages are included in standard or the the ubuntu-desktop task and a stock system does not fail to upgrade.

Brian Murray (brian-murray) wrote :

I was also able to recreate this by editing sources.list from xenial to bionic after restoring the apt-clone file.

I did NOT encounter this bug, after restoring the clone file, and then editing sources.list from xenial to bionic and first installing the new version of apt which also pulled in libc among other things.

Brian Murray (brian-murray) wrote :

I performed another upgrade with the apt-clone file from this bug and editing sources.list from xenial to bionic but this time I first installed the version of libc6.

Start-Date: 2018-05-01 12:29:37
Commandline: apt-get install libc6
Requested-By: bdmurray (1000)
Upgrade: libc6-dbg:amd64 (2.23-0ubuntu10, 2.27-3ubuntu1), libc6-dev:amd64 (2.23-0ubuntu10, 2.27-3ubuntu1), libc6:amd64 (2.23-0ubuntu10, 2.27-3ubuntu1), locales:amd64 (2.23-0ubuntu10, 2.27-3ubuntu1), libc-bin:amd64 (2.23-0ubuntu10, 2.27-3ubuntu1), libc6-i386:amd64 (2.23-0ubuntu10, 2.27-3ubuntu1), libc-dev-bin:amd64 (2.23-0ubuntu10, 2.27-3ubuntu1)
End-Date: 2018-05-01 12:29:56

Again I did not encounter the bug when upgrading via this method.

I could reproduce this issue with oem image (somerville 20170614-0). With exactly the same error "dpkg: cycle found while processing triggers:"

But can't reproduce this issue with oem image (columbia 20161201-0).

Attachment is the log for oem image (columbia 20161201-0).

I'll keep identifying root cause for this issue.

Brian Murray (brian-murray) wrote :

It's worth noting that when the apt-clone file is restored that the packages from PPAs are not installed (surely a bug in apt-clone) and so it is not related to the PPA packages rather some combination of the packages from the official archive.

tags: added: id-5af34d8d6d9b09e77c9ac829
Iain Lane (laney) wrote :

I spent a bit of time looking into this one, and I really have no idea. I followed Brian's lead and restored the apt-clone file in comment #20, which makes the bug reproduce.

I upgrade all the machine to all of xenial-{proposed,security,updates} and it still reproduces. I updated desktop-file-utils and glib2.0 to have *all* of their triggers be noawait, even the one which actually needs to be await (schemas).

ubuntu@laney:/var/lib/dpkg/info$ more gnome-menus.triggers bamfdaemon.triggers libglib2.0-0\:amd64.triggers mime-support.triggers desktop-file-utils.triggers
::::::::::::::
gnome-menus.triggers
::::::::::::::
interest-noawait /usr/share/applications
#interest-noawait gmenucache
::::::::::::::
bamfdaemon.triggers
::::::::::::::
interest-noawait /usr/share/applications
interest-noawait gmenucache
::::::::::::::
libglib2.0-0:amd64.triggers
::::::::::::::
interest-noawait /usr/lib/x86_64-linux-gnu/gio/modules
interest-noawait /usr/lib/gio/modules
interest-noawait /usr/share/glib-2.0/schemas
# Triggers added by dh_makeshlibs
activate-noawait ldconfig
::::::::::::::
mime-support.triggers
::::::::::::::
interest-noawait /usr/lib/mime/packages
interest-noawait /usr/share/applications
::::::::::::::
desktop-file-utils.triggers
::::::::::::::
interest-noawait /usr/share/applications

My final attempt was to make *all* file triggers noawait, by editing /var/lib/dpkg/info/*.triggers and /var/lib/dpkg/triggers/File. This also failed, but maybe this isn't a good way to do cowboy that change.

What is this?

tags: added: triggers-looping
Julian Andres Klode (juliank) wrote :

My investigation has shown that upgrading libc6 first produces a vastly different installation ordering. Also, turning off immediate configuration of essential packages in apt makes it work; but triggers bug 1771791 in systemd much more easily than now.

I think it might make sense to set Immediate-Configure to 0 for upgrades. There's a higher chance stuff gets messed up (because now most configuration is done at the end, even of essential packages); but essential packages are supposed to work unconfigured; so it "should" be fine...

agus sukamto (soekamto) on 2018-05-30
Changed in gnome-menus (Ubuntu):
status: Confirmed → Fix Released
Changed in gnome-menus (Ubuntu):
status: Fix Released → Confirmed
Changed in gnome-menus (Ubuntu):
milestone: none → ubuntu-18.04.1
Julian Andres Klode (juliank) wrote :

Still failing with current -proposed enabled. Let's hope it solves itself once we fixed all other instances of triggers.

Iain Lane (laney) wrote :

@juliank, I'll assign this to you for tracking purposes if you don't mind (the rls-bb-tracking page)

Changed in gnome-menus (Ubuntu):
assignee: nobody → Julian Andres Klode (juliank)
Changed in gnome-menus (Ubuntu Xenial):
assignee: nobody → Julian Andres Klode (juliank)
Brian Murray (brian-murray) wrote :

I tested this today by first restoring the clone file found in the tarball in comment #20 then enabling and installing all the packages in -proposed for Ubuntu 16.04. I then modified DistUpgradeController.py in the dist-upgrader tarball so that -proposed would*n't* be disabled during the upgrade. With all of that I still encountered the following error:

Removing webbrowser-app (0.23+16.04.20161028-0ubuntu2) ...
dpkg: cycle found while processing triggers:
 chain of packages whose triggers are or may be responsible:
  bamfdaemon -> desktop-file-utils
 packages' pending triggers which are or may be unresolvable:
  gnome-menus: /usr/share/applications
  bamfdaemon: /usr/share/applications
  libglib2.0-0:amd64: /usr/share/glib-2.0/schemas
  desktop-file-utils: /usr/share/applications
  mime-support: /usr/share/applications
dpkg: error processing package gnome-menus (--remove):
 triggers looping, abandoned
Processing triggers for desktop-file-utils (0.22-1ubuntu5.2) ...
Processing triggers for mime-support (3.59ubuntu1) ...
Processing triggers for libglib2.0-0:amd64 (2.48.2-0ubuntu3) ...
Errors were encountered while processing:
 gnome-menus

Brian Murray (brian-murray) wrote :

Here's some more information from the failure:

Errors were encountered while processing:
 libgoa-backend-1.0-1:amd64
 glib-networking-services
 libgtk-3-0:amd64
 libgoa-1.0-0b:amd64
 bamfdaemon
 glib-networking:amd64
 libclutter-gtk-1.0-0:amd64
 libgail-3-0:amd64
 libunity-control-center1
 libglib2.0-bin
 locales
 gir1.2-goa-1.0:amd64
 libwebkit2gtk-4.0-37:amd64
 libwebkit2gtk-4.0-37-gtk2:amd64
 libsoup2.4-1:amd64
 libsnapd-glib1:amd64
 libgrilo-0.3-0:amd64
 gir1.2-snapd-1:amd64

Changed in oem-priority:
assignee: Chen-Han Hsiao (Stanley) (swem) → nobody
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-menus (Ubuntu Xenial):
status: New → Confirmed
Changed in ubuntu-release-upgrader (Ubuntu Bionic):
status: New → Triaged
Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Triaged
Changed in ubuntu-release-upgrader (Ubuntu Xenial):
status: New → Invalid
Steve Langasek (vorlon) on 2018-08-07
Changed in ubuntu-release-upgrader (Ubuntu):
status: Triaged → In Progress
Changed in ubuntu-release-upgrader (Ubuntu Bionic):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-release-upgrader - 1:18.10.7

---------------
ubuntu-release-upgrader (1:18.10.7) cosmic; urgency=medium

  * Upgrade libc6 before other packages to work around trigger issues
    (LP: #1766890)

 -- Julian Andres Klode <email address hidden> Tue, 07 Aug 2018 23:01:50 +0200

Changed in ubuntu-release-upgrader (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-menus (Ubuntu Bionic):
status: New → Confirmed
description: updated
Changed in gnome-menus (Ubuntu Bionic):
status: Confirmed → Won't Fix
Changed in gnome-menus (Ubuntu Xenial):
status: Confirmed → Won't Fix
Changed in gnome-menus (Ubuntu Bionic):
status: Won't Fix → Triaged
Changed in gnome-menus (Ubuntu Xenial):
status: Won't Fix → Confirmed
Changed in gnome-menus (Ubuntu Bionic):
status: Triaged → Confirmed

Hello Taihsiang, or anyone else affected,

Accepted ubuntu-release-upgrader into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-release-upgrader/1:18.04.23 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ubuntu-release-upgrader (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-bionic
Brian Murray (brian-murray) wrote :
Download full text (3.9 KiB)

I tested an upgrade today from Ubuntu 16.04 to Ubuntu 18.04 using the dist-upgrader from -proposed but not using the clone attached in this bug report and the upgrade did complete successfully with libc6 being upgraded first.

Log started: 2018-08-09 09:56:06
(Reading database ... ^M(Reading database ... 5%^M(Reading database ... 10%^M(Reading database ... 15%^M(Reading database ... 20%^M(Reading database ... 25%^M(Reading database ... 30%^M(Reading database ... 35%^M(Reading database ... 40%^M(Reading database ... 45%^M(Reading database ... 50%^M(Reading database ... 55%^M(Reading database ... 60%^M(Reading database ... 65%^M(Reading database ... 70%^M(Reading database ... 75%^M(Reading database ... 80%^M(Reading database ... 85%^M(Reading database ... 90%^M(Reading database ... 95%^M(Reading database ... 100%^M(Reading database ... 278731 files and directories currently installed.)^M
Preparing to unpack .../libc-dev-bin_2.27-3ubuntu1_amd64.deb ...^M
Unpacking libc-dev-bin (2.27-3ubuntu1) over (2.23-0ubuntu10) ...^M
Preparing to unpack .../libc6-dev_2.27-3ubuntu1_amd64.deb ...^M
Unpacking libc6-dev:amd64 (2.27-3ubuntu1) over (2.23-0ubuntu10) ...^M
Preparing to unpack .../libc6-dbg_2.27-3ubuntu1_amd64.deb ...^M
Unpacking libc6-dbg:amd64 (2.27-3ubuntu1) over (2.23-0ubuntu10) ...^M
Preparing to unpack .../locales_2.27-3ubuntu1_all.deb ...^M
Unpacking locales (2.27-3ubuntu1) over (2.23-0ubuntu10) ...^M
Preparing to unpack .../libc6_2.27-3ubuntu1_amd64.deb ...^M
Checking for services that may need to be restarted...^M
Checking init scripts...^M
Nothing to restart.^M
Unpacking libc6:amd64 (2.27-3ubuntu1) over (2.23-0ubuntu10) ...^M
Setting up libc6:amd64 (2.27-3ubuntu1) ...^M
Installing new version of config file /etc/ld.so.conf.d/x86_64-linux-gnu.conf ...^M
Checking for services that may need to be restarted...^M
Checking init scripts...^M
Nothing to restart.^M
Processing triggers for man-db (2.7.5-1) ...^M
(Reading database ... ^M(Reading database ... 5%^M(Reading database ... 10%^M(Reading database ... 15%^M(Reading database ... 20%^M(Reading database ... 25%^M(Reading database ... 30%^M(Reading database ... 35%^M(Reading database ... 40%^M(Reading database ... 45%^M(Reading database ... 50%^M(Reading database ... 55%^M(Reading database ... 60%^M(Reading database ... 65%^M(Reading database ... 70%^M(Reading database ... 75%^M(Reading database ... 80%^M(Reading database ... 85%^M(Reading database ... 90%^M(Reading database ... 95%^M(Reading database ... 100%^M(Reading database ... 278807 files and directories currently installed.)^M
Preparing to unpack .../libc-bin_2.27-3ubuntu1_amd64.deb ...^M
Unpacking libc-bin (2.27-3ubuntu1) over (2.23-0ubuntu10) ...^M
Processing triggers for man-db (2.7.5-1) ...^M
Setting up libc-bin (2.27-3ubuntu1) ...^M
Setting up libc-dev-bin (2.27-3ubuntu1) ...^M
Setting up libc6-dev:amd64 (2.27-3ubuntu1) ...^M
Setting up libc6-dbg:amd64 (2.27-3ubuntu1) ...^M
Setting up locales (2.27-3ubuntu1) ...^M
Installing new version of config file /etc/locale.alias ...^M
Generating locales (this might take a while)...^M
...
Generation complete.^M
Log ended: 2018-08-09 09:56:24

Log started: 2018-08-09 09:57:01
(Reading database...

Read more...

Brian Murray (brian-murray) wrote :

I also performed an upgrade from Ubuntu 16.04, with the apt-clone file restored, to Ubuntu 18.04 using the dist-upgrader from -proposed.. The upgrade proceeded without error and libc6 was installed first.

bdmurray@clean-xenial-amd64:~$ grep -n "libc6\|gnome-menus" /var/log/dist-upgrade/apt-term.log
9:Preparing to unpack .../libc6-dev_2.27-3ubuntu1_amd64.deb ...
10:Unpacking libc6-dev:amd64 (2.27-3ubuntu1) over (2.23-0ubuntu10) ...
11:Preparing to unpack .../libc6-dbg_2.27-3ubuntu1_amd64.deb ...
12:Unpacking libc6-dbg:amd64 (2.27-3ubuntu1) over (2.23-0ubuntu10) ...
15:Preparing to unpack .../libc6_2.27-3ubuntu1_amd64.deb ...
19:Unpacking libc6:amd64 (2.27-3ubuntu1) over (2.23-0ubuntu10) ...
20:Setting up libc6:amd64 (2.27-3ubuntu1) ...
32:Preparing to unpack .../libc6-i386_2.27-3ubuntu1_amd64.deb ...
33:Unpacking libc6-i386 (2.27-3ubuntu1) over (2.23-0ubuntu10) ...
36:Setting up libc6-dev:amd64 (2.27-3ubuntu1) ...
37:Setting up libc6-dbg:amd64 (2.27-3ubuntu1) ...
59:Setting up libc6-i386 (2.27-3ubuntu1) ...
224:Processing triggers for gnome-menus (3.13.3-6ubuntu3.1) ...
237:Processing triggers for gnome-menus (3.13.3-6ubuntu3.1) ...
305:Processing triggers for gnome-menus (3.13.3-6ubuntu3.1) ...
701:dpkg: gnome-menus: dependency problems, but processing triggers anyway as you requested:
702: gnome-menus depends on python3:any (>= 3.1~); however:
705:Processing triggers for gnome-menus (3.13.3-6ubuntu3.1) ...
4150:Preparing to unpack .../gnome-menus_3.13.3-11ubuntu1.1_amd64.deb ...
4151:Unpacking gnome-menus (3.13.3-11ubuntu1.1) over (3.13.3-6ubuntu3.1) ...
12060:Setting up gnome-menus (3.13.3-11ubuntu1.1) ...
14849:Processing triggers for gnome-menus (3.13.3-11ubuntu1.1) ...
14901:Processing triggers for gnome-menus (3.13.3-11ubuntu1.1) ...
14923:Processing triggers for gnome-menus (3.13.3-11ubuntu1.1) ...

Brian Murray (brian-murray) wrote :

Hello Taihsiang, or anyone else affected,

Accepted ubuntu-release-upgrader into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-release-upgrader/1:18.04.24 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Julian Andres Klode (juliank) wrote :

I also did some more verification with the graphical frontend and the apt-clone file restored, and it worked perfectly well, with libc6 upgraded first. Progress reporting was a bit weird as it went to 100% for the libc stuff, and then down again, but it could be worse.

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-release-upgrader - 1:18.04.24

---------------
ubuntu-release-upgrader (1:18.04.24) bionic; urgency=medium

  * DistUpgradeController.py: Remove an unnecessary debugging entry when
    calculating the debs to remove.

ubuntu-release-upgrader (1:18.04.23) bionic; urgency=medium

  * Upgrade libc6 before other packages to work around trigger issues
    (LP: #1766890)

 -- Brian Murray <email address hidden> Thu, 09 Aug 2018 10:54:40 -0700

Changed in ubuntu-release-upgrader (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for ubuntu-release-upgrader has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Changed in gnome-menus (Ubuntu Bionic):
assignee: nobody → Julian Andres Klode (juliank)
To post a comment you must log in.