Volume control icon not present after upgrade to Lucid final

Bug #552221 reported by benohb on 2010-03-31
102
This bug affects 20 people
Affects Status Importance Assigned to Milestone
gnome-media (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: gnome-system-tools

After an upgrade to Lucid users report loosing their volume control applet. Looking in System > Preferences > Startup Applications (if you do not have this, it is most likely another bug - if so, the application will be called Sessions) there is no entry for Volume Control "gnome-volume-control-applet".

http://ubuntuforums.org/showthread.php?p=9008402
http://ubuntuforums.org/showthread.php?p=9121860

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: gnome-system-tools 2.29.92-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-18.27-generic 2.6.32.10+drm33.1
Uname: Linux 2.6.32-18-generic i686
Architecture: i386
Date: Wed Mar 31 02:29:19 2010
ExecutablePath: /usr/bin/users-admin
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100224.1)
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: gnome-system-tools
XsessionErrors: (polkit-gnome-authentication-agent-1:1785): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

benohb (hamid) wrote :
Milan Bouchet-Valat (nalimilan) wrote :

Well, pasting a link, expecting triagers will go through the whole thread to understand your problem is hardly a nice practice. I see there that your problem is solved, and you don't provide any detail about the problem. Did you upgrade from Karmic? Was the applet present in the list, only unchecked?

And the package is wrong:
$ dpkg -S gnome-volume-control-applet
gnome-media: /usr/bin/gnome-volume-control-applet
gnome-media: /etc/xdg/autostart/gnome-volume-control-applet.desktop
(ironically, the latter file is the one you should have on your system for the applet to start on its own)

affects: gnome-system-tools (Ubuntu) → gnome-media (Ubuntu)
Changed in gnome-media (Ubuntu):
status: New → Incomplete
importance: Undecided → Medium
Milan Bouchet-Valat (nalimilan) wrote :

Actually, in Ubuntu, you need to add the notification applet to the panel (not the notification area). It provides the messaging and the volume icon, that's why gnome-volume-control-applet is disabled (not sure how, though). The bug is in the fact that upgraders are not suggested to add it, but that may be a planned feature.

Milan Bouchet-Valat (nalimilan) wrote :

When exactly did you upgrade from Karmic? Normally, since beta1, the indicator-applet is added to the panel automatically. If you upgraded before that, then you may have missed that feature.

benohb (hamid) wrote :

Sory abot link ..I install 10.04 /alpha -3 and after update , the icon of volume Disappeared...!
now i use a "gnome-volume-control-applet" Form Ubuntu 9.10

Thanks for the answer

Milan Bouchet-Valat (nalimilan) wrote :

OK, thanks for the reply. So you suffer from this bug because you were an early tester. You can either continue using gnome-volume-control-applet, or add the indicator applet to your panel.

Changed in gnome-media (Ubuntu):
status: Incomplete → Invalid
nhasian (nhasian) wrote :

I'm experiencing this bug as well. I upgraded to 10.04 Alpha3 from Karmic too. I have all the updates for lucid right now. I also have "Notification Area 2.30.0" on my menu bar, but no volume or messing icon.

Milan Bouchet-Valat (nalimilan) wrote :

nhasian: you need to add the "notification applet", which is different from the "notification area".

benohb (hamid) on 2010-04-02
Changed in gnome-media (Ubuntu):
status: Invalid → Fix Released
komputes (komputes) on 2010-04-14
summary: - volume icon is missing
+ Volume Control "gnome-volume-control-applet" entry is removed from
+ Startup Applications "gnome-session-properties" after release-upgrade to
+ Lucid
description: updated

Hi benohb,

It seems the issue is still there. Note that creating a startup entry for "gnome-volume-control-applet" is not a fix but a workaround. If this is all you did, please let me know. The actual bug will be fixed once a user can do a distribution upgrade without losing the volume control applet. Will mark as confirmed as I have had two users recently report this issue after an upgrade to Lucid. Will test this myself and let you know if the bug has actually been fixed.

Changed in gnome-media (Ubuntu):
assignee: nobody → komputes (komputes)
status: Fix Released → Confirmed
Peter Matulis (petermatulis) wrote :

I upgraded today and I lost the volume applet.

I started a Lucid upgrade this morning at 8:50 EDT albeit with the beta2 DVD. An hour later I mopped up with a network upgrade.

komputes (komputes) on 2010-04-14
Changed in gnome-media (Ubuntu):
assignee: komputes (komputes) → nobody
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
summary: Volume Control "gnome-volume-control-applet" entry is removed from
Startup Applications "gnome-session-properties" after release-upgrade to
- Lucid
+ Lucid. Volume control applet not started with session.

komputes, Peter Matulis: Please ensure you haven't removed by hand the indicator applet in Karmic before upgrading. gnome-volume-control-applet is removed *on purpose* from startup programs, because it's replaced by the indicator applet.

OTOH, we don't force adding the indicator applet into the panel after an upgrade, because it is assumed you knew what you were doing when you removed it. But maybe we should consider adding it anyway, and let you get rid of it if needed. To get the indicator applet back in the panel, have a look at instructions I posted above.

Please tell whether my above assumption is right.

Changed in gnome-media (Ubuntu):
status: Confirmed → Incomplete
summary: - Volume Control "gnome-volume-control-applet" entry is removed from
- Startup Applications "gnome-session-properties" after release-upgrade to
- Lucid. Volume control applet not started with session.
+ Volume control icon not present after upgrade to Lucid when app
+ indicator applet has been removed by hand in Karmic
Peter Matulis (petermatulis) wrote :

@Milan, how do I add the "notification applet"? All I see is the "notification area" under the 'Add to Panel...' facility.

Peter Matulis (petermatulis) wrote :

OK, I installed the "indicator applet" and I got the knob, plus an envelope.

Sebastien Bacher (seb128) wrote :

the indicator is added to the configuration on upgrade to lucid

Sebastien: Seems to be something weird here. If I've understood correctly, the applet won't be added if people come from Karmic and have removed it there. Am I completely wrong? That would be the only explanation...

benohb (hamid) on 2010-04-15
Changed in gnome-media (Ubuntu):
status: Incomplete → Fix Released
neub (benpaka) wrote :

I had the same problem and I needed to go to this bug report to understand that adding the indicator-applet is the thing to correct this bug.

I think that, the description of indicator-applet should be updated to add something like: "... need your attention on the desktop (volume, instant message, emails, ...)"

OK, I have to reopen this because in addition to the 3 users that have reported to suffer from this bug after an upgrade, I can also confirm it. I have upgraded 3 Hardy systems last friday, and none of them had the indicator-applet added.

So we'd need to be sure that the actual wanted behavior is adding the applet. Else, another solution would be to autostart gnome-volume-control-applet when we detect that the applet is not present.

Changed in gnome-media (Ubuntu):
status: Fix Released → Triaged
summary: - Volume control icon not present after upgrade to Lucid when app
- indicator applet has been removed by hand in Karmic
+ Volume control icon not present after upgrade to Lucid final
redkirk (redkirk) wrote :

Using "Upgrade Manager" to do online upgrade from 9.10 Karmic to 10.04 Lucid on Sat 2010-05-01.
Same problem - Volume Control icon disappears. Took finding this thread to solve problem. Very annoying to take an entire weekend looking for a solution.

redkirk (redkirk) wrote :

Sorry for 2nd post (where's edit comment on this board).

There was no *obvious* indication that I was removing the "Indicator Applet" during this upgrade. Why would I?

dmn86 (dmn86) wrote :

Have the same problem. When I was on 9.10 volume control applet was present on panel. I'm sure I have not removed it manually. After upgrading to 10.04 it disappeared from panel and cannot be found both in system->startup and "rightclick->add to panel". I'm not experienced linux user, but for me it looks like volum control applet was deinstalled while updating and now there is nothing of similar functionality installed.

frotz (frotz) wrote :

dmn86 wrote on 2010-05-06:

> Have the same problem. When I was on 9.10 volume control applet was present on panel. I'm sure I have not removed it
> manually. After upgrading to 10.04 it disappeared from panel and cannot be found both in system->startup and "rightclick->add
> to panel". I'm not experienced linux user, but for me it looks like volum control applet was deinstalled while updating and now
> there is nothing of similar functionality installed.

I'm an experienced user and I found this annoying as well. Applets shouldn't disappear like that. The idea of a do-everything applet is a bad idea. What happened to the philosophy of "do one thing, but do it well"? Now I have to dink around with Preferences->Startup_Applications instead of simply adding it to the panel.

Tim Starling (tstarling) wrote :

I had indicator-applet after upgrade from Karmic to Lucid, but no indicator-sound. I expect such problems on upgrade, since I can't have ubuntu-desktop installed because it conflicts with fcron, which I need.

However, I notice that indicator-applet only recommends indicator-sound, it doesn't depend on it. That's probably why I didn't have it. I can't see any other meta-package which would have caused it to be installed. Maybe ubuntu-desktop should depend on indicator-applet-complete.

phil (fongpwf) wrote :

I had this problem as well. I upgraded from Jaunty to Karmic to Lucid today. I had held off on upgrading to Karmic due to the backlight cycling bug in Karmic. Once in Jaunty, I had no volume control and had to find this thread to find out what happened.

The problem with the indicator applet as a volume control is that is also adds the useless (to me) envelope icon which is now wasting valuable space on my relatively tiny netbook screen.

Changed in gnome-media (Ubuntu):
assignee: Canonical Desktop Team (canonical-desktop-team) → nobody
Jamie Lokier (jamie-shareable) wrote :

I've just upgraded a laptop, in the last 2 days, Jaunty -> Karmic -> Lucid (one upgrade each night).

(This was a very vanilla Jaunty installation, previously upgraded from Intrepid and kept the same for ages, very little extra installed, virtually no settings changes, and used by its owner almost exclusively for Firefox.)

Afterwards there was no volume control in the task bar. It was previously in a convenient location close to the top right.

The comments here say indicator-applet should be installed automatically, but that clearly hasn't happened.

(There is an envelope in the task bar, but it is still the Evolution launcher (which was there before), and looks like an open envelope rather than a closed one.)

I wasn't surprised the volume control disappeared as the same happened with my laptop, but in my case it's taken me 5 months to discover that's because (a) the upgrade process removes the old applet, but doesn't install the new applet, and (b) for some unclear reason the old volume control cannot be added from the "Add to Panel" menu.

For my friend's laptop, I will follow the instructions to manually edit startup applications to run the old applet. The indicator applet would confuse her due to the superfluous envelope, and also the new applet's volume control is much harder to use with a mouse (she has physical difficulties.)

Jamie Lokier (jamie-shareable) wrote :

Responding to comment #18, Milan Bouchet-Valat wrote on 2010-05-02:

> So we'd need to be sure that the actual wanted behavior is adding the applet. Else, another solution would be to autostart gnome-volume-control-applet when we detect that the applet is not present.

- How about *not remove* the gnome-volume-control-applet on upgrade? Most users who care (maybe all) had it there before the upgrade. I'm not sure if the applet changed name; if so, then rename?

Also, I suspect the following would also help most affected users.

- List the gnome-volume-control-applet under "Add to Panel". It was there in Karmic and earlier as "Volume control applet" or something like that.

Because it is no longer shown in "Add to Panel", I assumed for months that it had been removed from the distribution, as I assumed all installed and properly packaged applets would appear in that list.

There is really no clue at all that adding "Indicator applet" provides a volume control. Even including "volume" somewhere in the menu's descriptive text would have been helpful.

Finally: Sorry, I was wrong in the previous comment about it being much harder to control the indicator-applet with the mouse. I was echoing a complaint elsewhere that it's now a horizontal scrollbar and not controllable with mouse "scroll wheel" or touchpad scroll area. But actually those do still work.

(However, I suggest the old applet's visuals are better when scrolling: The gnome-volume-control-applet's changing tooltip gives much better visual feedback about the volume, especially useful when there's nothing currently making a sound. And the old applet shows as muted when slid to the minimum volume; the indicator-applet doesn't.)

Thanks

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers