softwarecenter.db.update - WARNING - The file: '/usr/share/app-install/desktop/gnome-do.desktop' could not be read correctly.

Bug #731002 reported by miegiel on 2011-03-08
192
This bug affects 33 people
Affects Status Importance Assigned to Milestone
app-install-data-ubuntu (Ubuntu)
Low
Unassigned
Natty
Low
Unassigned
gnome-do (Ubuntu)
Low
Michael Vogt
Natty
Low
Michael Vogt

Bug Description

Binary package hint: software-center

While updating with 'apt-get' when 'software-center' was being setup, I got the warning below.

Setting up software-center (3.1.23.1) ...
Updating software catalog...this may take a moment.
2011-03-08 00:08:35,652 - softwarecenter.db.update - WARNING - The file: '/usr/share/app-install/desktop/gnome-do.desktop' could not be read correctly. The application associated with this file will not be included in the software catalog. Please consider raising a bug report for this issue with the maintainer of that application
Software catalog update was successful.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: software-center 3.1.23.1
ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
Uname: Linux 2.6.38-5-generic i686
Architecture: i386
Date: Tue Mar 8 01:10:39 2011
InstallationMedia: Xubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110112)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: software-center
UpgradeStatus: Upgraded to natty on 2011-02-01 (34 days ago)

miegiel (nix-miegiel) wrote :
miegiel (nix-miegiel) wrote :

Maybe I should have filed this under 'gnome-do' instead of 'software-center'.

as a workaroud for the error, only edit the file : /usr/share/applications/gnome-do.desktop, by removing the erroneous line after 'Comment[kk]' and run ' sudo update-desktop-database'. And it's a bug from gnome-do, not software-center

miegiel (nix-miegiel) wrote :

Thanks, I think this is a duplicate of another bug (the 'Comment[kk]' confused me in that report), but I can't find it anymore.

wolfger (wolfger) on 2011-03-08
affects: software-center (Ubuntu) → gnome-do (Ubuntu)
Changed in gnome-do (Ubuntu):
status: New → Confirmed
José Lou Chang (obake) wrote :

I have also came across that error message upon updating Ubuntu natty with the terminal today:

Setting up software-center (3.1.23.2) ...
Updating software catalog...this may take a moment.
2011-03-11 14:41:40,854 - softwarecenter.db.update - WARNING - The file: '/usr/share/app-install/desktop/gnome-do.desktop' could not be read correctly. The application associated with this file will not be included in the software catalog. Please consider raising a bug report for this issue with the maintainer of that application
Software catalog update was successful.
Setting up system-config-printer-common (1.3.1+20110222-0ubuntu5) ...
Setting up system-config-printer-gnome (1.3.1+20110222-0ubuntu5) ...
Setting up system-config-printer-udev (1.3.1+20110222-0ubuntu5) ...
Setting up udisks (1.0.2-4) ...
Setting up indicator-sound (0.6.3-0ubuntu1) ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
Processing triggers for python-support ...
Processing triggers for python-central ...

José Lou Chang (obake) wrote :

I do not know how this is related to gnome-do. Considering that I do not have it installed.

cntraviata (shenglizhezhe) wrote :

WARNING - The file: '/usr/share/app-install/desktop/gnome-do.desktop' could not be read correctly. The application associated with this file will not be included in the software catalog. Please consider raising a bug report for this issue with the maintainer of that application.

Micah Gersten (micahg) wrote :

Most people are hitting this in app-install-data, but this needs to be fixed in gnome-do first. Then, app-install-data can be updated.

Changed in app-install-data-ubuntu (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Changed in gnome-do (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
Changed in app-install-data-ubuntu (Ubuntu):
milestone: none → ubuntu-11.04
Changed in gnome-do (Ubuntu):
milestone: none → ubuntu-11.04

I don't think this has something to do with gnome-do. See my attached error-messages after reinstall software-center. There are tons of this error, not only with gnome-do and the software-center does not show a single entry. Its completely empty.

Jacopo Moronato (jmoronat) wrote :

It seems to be fixed in latest Gnome-Do revision, see bug #688563 .

Changed in gnome-do (Ubuntu Natty):
status: Triaged → Fix Committed

Really? Because I don't have gnome-do installed. But there was an update for the software-center too, after that it was gone.

Jacopo Moronato (jmoronat) wrote :

I've installed Natty a few hours ago, with latest Software Center, and I noticed that warning.

Jacopo Moronato (jmoronat) wrote :

Of course we have to wait for the Gnome-Do revision to be updated to ubuntu repositories.

Micah Gersten (micahg) wrote :

This is Fix Committed upstream, not in Ubuntu.

Changed in gnome-do (Ubuntu Natty):
status: Fix Committed → Triaged
Michael Vogt (mvo) on 2011-04-01
Changed in gnome-do (Ubuntu Natty):
assignee: nobody → Michael Vogt (mvo)
status: Triaged → In Progress
Michael Vogt (mvo) on 2011-04-01
Changed in app-install-data-ubuntu (Ubuntu Natty):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package app-install-data-ubuntu - 0.11.04.7.1

---------------
app-install-data-ubuntu (0.11.04.7.1) natty; urgency=low

  * menu-data-additional/fglrx-driver.desktop:
    - fix package name of fglrx
  * menu-data/gnome-do.desktop:
    - fix gnome-do entry (LP: #731002)
 -- Michael Vogt <email address hidden> Fri, 01 Apr 2011 15:46:41 +0200

Changed in app-install-data-ubuntu (Ubuntu Natty):
status: In Progress → Fix Released
Michael Vogt (mvo) on 2011-04-01
Changed in gnome-do (Ubuntu Natty):
status: In Progress → Fix Released
vmc (vmclark) wrote :

This bug is still around.

Using Ubuntu-GNOME 13.10, installing nvidia_173 and I get this warring.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions