The file: '/usr/share/app-install/desktop/gnome-do.desktop' could not be read correctly

Bug #730775 reported by Peter Belew on 2011-03-07
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-do (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: update-manager

'E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.'

I can't update this system either with the GUI update-manager or with apt-get from the command line.

 Linux distro/version and kernel version
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu Natty (development branch)
Release: 11.04
Codename: natty
Linux cupid 2.6.38-5-generic #32-Ubuntu SMP Tue Feb 22 16:09:46 UTC 2011 i686 athlon i386 GNU/Linux
model name : Mobile AMD Sempron(tm) Processor 2800+
cpu MHz : 800.000/1600.000

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: update-manager 1:0.146.1
ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
Uname: Linux 2.6.38-5-generic i686
Architecture: i386
Date: Mon Mar 7 09:51:47 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20101202)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: update-manager
UpgradeStatus: Upgraded to natty on 2011-02-01 (34 days ago)

Peter Belew (peterbe) wrote :
Peter Belew (peterbe) wrote :

Errors from running apt-get:

# apt-get dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Failed
The following packages have unmet dependencies:
 libcanberra-gtk0 : Breaks: libcanberra-gtk3-0 (< 0.28-0ubuntu1) but 0.26-1ubuntu9 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

RedSingularity (redsingularity) wrote :

Thanks for reporting this. Please run the following 2 commands:

sudo apt-get update | tee ~/Desktop/Update1

sudo apt-get upgrade | tee ~/Desktop/Upgrade1

Afterward attach the 2 files that will be located on your desktop.

Changed in update-manager (Ubuntu):
status: New → Incomplete
Peter Belew (peterbe) wrote :

Thanks, RedSingularity!

Before reading comment #3, I tried updating both wiith update-manager and apt-get, with the same errors as before.

Tnen, after I read those instructions, I ran the two commands.

Here's ~/Desktop/Update1

Peter Belew (peterbe) wrote :

Here's the apt-get upgrade output.

Note the following error:

2011-03-08 08:48:01,892 - softwarecenter.db.update - WARNING - The file: '/usr/share/app-install/desktop/gnome-do.desktop' could not be read correctly. The application associated with this file will not be included in the software catalog. Please consider raising a bug report for this issue with the maintainer of that application

Peter Belew (peterbe) wrote :

After running the 2 commands specified in #3, and rebooting, I tried running update-manager - and again got the error message in a popup:

Could not calculate the upgrade

An unresolvable problem occurred while calculating the upgrade.

Please report this bug against the 'update-manager' package and include the following error message:
'E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.'

RedSingularity (redsingularity) wrote :

Try this:

sudo mv /usr/share/app-install/desktop/gnome-do.desktop /usr/share/app-install/desktop/gnome-do-test

Then run:

sudo apt-get update

and......

sudo apt-get upgrade | tee ~/Desktop/Upgrade2

Just attach the output from the upgrade. Will be called "Upgrade2" on desktop.

Peter Belew (peterbe) wrote :

I just performed the test in comment #7, after renaming gnome-do.desktop (The file produced I've called Upgrade5, since I did some upgrades in between).

No upgrades were made this time - various upgrades were held back. The output file shows this.

RedSingularity (redsingularity) wrote :

So the error is gone now but you have held packages? Attach your sources.list file. To get it on the desktop run this:

cat /etc/apt/sources.list > ~/Desktop/Sources

Peter Belew (peterbe) wrote :

Actually I get the same error when I run update-manager.

Here's my sources.list file.

Sources look good. Nothing foreign in there. Are you getting the error about gnome-do every time you try to update/upgrade the system?

Peter Belew (peterbe) wrote :

"Are you getting the error about gnome-do every time you try to update/upgrade the system?" -- Yes, I am.

Peter Belew (peterbe) wrote :

Actually, that's with

   apt-get dist-upgrade

Gnome-do.desktop should still me "moved" so run this to make sure:

ls /usr/share/app-install/desktop/gnome-do.desktop

And paste the output of that.

Peter Belew (peterbe) wrote :

ls /usr/share/app-install/desktop/gnome-do.desktop
ls: cannot access /usr/share/app-install/desktop/gnome-do.desktop: No such file or directory

Still renamed to gnome-do-test, which contains

cat gnome-do-test
[Desktop Entry]
X-AppInstall-Package=gnome-do
X-AppInstall-Popcon=10776
X-AppInstall-Section=universe

Name=GNOME Do
Type=Application
Exec=gnome-do
Terminal=false
Icon=gnome-do
Comment=Do things as quickly as possible (but no quicker) with your files, bookmarks, applications, music, contacts, and more!
және тағы кез-келген бар нәрселеріңізбен мүмкіндігінше жылдам (бірақ жылдамырақ емес) жұмыс істеңіз!
Categories=Utility;
X-Ubuntu-Gettext-Domain=app-install-data

BTW the third-from-last line appears to be in a Turkic language - am I right?

Yes it looks like another language. Lets do this:

1) sudo apt-get autoremove --purge gnome-do

then run this command to search for residual files:

2) sudo find / -name *gnome-do*

Paste the output to your next post.

(Don't reinstall gnome-do until we remove some of the residual files)

Peter Belew (peterbe) wrote :

I did (1) then (2):

root@cupid:~# apt-get autoremove --purge gnome-do
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package gnome-do is not installed, so not removed
The following packages will be REMOVED:
  gir1.2-dbusmenu-glib-0.4* gir1.2-unity-3.0* libgkeyfile1.0-cil*
  libgudev1.0-cil*
0 upgraded, 0 newly installed, 4 to remove and 149 not upgraded.
After this operation, 348 kB disk space will be freed.
Do you want to continue [Y/n]? y
(Reading database ... 205091 files and directories currently installed.)
Removing gir1.2-unity-3.0 ...
Removing gir1.2-dbusmenu-glib-0.4 ...
Removing libgkeyfile1.0-cil ...
Removing libgkeyfile1.0-cil from Mono
Removing libgudev1.0-cil ...
Removing libgudev1.0-cil from Mono
Processing triggers for python-support ...

root@cupid:~# find / -name "*gnome-do*"
/var/lib/dpkg/info/gnome-doc-utils.list
/var/lib/dpkg/info/gnome-doc-utils.prerm
/var/lib/dpkg/info/gnome-doc-utils.md5sums
/var/lib/dpkg/info/gnome-doc-utils.postinst
/usr/share/aclocal/gnome-doc-utils.m4
/usr/share/doc/gnome-doc-utils
/usr/share/icons/Humanity/apps/16/gnome-do-panel.svg
/usr/share/icons/Humanity/apps/22/gnome-do-panel.svg
/usr/share/icons/Humanity/apps/24/gnome-do-panel.svg
/usr/share/icons/ubuntu-mono-light/apps/22/gnome-do-symbolic.svg
/usr/share/icons/ubuntu-mono-light/apps/24/gnome-do-symbolic.svg
/usr/share/icons/ubuntu-mono-dark/apps/22/gnome-do-symbolic.svg
/usr/share/icons/ubuntu-mono-dark/apps/24/gnome-do-symbolic.svg
/usr/share/icons/Humanity-Dark/apps/16/gnome-do-panel.svg
/usr/share/gnome-doc-utils
/usr/share/gnome-doc-utils/gnome-doc-utils.make
/usr/share/omf/gnome-doc-xslt
/usr/share/omf/gnome-doc-xslt/gnome-doc-xslt-de.omf
/usr/share/omf/gnome-doc-xslt/gnome-doc-xslt-C.omf
/usr/share/omf/gnome-doc-make
/usr/share/omf/gnome-doc-make/gnome-doc-make-de.omf
/usr/share/omf/gnome-doc-make/gnome-doc-make-C.omf
/usr/share/python-support/gnome-doc-utils.public
/usr/share/gnome/help/gnome-doc-xslt
/usr/share/gnome/help/gnome-doc-xslt/C/gnome-doc-xslt.xml
/usr/share/gnome/help/gnome-doc-xslt/de/gnome-doc-xslt.xml
/usr/share/gnome/help/gnome-doc-make
/usr/share/gnome/help/gnome-doc-make/C/gnome-doc-make.xml
/usr/share/gnome/help/gnome-doc-make/de/gnome-doc-make.xml
/usr/share/locale-langpack/en_GB/LC_MESSAGES/gnome-doc-utils.mo
/usr/share/locale-langpack/en_AU/LC_MESSAGES/gnome-doc-utils.mo
/usr/share/locale-langpack/en@shaw/LC_MESSAGES/gnome-doc-utils.mo
/usr/share/locale-langpack/en_CA/LC_MESSAGES/gnome-doc-utils.mo
/usr/share/app-install/icons/gnome-do.svg
/usr/share/app-install/desktop/gnome-do-test
/usr/share/pkgconfig/gnome-doc-utils.pc
/usr/bin/gnome-doc-tool
/usr/bin/gnome-doc-prepare
root@cupid:~#

Ok, now run the following:

sudo rm -r /usr/share/app-install/desktop/gnome-do-test
sudo rm -r /usr/bin/gnome-doc-tool
sudo rm -r /usr/bin/gnome-doc-prepare
sudo rm -r /usr/share/pkgconfig/gnome-doc-utils.pc
sudo rm -r /usr/share/gnome-doc-utils

Then reinstall the application and see if the problem persists.

affects: update-manager (Ubuntu) → gnome-do (Ubuntu)
summary: - update-manager fails due to held packages
+ The file: '/usr/share/app-install/desktop/gnome-do.desktop' could not be
+ read correctly

Actually this seems to be a duplicate of bug 731002. Marking.

Changed in gnome-do (Ubuntu):
status: Incomplete → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers