Docky locks up on 'About Do'

Bug #361679 reported by Confuseling on 2009-04-15
72
This bug affects 11 people
Affects Status Importance Assigned to Milestone
Do
High
Unassigned
gnome-do (Ubuntu)
High
Unassigned
Nominated for Jaunty by Grant Bowman
Nominated for Karmic by Grant Bowman

Bug Description

Binary package hint: gnome-do

Several reports that using Jaunty and selecting 'About Do' on the right click menu of the 'GNOME Do' icon in Docky freezes the system.

Some users can click the 'close' button to regain system. I can't (although I can move the mouse), and have to Ctrl-Alt-Backspace or switch to a virtual terminal to reset.

[EDIT - you can, obviously, just hit return instead. Don't quite know why I didn't think of that. :-)]

Can't find any interesting messages in /var/log/messages, dmesg or ~/.xsession-errors, and running GNOME Do from a terminal doesn't produce any output. This does not occur in non Docky modes of Do.

Details:

lsb_release -rd
 Description: Ubuntu 9.04
 Release: 9.04
apt-cache policy gnome-do
 gnome-do:
   Installed: 0.8.1.3-0ubuntu2
   Candidate: 0.8.1.3-0ubuntu2
   Version table:
  *** 0.8.1.3-0ubuntu2 0
         500 http://ports.ubuntu.com jaunty/universe Packages
         100 /var/lib/dpkg/status

eeepc 1000 using updated fresh Jaunty install on EXT4, compiz, EXA

Forum link:
http://ubuntuforums.org/showthread.php?t=1124761

ProblemType: Bug
Architecture: lpia
DistroRelease: Ubuntu 9.04
Package: gnome-do 0.8.1.3-0ubuntu2
ProcEnviron:
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-do
Uname: Linux 2.6.28-11-lpia i686

Confuseling (m-gentry) wrote :

On Wed, Apr 15, 2009 at 8:23 AM, Confuseling <email address hidden> wrote:

> Jaunty install on EXT4, compiz, EXA
>

I really can't imagine what in our code would be causing thing. I'm going to
start by blaming this on the intel driver which seems to be all kinds of
fail in Jaunty. Can you try UXA maybe?

--
--Alex Launi

Confuseling (m-gentry) on 2009-04-15
description: updated
Confuseling (m-gentry) wrote :

Thanks for the swift response.

Tried UXA. 1st attempt still froze, but did allow me to click close button on window decorations. Second and third attempts freeze as before, have to Ctrl-Alt-Backspace.

I noticed that I can click and drag to select text in the About Do window. Youtube video continues merrily playing away in the background.

Odd.

Nick B. (futurepilot) wrote :

I've been able to reproduce this on two computers using Nvidia cards, so I don't think it's specific to the Intel driver. I also tested it with Metacity's compositor instead of Compiz and it had the same problem.

 affects ubuntu/gnome-do
 status confirmed
 importance high
 affects do
 status confirmed
 importance high

Oooh. I can almost reproduce this.

So, I think what's happening is this: Do takes out pointer and keyboard
grabs when summoned so that (a) all keyboard input goes to Do, and (b)
clicking the mouse outside the Do window closes Do. It seems we also
take out such a grab when showing the context menus, for similar
reasons. This is all well and good - normally the worst that can happen
is that the first click you make unsummons Do, which releases the grab.

However... the About (and Preferences) windows block the main Do
interface for reasons which I'm sure were good reasons but I forget.
So: the context-menu pops up, taking a pointer grab. If you click
"Preferences", the menu is dismissed, the grab released, and _then_ the
preferences window is shown (which now blocks the main UI). If you
click "About Do", however, the About window is shown *before* the
context menu is dismissed and the pointer grab is dropped. So all mouse
clicks go to Do, but the interface is blocked while the window is shown,
so mouse clicks now *don't* release the grab.

I think that's the case, and if so, the fix should be a simple matter of
dismissing the context menu & grab before showing the About box.

Changed in gnome-do (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Changed in do:
milestone: none → 0.8.2
Confuseling (m-gentry) on 2009-06-09
description: updated
Jason Smith (jassmith) on 2009-06-19
Changed in do:
status: Confirmed → Fix Committed
Changed in do:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-do - 0.8.2+dfsg-1

---------------
gnome-do (0.8.2+dfsg-1) unstable; urgency=low

  * New upstream release
    + No longer uses a plugin repository. Fixes many plugin-
      related issues. (LP: #343096, LP: #330025, LP #345001)
    + No longer blocks on "About Do" (LP: #361679)
    + Reacts correctly when a Composite manager is enabled/
      disabled at runtime. (LP: #346347, LP: #390150)
    + Fixes for space reserved by Docky blocking drag and
      drop operations. (LP: #354729, LP: #347052, LP: #382843)
    + Properly sets "Hidden" key on autostart files in response to
      "Start on login" option. (Closes: #526023) (LP: #369988)
  * debian/patches/10_application_search_path:
    + Drop; included upstream
  * debian/patches/10_sk_translation_update:
    + Import sk translation update from Debian BTS.
      (Closes: #531779)
  * debian/patches/11_fix_autostart_when_directory_does_not_exist:
    + Patch from upstream. Fixes the "Start on login" option when the
      ~/.config/autostart directory does not exist. (LP: #393729)
  * debian/control:
    + Update standards version to 3.8.2; no changes required.
    + Add libtool to Build-Depends; required for autoreconf.
    + Add Recommends: on new gnome-do-docklets package.
  * debian/gnome-do.1
    + Fix spelling: GNOME-Do => GNOME Do.
    + Miscelaneous lintian fixes; NAME section, escaping minus signs with \-
  * debian/copyright:
    + Update for new copyright holders.
    + Minor update to DEP-5 format

 -- Steve Kowalik <email address hidden> Wed, 12 Aug 2009 07:36:56 +0100

Changed in gnome-do (Ubuntu):
status: Confirmed → Fix Released
Grant Bowman (grantbow) wrote :

I'm running version 0.8.2+dfsg-1 on Karmic now and it's still happening.

Grant Bowman (grantbow) wrote :

I didn't know how to mark a regression so I changed to in progress. I hope that's the appropriate procedure in this case. Please advise.

Changed in gnome-do (Ubuntu):
status: Fix Released → In Progress
mgolisch (mgolisch-googlemail) wrote :

iam on Karmic using version gnome-do_0.8.2+dfsg-1_amd64 and have a similar problem:
The About window cant be closed by clicking the X or the Close button.

IKT (ikt) wrote :

mgolisch: Is compiz enabled for you?

Paul Merrill (pmerrill) wrote :

This bug is affecting me on Karmic. Using gnome-do_0.8.2+dfsg-1_amd64.

The weird thing is, it happens ONLY when Compiz is disabled. So you guys fixed the Docky bug, but it's still there on the non-compositing theme.

IKT (ikt) wrote :

Hi all, if you're running 10.04 or 10.10 are you still affected by the bug?

IKT (ikt) wrote :

Going to set this back to fix released, since there have been no responses about the issue in 10.04 and upwards.

Changed in gnome-do (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers