Duplicate monitor IDs lead to garbage characters in gnome-display-properties

Bug #651731 reported by David Gibson on 2010-09-30
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-desktop
Expired
Medium
gnome-desktop3 (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gnome-control-center

I routinely connect my laptop to an external monitor - an IBM 20" display connected via VGA.

In earlier Ubuntu releases this worked fine, with the two monitors showing up as 'Laptop' and 'IBM 20"' (IIRC) in the gnome-display-properties window. In Karmic and Lucid, however, functionality is still fine, but the label on the external monitor is usually filled with garbage characters. Exactly what shows up varies, but it is usually a handful of unicode characters without proper glyphs, followed by '20"'.

I'm not sure where to start gathering debug information on this one. It is entirely reproducible on my setup, however, so if pointed at the right tools I can easily gather whatever information would be useful.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: gnome-control-center 1:2.30.1-0ubuntu1
Uname: Linux 2.6.33.2-yookeroo70 x86_64
Architecture: i386
Date: Thu Sep 30 12:28:53 2010
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
ProcEnviron:
 PATH=(custom, user)
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-control-center

David Gibson (dwg) wrote :
David Gibson (dwg) wrote :

Note that as the ubuntu-bug gathered information shows, I'm currently running a custom x86_64 kernel. However when I was running the standard Ubuntu kernel this bug showed up AFAICT identically.

Sebastien Bacher (seb128) wrote :

thank you for your bug report, could you add your Xorg.log to the bug?

Changed in gnome-control-center (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Sebastien Bacher (seb128) wrote :

rather the Xorg.0.log log file

David Gibson (dwg) wrote :

Ok, Xorg.0.log attached. This one was taken after the laptop has been on for a while and there have been multiple monitor switches and suspend/resumes since boot. I can produce a new one with a more controlled sequence if that would help.

Sebastien Bacher (seb128) wrote :

not sure what the issue is

"(II) intel(0): EDID vendor "IBM", prod id 6736" is in the log

gnome-desktop uses /usr/share/hwdata/pnp.ids to match to a name:
"IBM IBM Brasil
IBM IBM France"

those are the entries matching, not sure if the code could be confused by having 2 lines for the same id though

affects: gnome-control-center (Ubuntu) → gnome-desktop (Ubuntu)
Changed in gnome-desktop (Ubuntu):
status: Incomplete → New
Sebastien Bacher (seb128) wrote :

Could you edit /usr/share/hwdata/pnp.ids and delete one of the IBM lines?

David Gibson (dwg) wrote :

Ok. I don't have a /usr/share/hwdata/pnp.ids, but I do have a /usr/share/libgnome-desktop/pnp.ids, which seems to contain the data you describe.

Removing one of the entries seems to do the trick: as soon as I removed the "IBM France" entry, the monitor showed up in the control panel as "IBM Brasil 20"". Something I didn't mentioned earlier is that while a string of garbage was the most common symptom before, a few garbage characters then "France" was also quite common which makes sense now I know the data is coming from this list.

Nonetheless looks like there is a bug where multiple matching entries in the table causes the string to be mangled.

David Gibson (dwg) wrote :

So, it seems we've located the bug. What are the next steps in terms of getting a fix upstream?

summary: - regression: Monitor label has garbage characters in gnome-display-
+ duplicate monitor ids lead to garbage characters in gnome-display-
properties
Changed in gnome-desktop:
importance: Undecided → Unknown
status: New → Unknown
Changed in gnome-desktop (Ubuntu):
status: New → Triaged
Sebastien Bacher (seb128) wrote :

The next step is to let upstream know about the issue, I've opened a bug onhttps://bugzilla.gnome.org/show_bug.cgi?id=632145. Let's see now if somebody comes with a fix for it

Changed in gnome-desktop:
importance: Unknown → Medium
status: Unknown → New
Fabián Rodríguez (magicfab) wrote :

I reported a duplicate bug in 10.10 about this for an EloTouch screen (Bug #672696).

In /usr/share/hwdata/pnp.ids I confirm there were duplicate IDs for this manufacturer:

ELO Elo TouchSystems Inc
ELO Tyco Electronics

Removing one of them takes care of the issue.

Fabián Rodríguez (magicfab) wrote :

In 10.04 LTS the file is at /usr/share/libgnome-desktop/pnp.ids
In 10.10 the file is at /usr/share/hwdata/pnp.ids

summary: - duplicate monitor ids lead to garbage characters in gnome-display-
+ Duplicate monitor IDs lead to garbage characters in gnome-display-
properties
Changed in gnome-desktop:
status: New → Expired
Sebastien Bacher (seb128) wrote :

The issue got fixed in upstream git

affects: gnome-desktop (Ubuntu) → gnome-desktop3 (Ubuntu)
Changed in gnome-desktop3 (Ubuntu):
status: Triaged → Fix Committed
Sebastien Bacher (seb128) wrote :

The issue is fixed with gnome-desktop 3.6 in quantal

Changed in gnome-desktop3 (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.