[soundnua] Unmutting sound effects using the slider doesn't work

Bug #986692 reported by bear7 on 2012-04-21
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
OEM Priority Project
Medium
Unassigned
Precise
Medium
Unassigned
Quantal
Medium
Unassigned
gnome-control-center
Fix Released
Medium
gnome-control-center (Ubuntu)
Low
Unassigned
Precise
Low
Unassigned

Bug Description

[IMPACT]

When users unckeck the "Mute" checkbox on "Alert volume" you reset the slider and the checkbox is automatically unchecked. However, the "Alert volume" is not actually unmuted. This is a significat design issue for obvious reasons, but also has the side effect that if the the user does not know that he's not getting audio alerts (s)he may miss some important work.
When

[TESTCASE]

After poking with it a bit, I think I just isolated it: it only happens when instead of unckecking the "Mute" checkbox on "Alert volume" you reset the slider and the checkbox is automatically unchecked. Visually the end result is the same (non-zero volume leve and unckecked box) but how you get there has different effect. By the way the "Output volume" slider doesn't have this problem, only the "Alert volume".

[Regression Potential]

Small. The code has been merged upstream and has been tested in both upstream and ubuntu. The diff is only one additional line of code.

[Original Report]

Sound--> Tab "Sound Effects"
After bringing alert volume to the minimum none of the selected alert was working. Everything else is ok. Sound in other places is perfect.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: gnome-control-center 1:3.3.92-0ubuntu4
ProcVersionSignature: Ubuntu 3.2.0-20.33-generic 3.2.12
Uname: Linux 3.2.0-20-generic x86_64
ApportVersion: 1.95-0ubuntu1
Architecture: amd64
CasperVersion: 1.312
Date: Sat Apr 21 21:10:21 2012
ExecutablePath: /usr/bin/gnome-control-center
LiveMediaBuild: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120328)
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
SourcePackage: gnome-control-center
UpgradeStatus: No upgrade log present (probably fresh install)

bear7 (bear7) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

thank you for your bug report, why would they play if they are muted?

Changed in gnome-control-center (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
George Sakkis (george-sakkis) wrote :

The description is incomplete/misleading; in my case at least the bug was that re-unmuting sound effects after muting them had no effect.

After poking with it a bit, I think I just isolated it: it only happens when instead of unckecking the "Mute" checkbox on "Alert volume" you reset the slider and the checkbox is automatically unchecked. Visually the end result is the same (non-zero volume leve and unckecked box) but how you get there has different effect. By the way the "Output volume" slider doesn't have this problem, only the "Alert volume".

Hope this helps.

Sebastien Bacher (seb128) wrote :

The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

Changed in gnome-control-center (Ubuntu):
status: Incomplete → New
Changed in gnome-control-center (Ubuntu):
status: New → Triaged
summary: - Re-Muted Sound Effects doesn't play.
+ Unmutting sound effects using the slider doesn't work
Changed in gnome-control-center:
importance: Unknown → Medium
status: Unknown → Confirmed

the bug has been fixed upstream and will be fixed with the next update in quantal

" sound: Make sure the event sound stream stays unmuted

    Apply mute changes to the stream straight away so that we don't get a
    race with gvc_mixer_event_role_push_volume().
    See https://bugs.freedesktop.org/show_bug.cgi?id=51413 for details.

    https://bugzilla.gnome.org/show_bug.cgi?id=677478"

Changed in gnome-control-center (Ubuntu):
status: Triaged → Fix Committed
Changed in gnome-control-center:
status: Confirmed → Fix Released
Taiten Peng (taitenpeng) wrote :

Sorry I dont see how upstream is going to fix this, however there is a very quick fix for this.

Index: gnome-control-center-3.4.2/panels/sound-nua/gvc-mixer-dialog.c
===================================================================
--- gnome-control-center-3.4.2.orig/panels/sound-nua/gvc-mixer-dialog.c 2012-09-18 14:54:02.686384033 +0800
+++ gnome-control-center-3.4.2/panels/sound-nua/gvc-mixer-dialog.c 2012-09-18 16:16:52.255026778 +0800
@@ -509,6 +509,8 @@
                 /* Make sure we do not unmute muted streams, there's a button for that */
                 if (volume == 0.0)
                         gvc_mixer_stream_set_is_muted (stream, TRUE);
+ else
+ gvc_mixer_stream_set_is_muted (stream, FALSE);
                 /* Only push the volume if it's actually changed */
                 if (gvc_mixer_stream_set_volume(stream, (pa_volume_t) rounded) != FALSE)
                         gvc_mixer_stream_push_volume (stream);
Index: gnome-control-center-3.4.2/panels/sound/gvc-mixer-dialog.c
===================================================================
--- gnome-control-center-3.4.2.orig/panels/sound/gvc-mixer-dialog.c 2012-03-05 22:04:55.000000000 +0800
+++ gnome-control-center-3.4.2/panels/sound/gvc-mixer-dialog.c 2012-09-18 16:16:17.238853143 +0800
@@ -784,6 +784,8 @@
                 /* Make sure we do not unmute muted streams, there's a button for that */
                 if (volume == 0.0)
                         gvc_mixer_stream_set_is_muted (stream, TRUE);
+ else
+ gvc_mixer_stream_set_is_muted (stream, FALSE);
                 /* Only push the volume if it's actually changed */
                 if (gvc_mixer_stream_set_volume(stream, (pa_volume_t) rounded) != FALSE)
                         gvc_mixer_stream_push_volume (stream);

Anthony Wong (anthonywong) wrote :

Is this still going to be fixed in quantal?

Taiten Peng (taitenpeng) wrote :

added to oem-priority as it effects couple project which is going to release with precise.

Taiten Peng (taitenpeng) on 2012-09-20
Changed in oem-priority:
assignee: nobody → Taiten Peng (taitenpeng)
importance: Undecided → Medium
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

@Taiten: upstream fixed it this way:
https://mail.gnome.org/archives/commits-list/2012-June/msg05768.html

It's not issue to fix for quantal (and precise), it just seems such a detail that we didn't rank it high but we can prioritize that if that's an issue for the oem images

Changed in gnome-control-center (Ubuntu Precise):
status: New → Triaged
importance: Undecided → Low
Taiten Peng (taitenpeng) wrote :

Sabastien,

Thanks and yes please do, we need to ensure the fix in upcoming delivery to oem.

Taiten Peng (taitenpeng) wrote :

The upcoming delivery will be precise to oem project

Taiten Peng (taitenpeng) on 2012-09-27
tags: added: heneken1
tags: removed: heneken1
James M. Leddy (jm-leddy) wrote :

Hi Taiten,

I've subscribed ubuntu-sponsors who can hopefully help with the backport to precise. I'll also fill out the sru template per the process, but it would be a great help if you could do it if I don't get to it by the end of business today:

https://wiki.ubuntu.com/StableReleaseUpdates

Didier Roche (didrocks) wrote :

@jm-leddy: unsuscribing ubuntu-sponsors. The team goal is not to help to backport patches but to sponsors work :)

If you have issues in backporting the patch, please go on #ubuntu-motu or #ubuntu-devel on freenode on IRC so that we can help you. Thanks!

Sebastien Bacher (seb128) wrote :

I'm working on the new g-c-c SRU and commited that fix to lp:~ubuntu-desktop/gnome-control-center/precise

Changed in gnome-control-center (Ubuntu Precise):
status: Triaged → In Progress
James M. Leddy (jm-leddy) wrote :

@didrocks: Sorry about that. Got confused about process again.

@seb128: Thanks for committing!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.4.2-0ubuntu16

---------------
gnome-control-center (1:3.4.2-0ubuntu16) quantal; urgency=low

  * debian/patches/git_unmute_sound_event.patch:
    - "sound: Make sure the event sound stream stays unmuted" (lp: #986692)
 -- Sebastien Bacher <email address hidden> Fri, 28 Sep 2012 20:01:25 +0200

Changed in gnome-control-center (Ubuntu Quantal):
status: Fix Committed → Fix Released
description: updated
Taiten Peng (taitenpeng) wrote :

Hi Sebastien,

Thank you

Hello lniedzwiecki, or anyone else affected,

Accepted gnome-control-center into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/gnome-control-center/1:3.4.2-0ubuntu0.6 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-control-center (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed

Fix failed in precise-proposed.

Steps to reproduce:
1. Launch "gnome-control-center sound-nua"
2. Click on tab "Sound Effects" and confirm alert sound actually working by click on different alert sound.
3. Check "Mute" on "Alert volume" scroll bar, make sure it's checked and noticed "Alert volume" is scroll to very left as muted.
4. Adjust "Alert volume" to maximum manually and noticed the checkbox is automatically unchecked
5. Click on different Alter Sound in the menu.

Expected result:
Alert sound should acting by click on the menu for different theme.

Actual result:
Alert sound kept muted.

Installed Pacakge version:
ii gnome-control-center 1:3.4.2-0ubuntu0.6 utilities to configure the GNOME desktop
ii gnome-control-center-data 1:3.4.2-0ubuntu0.6 configuration applets for GNOME - data files
ii libgnome-control-center1 1:3.4.2-0ubuntu0.6 utilities to configure the GNOME desktop

tags: added: verification-failed
removed: verification-needed
Taiten Peng (taitenpeng) wrote :

The patch attached actually fixed the issue.

Please verify the package in PPA
https://launchpad.net/~taitenpeng/+archive/ppa

Sebastien Bacher (seb128) wrote :

Thanks, is there any regression with the upload? If not it could be good to not block the update since it includes other fixes that should ideally move to -updates, we can revisit that bug later on.

The patch used though here is the one from upstream, can you check if the bug is resolved in e.g quantal? It worked for me when I tried and it would be useful to know if the upstream fix is complete or if that needs your variant of the patch still and why

Taiten Peng (taitenpeng) wrote :

Hi Sebastien,

The regression will happen on some oem preinstall machine with precise if user upgrade gnome-control-center to version 1:3.4.2-0ubuntu0.6.

I also verified on a fresh 12.10 64bit with fully update the packages with/without proposal archive, the issue still occurred, same steps to reproduce in #20.

Sebastien Bacher (seb128) wrote :

@Taiten: what regression? that feature was already broken before the SRU?

could you reply to the questions about upstream, they fixed it with https://mail.gnome.org/archives/commits-list/2012-June/msg05768.html which is different from your fix

is upstream/quantal/raring broken? Do you plan to send your version of the fix to GNOME if the upstream code is buggy?

Sebastien Bacher (seb128) wrote :

Ok, ignore that, there is no regression, it's just that the patch was applied only to the GNOME version of the code and not the one used under Unity ... I will fix that in a follow up upload

Sebastien Bacher (seb128) wrote :

ok, I've reuploaded an updated version and verified that one works as it should

summary: - Unmutting sound effects using the slider doesn't work
+ [soundnua] Unmutting sound effects using the slider doesn't work
Changed in gnome-control-center (Ubuntu):
status: Fix Released → Fix Committed
Changed in gnome-control-center (Ubuntu Quantal):
status: Fix Released → Triaged
Changed in gnome-control-center (Ubuntu Precise):
status: Fix Committed → In Progress
Sebastien Bacher (seb128) wrote :

the issue is fixed in raring with g-c-c 3.6

Changed in gnome-control-center (Ubuntu):
status: Fix Committed → Fix Released

Hello lniedzwiecki, or anyone else affected,

Accepted gnome-control-center into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/gnome-control-center/1:3.4.2-0ubuntu0.7 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-control-center (Ubuntu Precise):
status: In Progress → Fix Committed
tags: removed: verification-failed
tags: added: verification-needed
Sebastien Bacher (seb128) wrote :

@Taiten: could you try if the new version works for you?

Sebastien Bacher (seb128) wrote :

it works for me, setting to verification-done

tags: added: verification-done
removed: verification-needed
Taiten Peng (taitenpeng) wrote :

@seb128

Sorry I was travelling at customer side, I can confirm this works for me with precise.
Thanks for make this happen.

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.4.2-0ubuntu0.7

---------------
gnome-control-center (1:3.4.2-0ubuntu0.7) precise-proposed; urgency=low

  * debian/patches/git_unmute_sound_event.patch:
    - use the patch for sound-nua and Unity sessions as well (lp: #986692)

gnome-control-center (1:3.4.2-0ubuntu0.6) precise-proposed; urgency=low

  * debian/patches/git_unmute_sound_event.patch:
    - "sound: Make sure the event sound stream stays unmuted" (lp: #986692)
  * debian/UbuntuLogo.png:
    - updated logo for 12.04.1 (lp: #1041369)

  [ Ritesh Khadgaray ]
  * debian/patches/git_update_keyring_password.patch:
    gnome-keyring passwd should be changed on system password change
    (LP: #416825)
 -- Sebastien Bacher <email address hidden> Mon, 19 Nov 2012 11:46:46 +0100

Changed in gnome-control-center (Ubuntu Precise):
status: Fix Committed → Fix Released
Adolfo Jayme (fitojb) on 2014-06-22
no longer affects: gnome-control-center (Ubuntu Quantal)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.