Ubuntu

There is no easy way to change proxy settings in Ubuntu 11.10

Reported by Nicolás Abel Carbone on 2011-09-28
176
This bug affects 46 people
Affects Status Importance Assigned to Milestone
gnome-control-center
New
Undecided
Unassigned
gnome-control-center (Ubuntu)
Critical
Rodrigo Moya
Oneiric
Critical
Rodrigo Moya
network-manager-applet (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned

Bug Description

I can't found a easy (not-cli, at least) way of changing the proxy settings in Ubuntu 11.10. There is no option to change any network settings in gnome-control-center, and the network-applet does not have the option to change the proxy.

I think that a GUI for changing the proxy is a must-have, specially since it was available in Ubuntu 11.04. Also, is my opinion that, at least in the long term, the proxy settings should be related to the network options, so a different proxy is set to every network (specially important for notebooks with are used in different locations).

A screenshot of gnome-control-center is attached, showing the lack of network options.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: gnome-control-center 1:3.2.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
ApportVersion: 1.23-0ubuntu2
Architecture: amd64
Date: Wed Sep 28 11:03:32 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110921.2)
SourcePackage: gnome-control-center
UpgradeStatus: No upgrade log present (probably fresh install)
usr_lib_gnome-control-center:
 deja-dup 20.0-0ubuntu3
 gnome-bluetooth 3.2.0-0ubuntu1
 indicator-datetime 0.2.95-0ubuntu1

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
spupuz@gmail.com (spupuz) wrote :

have some problem after today apt-get upgrade

Jean-Baptiste Lallement (jibel) wrote :

I confirm that this feature vanished after applying updates on 2011-09-28.

Changed in gnome-control-center (Ubuntu Oneiric):
importance: Undecided → Critical
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
milestone: none → ubuntu-11.10
assignee: Canonical Desktop Team (canonical-desktop-team) → nobody
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
tags: added: regression-release rls-mgr-o-tracking
Martin Pitt (pitti) on 2011-09-29
Changed in gnome-control-center (Ubuntu Oneiric):
assignee: Canonical Desktop Team (canonical-desktop-team) → Rodrigo Moya (rodrigo-moya)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager-applet - 0.9.1.90-0ubuntu3

---------------
network-manager-applet (0.9.1.90-0ubuntu3) oneiric; urgency=low

  * debian/libnm-gtk-dev.install:
    - Add missing .pc file (LP: #861443)
 -- Rodrigo Moya <email address hidden> Thu, 29 Sep 2011 10:24:08 +0200

Changed in network-manager-applet (Ubuntu Oneiric):
status: New → Fix Released
Martin Pitt (pitti) on 2011-09-29
Changed in gnome-control-center (Ubuntu Oneiric):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.2.0-0ubuntu3

---------------
gnome-control-center (1:3.2.0-0ubuntu3) oneiric; urgency=low

  [ Rodrigo Moya ]
  * debian/patches/00git_show_search_view.patch:
    - Make sure we gtk_widget_show the search view (LP: #860950)
  * debian/UbuntuLogo.png:
    - Use the correct version of the icon (LP: #860497)
  * debian/control:
    - Add missing NetworkManager build dependencies (LP: #861443)
  * debian/patches/12_add_never_turn_screen_off.patch:
    - Add back the "never turn screen off" option (LP: #862154)

  [ Jeremy Bicha ]
  * debian/patches/53_use_ubuntu_help.patch: Use gnome-help when running
    GNOME or GNOME Fallback (LP: #852911)
 -- Rodrigo Moya <email address hidden> Thu, 29 Sep 2011 12:47:53 +0200

Changed in gnome-control-center (Ubuntu Oneiric):
status: In Progress → Fix Released
Adam Niedling (krychek) wrote :

I still don't have any way to set proxy settings in Oneiric updated just now.
The network settings is missing in the control center.

Also in the network manager applet I can't find any way to change proxy settings.

Rodrigo Moya (rodrigo-moya) wrote :

Do you have the 2 packages that fix the issue (see comments #5 and #6)?

Adam Niedling (krychek) wrote :

It was my bad, sorry. I didn't do a complete update.
It works fine.

RawwrBag (sthaber) wrote :

For me, the proxy settings simply have no effect, even through reboot. Both Firefox and Chrome do not use the proxy. Also the exempt hosts list is missing.

RawwrBag (sthaber) wrote :

More info: the new GUI doesn't correctly toggle gconf/system/http_proxy/use_http_proxy to true when only a socks server is specified. Without this, neither Chrome nor Firefox will attempt to tunnel through socks. As a workaround, set this value manually using gconf-editor. Also the ignored hosts list is very useful for users on corporate networks where they do need some internal resources. It should be included.

ThierryM (thierry-munoz) wrote :

I agree with RawwrBag. The proxy settings don't work on 11.10 even after a reboot. On 10.10 it's worked immediatly without any problem and we could choose between many locations (it isn't possible since 11.10).

BEmanuel.PE (bemanuel-pe) wrote :

Adjusting gconf proxy works!

RawwrBag (sthaber) wrote :

Does somebody following this want to file a separate bug for this? I'm crazy busy at work today but this is definitely a critical day one bug that should be addressed.

RawwrBag (sthaber) wrote :

Nevermind, I took care of it: bug 876839.

MrCopilot (mrcopilot) wrote :

Duplicate Bug, Duplicate comment...

Disappointed....

New Updates still do not allow for setting ignore_hosts, which in almost all cases where a proxy is needed there is an intranet that is not sent through the proxy.

I love automatic security updates, an essential part of the Ubuntu experience.

I do not love nor am I enchanted by having the aforementioned automatic security update remove access to the corporate intranet that was working fine before I consented to install updates.

Removal of the old version left its settings around, and when compared to new set, they were better organized and more complete.

I've added ignore_hosts setting to the new set in hopes that its implemented but not in the gui yet. I'll find out on the next reboot I suppose, Else I am confined to Firefox for the intranet as it allows manual proxy setup with exclusions.

This replacement was shortsighted and not at all customer focused. So here is a tip for you, free of charge.

If a large group of your users depend on standard ways of doing things, PROXY SETTINGS for instance, DO NOT REPLACE THAT FUNCTIONALITY with LESS FUNCTION.

One would think this is self evident, I guess not.

This bug is from early September, Almost November now and it is almost finished, but pushed out on my machine anyway.

Just Wow.

MrCopilot;

We understand your frustration. Ignoring hosts for proxy is something that tends to be useful, but perhaps it was deemed not as frequently used as the other functions by upstream developers, which is why it's no longer exposed in the UI (which is something Ubuntu gets from upstream, so it applies to all distributions using Gnome3). As you undoubtedly have noticed, the option is still available via command-line, as such:

gsettings set org.gnome.system.proxy ignore-hosts ['localhost', '127.0.0.0/8', 'some.other.host']

However, the issue you're describing is something different than not being able to change proxy settings at all. As such, I'd like to invite you to file a new, separate bug report that covers *precisely and only* exposing ignore-hosts in UI. We can then send this report to the upstream developers at GNOME (alternatively, you can just file the bug there directly (see https://wiki.ubuntu.com/Bugs/Upstream/GNOME)). This way it will run the best chance of being taken care of by developers.

MrCopilot (mrcopilot) wrote :

No sweat, I'll file the upstream bug, however let me quote the desription of this bug and your reply and you can weigh wether this bug is squashed.

>>I can't found a easy (not-cli, at least) way of changing the proxy settings in Ubuntu 11.10.

>>As you undoubtedly have noticed, the option is still available via command-line, as such:
>>gsettings set org.gnome.system.proxy ignore-hosts ['localhost', '127.0.0.0/8', 'some.other.host']

Clearly, no_proxy or ignore_hosts is a proxy setting. Just try using curl in a corporate intranet environment of moderate size without it.

I would also expect to see seperate setting for https_proxy but that at least is an actual edgecase.

The minor inconvienience of finding out, "why is the intranet down" was easily remedied, "proxy settings changed".
Long time user, setting via commandline of via the tool d'jure for gconf was also easily discoverable and was minimally distracting overall.

What is more disturbing was the choice to blindly update the tools with a demonstrably inferior reiteration. That is a Ubuntu decision, and a Ubuntu bug. I recommend ubuntu to many of my coworkers, taking down access to 50% to 90% of their job this morning was a bug.

Network setup, configuration, and maintenance must be a high priority, if there is no maintainer for those packages that touch these areas and ship with the base Ubuntu install, then I am taken well aback. If there is such person(s) they let quite a few of us down today, and tarnished an otherwise shiny and spreading Ubuntu reputation within our organization.

So, I will leave the way I came in, disappointed...

Little Jawa (littlejawa) wrote :

Still no way to set exceptions to proxy settings in the network applet in 12.04.

I would also add that with the previous network settings GUI, we had the possibility to create "profiles" for proxy settings. It was quite useful when you worked regularly at different locations, each with different network proxy... You just had to select the corresponding profile and everything worked. Now you have to change your settings manually each time you move to another location.
Looks like a regression to me :-(

bash321 (bash321) wrote :

<<<<<Response:
Still no way to set exceptions to proxy settings in the network applet in 12.04.

I would also add that with the previous network settings GUI, we had the possibility to create "profiles" for proxy settings. It was quite useful when you worked regularly at different locations, each with different network proxy... You just had to select the corresponding profile and everything worked. Now you have to change your settings manually each time you move to another location.
 Looks like a regression to me :-(
<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
still a problem in Ubuntu 13.04 raring!!!
profiles would be a great idea... as you could choose to not have a proxy network at home but one at work!
It would be great if it was fixed.. like it was in the previous proxy network applet.

+1

I've got "hacks" all over the place to set proxy settings based on locations. This would be an ideal feature for Network Travellers.

Thanks for all the great work.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers