Ubuntu

Add back system-wide network proxy settings

Reported by Adam Niedling on 2011-06-10
152
This bug affects 29 people
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
High
Rodrigo Moya
Oneiric
High
Rodrigo Moya

Bug Description

Binary package hint: gnome-control-center

Using Oneiric alpha1 and gnome-control-center 1:3.0.2-1ubuntu4.
In the control center I click on the Network button and I configure the network proxy settings there. I set it to Manual proxy.
It had no effect on apt-get, update manager and Chromium. None of them is able to connect to the internet.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: gnome-control-center 1:3.0.2-1ubuntu4
ProcVersionSignature: Ubuntu 2.6.39-3.10-generic 2.6.39
Uname: Linux 2.6.39-3-generic i686
Architecture: i386
Date: Fri Jun 10 15:32:56 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110531.1)
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, no user)
 LANG=en_US
 LC_MESSAGES=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-control-center
UpgradeStatus: No upgrade log present (probably fresh install)

Adam Niedling (krychek) wrote :
Jean-Baptiste Lallement (jibel) wrote :

Thanks for your report. Confirmed and *_proxy environment variables are not updated in /etc/environment.
Setting to triage/high and targeting to Oneiric

Changed in gnome-control-center (Ubuntu):
importance: Undecided → High
status: New → Triaged
Changed in gnome-control-center (Ubuntu Oneiric):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
tags: added: regression-release
Adam Niedling (krychek) wrote :

Thanks for the quick reply!
I also tried the following commands with no luck:

export http_proxy=www.proxyserver.net:port
export https_proxy=www.proxyserver.net:port
export ftp_proxy=www.proxyserver.net:port

I don't know if they are supposed to work with Oneiric.

Jean-Baptiste Lallement (jibel) wrote :

It should work but depends on the application.
There are different places to set the proxy settings:
 * Environment variables in /etc/environment
 * apt settings: Acquire::http::proxy and also https and ftp in /etc/apt/apt.conf or /etc/apt/apt.conf.d/
 * the dconf keys located at org.gnome.system.proxy
 * and some application seems to be looking at the legacy gconf keys /system/proxy and /system/http_proxy, but it should have been converted to dconf.

---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Martin Pitt (pitti) wrote :

Our 50_ubuntu_systemwide_prefs.patch is supposed to call ubuntu-system-service with the new proxy values, but it seems this needs to be ported harder to gnome-control-center 3.0? Rodrigo, can you please look into this?

Changed in gnome-control-center (Ubuntu Oneiric):
assignee: Canonical Desktop Team (canonical-desktop-team) → Rodrigo Moya (rodrigo-moya)
summary: - Oneiric disregards network proxy settings
+ Applying network proxy settings system-wide has no effect

Ah, the patch is currently disabled, and there's no "apply system-wide" button at all. We need to add back the patch.

summary: - Applying network proxy settings system-wide has no effect
+ Add back system-wide network proxy settings
yay (yay101) wrote :

Was just about to post this bug. Any idea when i can test it?

yay (yay101) wrote :

I got all excited when i saw gnome-control-center in todays updates, no change yet?

Adam Niedling (krychek) wrote :

This is still an issue in Aplha 2! Is this gonna get fixed? Thanks.

Jan Kroeze (thejcwk) wrote :

I can confirm this is still present. Seems to affect Pidgin too.

Still confirming it, tested on alpha 3. Seems like the proxy setting in the settings menu has absolutely no effect: Firefox fails to use proxy if made to use system settings.

Changed in gnome-control-center (Ubuntu Oneiric):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.1.90-0ubuntu2

---------------
gnome-control-center (1:3.1.90-0ubuntu2) oneiric; urgency=low

  * debian/patches/10_keyboard_layout_on_unity.patch:
    - Show keyboard layout bits on Unity (LP: #834523)
  * debian/patches/50_ubuntu_systemwide_prefs.patch:
    - Add back system-wide proxy settings (LP: #795519)
  * debian/patches/04_add_theme_selection.patch:
    - Only connect to "changed" signal after the initial selection (LP: #834240)
 -- Rodrigo Moya <email address hidden> Wed, 31 Aug 2011 12:55:13 +0200

Changed in gnome-control-center (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Ankit Vani (ankitkv) wrote :

I'm unable to test this fix right now but I would like to note that even in Ubuntu 11.04, the proxy authentication was not applied globally. Please confirm that authentication works properly in this fix as well.

for instance, in 11.04, the proxies used to be set as
http://host:port/
instead of
http://username:password@host:port/
in the env variables and apt.conf. I had to manually add the username and password in the respective files.

Ankit Vani (ankitkv) wrote :

On installing beta 1, I found that there is no way to graphically enter the authentication details for proxies. I run ubuntu behind my college's wifi proxy, so do a lot of other people here who do not know to change the config files.

Brad Figg (brad-figg) on 2011-09-02
tags: added: rls-mgr-o-tracking

Hi, even with the new fix, I continue to struggle.

1. In Firefox I set proxy configuration to Use System Proxy Settings.
2. On Gnome-control-center I set my proxy and click on Apply System Wide
3. Proxy is set on /etc/environment and all http_proxy variables are set.
4. Firefox doesn't connect to internet (Chrome neither)

The only way I can manage to use the proxy is setting it manually on Firefox

@juliansuarezlopera,
the same thing is happening with me. don't we have any way to enter the system-wide proxy settings (including firefox and chrome) ?

jan2ary (jan2ary) wrote :

Doesn't work for me too - after last night upgrade to Beta 1.
Also I'm really upset because of no more location based proxy settings here like Home, Office etc., also there is no more protocol wide proxy settings (the same for all http, https, ftp etc). Each time I change a location I have to rewrite proxy settings for each protocol manually. Sad.

davidcaste (davidcaste) wrote :

Also, with Oneiric's new proxy configuration screen is not possible to configure proxy exception rules. This functionality was present in Ubuntu 10.04.

Changed in gnome-control-center (Ubuntu Oneiric):
status: Fix Released → In Progress

Proxy settings now apply correctly to firefox and chromium but the following features are still missing from the previous release:
 * /etc/apt/apt.conf is not updated
 * No way to add authenticated proxy
 * No way do add an exclusion list.
 * No 'Use this setting for all protocols' option

reopening.

Rodrigo Moya (rodrigo-moya) wrote :

/etc/apt/apt.conf not being updated is a bug in ubuntu-system-service, so please file a new one for that product.

About authenticated proxy, there is no UI indeed, and it's too late in the cycle to add it, so it will have to wait until 3.3, but for the time being people can use http://user:password@host:port URLs. It's filed upstream as https://bugzilla.gnome.org/show_bug.cgi?id=646354

About exclusion list, ditto, no UI till 3.3, but it is possible to set the list in GSettings, under /system/proxy/ignored-hosts

Halu Wong (waichai) wrote :

Even proxy setting was set in /etc/environment, once i get back to setting UI system setting --> network --> network proxy.
The HTTP Proxy field is blank!
Chrome cannot use the system-wide proxy setting! It's working great before in 11.04

@waichai I'm having the same issue, the UI always empties the http Proxy field

I'm closing this report again, because system-wide network proxy settings is back.
I filed bug 853751 for the 'blank field' issue
and will try to find a pattern to replicate the ubuntu-system-service issue.

Thanks.

Changed in gnome-control-center (Ubuntu Oneiric):
status: In Progress → Fix Released
jan2ary (jan2ary) wrote :

The Network settings no more present in gnome-control-center, and there is no place to configure proxy settings.

jan2ary (jan2ary) wrote :

There is a Bug #861443, I'm subscribed.

MrCopilot (mrcopilot) wrote :

Disappointed....

New Updates still do not allow for setting ignore_hosts, which in almost all cases where a proxy is needed there is an intranet that is not sent through the proxy.

I love automatic security updates, an essential part of the Ubuntu experience.

I do not love nor am I enchanted by having the aforementioned automatic security update remove access to the corporate intranet that was working fine before I consented to install updates.

Removal of the old version left its settings around, and when compared to new set, they were better organized and more complete.

I've added ignore_hosts setting to the new set in hopes that its implemented but not in the gui yet. I'll find out on the next reboot I suppose, Else I am confined to Firefox for the intranet as it allows manual proxy setup with exclusions.

This replacement was shortsighted and not at all customer focused. So here is a tip for you, free of charge.

If a large group of your users depend on standard ways of doing things, PROXY SETTINGS for instance, DO NOT REPLACE THAT FUNCTIONALITY with LESS FUNCTION.

One would think this is self evident, I guess not.

This bug is from early September, Almost November now and it is almost finished, but pushed out on my machine anyway.

Just Wow.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.