[Regression] gnome control centre does not allow you to disable the laptop screen while leaving an external DisplayPort connected screen working

Bug #828623 reported by Dave Russell on 2011-08-18
108
This bug affects 27 people
Affects Status Importance Assigned to Milestone
gnome-control-center
Expired
Medium
Fedora
Won't Fix
Medium
gnome-control-center (Ubuntu)
High
Chris Halse Rogers
Oneiric
High
Chris Halse Rogers

Bug Description

Lenovo T500 with displayport has a 1920x1200 monitor attached, I use the displayport in a similar way to a docking station in that I attach the monitor with a displayport to dvi cable, and then expect to be able to switch off the laptops internal display, only leaving the external monitor working.

Screen detection works fine, mirrored screen works fine, but disabling the internal display and activating the external display just leads to the screen going black until the timeout has been reached, whereupon it reverts to its previous setting.

This is a fully updated oneiric install

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: gnome-control-center 1:3.1.4-0ubuntu5
ProcVersionSignature: Ubuntu 3.0.0-8.11-generic 3.0.1
Uname: Linux 3.0.0-8-generic x86_64
Architecture: amd64
Date: Thu Aug 18 10:35:59 2011
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110803.1)
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-control-center
UpgradeStatus: No upgrade log present (probably fresh install)

Dave Russell (drussell) wrote :
Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
Dave Russell (drussell) wrote :

A workaround is to run the following commands:

xrandr --size 1920x1200 --output LVDS1 --off --output HDMI1 --mode 1920x1200
compiz --replace

Still, it really should work via the gui...

Juha Siltala (topyli) wrote :

I don't have this problem. I use VGA, which may or may not be relevant.

Dave Russell (drussell) wrote :

Thanks, I think it does make a difference... need to find someone who is using dvi/hdmi/displayport

I'll retry again to make sure no updates have fixed this in the background.

Dave Russell (drussell) wrote :

Yup, no change, still broken :o/

Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting seems to be an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

Changed in gnome-control-center (Ubuntu):
importance: Undecided → Low
Joshua R. Poulson (jrp) wrote :

I also have this issue on my W510 Thinkpad.

Dave Russell (drussell) wrote :

I've just done some further testing. The behaviour varies depending on whether I use the displayport or vga connections.

Laptop Panel + VGA = With both on, the picture is perfect and I can move windows from one to the other.

NO Laptop Panel, Just VGA = I am able to disable the onboard laptop screen and just have the external monitor, however the external display is corrupted.

Displayport connectivity behaves as described previously mentioned, i.e. still completely blank when attempting to disable laptop screen, but fine if both are allowed to display.

I have also verified that the same behaviour is exhibited under Fedora 16 Alpha LiveCD. Will raise upstream and Fedora Bugs.

Dave Russell (drussell) on 2011-09-14
summary: - gnome control centre does not allow you to disable the laptop screen
- while leaving an external connected screen working
+ [Regression] gnome control centre does not allow you to disable the
+ laptop screen while leaving an external connected screen working

@seb128

Upstream bug created: https://bugzilla.gnome.org/show_bug.cgi?id=659039

I've also referenced the Fedora bug, I'd be grateful if you could verify it's setup correctly.

affects: gnome-control-center (Fedora) → fedora
Changed in fedora:
importance: Undecided → Unknown
status: New → Unknown
Changed in gnome-control-center:
importance: Undecided → Unknown
status: New → Unknown
Changed in gnome-control-center (Ubuntu):
status: Confirmed → Triaged
Dave Russell (drussell) on 2011-09-23
summary: [Regression] gnome control centre does not allow you to disable the
- laptop screen while leaving an external connected screen working
+ laptop screen while leaving an external DisplayPort connected screen
+ working
Sebastien Bacher (seb128) wrote :

Thank for sending the bug to GNOME, it seems correctly setup yes ;-)

Bryce Harrington (bryce) wrote :

I think I'm able to reproduce more or less this same bug.

For me, it occurs only when I use gnome-control-center to switch from VGA-off-and-LVDS-on directly to VGA-on-and-LVDS-off. If I start with both displays on, and disable LVDS, it works fine. If I use xrandr, it works fine. See bug #737891 (set as a dupe of this one now) for details.

For diagnosing, I used 'xrandr --verbose', which indicates some difference in how the crtcs are being mapped.

I also enabled graphics debugging (sudo xdiagnose, first checkbox, apply, reboot), then collected dmesg before and after doing the switch, once with gnome-control-center, and once with xrandr. I will attach both of these files. (The logs fill with pipe A underrun messages which I believe to be irrelevant so have filtered those out for clarity.)

Bryce Harrington (bryce) wrote :
Bryce Harrington (bryce) wrote :
Bryce Harrington (bryce) wrote :
Bryce Harrington (bryce) wrote :

Since the bug is reported as a regression, bumping up to high priority.

Changed in gnome-control-center (Ubuntu):
importance: Low → High
Changed in gnome-control-center:
importance: Unknown → Medium
status: Unknown → Incomplete
Changed in gnome-control-center:
status: Incomplete → New
tags: added: rls-mgr-o-tracking
Martin Pitt (pitti) on 2011-10-07
Changed in gnome-control-center (Ubuntu Oneiric):
assignee: nobody → Chris Halse Rogers (raof)
Sebastien Bacher (seb128) wrote :

Could somebody create "gsd-debug-randr" file in you user directory, restart the session, change the screen settings and copy the "gsd-debug-randr.log" which got created in the user directory to the bug?

Sebastien Bacher (seb128) wrote :

bug #861426 is similar

Dave Russell (drussell) wrote :

Thanks for the suggestion, I won't be able to do this until next week... but as soon as I'm able I'll give that a try.

Just installed 11.10 on my laptop - same problem, using an HDMI external monitor through a display port. It is a regression.

Changed in gnome-control-center:
status: New → Incomplete
Karl Rosenbaum (kalle) wrote :

Here's the requested gsd-debug-randr.log.

Karl Rosenbaum (kalle) wrote :

I should also say that nothing is being printed in gsd-debug-randr.log when I change the screen settings. All data is printed before that.

Sebastien Bacher (seb128) wrote :

Karl, could you describe wha

Sebastien Bacher (seb128) wrote :

Karl, could you describe what is your issue exactly? The log suggest that you get a mirror 1152x864 on your laptop and external screens

Karl Rosenbaum (kalle) wrote :

Those figures are wrong . This is my issue:

I log in and get dual display with laptop monitor at 1440x900 and external monitor on displayport at 1920x1080. Then I open the display settings and turn off the internal monitor and click "Apply". Then both screen turn blank. For some reason there is no timeout so the screens remain blank forever. Hitting Ctrl+Alt+F1 and such does not change anything. I simply have to force poweroff.

I'm able to successfully turn off the external monitor, though. When I turn off the external monitor, I do get the timeout dialog.

Maybe the timeout dialog appears in the first case also, but I can't see it and it doesn't restore after the timeout.

Sebastien Bacher (seb128) wrote :

Karl, could you run an "xrandr --verbose" and add the log to the bug? Does using "xrandr --output LVDS1 --off " leads to the same issue?

Sebastien Bacher (seb128) wrote :

rather "xrandr --output eDP-1 --off" for you

Karl Rosenbaum (kalle) wrote :

Yes 'xrandr --output eDP-1 --off' works, kind of. The internal display turns off (as expected) and the external display is garbled, but it will come out fine after ctrl-alt-f1 and ctrl-alt-f7.

Karl Rosenbaum (kalle) wrote :

I've attached my syslog. I changed the screen settings at about 15:42:04. There is al lot of output after that. Maybe that helps.

Chris Halse Rogers (raof) wrote :

I think I've got a workaround locally, but I'd like to check that the bug I'm working around locally is the same bug as here. The gnome-desktop3 packages in https://edge.launchpad.net/~raof/+archive/aubergine contain a patch to wait 50msec during the modesetting to ensure that the previous configuration changes have been applied before trying to apply the new config. For me, this seems to reliably work around problems when disabling LVDS with an external display.

This is not a proper fix, but will point towards where to look in the kernel for a proper fix.

Could you please test these packages (libgnome-desktop-3-2 version 3.2.0-0ubuntu4.2~raof1) and check whether you can reproduce this bug with them? You'll need to restart after installing the update, to ensure that gnome-settings-daemon is using the right library.

Karl Rosenbaum (kalle) wrote :

The patch did not help. I experience the exact same behaviour.

kalle@elvira:~$ dpkg -l|grep raof
ii gnome-desktop3-data 3.2.0-0ubuntu4.2~raof1 Common files for GNOME desktop apps
ii libgnome-desktop-3-2 3.2.0-0ubuntu4.2~raof1 Utility library for loading .desktop files - runtime files

The system is rebooted after installation of these packages. I tried this both on my ubuntu installation and on a live usb stick with persistence file, so that the installed packages would survive the reboot. The syslog looks the same as the one in comment #28.

Chris Halse Rogers (raof) wrote :

@Karl - I believe that your problem is not the same as this bug. Nouveau is having a hard time even detecting your eDP at all. There's a series of patches to improve Nouveau's eDP handling upstream (I *think* they're in the 3.1 kernel, but they might be landing in 3.2) - you could try a newer mainline build http://kernel.ubuntu.com/~kernel-ppa/mainline/daily/ and see if that resolves your bug.

Sadly, those patches aren't likely to be backportable to the Oneiric kernel; they involve basically rewriting Nouveau's eDP support.

Karl Rosenbaum (kalle) wrote :

Yes, you may be right. I just think that it's remarkable that it's the exact same display configuration that fails in (almost) the same way as the bug description. All other display configurations I've tried works fine, including mirror, dual and only internal.

What doesn't fit into the bug description is that I don't get the timeout where the display is reverted to the previous configuration. Maybe I'll try a newer kernel later.

@Chris: So you don't get the same kind of errors in syslog as I get when you reproduce this bug?

Apal Marlak (apal-marlak) wrote :

Hi, I just encountered this bug with my setup.

I have a Lenovo X200, and I use a 20" LCD on the VGA port as my main screen usually.
I installed Oneiric Ocelot today, and when I turn off the laptop main screen, my external LCD shows a corrupted image.

I created the file you need, and here is the log. It's strange that it mentions 1024x768, as my laptop LCD is set at 1280x800, and my external LCD at 1680x1050.

Is it what you need?

Chris Halse Rogers (raof) wrote :

@Karl: No - there aren't any errors in my case. All levels of the stack - X, the intel driver, and the kernel - think that the mode has been successfully set.

Rockwalrus (rockwalrus) wrote :

I was able to fix these symptoms by going into dconf and enabling the xrandr plugin for gnome-settings-daemon, which for some reason had lots of plugins get disabled after upgrading to oneiric.

Bryce Harrington (bryce) wrote :

[The Design Team has identified this as a blocker issue for precise, so setting the Importance to Critical. This may be adjusted down once the bug has received further design and engineering analysis, if appropriate.]

Changed in gnome-control-center (Ubuntu):
importance: High → Critical
Bryce Harrington (bryce) wrote :

@Chris, could you list some next actions for this bug (either by you or others) that would help in moving it towards a solution?

Tom Ellis (tellis) wrote :

I see the same behaviour under 11.10 with my external monitor connected to the VGA port of my Lenovo x200. If I disable the laptop display I get a scrambled external monitor screen.

Under precise with the latest updates as of today, it's working fine and the behaviour is not visible.

Chris Halse Rogers (raof) wrote :

I believe that this has been fixed in the 3.2 kernel; I need to check on my hardware and should run a bisect to work out when it was fixed and whether the fix is backportable to Oneiric.

Martin Pitt (pitti) on 2012-01-11
Changed in gnome-control-center (Ubuntu):
importance: Critical → High
Bryce Harrington (bryce) wrote :

Setting to fixed for precise as per Chris' last comment.
Leaving the task open for oneiric in case Chris wants to complete the backport of the fix.

Changed in gnome-control-center (Ubuntu):
status: Triaged → Fix Released
Changed in gnome-control-center:
status: Incomplete → Expired
Bryce Harrington (bryce) wrote :

It's been long enough that there's probably not much value in completing the oneiric backport.

Changed in gnome-control-center (Ubuntu Oneiric):
status: Triaged → Won't Fix
Changed in fedora:
importance: Unknown → Medium
status: Unknown → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints

Remote bug watches

Bug watches keep track of this bug in other bug trackers.