GNOME 3 System Settings: Provide stub icons for launching Ubuntu specific capplets

Bug #787694 reported by Till Kamppeter on 2011-05-24
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu One Control Panel
Status tracked in Trunk
Trunk
Medium
Rodrigo Moya
gnome-control-center (Ubuntu)
High
Rodrigo Moya
Oneiric
High
Rodrigo Moya
jockey (Ubuntu)
High
Rodrigo Moya
Oneiric
High
Rodrigo Moya
software-properties (Ubuntu)
High
Rodrigo Moya
Oneiric
High
Rodrigo Moya
system-config-printer (Ubuntu)
High
Rodrigo Moya
Oneiric
High
Rodrigo Moya
ubuntuone-control-panel (Ubuntu)
High
Rodrigo Moya
Oneiric
High
Rodrigo Moya

Bug Description

Binary package hint: gnome

GNOME 3 comes with a new System Settings environment which ships many completely new, written from scratch system configuration utilities. The previously used utilities often contain a lot of developer experience and so are far superior in terms of usability. To get this conserved in the GNOME of Oneiric one would need to rewrite these tools completely, often converting them from Python to C. This will introduce a lot of new bugs, waste a lot of developer time or the tools get replaced by the new GNOME tool and many bugs fixed in the old tool get reported again.

To avoid this necessity of the re-invention of the wheel we need the possibility, at least for Ubuntu, to replace selected GNOME tools by the separate tools which were used in Natty and earlier. For this we need at least a possibility to embed Python programs in the System Settings, for example by some kind of wrapper applet. Even better would be a possibility to embed general X applications.

The problem came up with system-config-printer. See https://blueprints.launchpad.net/ubuntu/+spec/desktop-o-system-config-printer-vs-gnome-3-control-center

Changed in meta-gnome2 (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Till Kamppeter (till-kamppeter) wrote :

This bug is option #4 of the Blueprint. If the solution gets too complex or if there are other problems with it, solving bug 787703 (option 1 of the Blueprint) would be an alternative.

Martin Pitt (pitti) on 2011-05-25
affects: meta-gnome2 (Ubuntu) → gnome-control-center (Ubuntu)
Martin Pitt (pitti) on 2011-05-25
Changed in gnome-control-center (Ubuntu Oneiric):
assignee: nobody → Rodrigo Moya (rodrigo-moya)
milestone: none → oneiric-alpha-2
tags: added: desktop-priority
tags: removed: desktop-priority
Martin Pitt (pitti) wrote :

Discussed with Rodrigo; it's rather impractical to embed everything (python, gtk 2, ugly looking menu bars, etc.), so we'll instead just launch ubuntuone control center, software-properties, language-selector, jockey-gtk etc. as external programs from stub icons. For printers we might have some middle ground by using the printer list from the upstream capplet, but calling s-c-p for configuring the actual printers.

summary: - GNOME 3 System Settings: Allow Python Programs (or general programs) as
- embedded capplet
+ GNOME 3 System Settings: Provide stub icons for launching Ubuntu
+ specific capplets
Changed in gnome-control-center (Ubuntu Oneiric):
status: Confirmed → In Progress
Rodrigo Moya (rodrigo-moya) wrote :

I already have the code to load external apps in the control center, with a test external panel working great. Will submit this patch to our package on Monday, when we upgrade to 3.1.x

Martin Pitt (pitti) on 2011-07-01
Changed in gnome-control-center (Ubuntu Oneiric):
milestone: oneiric-alpha-2 → ubuntu-11.10-beta-1
Changed in software-properties (Ubuntu Oneiric):
assignee: nobody → Rodrigo Moya (rodrigo-moya)
Changed in ubuntuone-control-panel (Ubuntu Oneiric):
assignee: nobody → Rodrigo Moya (rodrigo-moya)
Changed in jockey (Ubuntu Oneiric):
assignee: nobody → Rodrigo Moya (rodrigo-moya)
Changed in system-config-printer (Ubuntu Oneiric):
assignee: nobody → Rodrigo Moya (rodrigo-moya)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.1.3-0ubuntu1

---------------
gnome-control-center (1:3.1.3-0ubuntu1) oneiric; urgency=low

  * New upstream release
  * debian/control:
    - Bump gsettings-desktop-schemas-dev build dependency
  * debian/libgnome-control-center1.symbols:
    - Updated symbols
  * debian/patches/01_allow_external_panels.patch:
    - Allow running not-embedded panels (aka externals) (LP: #787694)
  * debian/patches/03_disable_some_panels.patch:
    - Disable color and online-accounts panels
  * debian/patches/01_git_kill_warnings.patch:
    - Kill compilation warnings
  * debian/patches/show_in_unity.patch:
    - Remove upstreamed patch
 -- Rodrigo Moya <email address hidden> Tue, 05 Jul 2011 12:25:48 +0200

Changed in gnome-control-center (Ubuntu Oneiric):
status: In Progress → Fix Released
Changed in jockey (Ubuntu Oneiric):
importance: Undecided → High
Changed in software-properties (Ubuntu Oneiric):
importance: Undecided → High
Changed in system-config-printer (Ubuntu Oneiric):
importance: Undecided → High
Changed in ubuntuone-control-panel (Ubuntu Oneiric):
importance: Undecided → High
dobey (dobey) on 2011-07-08
Changed in ubuntuone-control-panel:
assignee: nobody → Rodrigo Moya (rodrigo-moya)
importance: Undecided → Medium
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-properties - 0.80.13

---------------
software-properties (0.80.13) oneiric; urgency=low

  * merge control center fix from Rodrigo Moya, many thanks!
    (lp:~rodrigo-moya/software-properties/fix-787694) LP: #787694
 -- Michael Vogt <email address hidden> Mon, 11 Jul 2011 11:34:51 +0200

Changed in software-properties (Ubuntu Oneiric):
status: New → Fix Released
Changed in jockey (Ubuntu Oneiric):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package jockey - 0.9.3-0ubuntu1

---------------
jockey (0.9.3-0ubuntu1) oneiric; urgency=low

  * New upstream release. Changes since our last trunk merge:
    - more Python 3 compatible imports
    - ui.py: Move to AppIndicator3 for GTK 3 compatibility
    - merge translations, update German fuzzy strings
    - fglrx example handler: Rename ATI → AMD (LP: #755260)
  * debian/control: Update appindicator GIR dependency.
  * Cherrypick changes from trunk:
    - gtk/jockey-gtk.desktop.in: Use correct categories to show up on the new
      gnome-control-center. Thanks Rodrigo Moya! (LP: #787694)
    - Add NoDisplay=true to autostart .desktop file and have jockey-gtk show up
      in Unity. Thanks Mike Terry.
 -- Martin Pitt <email address hidden> Wed, 13 Jul 2011 16:36:39 +0200

Changed in jockey (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package system-config-printer - 1.3.3+20110712-0ubuntu2

---------------
system-config-printer (1.3.3+20110712-0ubuntu2) oneiric; urgency=low

  [ Till Kamppeter ]
  * debian/control: Versioned build dependency on desktop-file-utils, because of
    LP: #814034.

  [ Rodrigo Moya ]
  * debian/patches/05_menu_entries.patch:
    - Add .desktop magic to have s-c-p show up on the new gnome-control-center
      (LP: #787694)
 -- Till Kamppeter <email address hidden> Thu, 21 Jul 2011 13:24:14 +0200

Changed in system-config-printer (Ubuntu Oneiric):
status: New → Fix Released
dobey (dobey) on 2011-07-22
Changed in ubuntuone-control-panel (Ubuntu Oneiric):
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-control-panel - 1.1.1-0ubuntu1

---------------
ubuntuone-control-panel (1.1.1-0ubuntu1) oneiric; urgency=low

  * New upstream release.
    - Provide stub categories for GNOME 3 control center (LP: #787694)
 -- Rodney Dawes <email address hidden> Fri, 22 Jul 2011 17:26:49 -0400

Changed in ubuntuone-control-panel (Ubuntu Oneiric):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers