gnome-window-properties gives error about configuration tool not being "registered"

Bug #269805 reported by Alastair Sherringham on 2008-09-13
88
This bug affects 6 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
High
Michael Vogt
Intrepid
High
Michael Vogt
Jaunty
High
Michael Vogt
gnome-control-center (Ubuntu)
High
Michael Vogt
Intrepid
High
Michael Vogt
Jaunty
High
Michael Vogt
metacity (Ubuntu)
High
Michael Vogt
Intrepid
High
Michael Vogt
Jaunty
High
Michael Vogt

Bug Description

Binary package hint: gnome-control-center

Ubuntu 8.10 Alpha5
+ full update as of 2008-09-13 13:00 GMT

Selecting menu System/Preferences/Windows - gives error dialog :

"Cannot start the preferences application for your window manager
Window manager "compiz" has not registered a configuration tool"

Same error if Metacity is used (visual effects off).

Problem application appears to be : gnome-window-properties
Which seems to be part of : gnome-control-center

gnome-control-center
1:2.23.90-0ubuntu10

Michael Vogt (mvo) wrote :

Thanks for your bugreport.

What version of compiz and metacity are you using? We uploaded new version with updated desktop files last week, maybe they did not made it to your mirror yet?

Thanks,
 Michael

Changed in gnome-control-center:
status: New → Incomplete
Stef Walter (stefw) wrote :

BTW, this happens both on an upgraded (from 8.04) system, as well as a freshly installed alpha-5, dist-upgrade'd to latest.

stef@stefo:~$ dpkg --list | egrep 'compiz|metacity'
ii compiz 1:0.7.7+git20080807-0ubuntu7 OpenGL window and compositing manager
ii compiz-core 1:0.7.7+git20080807-0ubuntu7 OpenGL window and compositing manager
ii compiz-fusion-plugins-extra 0.7.7+git20080807-0ubuntu1 Collection of extra plugins from OpenCompositing for Compiz
ii compiz-fusion-plugins-main 0.7.7+git20080807-0ubuntu1 Collection of plugins from OpenCompositing for Compiz
ii compiz-gnome 1:0.7.7+git20080807-0ubuntu7 OpenGL window and compositing manager - GNOME window decorator
ii compiz-plugins 1:0.7.7+git20080807-0ubuntu7 OpenGL window and compositing manager - plugins
ii compiz-wrapper 1:0.7.7+git20080807-0ubuntu7 OpenGL window and compositing manager, wrapper script
ii compizconfig-backend-gconf 0.7.7+git20080618-0ubuntu1 Settings library for plugins - OpenCompositing Project
ii libcompizconfig0 0.7.7+git20080807-0ubuntu1 Settings library for plugins - OpenCompositing Project
ii libmetacity0 1:2.23.610-0ubuntu1 library of lightweight GTK2 based Window Manager
ii metacity 1:2.23.610-0ubuntu1 A lightweight GTK2 based Window Manager
ii metacity-common 1:2.23.610-0ubuntu1 Shared files of lightweight GTK2 based Window Manager

Michael Vogt (mvo) on 2008-09-15
Changed in gnome-control-center:
assignee: nobody → mvo
importance: Undecided → High
milestone: none → intrepid-alpha-6
status: Incomplete → Triaged

My versions match Stef's.

darthanubis (darthanubis) wrote :

dpkg --list | egrep 'compiz|metacity'
ii compiz 1:0.7.7+git20080807-0ubuntu7 OpenGL window and compositing manager
ii compiz-core 1:0.7.7+git20080807-0ubuntu7 OpenGL window and compositing manager
ii compiz-fusion-plugins-extra 0.7.7+git20080807-0ubuntu1 Collection of extra plugins from OpenComposi
ii compiz-fusion-plugins-main 0.7.7+git20080807-0ubuntu1 Collection of plugins from OpenCompositing f
ii compiz-fusion-plugins-unsupported 0.7.6-1 Compiz Fusion plugins - "unsupported" collec
ii compiz-gnome 1:0.7.7+git20080807-0ubuntu7 OpenGL window and compositing manager - GNOM
ii compiz-plugins 1:0.7.7+git20080807-0ubuntu7 OpenGL window and compositing manager - plug
ii compiz-wrapper 1:0.7.7+git20080807-0ubuntu7 OpenGL window and compositing manager, wrapp
ii compizconfig-backend-gconf 0.7.7+git20080618-0ubuntu1 Settings library for plugins - OpenCompositi
ii compizconfig-settings-manager 0.7.7+git20080630-0ubuntu1 Compiz configuration settings manager
ii libcompizconfig0 0.7.7+git20080807-0ubuntu1 Settings library for plugins - OpenCompositi
ii libemeraldengine0 0.7.2-0ubuntu2 Decoration engines for compiz-fusion
ii libmetacity0 1:2.23.610-0ubuntu1 library of lightweight GTK2 based Window Man
ii metacity 1:2.23.610-0ubuntu1 A lightweight GTK2 based Window Manager
ii metacity-common 1:2.23.610-0ubuntu1 Shared files of lightweight GTK2 based Windo
ii python-compizconfig

Confirmed here.

The same here:

dimss@frukt:~$ dpkg --list | egrep 'compiz|metacity'
ii compiz 1:0.7.7+git20080807-0ubuntu7 OpenGL window and compositing manager
ii compiz-core 1:0.7.7+git20080807-0ubuntu7 OpenGL window and compositing manager
ii compiz-fusion-plugins-extra 0.7.7+git20080807-0ubuntu1 Collection of extra plugins from OpenComposi
ii compiz-fusion-plugins-main 0.7.7+git20080807-0ubuntu1 Collection of plugins from OpenCompositing f
ii compiz-gnome 1:0.7.7+git20080807-0ubuntu7 OpenGL window and compositing manager - GNOM
ii compiz-plugins 1:0.7.7+git20080807-0ubuntu7 OpenGL window and compositing manager - plug
ii compiz-wrapper 1:0.7.7+git20080807-0ubuntu7 OpenGL window and compositing manager, wrapp
ii compizconfig-backend-gconf 0.7.7+git20080618-0ubuntu1 Settings library for plugins - OpenCompositi
ii libcompizconfig0 0.7.7+git20080807-0ubuntu1 Settings library for plugins - OpenCompositi
ii libmetacity0 1:2.23.610-0ubuntu1 library of lightweight GTK2 based Window Man
ii metacity 1:2.23.610-0ubuntu1 A lightweight GTK2 based Window Manager
ii metacity-common 1:2.23.610-0ubuntu1 Shared files of lightweight GTK2 based Windo
dimss@frukt:~$

Michael Vogt (mvo) on 2008-09-17
Changed in gnome-control-center:
status: Triaged → In Progress
Michael Vogt (mvo) wrote :

I close the gnome-control-center task, this is a problem with metacity and compiz only.

Changed in gnome-control-center:
milestone: intrepid-alpha-6 → none
status: In Progress → Invalid
Changed in metacity:
assignee: nobody → mvo
importance: Undecided → High
milestone: none → intrepid-alpha-6
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package metacity - 1:2.23.610-0ubuntu2

---------------
metacity (1:2.23.610-0ubuntu2) intrepid; urgency=low

  * re-add /usr/share/gnome/wm-properties/metacity-wm.desktop
    so that the gnome-window-preferences works again (LP: #269805)

 -- Michael Vogt <email address hidden> Wed, 17 Sep 2008 12:44:29 +0200

Changed in metacity:
status: Fix Committed → Fix Released
Michael Vogt (mvo) on 2008-09-17
Changed in compiz:
assignee: nobody → mvo
importance: Undecided → High
milestone: none → intrepid-alpha-6
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.7.7+git20080807-0ubuntu10

---------------
compiz (1:0.7.7+git20080807-0ubuntu10) intrepid; urgency=low

  * re-add /usr/share/gnome/wm-properties/compiz.desktop to
    make the gnome-window-properties work again (LP: #269805)

 -- Michael Vogt <email address hidden> Wed, 17 Sep 2008 13:02:06 +0200

Changed in compiz:
status: In Progress → Fix Released

I have just come across this same issue in the latest Alpha of Januty.

Reproduced and milestoned.

Changed in compiz:
milestone: intrepid-alpha-6 → jaunty-alpha-6
status: Fix Released → Triaged
Pedro Fragoso (ember) wrote :

I can confirm this on compiz but on metacity works fine.

Michael Vogt (mvo) on 2009-03-04
Changed in compiz:
status: Triaged → In Progress
Chris Coulson (chrisccoulson) wrote :

This is also the cause of several bugs reported against gnome-appearance-properties in Jaunty, because it doesn't change the Metacity theme if you select a new theme whilst running Compiz.

Michael Vogt (mvo) on 2009-03-09
Changed in compiz:
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

Michael says this is fixed in his bzr branch.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.8.2-0ubuntu1

---------------
compiz (1:0.8.2-0ubuntu1) jaunty; urgency=low

  * new upstream release 0.8.2
    - dropped 070_revert_prop_change (upstream now)
    - dropped 071_fix_window_move (upstream now)
  * debian/patches/033_compiz_manager_xdg_dirs:
    - fix compiz-wrapper when multiple compiz dirs are given
      (patch got dropped during the jaunty cycle) LP: #141621
  * re-re-add /usr/share/gnome/wm-properties/compiz.desktop to
    make the gnome-window-properties work again (LP: #269805)
  * debian/source_compiz.py, debian/rules:
    - include apport hook (LP: #338472)

 -- Michael Vogt <email address hidden> Mon, 09 Mar 2009 10:23:38 +0100

Changed in compiz:
status: Fix Committed → Fix Released
darthanubis (darthanubis) wrote :

What do you know, I was here for the same thing two years ago. Now I see the same issue in 10.10.

Vladislav Rovda (filincrew) wrote :

This bug affects me to.

Description: Ubuntu maverick (development branch)
Release: 10.10

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers