can't configure display resolution (monitor, graphics card) manually in gui

Bug #240916 reported by TheZorch on 2008-06-18
122
This bug affects 11 people
Affects Status Importance Assigned to Milestone
gnome-control-center (Baltix)
Undecided
Unassigned
gnome-control-center (Ubuntu)
Wishlist
Ubuntu Desktop Bugs

Bug Description

I've discovered a serious problem with Screen Resolution under Preferences which should be immediately addressed. The problem is a limited set of resolution opens for users of older Nvidia and ATI graphics card. I ran into this problem after install Hardy Heron on my desktop with an Nvidia Geforce FX 5600 8x AGP card. My resolution options were limited to 640x480 after installing the drivers via Administration~>Hardware Drivers. I use Compiz Fusion's zooming and color inversion features due to my visual impairment but limiting my screen resolution to 640x480 made using certain dialog boxes impossible.

I searched for resolutions to this problem. I first tried EnvyNG, a tool which uses scripts to install Nvidia and ATI drives but this didn't fix the problem and the legacy drivers wouldn't work with desktop compositing GLX. I tried using xrandr, xfix, nvida-settings, and nvidia-xconfig but none of these would fix the problem either. Finally, I found a forum suggesting that I run the old GTK screen resolution tools from Gutsy which is still within Hardy. Here is where I discovered the serious limitation of the new Screen Resolution window in Hardy.

The old GTK Screen Resolution window for Ubuntu Gutsy Gibbon 7.10 lets you specify what kind of monitor you are using manually X.org is unable to determine what kind of monitor you have when you install Ubuntu. Screen Resolution under the Preferences menu in Ubuntu Hardy Heron 8.04 does not give the user this option. This is a serious limitation which I believe should be addressed as soon as possible. Not allowing a user to specify what type of monitor they have and relying totally on the driver and X.org to figure out what monitor is being used will effect users like me who do not have standard monitors. My display is a VGA capable Sun Microsystems 21inch workstation display. It is not standard because when I try to use it with a laptop running Wkindows Vista the OS is unable to determine what kind of monitor it is and the display blinks on and off as the driver tries to figure out what it is. An option to manually select what monitor you have should be added to Screen Resolution in Hardy Heron.

Dariel Dato-on (odd-rationale) wrote :

Thank you for filing this bug. The new Xorg for Hardy Heron relies more on auto-detection than Gutsy's. However, you can specify the same options such as Screen Resolution, Monitor model, etc. in both versions the same way. The options you speicfy, will over ride the auto-detection.

Hope that helps...

P.S. I, too found the new Xorg more confusing rather than simpler... :|

Bryce Harrington (bryce) wrote :

Hi thezorch,

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with the latest development release of Ubuntu? (ISOs are available from cdimage.ubuntu.com)

If it remains an issue, could you also attach a new /var/log/Xorg.0.log?
Thanks in advance.

The output of lspci -vvnn would also be worth having.

Changed in xorg:
status: New → Incomplete
Przemek K. (azrael) wrote :

I'm also affected by this bug.
I'm using Ubuntu for over 3 years, and I've survived many difficulties with configuration, but now I must say that the new Xorg resolution autodetection simply sucks!
It can't detect correct resolution settings on both my laptop (ati, 8.04) and pc (nvidia, 8.10), using both open and closed driver. I always have to configure xorg.conf by hand because that's the only option to get the best results.
Not having any possibility to manually choose graphics card and monitor in GUI is a serious limitation and a regression from previous versions.
Yes, I know that power users like me can type in whole xorg.conf by hand, but that's painful and takes much more time than clicking in the gui and choosing all the stuff manually.
I miss the old tools from breezy-feisty era.

On Thu, Dec 4, 2008 at 4:56 PM, Przemysław Kulczycki
<email address hidden> wrote:
> I'm also affected by this bug.
> I'm using Ubuntu for over 3 years, and I've survived many difficulties with configuration, but now I must say that the new Xorg resolution autodetection simply sucks!
> It can't detect correct resolution settings on both my laptop (ati, 8.04) and pc (nvidia, 8.10), using both open and closed driver. I always have to configure xorg.conf by hand because that's the only option to get the best results.
> Not having any possibility to manually choose graphics card and monitor in GUI is a serious limitation and a regression from previous versions.
> Yes, I know that power users like me can type in whole xorg.conf by hand, but that's painful and takes much more time than clicking in the gui and choosing all the stuff manually.
> I miss the old tools from breezy-feisty era.
>
> ** Tags added: display resolution xrandr
>
> ** Also affects: gnome-control-center (Ubuntu)
> Importance: Undecided
> Status: New
>
> ** Summary changed:
>
> - Screen Resolution Limitations
> + can't configure display resolution (monitor, graphics card) manually in gui
>
> --
> can't configure display resolution (monitor, graphics card) manually in gui
> https://bugs.launchpad.net/bugs/240916
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Kubuntu 8.04 still has the feature to select a monitor type in the
screen resolution tool. I've been told you can take the config file
for X.org from this version or a previous version of Ubuntu and
overwrite the one used in 8.10 to correct the problem. What would
really fix it is if the option to manually change these settings in
the screen resolution GUI were put back in. Relying totally on
autodetection was a bad decision, its not that X.org is ready, its
that now all hardware types follow the rules and then there is the
closed source drivers which are a part of that chain. Someone needs
to bring this up to the powers that be in the community who make the
decisions as to what goes into each new version of Ubuntu and its
variants (Kubuntu, Xubuntu, etc) and let them know this needs to be
fixed.

--
Michael "TheZorch" Haney
<email address hidden>
Free Your Computer from the Tyranny of Microsoft www.ubuntu.com

Przemek K. (azrael) wrote :

I've linked 2 relevant blueprints to this bug.

Bryce Harrington (bryce) on 2008-12-19
Changed in xorg:
assignee: nobody → albertomilone
importance: Undecided → Wishlist
status: Incomplete → Triaged
Przemek K. (azrael) wrote :

http://beranger.org/index.php?page=diary&2008/03/18/07/35/55-the-value-of-a-meaningful-xorg-c
Here's a good read about why a good xorg.conf file matters. It's not related directly to the bug, but it touches the matter of having a self-explanatory xorg.conf file instead of an almost empty one while xorg's autodetection is not perfect.

Sebastien Bacher (seb128) wrote :

the issue is not specific to the GNOME capplet

Changed in gnome-control-center:
importance: Undecided → Low
status: New → Invalid
Sebastien Bacher (seb128) wrote :

reading again the description it could be a feature request for the capplet, the screen detection should be just working in xorg though and there is no plan to add monitor configuration to this capplet

On Tue, Jan 13, 2009 at 7:54 AM, Sebastien Bacher <email address hidden> wrote:
> reading again the description it could be a feature request for the
> capplet, the screen detection should be just working in xorg though and
> there is no plan to add monitor configuration to this capplet
>

No monitor configuration options in the genome screen resolution
capplet is a serious limitation and is poor design. Users who
encounter this problem face a long and frustrating process of trying
to fix Xorg's inability to properly detect the video modes their
hardware can support. This is an option that should never have been
removed and should remain a part of the capplet in all future versions
in the event Xorg fails to properly detect video settings. This is a
common sense option that most users would expect to find. The lack of
this option in the current versions of Ubuntu has forced many new
users to abandon the operating system because there is no simple
solution to fix the screen resolution issue.

The addition of this option to the screen resolution capplet must be
regarded as "Critical".

--
Michael "TheZorch" Haney
<email address hidden>

Jon Trott (jon-jpusa) wrote :

Thanks for posting this bug notice. Yes, I too have the issue. I'm using one of those infernal integrated Motherboards (has AGP video and sound, etc., integrated). I think it is an intel video set. Ubuntu does allow my monitor to run at 1024 by 768, but doesn't recognize it and lists it as "Unknown." Further, when I run video tests on the gnome desktop via the Administration > Test Hardware program, it does test correctly and set up my monitor w/ 85 mhz setting (correct, I believe). However, it does "offset" the image slightly from windows xp's settings (the image drifts right about a quarter to half inch under linux -- I use the same monitor hooked to two machines using a switchbox).

I'd appreciate this being fixed. Using the older Linux versions, I could just TELL Linux to use a Diamondtron (or was it Gateway?) monitor.

Needs to be fixed next time out. Loving Ubuntu, so don't get me wrong.

Jon Trott

Bryce Harrington (bryce) on 2009-03-06
Changed in gnome-control-center:
importance: Low → Wishlist
status: Invalid → Triaged
Sebastien Bacher (seb128) wrote :

those comment about how things are urgent and have to be fixed now will not make those fixed faster, quite the contrary if you insist on blaming the graphical tool where the issue is also in infrastructure it's using, nobody disagree that should be fixed but that's not as easy as you seem to think

It is horribly difficult to put back an existing manual configuration
utility that was present in a recent version? That is the original
solution I wanted.

Fixing every possible permutation of hardware in the automatic config
would be horribly difficult, but that seems to be the only thing you
might be willing to do.

I simply want SOME mechanism to configure my laptop, and I had one,
and it went away and the replacement is broken.

On Fri, Mar 6, 2009 at 3:05 AM, Sebastien Bacher <email address hidden> wrote:
> those comment about how things are urgent and have to be fixed now will
> not make those fixed faster, quite the contrary if you insist on blaming
> the graphical tool where the issue is also in infrastructure it's using,
> nobody disagree that should be fixed but that's not as easy as you seem
> to think
>
> --
> can't configure display resolution (monitor, graphics card) manually in gui
> https://bugs.launchpad.net/bugs/240916
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

Eric R Drayer (ericdrayer) wrote :
Download full text (10.3 KiB)

I hope that I am putting this information in the right place.
I would also like to preface this problem with the
statement that ubuntu 8.1 and XP have a similar
track record with this problem with me.

I have a
2.6.24-23-generic (#1 SMP Thu Nov 27 18:13:46 UTC 2008)Kernal,
gnome,quad6600, atiradeon rv250(open source driver),
intrepid 8.1 all updates no (compiz or fusion or)
desktop effects.

I recently bought a new monitor.samsung 2333SW lcd 23".
the monitor is not recognized by the capplet
(configure display settings).
the resolution is not optimal.
I do not know how to change the resolution.
I have forgoten the comand for my Xorg version
and the version does not show up in the sysinfo application.
the current resolution is 1024*768 48Khz 60Hz NN.
the best resolution is 1920*1080.
My situation is improved from the previous monitor
but I am hopeful that I will be able to use the
better resolution soon.
perhaps I will find more information on this issue
if I use different search key words but this was
the closest I could find.
It would be nice to have a few more designated
key words(areas or connections in the database)
ATI,MONITOR,Nvidia

above I noticed that there was a request for some info.
I have provided it below.

root@eric-desktop:/home/eric# lspci
00:00.0 Host bridge: Intel Corporation 82G33/G31/P35/P31 Express DRAM Controller (rev 02)
00:01.0 PCI bridge: Intel Corporation 82G33/G31/P35/P31 Express PCI Express Root Port (rev 02)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 01)
00:1c.2 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 3 (rev 01)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 01)
00:1f.2 IDE interface: Intel Corporation 82801GB/GR/GH (ICH7 Family) SATA IDE Controller (rev 01)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 01)
03:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8056 PCI-E Gigabit Ethernet Controller (rev 13)
04:03.0 VGA compatible controller: ATI Technologies Inc Radeon RV250 [Mobility FireGL 9000] (rev 01)
root@eric-desktop:/home/eric#

root@eric-desktop:/home/eric# lspci -vnn
00:00.0 Host bridge [0600]: Intel Corporation 82G33/G31/P35/P31 Express DRAM Controller [8086:29c0] (rev 02)
 Subsystem: ABIT Computer Corp. Device [147b:108e]
 Flags: bus master, fast devsel, latency 0
 Capabilities: [e0] Vendor Specific Information <?>
 Kernel modules: ...

TheZorch (thezorch) wrote :

Saying that this is a "harder than you might think" problem to fix is
a cop out. How hard is it to add a manual configuration tab to the
screen resolution app so you can tell X Windows to use "X" type
monitor settings when its auto-configuration method gets it wrong.
No, this not only needs to be fixed it "must" be fixed. The feature
should never have been removed in the first place it was a bad call to
do so.

Let me put it this way, this missing feature is "hindering" the
adoption of Ubuntu by new users, period. Fixing this should be
high-priority, no excuses. The only acceptable outcome is to fix this
before the next release of Ubuntu, not doing so is a failure of the
development community to listen to the needs of the user base.

--
Michael "TheZorch" Haney
<email address hidden>
http://thezorch.googlepages.com/home
Skype: thezorch (Voice and/or Chat)
AIM: <email address hidden>
Yahoo IM: zorchhaney
ICQ: 343230252
GoogleTalk: thezorch
MSN Messeger: <email address hidden>
Free Your Computer from the Tyranny of Microsoft www.ubuntu.com

Sebastien Bacher (seb128) wrote :

such agressive behaviour is not welcome on bugs, that's not up to you to say what other people have to do those contributors there are mostly volunteer doing work on their after work hours to fix issues, nobody removed something working the new tool use the current xorg api where the other told was hackish and has many issues and buggy cases

TheZorch (thezorch) wrote :

On 3/7/09, Sebastien Bacher <email address hidden> wrote:
> such agressive behaviour is not welcome on bugs, that's not up to you to
> say what other people have to do those contributors there are mostly
> volunteer doing work on their after work hours to fix issues, nobody
> removed something working the new tool use the current xorg api where
> the other told was hackish and has many issues and buggy cases
>

Then what is being done to resolve this? Give us a solution to this,
its a perfectly reasonable request. I am sorry for getting angry, but
I've been waiting a very long time for a fix to this problem and have
yet to receive an answer. Don't ignore us, help us, please.

--
Michael "TheZorch" Haney
<email address hidden>

Sebastien Bacher (seb128) wrote :

> Then what is being done to resolve this?

Nothing right now apparently by lack on manpower but you are welcome to starting working on the issue on find somebody interested in tackling that

Eric R Drayer (ericdrayer) wrote :

I posted here a few days ago and have another observation.
the objects that should be displayed as regular ( perfect ) are elongated left to right.
I hope that when someone has time for this that this information is helpful.

Bryce Harrington (bryce) wrote :

Eric, that just means you're using a 4:3 resolution on a 16:9 or 16:10 monitor or something. Maybe you're using -vesa, which has very limited support for widescreen resolutions. In any case, it's a lesser detail and not directly relevant to this bug report.

TheZorch (thezorch) wrote :

I was told by someone in an Ubuntu support mailing list that you can
make a copy of the xorg.conf file that has the proper video card and
monitor configurations and overwrite the xorg.conf file in a new
install which doesn't properly detect these settings and the copied
file will work.

Is this true? The next release of Ubuntu is coming up and I want to
do a full reinstall rather than an upgrade, so can I use my existing
xorg.comf file to make my current display settings work properly?

--
Michael "TheZorch" Haney
<email address hidden>
http://thezorch.googlepages.com/home
Skype: thezorch (Voice and/or Chat)
AIM: <email address hidden>
Yahoo IM: zorchhaney
ICQ: 343230252
GoogleTalk: thezorch
MSN Messeger: <email address hidden>
Free Your Computer from the Tyranny of Microsoft www.ubuntu.com

reduz (reduzio) wrote :

Well, as the bug i reported was marked as a duplicate of this one (https://bugs.launchpad.net/bugs/260436), which I agree with, i'm leaving a comment to remark that this behavior not only happens for undetected monitors, but with most cheap KVM switches out there (which make the video card unable to detect the monitor). Of course finding the monitor modeline and setting an entry on xorg.conf fixes the problem, but then user is left to its own luck to find the correct modeline on the internet (or the monitor docs, -in case he/she still has them-). A proper configuration window to allow selection of the monitor model (or similar) would be ages more userfriendly in case of unable to detect... ubutu already had that functionality, but it was taken away, which i feel is sad.. so why is this on wishlist?

As a workaround, for those who can run command line tools, there's instructions how to generate the appropriate modelines and where to stick them in xorg.conf in a comment in the duplicate bug...
https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/260436/comments/18
...which has apparently been useful to some.

I'll try to restate them more clearly here. They rely on two tools - gtf and xrandr - and a text editor.

xrandr should be invoked with no arguments to tell you the names of your displays.

These are the names which should be used in the xorg.conf later. Here's the output shown in my command line.

cefn@cefn-linux-tablet:~$ xrandr
Screen 0: minimum 320 x 200, current 1280 x 768, maximum 1440 x 1792
VGA disconnected (normal left inverted right x axis y axis)
LVDS connected 1280x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1280x768_60.00 60.0*+
   1280x768 59.9 +
   1024x768 85.0 75.0 70.1 60.0
   1024x600_60.00 60.0
   832x624 74.6
   800x600 85.1 72.2 75.0 60.3 56.2
   640x480 85.0 72.8 75.0 59.9
   720x400 85.0
   640x400 85.1
   640x350 85.1
TV disconnected (normal left inverted right x axis y axis)

Then gtf can be invoked to create a modeline suitable for you based on what you know about your display, maybe from reading the manual.

cefn@cefn-linux-tablet:~$ gtf 1440 900 60

  # 1440x900 @ 60.00 Hz (GTF) hsync: 55.92 kHz; pclk: 106.47 MHz
  Modeline "1440x900_60.00" 106.47 1440 1520 1672 1904 900 901 904 932 -HSync +Vsync

Finally you should create an entry in your xorg.conf which combines all these bits of information. It's advisable to save a copy of your old xorg.conf with a new name, like xorg.conf.bak. In some cases your existing xorg.conf will be blank.

My modified xorg.conf looked as below. Note the declaration of a virtual resolution which was wide enough to put the displays side by side or above each other...

Section "Monitor"
 Identifier "Configured Monitor"
EndSection

Section "Monitor"
 Identifier "VGA"
 Modeline "1440x900_60.00" 106.47 1440 1520 1672 1904 900 901 904 932 -HSync +Vsync
EndSection

Section "Screen"
 Identifier "Default Screen"
 Monitor "Configured Monitor"
 Device "Configured Video Device"
 SubSection "Display"
  Virtual 1440 1700
 EndSubSection
EndSection

Section "Device"
 Identifier "Configured Video Device"
EndSection

Once you've made these edits, and you log out and log back in, the new modeline should be visible even in your graphical tool like grandr. If not, you can invoke the display changes using xrandr.

Changed in gnome-control-center (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
CymruAmBydd (morusnigra) wrote :

Thank you Cefn, excellent work around.

I have just installed 9.10 having previously used Gutsy, Hardy, Intrepid and Jaunty and having to replace my trusty iiyama vision master pro 512 with a Sony Multiscan 520GS and swapping out my Belkin Omniview E-series KVM for the Avocent Switchview 100 KVM; which has sound. Kept the FX5200 graphics card. Somewhere along the line I lost control of the monitor refresh rate.

I found the tech specs for my Sony Multiscan 520GS i.e. max resolution of 1600 x 1200 @75Hz etc.

gtf to generate the modeline

and edited xorg.conf in a terminal (sudo nano /etc/X11/xorg.conf):

Section "Monitor"
        Identifier "Sony CPD-520GS"
        HorizSync 30-96
        VertRefresh 48-160
        Modeline "1600x1200_75.00" 205.99 1600 1720 1896 2192 1200 1201 1204$
EndSection

Section "Screen"
        Identifier "Default Screen"
        Device "Default Device"
        Monitor "Sony CPD-520GS"
        DefaultDepth 24
        SubSection "Display"
                Depth 24
                Modes "1600x1200_75.00"
        EndSubSection
EndSection

Section "Module"
        Load "glx"
EndSection

Section "Device"
        Identifier "Default Device"
        Driver "nvidia"
        Option "NoLogo" "True"
EndSection

NOW at last I have control!

It shouldn't be like this.

The only minor wrinkle is that I can't get the max resolution.

The best I can do is 1400 x 1050 @ 70Hz but at least it's workable i.e. the I have control and the screen doesn't wobble any more.

Failure to get the max res may be down to the KVM switch but having spent hours this morning I'm not about to put the monitor directly onto the pc to test this - I might do it later.

NB. 1400 x 1050 @ 75Hz doesn't work and 1400 x 1050 @ 85Hz doesn't work, none of the 4:3 aspect ratio 1600 x 1200's work i.e. very strange distorted and dulled or absent image which luckily reverts back to the previous setting after a short while to give me the chance of another attempt.

Thank you.

TheZorch (thezorch) wrote :
Download full text (3.2 KiB)

On Mon, Nov 2, 2009 at 7:52 AM, CymruAmBydd <email address hidden> wrote:
> Thank you Cefn, excellent work around.
>
> I have just installed 9.10 having previously used Gutsy, Hardy, Intrepid
> and Jaunty and having to replace my trusty iiyama vision master pro 512
> with a Sony Multiscan 520GS and swapping out my Belkin Omniview E-series
> KVM for the Avocent Switchview 100 KVM; which has sound. Kept the FX5200
> graphics card. Somewhere along the line I lost control of the monitor
> refresh rate.
>
> I found the tech specs for my Sony Multiscan 520GS i.e. max resolution
> of 1600 x 1200 @75Hz etc.
>
> gtf to generate the modeline
>
> and edited xorg.conf in a terminal (sudo nano /etc/X11/xorg.conf):
>
>
> Section "Monitor"
>        Identifier    "Sony CPD-520GS"
>        HorizSync     30-96
>        VertRefresh    48-160
>        Modeline "1600x1200_75.00"  205.99  1600 1720 1896 2192  1200 1201 1204$
> EndSection
>
> Section "Screen"
>        Identifier      "Default Screen"
>        Device          "Default Device"
>        Monitor         "Sony CPD-520GS"
>        DefaultDepth    24
>        SubSection "Display"
>                Depth   24
>                Modes   "1600x1200_75.00"
>        EndSubSection
> EndSection
>
> Section "Module"
>        Load    "glx"
> EndSection
>
> Section "Device"
>        Identifier      "Default Device"
>        Driver  "nvidia"
>        Option  "NoLogo"        "True"
> EndSection
>
>
> NOW at last I have control!
>
> It shouldn't be like this.
>
> The only minor wrinkle is that I can't get the max resolution.
>
> The best I can do is 1400 x 1050 @ 70Hz but at least it's workable i.e.
> the I have control and the screen doesn't wobble any more.
>
> Failure to get the max res may be down to the KVM switch but having
> spent hours this morning I'm not about to put the monitor directly onto
> the pc to test this - I might do it later.
>
> NB. 1400 x 1050 @ 75Hz doesn't work and 1400 x 1050 @ 85Hz doesn't work,
> none of the 4:3 aspect ratio 1600 x 1200's work i.e. very strange
> distorted and dulled or absent image which luckily reverts back to the
> previous setting after a short while to give me the chance of another
> attempt.
>
> Thank you.
>

This is why Ubuntu, and X.org in general, needs to have a way to
manually select what type of monitor you have in a GUI. This problem
has persisted long enough, when will this be resolved? Its now beyond
time for this to be fixed. Its ridiculous that such a simple matter
as this has been allowed to molder this long, and its such a vital
component of the operating system ... the Display. Without it you
can't use Ubuntu at all.

Why hasn't this problem been resolved? This problem has existed in
Ubuntu since 8.04. Having to edit a config file (ie; xorg.conf) to
get something as simple as this to work properly in a Modern Day
Operating System is absolutely unacceptable. Canonical needs to stop
putting their heads in the sand and fix this embarrassment.

--
Michael "TheZorch" Haney
<email address hidden>
http://thezorch.googlepages.com/home
Twitter: TheZorch | Skype: thezorch
AIM: <email address hidden> | Yahoo IM: zorchhaney
ICQ: 343230252 | GoogleTalk: thezorch
MSN M...

Read more...

mahjongg (mahjongg) wrote :

I have been hit by the "monitor not detected" problem too, and at several times. With an old Targa monitor, but also with some laptop LCD's. I think the problem is very common, but is often mis-diagnosed as a "driver issue".
Since the introduction of a new x-system in Ubuntu 9.x the problems has become a virtual show-stopper. In the past Ubuntu had a tool to manually select a monitor that solved the problem. Now users are simply stuck with the default resolution of 800x600 which is quite unacceptable, especially on a laptop LCD that can do 1024x768.

Ubuntu 9.x seems to work on the principle that it is always possible to auto-detect the capabilities of the Monitor, which is simply a fallacy!

There are many reasons why the plug-and-play (auto-detect) mechanism for auto-detecting the monitor capabilities is simply not present or working. For example older monitors from the pre- PnP era, or monitors connected through the VGA port with a VGA to RGB cable (older trinitron monitors, with RGB RCA video connectors), or LCD's built into older laptop where the PnP mechanism isn't implemented, ("because the display capabilities are fixed") all simply do not support the serial EEPROM with PnP monitor data. Or sometimes even if the monitor has these capabilities its not working for example because of a bad VGA cable that doesn't have (or it has but its broken) the wires for the serial EEPROM with the monitor capabilities.
In any of these cases a non-technical user , (one that is lost when told to edit the xorg.conf file) is simply confined to 800x600, even if the video hardware and monitor combo can do much higher resolutions.
A capability to manually select a monitor is essential, and should be provided.

mahjongg (mahjongg) wrote :

I was finally able to give an old laptop the 1024 x 768 resolution I knew the LCD could do (from the 800 x 600 + large gray border around it it did do because Ubuntu 9.10 did a "monitor not detected" on me) by adding an xorg.conf text file in /etc/X11 with just the following few lines only:

Section "Monitor"
Identifier "Configured Monitor"
HorizSync 60-60
VertRefresh 43-117
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

TheZorch (thezorch) wrote :

On Mon, Jan 11, 2010 at 6:03 PM, mahjongg <email address hidden> wrote:
> I was finally able to give an old laptop the 1024 x 768 resolution I
> knew the LCD could do (from the 800 x 600 + large gray border around it
> it did do because Ubuntu 9.10 did a "monitor not detected" on me) by
> adding an xorg.conf text file in /etc/X11 with just the following few
> lines only:
>
> Section "Monitor"
> Identifier "Configured Monitor"
> HorizSync 60-60
> VertRefresh 43-117
> EndSection
>
> Section "Screen"
> Identifier "Default Screen"
> Monitor "Configured Monitor"
> Device "Configured Video Device"
> DefaultDepth 24
> SubSection "Display"
> Depth 24
> Modes "1024x768" "800x600" "640x480"
> EndSubSection
> EndSection
>

I keep my settings from my original xorg.conf file around to copy &
paste into a new xorg.conf whenever I reinstall Ubuntu. Otherwise, I
wouldn't be able to enable the Nvidia drivers properly with it.

--
Michael "TheZorch" Haney
<email address hidden>
http://thezorch.googlepages.com/home
Twitter: TheZorch | Skype: thezorch
AIM: <email address hidden> | Yahoo IM: zorchhaney
ICQ: 343230252 | GoogleTalk: thezorch
MSN Messeger: <email address hidden>
Free Your PC from the Bondage of Windows http://www.ubuntu.com

Vic Main (vmain) wrote :

To quote maJongg..

"I have been hit by the "monitor not detected" problem too, . I think the problem is very common, but is often mis-diagnosed as a "driver issue".
"The problems has become a virtual show-stopper" It was that for me. I tried to fix the problem (or at least get around it at least 2 years ago) I was running

Ubuntu 8.x, and ended up with a 800x600 resolution. I recently installed version 10.04 and tried to resolve this problem again. At least the generic driver would do 1024x768. I have a NVIDIA GeForce4 MX440 with AGP8X card, and found out how to get around this problem.

I have to echo the sentiments of majongg and TheZorch regarding this problem hindering the adoption of Linux, it certainly did for me!!. I spent at least a full day trying to get my monitor to display correctly. Thanks to the generous help from the forum.

The main problem (let alone the monitor not being recognized), is that the software wildly guesses at the range of the HSYNC and VSYNC
which it writes to the xorg.conf file.

Thanks, Vic

On Fri, Sep 10, 2010 at 11:28 PM, Vic Main <email address hidden> wrote:
> To quote maJongg..
>
> "I have been hit by the "monitor not detected" problem too, . I think the problem is very common, but is often mis-diagnosed as a "driver issue".
> "The problems has become a virtual show-stopper" It was that for me. I tried to fix the problem (or at least get around it at least 2 years ago) I was running
>
> Ubuntu 8.x, and ended up with a 800x600 resolution. I recently installed
> version 10.04 and tried to resolve this problem again. At least the
> generic driver would do 1024x768. I have a NVIDIA GeForce4 MX440 with
> AGP8X card, and found out how to get around this problem.
>
> I have to echo the sentiments of majongg and TheZorch regarding this
> problem hindering the adoption of Linux, it certainly did for me!!. I
> spent at least a full day trying to get my monitor to display correctly.
> Thanks to the generous help from the forum.
>
> The main problem (let alone the monitor not being recognized), is that the software wildly guesses at the range of the HSYNC and VSYNC
> which it writes to the xorg.conf file.
>
> Thanks, Vic
>

The quickest way this can be fixed is if the feature in the screen
resolution window that let you "manually" select your monitor was put
back where it belongs, or a new GUI was made just for the monitor that
does the same thing. It is not the drivers, its Xorg and also the
fact that this feature was "removed" from Ubuntu several versions back
when it shouldn't have been.

Honestly, this could have and should have been fixed long ago. What
is the problem? Why hasn't this been dealt with in like 2 years?
Don't tell me its not a high priority issue, it is a High Priority
issue because this problem has "prevented" new users from adopting
Ubuntu. This is serious, this a usability issue, and it needs to be
dealt with ASAP.

No other answer is acceptable, its been long enough, get this issue
fixed. Its an embarrassment to the community that this problem has
persisted for so long, and its an embarrassment to LaunchPad that this
bug hasn't been made a high priority so it can finally get fixed.

Pass this onto which even group this needs to go to and have them do
something about this instead of letting the problem molder.

--
Michael "TheZorch" Haney
"The greatest tragedy in mankind's entire history may be the hijacking
of morality by religion." ~ Arthur C. Clarke
"The suppression of uncomfortable ideas may be common in religion and
politics, but it is not the path to knowledge, and there is no place
for it in the endeavor of science. " ~ Carl Sagan

Visit My Site:  http://sites.google.com/site/thezorch/home-1
To Contact Me:
http://sites.google.com/site/thezorch/home-1/zorch-central---contacts

Free Your PC from the Bondage of Windows http://www.ubuntu.com

tz (thomas-mich) wrote :

I had forgotten about this yet another thing Ubuntu refuses to even provide a workaround much less fix.

Some quick notes - yes I want this fixed too (actually I've abandoned Ubuntu - they will ruin notifications, but not put a refresh in the network manager which is similarly broken, nor fix it - more of the "automatic is broken but we won't give you a manual option theory).

First, it isn't just monitors. My original problem was a laptop with a VIA chipset. The original driver had a few problems (mainly wiht 3d), but was usable (E-F). G or H broke it and removed the manual configuration. The VIA driver locked up constantly (no, they never fixed that), but I could use the default minimal VESA, but it was 800x600 although the bios and everything else said the screen was 1024x768. But now there was no way to tell X even to use a plain VESA mode of 1024x768 with what amounted to standard VESA monitor timings. There is no detection involved.

Worse, it wasn't just removed from the distribution disk, it was removed from the repositories. If I wanted it, I would have to track down the old source and recompile from scratch.

It isn't a big, complex job looking into strange driver code and hardware, it is just putting back one tiny freaking program into the repositories if not the main distro.

Right now I can't tell it that my monitor is a plain, vanilla, standard VESA with resolution of 1024x768.

VESA is not some complex or quirky hardware, it is a freaking standard! And Ubuntu doesn't support it.

It isn't a high priority because their policy seems never to fix severely broken automatic configuration - either setup like this or ongoing like network-manager (they have time for vanity UI changes though), but at the same time rip out all the manual configuration so if your hardware is affected there is no way for you to fix it.

I'm in the process of switching to Fedora (13) - it seems to be more stable, and although not everything is fixed, it has a large package library and so far they seem to be more friendly to older hardware.

Bryce Harrington (bryce) on 2011-12-21
no longer affects: x-kit (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers