Wired and wireless connection details have not enough height and items overlap

Bug #1873184 reported by Olivier Febwin on 2020-04-16
86
This bug affects 11 people
Affects Status Importance Assigned to Milestone
OEM Priority Project
Undecided
Unassigned
gnome-control-center
Unknown
Unknown
gnome-control-center (Ubuntu)
Status tracked in Groovy
Focal
Low
Robert Ancell
Groovy
Low
Bin Li

Bug Description

* Impact

The details of the connection settings sometime overlap

* Test case

Connect the computer to a wired ethernet, go to settings and check the connection details, the items should be displayed separated and not overlapping

* Regression potential

Check that the connection details dialog is correctly displayed on different typo of connections, the change is in the layout of the elements so it could impact the layout in other cases

Olivier Febwin (febcrash) wrote :
Olivier Febwin (febcrash) wrote :

it was ok on 19.10

Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:
* Is this reproducible?
* If so, what specific steps should we take to recreate this bug?

This will help us to find and resolve the problem.

Changed in gnome-control-center (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Olivier Febwin (febcrash) wrote :

Yes you just must have to unplug your network cable ;)

Sebastien Bacher (seb128) wrote :

the UI automatically opens on screen? or what UI is in the screenshot about and how do trigger it?

Olivier Febwin (febcrash) wrote :

Sorry, the UI doesn't open automatically. You must open gnome-control-center and clic on network?.
See 2020-04-16_10-59.png

Quentin Caron (quentincrn) wrote :

I have the same problem in when I'm connected in wifi

Sebastien Bacher (seb128) wrote :

Do you have any warning/error if you start gnome-control-center from a command line?

I don't see the issue on the VPN or wifi dialos, I don't have a wired connection to test with at the moment though, would be worth report upstream as well on https://gitlab.gnome.org/GNOME/gnome-control-center/issues if you could?

Sebastien Bacher (seb128) wrote :
Changed in gnome-control-center (Ubuntu):
status: Incomplete → Confirmed
importance: Low → High
status: Confirmed → Triaged
summary: - There is a display bug when you unplug the network cable
+ Wired connection details has not enough height and items overlap
tags: added: focal

I think this should still be Low importance.

Changed in gnome-control-center (Ubuntu):
importance: High → Low
summary: - Wired connection details has not enough height and items overlap
+ Wired and wireless connection details has not enough height and items
+ overlap
summary: - Wired and wireless connection details has not enough height and items
+ Wired and wireless connection details have not enough height and items
overlap
Bin Li (binli) wrote :
Bin Li (binli) wrote :

The attachment "details-page.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Changed in gnome-control-center (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Bin Li (binli)
Changed in gnome-control-center (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.37.3-1ubuntu1

---------------
gnome-control-center (1:3.37.3-1ubuntu1) groovy; urgency=medium

  * New upstream version based on Debian
  * d/p/git-nongnome-segfault.patch,
    d/p/git-user-accounts-Use-newly-designed-fingerprint-enroll-dialo.patch,
    d/p/0029-applications-Use-new-snapd-glib-API-for-labelling-Sn.patch:
    - removed, included in the new version
  * debian/patches/gitlab_details_layout.patch:
   - correctly layout the ethernet details so they don't overlap,
     thanks Bin Li (lp: #1873184)

 -- Sebastien Bacher <email address hidden> Fri, 07 Aug 2020 23:07:10 +0200

Changed in gnome-control-center (Ubuntu):
status: Fix Committed → Fix Released
Rex Tsai (chihchun) on 2020-08-15
tags: added: oem-priority
Changed in gnome-control-center (Ubuntu Focal):
assignee: nobody → Robert Ancell (robert-ancell)
status: New → Fix Committed
importance: Undecided → Low
tags: added: fixed-in-3.36.5
description: updated

Hello Olivier, or anyone else affected,

Accepted gnome-control-center into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-control-center/1:3.36.4-0ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

tags: added: verification-needed verification-needed-focal
Olivier Febwin (febcrash) wrote :

3.36.4-0ubuntu2 fixes the issue
Thanks!

tags: added: verification-done-focal
removed: verification-needed-focal
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.