FFe: Update gnome-control-center to 3.27.90

Bug #1750174 reported by Jeremy Bicha on 2018-02-17
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
Wishlist
Unassigned
humanity-icon-theme (Ubuntu)
Undecided
Unassigned

Bug Description

FFe Justification
-----------------
This upgrade was ready a little bit late because we wanted to fix some regressions identified in testing the new version instead of rushing it in.

News
----
https://gitlab.gnome.org/GNOME/gnome-control-center/blob/master/NEWS

To Do
-----

1. The app icon was renamed from 'preferences-system' to 'gnome-control-center'. We'll want to update humanity-icon-theme and the Ubuntu Budgie default themes. But there is a naming issue with gnome-icon-theme so let's hold off on changing icon themes until that gets resolved:

https://gitlab.gnome.org/GNOME/gnome-control-center/issues/3

2. You can't maximize the Settings app (button is there, but doesn't work). Maybe only affects when run in a VM?

Done
----
1. Rebase 70_allow_sound_above_100.patch
(This patch has been somewhat upstreamed. However, the upstream feature is incomplete without the gnome-settings-daemon patches that haven't been accepted upstream yet. Also, the upstream gsettings schema for this feature has a different name than the Ubuntu schema. Didier's plan was to keep using the Ubuntu schema name until the gnome-settings-daemon patches were accepted. After that, we'll need a way to migrate the gsettings schema.)

-> rebasing is done, keeping the same gsettings key than in artful.

2. Background panel redesign (didn't land for 3.28 so never mind)

3. The default 'faces' (user avatars) were changed and there was an upgrade issue.

Other Info
----------
I believe this can be updated independently of gnome-settings-daemon or gnome-shell/mutter.

Packages are available in the GNOME3 Staging PPA for bionic.

Jeremy Bicha (jbicha) on 2018-02-17
description: updated
Jeremy Bicha (jbicha) on 2018-02-17
description: updated
Jeremy Bicha (jbicha) on 2018-02-27
description: updated
Didier Roche (didrocks) on 2018-03-02
description: updated
Jeremy Bicha (jbicha) on 2018-03-02
description: updated
summary: - Update gnome-control-center to 3.27.90
+ FFe: Update gnome-control-center to 3.27.90
Sebastien Bacher (seb128) wrote :

we should also include the revert from https://bugzilla.gnome.org/show_bug.cgi?id=794012 to add a regression

Jeremy Bicha (jbicha) on 2018-03-10
tags: added: block-proposed
Jeremy Bicha (jbicha) on 2018-03-11
tags: added: bionic
removed: block-proposed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package humanity-icon-theme - 0.6.15

---------------
humanity-icon-theme (0.6.15) bionic; urgency=medium

  * Add symlinks to handle gnome-control-center 3.28's new icon name
    (LP: #1750174)
  * Build-Depend on scour instead of python3-scour

 -- Jeremy Bicha <email address hidden> Sat, 10 Mar 2018 18:12:18 -0500

Changed in humanity-icon-theme (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (4.9 KiB)

This bug was fixed in the package gnome-control-center - 1:3.27.92-1ubuntu1

---------------
gnome-control-center (1:3.27.92-1ubuntu1) bionic; urgency=medium

  [ Jeremy Bicha ]
  * Sync with Debian. (LP: #1750174, LP: #1752928, LP: #1691867)
    Remaining changes:
    + debian/control.in:
      - Depend on fonts-ubuntu, language-selector-gnome, and
        whoopsie-preferences
      - Depend on instead of Recommend network-manager-gnome and
        system-config-printer-common
      - Recommend ibus, unity-control-center-faces, & ubuntu-system-service
      - Suggest instead of Recommend realmd and rygel
      - Build-Depend on libwhoopsie-preferences-dev
    + Split gnome-control-center-faces to a separate package so
      that it can be used by unity-control-center
    + Install apport hook
    + debian/gnome-control-center-data.install:
      - Don't install gnome-control-center.pkla since we use
        policykit-desktop-privileges instead
      - Install additional assets used by unity-control-center
    * debian/ubuntu-logo-icon.png, debian/source/include-binaries,
      debian/gnome-control-center-data.install: Include an Ubuntu logo
    * debian/gnome-control-center-data.links:
      - Link audio-speaker-center* to audio-speaker-mono* so that an
        icon is shown in the test speaker panel. (LP: #1704002)
    + debian/rules: Enable whoospie integration
    + debian/patches:
      - 08_lowercase_user_names.patch:
         Disallow upper-case letters in user names for compliance with adduser
      - 52_region_language.patch:
         Adapt region panel to use Ubuntu style regions
      - 64_restore_terminal_keyboard_shortcut.patch
         Bring back terminal shortcut
      - 70_allow_sound_above_100.patch:
         Allow setting volume above 100% in the Ubuntu session
      - 71_ubuntu_dock_settings.patch
         Add Dock panel for Ubuntu session
      - 99_add_lock-on-suspend.patch
         Add option to lock on suspend
      - ubuntu-gnome-version.patch:
         Add Ubuntu branding to Details panel
      - ubuntu-region-packagekit.patch
         fix detection of installed language packs
      - ubuntu-region-langpack-install.patch:
         check for missing language packs when loading region panel to pull
         in packs that arent included with the installer
      - ubuntu-language-support.patch
         Add Language Support button to Region & Language panel to
         work around (LP: #1631750)
      - ubuntu-printer-support.patch
         Add Advanced Printer Settings button to work around missing printer
         sharing feature (LP: #1718083)
      - ubuntu-legacy-notifications.patch
         Ubuntu ships compatibility names for .desktop that got renamed
         upstream, those use NoDisplay but the panel doesn't respect that key,
         skip known buggy entries for file-roller and nautilus (LP: #1716267)
      - connectivity-switch.patch
         Add Connectivity Checking switch to Privacy panel
      - privacy-panel-whoopsie.patch
         Support Ubuntu's whoopsie service in the Privacy panel
      - ubuntu-white-lists.patch
         Ensure lists have white background when used with Ambiance & Radiance
  * Update...

Read more...

Changed in gnome-control-center (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.