Ubuntu

Create Unity Control Center so can remain on old GNOME Control Center version

Reported by Robert Ancell on 2013-12-03
42
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Empathy
Fix Released
Medium
Eye of GNOME
Fix Released
Wishlist
GNOME Color Manager
Incomplete
Wishlist
GNOME media utilities
New
Wishlist
Nautilus
Fix Released
Wishlist
gThumb
Fix Released
Wishlist
activity-log-manager (Ubuntu)
Medium
Unassigned
chromium-browser (Ubuntu)
Medium
Chad Miller
compiz (Ubuntu)
Medium
Unassigned
deja-dup (Ubuntu)
Medium
Unassigned
empathy (Ubuntu)
Medium
Unassigned
eog (Ubuntu)
Medium
Unassigned
gnome-color-manager (Ubuntu)
Medium
Unassigned
gnome-control-center (Ubuntu)
Medium
Unassigned
gnome-control-center-signon (Ubuntu)
Medium
Alberto Mardegan
gnome-media (Ubuntu)
Medium
Unassigned
gthumb (Ubuntu)
Medium
Unassigned
indicator-bluetooth (Ubuntu)
Medium
Unassigned
indicator-datetime (Ubuntu)
Medium
Unassigned
indicator-power (Ubuntu)
Medium
Unassigned
indicator-session (Ubuntu)
Medium
Unassigned
indicator-sound (Ubuntu)
Medium
Unassigned
landscape-client (Ubuntu)
Medium
Unassigned
language-selector (Ubuntu)
Medium
Unassigned
nautilus (Ubuntu)
Medium
Unassigned
software-properties (Ubuntu)
Medium
Unassigned
system-config-printer (Ubuntu)
Medium
Unassigned
ubuntuone-control-panel (Ubuntu)
Medium
Unassigned
unity (Ubuntu)
Medium
Unassigned
unity-control-center (Ubuntu)
Medium
Robert Ancell
webaccounts-browser-extension (Ubuntu)
Medium
Unassigned

Bug Description

Ubuntu/Unity uses GNOME Control Center as the application to configure the Unity session. We've made a lot of changes appropriate for Ubuntu and Unity (61 patches) which makes it hard to maintain and creates a conflict for Ubuntu GNOME to use the control center. Unity 7 will be replaced by Unity 8 in the future which has a new settings interface.

So we can continue to remain on the current version of GNOME Control Center but allow Ubuntu GNOME to continue to update we will create a new project lp:unity-control-center which is a copy of GNOME Control Center 3.6 but with appropriate renaming so both can be installed.

A number of packages that refer to gnome-control-center need to be updated to refer to unity-control-center (see bug tasks).

A PPA for testing is https://launchpad.net/~ubuntu-desktop/+archive/unity-control-center

Related branches

lp:software-properties
No reviews requested
lp:~robert-ancell/gnome-control-center-signon/unity-control-center
Merged into lp:gnome-control-center-signon at revision 173
PS Jenkins bot: Approve (continuous-integration) on 2014-02-06
Alberto Mardegan: Approve on 2014-02-06
Sebastien Bacher: Pending requested 2014-02-06
lp:~robert-ancell/indicator-bluetooth/unity-control-center2
Merged into lp:indicator-bluetooth at revision 79
Ted Gould: Approve on 2014-01-22
PS Jenkins bot: Approve (continuous-integration) on 2014-01-21
lp:~robert-ancell/indicator-datetime/unity-control-center2
Merged into lp:indicator-datetime at revision 293
Charles Kerr: Approve on 2014-01-17
PS Jenkins bot: Approve (continuous-integration) on 2014-01-14
lp:~robert-ancell/indicator-power/unity-control-center2
Merged into lp:indicator-power at revision 221
Sebastien Bacher: Approve on 2014-01-15
PS Jenkins bot: Approve (continuous-integration) on 2014-01-14
lp:~robert-ancell/indicator-session/unity-control-center2
Merged into lp:indicator-session at revision 426
Ted Gould: Approve on 2014-01-22
PS Jenkins bot: Approve (continuous-integration) on 2014-01-21
Sebastien Bacher: Approve on 2014-01-15
lp:~robert-ancell/indicator-sound/unity-control-center2
Merged into lp:indicator-sound at revision 408
Ted Gould: Approve on 2014-01-22
PS Jenkins bot: Approve (continuous-integration) on 2014-01-21
Changed in unity-control-center (Ubuntu):
status: New → In Progress
assignee: nobody → Robert Ancell (robert-ancell)
importance: Undecided → Medium
description: updated
description: updated
Alberto Mardegan (mardy) wrote :

Fully agree on splitting the thing. One question, though: what do you think about installing the binaries in a different location (or with a different name), and have /usr/bin/gnome-control-center as a shell script that checks if we are running under unity (is that DESKTOP_SESSION=ubuntu?) and execs unity-control-center in that case, and the gnome-control-center in all the others?

That way, we might be able to reduce the number of affected packages.

Iain Lane (laney) wrote :

Mmm, yeah, we might be able to use the alternatives system or something to do that. I don't know though --- there would have to be a way to know that the support you want is in the control centre implementation that's going to be called.

Changed in activity-log-manager (Ubuntu):
status: New → In Progress
Changed in deja-dup (Ubuntu):
status: New → In Progress
Changed in eog (Ubuntu):
status: New → In Progress
Changed in gnome-color-manager (Ubuntu):
importance: Undecided → Medium
status: New → In Progress
Changed in eog (Ubuntu):
importance: Undecided → Medium
Changed in deja-dup (Ubuntu):
importance: Undecided → Medium
Changed in webaccounts-browser-extension (Ubuntu):
importance: Undecided → Medium
status: New → In Progress
Changed in ubuntuone-control-panel (Ubuntu):
importance: Undecided → Medium
status: New → In Progress
Changed in software-properties (Ubuntu):
importance: Undecided → Medium
status: New → In Progress
Changed in nautilus (Ubuntu):
importance: Undecided → Medium
status: New → In Progress
Changed in language-selector (Ubuntu):
importance: Undecided → Medium
status: New → In Progress
Changed in landscape-client (Ubuntu):
importance: Undecided → Medium
status: New → In Progress
Changed in indicator-sound (Ubuntu):
importance: Undecided → Medium
status: New → In Progress
Changed in indicator-session (Ubuntu):
importance: Undecided → Medium
status: New → In Progress
Changed in indicator-power (Ubuntu):
importance: Undecided → Medium
status: New → In Progress
Changed in indicator-bluetooth (Ubuntu):
importance: Undecided → Medium
status: New → In Progress
Changed in gthumb (Ubuntu):
importance: Undecided → Medium
status: New → In Progress
Changed in gnome-media (Ubuntu):
importance: Undecided → Medium
status: New → In Progress
Changed in gnome-control-center-signon (Ubuntu):
importance: Undecided → Medium
status: New → In Progress
Changed in gnome-control-center (Ubuntu):
importance: Undecided → Medium
status: New → In Progress
Robert Ancell (robert-ancell) wrote :

I'd prefer to go for the direct method of doing the full rename rather than redirecting. It appears there's only a finite number of applications that access the control center directly. Also, over time g-c-c and u-c-c are likely to diverge - better to solve the issues earlier than have them crop up in the future. FInally, when we migrate to ubuntu-system-settings this will have to happen anyway.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in chromium-browser (Ubuntu):
status: New → Confirmed
Changed in empathy (Ubuntu):
status: New → Confirmed
description: updated
Doug McMahon (mc3man) wrote :

This will probably preclude users from using both unity & gnome-shell in the same install??, (at least as far as settings panels
While not a big deal, if so I suspect you'll get a number of bug reports from Gs users about not being able to access 'settings'
(if when you fork g-s-d to u-s-d it creates more significant issues in a Gs session then maybe that should be addressed in some manner

Sebastien Bacher (seb128) wrote :

> This will probably preclude users from using both unity & gnome-shell in the same install??

no, it's the opposite, it means each desktop can have its version which reduces conflicts (they are co-installable)

> if when you fork g-s-d to u-s-d it creates more significant issues in a Gs session then maybe that should be addressed in some manner

what do you mean? the fork is create to reduce issues in Gs session (e.g allow to drop unity hacks under GNOME and let GNOME use a more recent version than the one that is adapted to Unity)

On 12/11/2013 12:11 PM, Sebastien Bacher wrote:
>> This will probably preclude users from using both unity & gnome-shell
> in the same install??
>
> no, it's the opposite, it means each desktop can have its version which
> reduces conflicts (they are co-installable)
>
>> if when you fork g-s-d to u-s-d it creates more significant issues in
> a Gs session then maybe that should be addressed in some manner
>
> what do you mean? the fork is create to reduce issues in Gs session (e.g
> allow to drop unity hacks under GNOME and let GNOME use a more recent
> version than the one that is adapted to Unity)
>
Sorry then, I guess I'm missing something.
Atm if I install u-c-c, ect it removes g-c-c so 'co-existence' isn't
possible, that's to change?

These were removed when u-c-c was installed

Removed the following packages:
gnome-control-center
gnome-control-center-datetime
gnome-control-center-signon
gnome-control-center-unity
ubuntu-desktop

Sebastien Bacher (seb128) wrote :

@Doug: that seems wrong, what happens if you try to install both? what g-c-c version do you have?

Doug McMahon (mc3man) wrote :

@Seb - I guess it's just caused by the current state of ppa & all will be better when released..
$ apt-cache policy gnome-control-center
gnome-control-center:
  Installed: (none)
  Candidate: 1:3.8.6-0ubuntu1+unity
  Version table:
     1:3.8.6-0ubuntu1+unity 0
        500 http://ppa.launchpad.net/ubuntu-desktop/unity-control-center/ubuntu/ trusty/main amd64 Packages
     1:3.6.3-0ubuntu49 0
        500 http://archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
        100 /var/lib/dpkg/status

That version is not installable due to
 gnome-control-center : Depends: libgoa-1.0-0 (>= 3.7.90) but it is not installable

I've recently build unity-contol-center on my own to test a patch that adds option for always showing the global menu (it also needs patched Unity).

https://bugs.launchpad.net/unity/+bug/682788 (that patches are attached here)

When I tried to install those packages there was one conflict with gnome-control-center-unity package so I removed it and installed u-c-c without removing other gnome-control-center packages.

Robert Ancell (robert-ancell) wrote :

Yes, gnome-control-center-unity is obsoleted by these changes, we are probably missing some dpkg magic to uninstall that on upgrade

Sebastien Bacher (seb128) wrote :

> gnome-control-center : Depends: libgoa-1.0-0 (>= 3.7.90) but it is not installable

it seems like the ppa needs to transition to the new gnome-online-account soname that got uploaded to trusty this week

> Yes, gnome-control-center-unity is obsoleted by these changes, we are probably missing some dpkg magic to uninstall that on upgrade

The new g-c-c and u-c-c should Conflicts on gnome-control-center-unity since neither the binary works with neither of those

After installing todays packages from PPA I observed several problems.

The icon in the launcher still doesn't launch u-c-c but gnome-control-center.

The dimensions of the u-c-c are not as they supposed to be and the window is wider but the height remains unchainged from the dafault.

I couldn't use Privacy and Online Accounts settings. When I clicked their icons the settings didn't load only the location bar changed.

When I closed the u-c-c window it opened again and again and again.

Sebastien Bacher (seb128) wrote :

> The icon in the launcher still doesn't launch u-c-c but gnome-control-center.

That's a good point, we are going to need to update the unity config and somewhat change the user configuration on upgrade.

@Robert: that might impact on custom scripts and other things, I'm still not convinced that changing the name is a good idea (without having a wrapper with the old name at least)

Robert Ancell (robert-ancell) wrote :

> The icon in the launcher still doesn't launch u-c-c but gnome-control-center.

This is due to the gsettings key /com/canonical/unity/launcher/favourites. This refers specifically to gnome-control-center.desktop and this key is likely to have been overridden in user configuration.

Robert Ancell (robert-ancell) wrote :

I've uploaded a gnome-control-center to the PPA with a wrapper that calls unity-control-center if it is installed and $XDG_CURRENT_DESKTOP is "Unity".

Now the icon launcher starts unity-control-center but if I launch "System settings..." from the indicator there are two icons on the launcher.

I've seen on the mailing lists that translations have been imported but apparently not all of them. I checked with my native language which is Polish and u-c-c doesn't have all the translated texts that are in g-c-c. I've made three example screenshots for each of the Control Centers.

http://ubuntuone.com/51mNx0hjWTVxWKJtmmNwq4

There is also a screenshot which shows that when I search in Unity Dash for Privacy settings I get not only the Unity settings but also Gnome. Settings for Gnome shouldn't appear in Dash.

Doug McMahon (mc3man) wrote :

Well I see 3 in the Dash - Settings (gnome), System Settings (unity) & Share
Maybe the .desktop for Settings should be OnlyShowIn=GNOME;
and the .desktop for 'Sharing' have a NoDisplay=true line

Changed in indicator-datetime (Ubuntu):
importance: Undecided → Medium
status: New → In Progress
Changed in activity-log-manager (Ubuntu):
importance: Undecided → Medium
Robert Ancell (robert-ancell) wrote :

Mateuz - are all the labels normally translated into Polish? As far as I can tell the translations are there, I'm wondering if the language packs are confusing things.

I purged the PPA today and reinstalled it again because you asked for it in mailing list.

Normally the translations are there for this labels in System settings...

All settings
Appearance

but in unity-control-center I don't see the Polish labels. Also all the labels in Appearance settings still display in English language but normally they are translated. There is one label in Brightness and blocking settings still in English.

The rest of the labels display properly in Polish except Text Entry and Backup (which looks different than in 13.10) but that isn't translated normally.

The settings for Online Accounts and Privacy finally work but clicking on the latter results in window becoming to wide and it also crashed.

Alberto Mardegan (mardy) on 2013-12-23
Changed in gnome-control-center-signon (Ubuntu):
assignee: nobody → Alberto Mardegan (mardy)
Alberto Mardegan (mardy) wrote :

Hi Robert, I linked my changes for gnome-control-center-signon to this bug. You are welcome to build the packages and add them to your PPA. :-)
Please let me know how to proceed (I cannot merge my changes to trunk because they depend on unity-control-center).

Robert Ancell (robert-ancell) wrote :

Alberto, I made similar changes in lp:~robert-ancell/gnome-control-center-signon/unity-control-center and these are in the PPA - might be worth checking if there are any differences. Sorry, I didn't link the branch to this bug.

I'll update this bug when unity-control-center lands into main and we can start shifting over to it.

Robert Ancell (robert-ancell) wrote :

unity-control-center now in Universe, MIR in bug 1266971

Robert Ancell (robert-ancell) wrote :

gnome-control-center 1:3.6.3-0ubuntu50 can now work with unity-control-center

Alberto Mardegan (mardy) wrote :

Robert, your branch was indeed better than mine (I was not renaming the packages). I just created a MP to integrate a few minor changes from my branch into yours:
https://code.launchpad.net/~mardy/gnome-control-center-signon/lp1257505/+merge/201000

Changed in gnome-control-center (Ubuntu):
status: In Progress → Fix Released
Changed in unity-control-center (Ubuntu):
status: In Progress → Fix Released
Changed in chromium-browser (Ubuntu):
importance: Undecided → Medium
Changed in empathy (Ubuntu):
importance: Undecided → Medium
Robert Ancell (robert-ancell) wrote :

Alberto - I'm pushing branches that enable panels in both control centers, that way we can land changes at any time and no users will have a control center with bits missing.

It doesn't look easy to do this for gnome-control-center-signon since the package contains a lot of common files. We might have to wait for the other components to be ready, and upload the gnome-control-center-signon at the same time we add unity-control-center to the seed. We can make gnome-control-center signon depend the version of u-c-c that is uploaded at that time.

Also, I talked to the Ubuntu GNOME team about what they plan to do with unity-control-center. They said that it was desirable to be able to access the online accounts in GNOME for the apps that need it. Will anything show in g-c-c once we move to u-c-c? Do you care about this use-case as an upstream?

Alberto Mardegan (mardy) wrote :

On 01/10/2014 05:24 AM, Robert Ancell wrote:
> It doesn't look easy to do this for gnome-control-center-signon since
> the package contains a lot of common files. We might have to wait for
> the other components to be ready, and upload the gnome-control-center-
> signon at the same time we add unity-control-center to the seed. We can
> make gnome-control-center signon depend the version of u-c-c that is
> uploaded at that time.

OK.

> Also, I talked to the Ubuntu GNOME team about what they plan to do with
> unity-control-center. They said that it was desirable to be able to
> access the online accounts in GNOME for the apps that need it. Will
> anything show in g-c-c once we move to u-c-c? Do you care about this
> use-case as an upstream?

I wonder whether by "Online Accounts" they meant GNOME Online Accounts
(GOA) or Ubuntu Online Accounts (UOA). The former should indeed be
visible in g-c-c without special support from our side; the latter is
currently visible as well in GNOME, causing two "Online Accounts" applet
to appear in the control center (bug 1040193). Do we want to continue
showing it there as well?

I would prefer if the Ubuntu GNOME session were as close as possible to
upstream, meaning that it would be fine for me if UOA was not appearing
in the GNOME control center. However, this would need at least two
things to happen first:

- If built with UOA support (as it is in Ubuntu), Empathy currently
opens the UOA panel when asked to configure accounts; we should probably
change that to a run-time decision, maybe based on the contents of
XDG_CURRENT_DESKTOP.

- Ubuntu's Shotwell build is tightly integrated with UOA, and in order
to publish on Facebook, Flickr or Picasa you need to have a
corresponding account setup in UOA. We should fix this by submitting our
patches upstream, and rework them so that the decision to use UOA can
happen at runtime. Unfortunately this could take several days of work,
and I'm afraid I don't have this time... :-(

Tim (darkxst) wrote :

On 10/01/14 21:23, Alberto Mardegan wrote:
> On 01/10/2014 05:24 AM, Robert Ancell wrote:
>> It doesn't look easy to do this for gnome-control-center-signon since
>> the package contains a lot of common files. We might have to wait for
>> the other components to be ready, and upload the gnome-control-center-
>> signon at the same time we add unity-control-center to the seed. We can
>> make gnome-control-center signon depend the version of u-c-c that is
>> uploaded at that time.
> OK.
>
>> Also, I talked to the Ubuntu GNOME team about what they plan to do with
>> unity-control-center. They said that it was desirable to be able to
>> access the online accounts in GNOME for the apps that need it. Will
>> anything show in g-c-c once we move to u-c-c? Do you care about this
>> use-case as an upstream?
> I wonder whether by "Online Accounts" they meant GNOME Online Accounts
> (GOA) or Ubuntu Online Accounts (UOA). The former should indeed be
> visible in g-c-c without special support from our side; the latter is
> currently visible as well in GNOME, causing two "Online Accounts" applet
> to appear in the control center (bug 1040193). Do we want to continue
> showing it there as well?
No, we ship GOA by default, however we do have users that use UOA
 as well (its just not installed by default). there are definitely a sub-set of
apps that only work with UOA, sometimes this is due to Ubuntu patches
, in other cases its just lack of upstream support for those apps.
>
> I would prefer if the Ubuntu GNOME session were as close as possible to
> upstream, meaning that it would be fine for me if UOA was not appearing
> in the GNOME control center. However, this would need at least two
> things to happen first:
Me too, but we can't just rip out the Ubuntu features that have been there
forever, causing regressions and screaming users!
>
> - If built with UOA support (as it is in Ubuntu), Empathy currently
> opens the UOA panel when asked to configure accounts; we should probably
> change that to a run-time decision, maybe based on the contents of
> XDG_CURRENT_DESKTOP.
I filed a patch upsteam for that, but it was never merged.
>
> - Ubuntu's Shotwell build is tightly integrated with UOA, and in order
> to publish on Facebook, Flickr or Picasa you need to have a
> corresponding account setup in UOA. We should fix this by submitting our
> patches upstream, and rework them so that the decision to use UOA can
> happen at runtime. Unfortunately this could take several days of work,
> and I'm afraid I don't have this time... :-(
>

Alberto Mardegan (mardy) wrote :

On 01/10/2014 01:47 PM, Tim wrote:
> No, we ship GOA by default, however we do have users that use UOA
> as well (its just not installed by default). there are definitely a sub-set of
> apps that only work with UOA, sometimes this is due to Ubuntu patches
> , in other cases its just lack of upstream support for those apps.

Right. So, the gnome-control-center-signon source package which provides
the UOA applet allows building the UOA applet as a standalone
application. Maybe we should package the standalone app in a separate
package, and make it available to GNOME users? In this way, they could
access UOA without having to install the unity-control-center.
Would this address your concerns?

[...]
>> - If built with UOA support (as it is in Ubuntu), Empathy currently
>> opens the UOA panel when asked to configure accounts; we should probably
>> change that to a run-time decision, maybe based on the contents of
>> XDG_CURRENT_DESKTOP.
> I filed a patch upsteam for that, but it was never merged.

Found it: https://bugzilla.gnome.org/show_bug.cgi?id=701903

Changed in deja-dup (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eog - 3.10.2-0ubuntu2

---------------
eog (3.10.2-0ubuntu2) trusty; urgency=medium

  * debian/patches/03_unity_control_center.patch:
    - Use Unity control center in Unity (LP: #1257505)
 -- Robert Ancell <email address hidden> Wed, 15 Jan 2014 14:48:07 +1300

Changed in eog (Ubuntu):
status: In Progress → Fix Released
Changed in gthumb:
importance: Unknown → Wishlist
status: Unknown → New
Changed in nautilus:
importance: Unknown → Wishlist
status: Unknown → New
Changed in eog:
importance: Unknown → Wishlist
status: Unknown → New
Changed in gnome-media:
importance: Unknown → Wishlist
status: Unknown → New
Changed in system-config-printer (Ubuntu):
importance: Undecided → Medium
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-color-manager - 3.8.3-1ubuntu1

---------------
gnome-color-manager (3.8.3-1ubuntu1) trusty; urgency=low

  * debian/patches/01_unity_control_center.patch:
    - Use Unity Control Center in Unity (LP: #1257505)
 -- Robert Ancell <email address hidden> Wed, 15 Jan 2014 16:15:06 +1300

Changed in gnome-color-manager (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package system-config-printer - 1.4.2+20130920-0ubuntu4

---------------
system-config-printer (1.4.2+20130920-0ubuntu4) trusty; urgency=low

  * debian/patches/05_menu_entries.patch:
    - Show in both GNOME control center and Unity control center (LP: #1257505)
 -- Robert Ancell <email address hidden> Wed, 15 Jan 2014 16:59:34 +1300

Changed in system-config-printer (Ubuntu):
status: In Progress → Fix Released
Changed in gnome-color-manager:
importance: Unknown → Wishlist
status: Unknown → New
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package language-selector - 0.119

---------------
language-selector (0.119) trusty; urgency=medium

  * data/language-selector.desktop.in:
    - Show in both unity-control-center and gnome-control-center (LP: #1257505)
 -- Robert Ancell <email address hidden> Wed, 15 Jan 2014 15:07:58 +1300

Changed in language-selector (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.8.2-0ubuntu8

---------------
nautilus (1:3.8.2-0ubuntu8) trusty; urgency=medium

  * debian/patches/20_unity_control_center.patch:
    - Fix uninitialized variable
 -- Robert Ancell <email address hidden> Wed, 15 Jan 2014 15:58:05 +1300

Changed in nautilus (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-properties - 0.92.32

---------------
software-properties (0.92.32) trusty; urgency=low

  * data/software-properties-gtk.desktop.in:
    - Show in both GNOME control center and Unity control center (LP: #1257505)
 -- Robert Ancell <email address hidden> Wed, 15 Jan 2014 16:44:57 +1300

Changed in software-properties (Ubuntu):
status: In Progress → Fix Released
Changed in gnome-color-manager:
status: New → Incomplete
Changed in nautilus:
status: New → Fix Released
Changed in gthumb:
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gthumb - 3:3.2.6-1ubuntu2

---------------
gthumb (3:3.2.6-1ubuntu2) trusty; urgency=medium

  * No-change rebuild for libwebp transition
 -- Iain Lane <email address hidden> Mon, 20 Jan 2014 12:18:09 +0000

Changed in gthumb (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-bluetooth - 0.0.6+14.04.20140124-0ubuntu1

---------------
indicator-bluetooth (0.0.6+14.04.20140124-0ubuntu1) trusty; urgency=low

  [ Charles Kerr ]
  * Gets us a little closer to the spec in two ways: 1. Indicator
    Visibility On the desktop, the indicator's header icon is visible
    whenever a default adapter is available (whether the adapter is
    powered or not) and the user's preference settings call for a
    visible Bluetooth indicator. On the phone, the indicator's header
    icon is visible whenever a default adapter is available *and* the
    adapter is powered. 2. Header Icon If Bluetooth is off, the header
    icon now uses the "bluetooth-disabled" icon. If Bluetooth is on, it
    now uses the "bluetooth-active" icon. If Bluetooth is on and has a
    connected device, it now uses the "bluetooth-paired" icon. (LP:
    #1126108)
  * Switching DBus service to an Upstart Job.

  [ Robert Ancell ]
  * Use unity-control-center if it is available. (LP: #1257505)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 79
 -- Ubuntu daily release <email address hidden> Fri, 24 Jan 2014 10:59:56 +0000

Changed in indicator-bluetooth (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-datetime - 13.10.0+14.04.20140124-0ubuntu1

---------------
indicator-datetime (13.10.0+14.04.20140124-0ubuntu1) trusty; urgency=low

  [ Robert Ancell ]
  * Support both gnome-control-center and unity-control-center. (LP:
    #1257505)
  * Run the unity-control-center panel under Unity. Rename the unity
    panel to just "datetime".

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 294
 -- Ubuntu daily release <email address hidden> Fri, 24 Jan 2014 11:00:08 +0000

Changed in indicator-datetime (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-sound - 12.10.2+14.04.20140124-0ubuntu1

---------------
indicator-sound (12.10.2+14.04.20140124-0ubuntu1) trusty; urgency=low

  [ Robert Ancell ]
  * Use unity-control-center if it is available. (LP: #1257505)

  [ Ted Gould ]
  * Own the server capabilities so we clean it up.

  [ Lars Uebernickel ]
  * Don't write 'interested-media-players' on startup
    IndicatorSound.Service read that gsettings key and inserted the
    players desktop ids into a MediaPlayerList, which emits "player-
    added" every time a player is added. This patch makes the service
    keep track of whether players are added because it is syncing the
    key or when a player appeared on the bus. .

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 408
 -- Ubuntu daily release <email address hidden> Fri, 24 Jan 2014 11:00:18 +0000

Changed in indicator-sound (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-power - 12.10.6+14.04.20140124-0ubuntu1

---------------
indicator-power (12.10.6+14.04.20140124-0ubuntu1) trusty; urgency=low

  [ Robert Ancell ]
  * Use unity-control-center if it is available. (LP: #1257505)

  [ Simon Steinbeiß ]
  * Run xfce-powermanager-settings when in an Xubuntu session.

  [ Lars Uebernickel ]
  * gcov.m4: add 1.10 to the lcov version list.
  * Run xfce-powermanager-settings when in an Xubuntu session.

  [ Calum Lind ]
  * From bug 1255655: "focus[es] the correct tab upon opening gnome-
    power-statistics when clicking the indicator battery.". (LP:
    #1255655)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 222
 -- Ubuntu daily release <email address hidden> Fri, 24 Jan 2014 10:59:48 +0000

Changed in indicator-power (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-session - 12.10.5+14.04.20140124-0ubuntu1

---------------
indicator-session (12.10.5+14.04.20140124-0ubuntu1) trusty; urgency=low

  [ Robert Ancell ]
  * Recommend yelp, gnome-control-center and gnome-control-center-signon
    since we try and launch these applications.
  * Use username as label if the real name is empty or whitespace. (LP:
    #872908)
  * Use unity-control-center if it is available. (LP: #1257505)

  [ Sebastien Bacher ]
  * clean out the extra-sessions directory, it's a leftover.
  * drop unused cmake file, it refears to geary and doesn't seem useful
    there.

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 426
 -- Ubuntu daily release <email address hidden> Fri, 24 Jan 2014 11:02:01 +0000

Changed in indicator-session (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package activity-log-manager - 0.9.7-0ubuntu5

---------------
activity-log-manager (0.9.7-0ubuntu5) trusty; urgency=medium

  * debian/patches/04_unity_control_center.patch:
    - Support unity-control-center (LP: #1257505)
 -- Robert Ancell <email address hidden> Tue, 28 Jan 2014 11:37:11 +1300

Changed in activity-log-manager (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package landscape-client - 13.07.3-0ubuntu2

---------------
landscape-client (13.07.3-0ubuntu2) trusty; urgency=medium

  * debian/patches/unity-control-center.patch:
    - Show in both GNOME control center and Unity control center (LP: #1257505)
 -- Robert Ancell <email address hidden> Wed, 29 Jan 2014 10:44:27 +1300

Changed in landscape-client (Ubuntu):
status: In Progress → Fix Released
Changed in unity (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Robert Ancell (robert-ancell) wrote :
Changed in chromium-browser (Ubuntu):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-control-panel - 13.09-0ubuntu2

---------------
ubuntuone-control-panel (13.09-0ubuntu2) trusty; urgency=medium

  * debian/patches/unity-control-center.patch:
    - Show in both GNOME control center and Unity control center (LP: #1257505)
 -- Robert Ancell <email address hidden> Wed, 29 Jan 2014 10:35:09 +1300

Changed in ubuntuone-control-panel (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-media - 3.4.0-1ubuntu2

---------------
gnome-media (3.4.0-1ubuntu2) trusty; urgency=medium

  * debian/patches/04_unity_control_center.patch:
    - Use Unity control center in Unity (LP: #1257505)
  * debian/patches/04_grecord_uses_gcc.patch
    - Obsoleted by 04_unity_control_center.patch
 -- Robert Ancell <email address hidden> Wed, 15 Jan 2014 16:01:19 +1300

Changed in gnome-media (Ubuntu):
status: In Progress → Fix Released
tags: added: patch
Changed in empathy (Ubuntu):
status: Confirmed → In Progress
Changed in compiz (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Robert Ancell (robert-ancell) wrote :

Compiz and unity are linked since they install files into /usr/share/gnome-control-center/keybindings/. We read from /usr/share/unity-control-center/keybindings/. Other packages that install here are metacity and gnome-shell but not sure if that matters.

We need to get them to install keybindings into both and/or get u-c-c to read from the old location as a workaround.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package webaccounts-browser-extension - 0.5-0ubuntu2

---------------
webaccounts-browser-extension (0.5-0ubuntu2) trusty; urgency=medium

  * debian/control:
    - Work with just unity-control-center-signon installed (LP: #1257505)
 -- Robert Ancell <email address hidden> Wed, 29 Jan 2014 17:01:40 +1300

Changed in webaccounts-browser-extension (Ubuntu):
status: In Progress → Fix Released
Chad Miller (cmiller) on 2014-01-29
Changed in chromium-browser (Ubuntu):
assignee: nobody → Chad Miller (cmiller)
Changed in eog:
status: New → Fix Released
Changed in compiz (Ubuntu):
status: Triaged → Fix Released
Changed in unity (Ubuntu):
status: Triaged → Fix Committed
Changed in empathy:
importance: Unknown → Medium
status: Unknown → New
Changed in empathy:
status: New → Fix Released
Robert Ancell (robert-ancell) wrote :

I think gnome-control-center-signon is complete right? Please correct if not.

Changed in gnome-control-center-signon (Ubuntu):
status: In Progress → Fix Released
Alberto Mardegan (mardy) wrote :

Yep, gnome-control-center-signon seems to be fine.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package empathy - 3.8.6-0ubuntu5

---------------
empathy (3.8.6-0ubuntu5) trusty; urgency=medium

  * debian/patches/ucc_panel_name.patch:
  * debian/patches/43_quicklists.patch:
    - Launch new unity-control-center panel (LP: #1257505)
 -- Robert Ancell <email address hidden> Wed, 19 Feb 2014 19:23:27 +1300

Changed in empathy (Ubuntu):
status: In Progress → Fix Released
Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.