network : gnome-control-center crashed with SIGABRT in g_assertion_message

Bug #1209092 reported by jan2ary on 2013-08-07
76
This bug affects 12 people
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
Medium
Unassigned
Saucy
Undecided
Unassigned

Bug Description

[ Description ]

gnome-control-center network can crash when unknown rfkill types are encountered

[ Fix ]

Ignore instead of crashing in this case.

[ Test case ]

The problem arised after upgrade to 13.10.
To reproduce:
1. Click on System Settings
2. Gnome Control Center window appears
3. Click on Network under Hardware section
4. At this point Gnome Control Center window crashes.

[ Regression potential ]

Stops crashing but does nothing instead. Just check the bt panel still works.

[ … ]

ProblemType: Crash
DistroRelease: Ubuntu 13.10
Package: gnome-control-center 1:3.6.3-0ubuntu30
ProcVersionSignature: Ubuntu 3.10.0-6.17-generic 3.10.3
Uname: Linux 3.10.0-6-generic x86_64
ApportVersion: 2.12-0ubuntu3
Architecture: amd64
Date: Wed Aug 7 09:30:30 2013
ExecutablePath: /usr/bin/gnome-control-center
InstallationDate: Installed on 2010-03-26 (1229 days ago)
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta amd64 (20100318)
MarkForUpload: True
ProcCmdline: gnome-control-center
Signal: 6
SourcePackage: gnome-control-center
StacktraceTop:
 ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 g_assertion_message () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/control-center-1/panels/libnetwork.so
 ?? () from /usr/lib/x86_64-linux-gnu/control-center-1/panels/libnetwork.so
 ?? () from /usr/lib/x86_64-linux-gnu/control-center-1/panels/libnetwork.so
Title: [network]: gnome-control-center crashed with SIGABRT in g_assertion_message()
UpgradeStatus: Upgraded to saucy on 2013-08-07 (0 days ago)
UserGroups: adm admin cdrom dialout dip lpadmin plugdev sambashare
usr_lib_gnome-control-center:
 activity-log-manager 0.9.7-0ubuntu4
 deja-dup 27.3.1-0ubuntu1
 gnome-control-center-signon 0.1.7~+13.10.20130724.1-0ubuntu1
 gnome-control-center-unity 1.3daily13.06.19~13.04-0ubuntu1
 indicator-datetime 12.10.3+13.10.20130731-0ubuntu1

jan2ary (jan2ary) wrote :

StacktraceTop:
 _g_log_abort () at /build/buildd/glib2.0-2.37.3/./glib/gmessages.c:255
 g_assertion_message (domain=domain@entry=0x7fa5ef6df6e3 "network-cc-panel", file=file@entry=0x7fa5ef6e1fb8 "rfkill-glib.c", line=line@entry=83, func=func@entry=0x7fa5ef6e2098 <__PRETTY_FUNCTION__.12664> "type_to_string", message=0x7fa613a5d9e0 "code should not be reached", message@entry=0x0) at /build/buildd/glib2.0-2.37.3/./glib/gtestutils.c:2075
 type_to_string (type=<optimized out>) at rfkill-glib.c:83
 cc_rfkill_glib_open (rfkill=0x7fa616249720) at rfkill-glib.c:232
 network_add_shell_header_widgets_cb (user_data=<optimized out>) at cc-network-panel.c:1111

Changed in gnome-control-center (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
jan2ary (jan2ary) wrote :

Running from the terminal I'm getting

$ gnome-control-center
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 14: reading configurations from ~/.fonts.conf is deprecated.
**
network-cc-panel:ERROR:rfkill-glib.c:83:type_to_string: code should not be reached
Aborted (core dumped)
$

Googling shows only this bug https://bugzilla.redhat.com/show_bug.cgi?id=969784 wich seems to be fixed in May 2013.

information type: Private → Public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
jan2ary (jan2ary) wrote :

The bug is still here as for gnome-control-center version 3.6.3-0ubuntu41.

Still affecting me in Ubuntu GNOME 13.10.

jan2ary (jan2ary) wrote :

The bug is still here as for gnome-control-center version 3.6.3-0ubuntu44.

snoopt (snoopt) wrote :

It affects after upgrading to Ubuntu 13.10. Actually it makes much harder to control ubuntu. Are there any other neworkmanager gui?

Iain Lane (laney) on 2013-10-23
Changed in gnome-control-center (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Iain Lane (laney)
Iain Lane (laney) wrote :

Alright, I've taken the patch from upstream and I'm building a package now.

There's currently a gnome-control-center under testing for a stable update to 13.10 so I'd rather not clash with that. Once that clears through testing we can do another round to include this fix. Keep watching your emails for the call for testing when it comes.

Michael Still (mikal) wrote :

I am experiencing this problem as well. Any news on your testing?

I worked around the issue by removing the bluetooth package entirely.

//DD
On 30 Oct 2013 11:41, "Michael Still" <email address hidden> wrote:

> I am experiencing this problem as well. Any news on your testing?
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1229588).
> https://bugs.launchpad.net/bugs/1209092
>
> Title:
> network : gnome-control-center crashed with SIGABRT in
> g_assertion_message
>
> Status in “gnome-control-center” package in Ubuntu:
> In Progress
>
> Bug description:
> The problem arised after upgrade to 13.10.
> To reproduce:
> 1. Click on System Settings
> 2. Gnome Control Center window appears
> 3. Click on Network under Hardware section
> 4. At this point Gnome Control Center window crashes.
>
> Thanks.
>
> ProblemType: Crash
> DistroRelease: Ubuntu 13.10
> Package: gnome-control-center 1:3.6.3-0ubuntu30
> ProcVersionSignature: Ubuntu 3.10.0-6.17-generic 3.10.3
> Uname: Linux 3.10.0-6-generic x86_64
> ApportVersion: 2.12-0ubuntu3
> Architecture: amd64
> Date: Wed Aug 7 09:30:30 2013
> ExecutablePath: /usr/bin/gnome-control-center
> InstallationDate: Installed on 2010-03-26 (1229 days ago)
> InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta amd64 (20100318)
> MarkForUpload: True
> ProcCmdline: gnome-control-center
> Signal: 6
> SourcePackage: gnome-control-center
> StacktraceTop:
> ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
> g_assertion_message () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
> ?? () from
> /usr/lib/x86_64-linux-gnu/control-center-1/panels/libnetwork.so
> ?? () from
> /usr/lib/x86_64-linux-gnu/control-center-1/panels/libnetwork.so
> ?? () from
> /usr/lib/x86_64-linux-gnu/control-center-1/panels/libnetwork.so
> Title: [network]: gnome-control-center crashed with SIGABRT in
> g_assertion_message()
> UpgradeStatus: Upgraded to saucy on 2013-08-07 (0 days ago)
> UserGroups: adm admin cdrom dialout dip lpadmin plugdev sambashare
> usr_lib_gnome-control-center:
> activity-log-manager 0.9.7-0ubuntu4
> deja-dup 27.3.1-0ubuntu1
> gnome-control-center-signon 0.1.7~+13.10.20130724.1-0ubuntu1
> gnome-control-center-unity 1.3daily13.06.19~13.04-0ubuntu1
> indicator-datetime 12.10.3+13.10.20130731-0ubuntu1
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/gnome-control-center/+bug/1209092/+subscriptions
>

Iain Lane (laney) on 2013-10-31
description: updated
Iain Lane (laney) on 2013-10-31
Changed in gnome-control-center (Ubuntu Saucy):
status: New → In Progress
Changed in gnome-control-center (Ubuntu):
status: In Progress → Fix Committed
assignee: Iain Lane (laney) → nobody
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.6.3-0ubuntu46

---------------
gnome-control-center (1:3.6.3-0ubuntu46) trusty; urgency=low

  [ Iain Lane ]
  * 0001-rfkill-glib-Don-t-use-g_assert_not_reached-in-type_t.patch:
    Cherry-pick 90f49a4d5dd646b8fce10f61a9231db4973a907b from upstream.
    rfkill-glib: Don't use g_assert_not_reached in type_to_string. New kernel
    versions can add new RFKILL types, we should not crash here, just say that
    we don't know what the switch is. (LP: #1209092)

  [ Jian-Ding Chen (timchen119) ]
  * Add additional options to the power option system sleep settings menu.
    Add 20 minutes and 2 hours options to give the user more fine-grained
    controls. (LP: #1244065)

  [ William Hua ]
  * debian/patches/input-sources-text-entry.patch:
    - Next group and double modifier input-source switching (LP: #1218322)
 -- Iain Lane <email address hidden> Thu, 31 Oct 2013 00:48:04 +0000

Changed in gnome-control-center (Ubuntu):
status: Fix Committed → Fix Released

Hello jan2ary, or anyone else affected,

Accepted gnome-control-center into saucy-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/gnome-control-center/1:3.6.3-0ubuntu45.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-control-center (Ubuntu Saucy):
status: In Progress → Fix Committed
tags: added: verification-needed
jan2ary (jan2ary) wrote :

Version 3.6.3-0ubuntu45.1 works good, the fix is here!
Thanks Brian for the fix.

Miklos Juhasz (mjuhasz) on 2013-11-01
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.6.3-0ubuntu45.1

---------------
gnome-control-center (1:3.6.3-0ubuntu45.1) saucy; urgency=low

  [ Iain Lane ]
  * 0001-rfkill-glib-Don-t-use-g_assert_not_reached-in-type_t.patch:
    Cherry-pick 90f49a4d5dd646b8fce10f61a9231db4973a907b from upstream.
    rfkill-glib: Don't use g_assert_not_reached in type_to_string. New kernel
    versions can add new RFKILL types, we should not crash here, just say that
    we don't know what the switch is. (LP: #1209092)

  [ William Hua ]
  * debian/patches/input-sources-text-entry.patch:
    - Next group and double modifier input-source switching (LP: #1218322)
 -- Iain Lane <email address hidden> Thu, 31 Oct 2013 00:29:53 +0000

Changed in gnome-control-center (Ubuntu Saucy):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

I am having this problem under ubuntu 12.04, on a machine where the latest gnome-control-center for that release (1:3.4.2-0ubuntu0.13.1) is installed.
I would like to know if installing the later package 3.6.3-0ubuntu0.53 or similar is possible and if it would help.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.