Adding a printer crashes Gnome Control Center (System Settings)

Bug #1163674 reported by JaSauders on 2013-04-03
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
Medium
Unassigned

Bug Description

When trying to add a printer the entire Gnome Control Center (System Settings) menu crashes. I get as far as seeing what printers are available to install. Once I click add it crashes each and every time.

Something interesting I noticed is if I install system-config-printer-gnome, it works fine. If I remove system-config-printer-gnome (I actually did a remove --purge), the problem pops back up again. Seems as if that package is playing a key role with compatibility.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: gnome-control-center 1:3.6.3-0ubuntu18
ProcVersionSignature: Ubuntu 3.8.0-16.26-generic 3.8.5
Uname: Linux 3.8.0-16-generic x86_64
ApportVersion: 2.9.2-0ubuntu5
Architecture: amd64
Date: Wed Apr 3 00:01:57 2013
InstallationDate: Installed on 2013-04-01 (2 days ago)
InstallationMedia: Ubuntu-GNOME 13.04 "Raring Ringtail" - Alpha amd64 (20130331)
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-control-center
UpgradeStatus: No upgrade log present (probably fresh install)
usr_lib_gnome-control-center:
 deja-dup 26.0-0ubuntu1
 gnome-control-center-signon 0.1.5-0ubuntu1

Related branches

JaSauders (jasauders) wrote :
Tim Lunn (darkxst) wrote :

Seems we are missing a dependency on 'system-config-printer-gnome'. All the other flavours have that in their desktop meta package, we probably should too.

Henry E Wyatt Jr (hewjr100) wrote :

Same problem I am having. I was installing hplip-gui, which allowed me to run hp-setup and install printer. I should just install system-config-printer-gnome, as I do not need hplip-gui.

Henry

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
Jeremy Bicha (jbicha) on 2013-04-13
Changed in gnome-control-center (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.6.3-0ubuntu23

---------------
gnome-control-center (1:3.6.3-0ubuntu23) raring; urgency=low

  * debian/patches/git_no_glxinfo.patch:
    - Merged upstream fix for display of nvidia blob info (LP: #1168612)
 -- Tim Lunn <email address hidden> Mon, 15 Apr 2013 18:45:44 +1000

Changed in gnome-control-center (Ubuntu):
status: Triaged → Fix Released
Dmitry Shachnev (mitya57) wrote :

Adding system-config-printer-gnome is not a proper solution because:

- System-config-printer-gnome pulls in a lot of deprecated (and unmaintained) libraries like pygtk or python-gnomekeyring;
- Having it installed will just hide the crash, not fix it.

The control center should work fine without s-c-p installed (this is how upstream works really). It would be good if someone who can reproduce this bug generated a stack trace and reported a bug upstream.

Jeremy Bicha (jbicha) wrote :

Dmitry, gnome-control-center's Add Printer dialog depends on system-config-printer-gnome's dbus service. I was surprised at that too which is why we didn't depend or recommend on it sooner.

Dmitry Shachnev (mitya57) wrote :

The service is in -common actually: http://packages.ubuntu.com/raring/all/system-config-printer-common/filelist.

Also, if g-c-c really depends on that service, maybe we should add a dependency to g-c-c, not to the metapackage?

Jeremy Bicha (jbicha) wrote :

Seb wanted it to be a recommends (at least for now) so I added the explicit dependency in the ubuntu-gnome metapackage (which is also what ubuntu-desktop does).

https://launchpad.net/ubuntu/+source/gnome-control-center/1:3.6.3-0ubuntu22

Installing system-config-printer-common wasn't enough to prevent the crash and I didn't dig in more deeply to figure out why.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers