Cursor moves with "Disable touchpad while typing"

Bug #1159959 reported by Leandro on 2013-03-25
92
This bug affects 20 people
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
Low
Unassigned

Bug Description

When using the "Disable Touchpad While Typing", the cursor still moves, yet the the click is disabled.

I'm not sure if this is a bug or simply a desirable feature, though.

The fact that the cursor moves is probably wrong, as it keeps distracting the user, and probably the user
has the habit to put the cursor somewhere in the screen where it does not bother beforie typing.

Actually, ideally, the cursor shoud disapear when typind is performed. And only return to function if
the touchpad or the mouse are clearly moved (or touched). I still get many undesirable "clicks" when
typing with the touchpad in this mode.

I'm using Ubuntu 13.04, 64 bits.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
Margarita Manterola (marga-9) wrote :

This bug was already present at least in Precise, 12.04.

Margarita Manterola (marga-9) wrote :

I searched launchpad and found several related bugs, from different distributions. It seems this has been the case since at least karmic.

I think this is a bug, and several people have reported it over time, but apparently it's not important enough.

--
Regards,
Marga

CaptSaltyJack (csjubuntu) wrote :

Is this fixed in 13.10?

Behnam Hatami (behnamhatami) wrote :

No,
I tried 13.10 64-bit and there was the same issue.

Sebastien Bacher (seb128) wrote :

Thank you for your bug report, the behaviour you describe is wanted: having the cursor hidding and showing creates changes on screen that can be confusing, it's also annoying for users because you have a second where you couldn''t use the trackpad ... with the current way you can start moving your cursor (it usually takes over a second to move to the target by what time the click is working)

Changed in gnome-control-center (Ubuntu):
importance: Undecided → Low

Sebastien,
The problem isn't just the cursor being showed or not. Actually you can "click" while typing. This is an unwanted behavior because you can (and in my case this always happens) click something unintentionally while typing a text.

Sebastien Bacher (seb128) wrote :

@Charlesschaefer: that's not what that bug is about, see the title "Cursor moves with...", click still being active is another issue and would be a syndaemon bug (does calling "syncdaemon -i 15.0 -K -R" for example works?)

Sebastien,
take a look at the end of the bug report. Leandro said:
" I still get many undesirable "clicks" when typing with the touchpad in this mode."

The same problem occurs since 12.04 with me.

But I agree this would be in another bug report.

Daniele Dellafiore (ildella) wrote :

same problema again on 13.04 and now 13.10 on XPS 13

jnns (jnns) wrote :

Problem also exhibited with Lenovo Thinkpad X230 w/ Ubuntu 13.10 64bit.

Atasa Rossios (atasa-rossios) wrote :

hey guys i really hope this is going to be fixed coz i had a big trouble when accidentally the cursor jumped somewhere else and i hist sent message quickly.
It is really nasty bug and very very serious.
I really hope they fix this ...
Ubuntu 13.10 on Inspiron 13Z 5323

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers