gnome-settings-daemon dies when C-A-DEL used as a shortcut to logout

Bug #11160 reported by Daniel Silverstone on 2004-12-13
48
Affects Status Importance Assigned to Milestone
gnome-control-center
Expired
Wishlist
gnome-control-center (Ubuntu)
Wishlist
Ubuntu Desktop Bugs

Bug Description

To reproduce:

Set your keyboard shortcut for "Log out" to Ctrl+Alt+Del

Press Ctrl+Alt+Del

witness the glory of your gnome-settings-daemon dying and respawning

http://bugzilla.gnome.org/show_bug.cgi?id=130634: http://bugzilla.gnome.org/show_bug.cgi?id=130634

Sebastien Bacher (seb128) wrote :

upstream bug about ctrl-alt-del:
http://bugzilla.gnome.org/show_bug.cgi?id=130634

Sebastien Bacher (seb128) wrote :

*** Bug 19686 has been marked as a duplicate of this bug. ***

Jon Leighton (jonleighton) wrote :

I don't agree that bug 19686 is a dupe of this one. Bug 19686 proposes adding
Ctrl+Alt+Delete as a default keybinding, whereas this bug addresses a technical
problem with doing so. Both are to be resolved upstream though, it seems.

Incidentally, I did not encounter this problem using the method I described in
bug 19686 -- did you use a different method? (I don't understand your instructions)

Sebastien Bacher (seb128) wrote :

both bugs are "ctrl-alt-del" should open a dialog to logout (your shortcut
change is a hack to do that)

Lionel Dricot (ploum) wrote :

Is this bug still relevant ?

William Grant (wgrant) wrote :

This appears to be fixed in Dapper.

Changed in control-center:
status: Unconfirmed → Fix Released
Changed in control-center:
status: Unconfirmed → Confirmed
Changed in control-center:
status: Confirmed → Needs Info
Changed in control-center:
assignee: seb128 → desktop-bugs
importance: Medium → Wishlist
status: Fix Released → Triaged
Siegfried Gevatter (rainct) wrote :

(Setting back to Fix Released, the last duplicate wasn't correct.)

Changed in gnome-control-center:
status: Triaged → Fix Released
Changed in gnome-control-center:
status: Incomplete → Invalid
Przemek K. (azrael) wrote :

Also see Bug #234884

Changed in gnome-control-center:
importance: Unknown → Wishlist
status: Invalid → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.