gnome-control-center does not remove system-wide proxy settings from /etc/environment when switch from manual to automatic mode.

Bug #1100587 reported by Alec Warner on 2013-01-17
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
Low
Unassigned
Precise
Low
Unassigned
Quantal
Low
Unassigned

Bug Description

* Impact: the environment proxy settings might end up being incorrectly set

* Test Case:

Go into system settings => network => Network Proxy => Method => Manual
Set a proxy (I chose 'goats' for the http bit, and 8080 as the port.

Click on 'apply system wide'.

Note that /etc/environment contains 'http_proxy="http://goats:8080"'

Then go into system settings => network => Network Proxy => Method => Automatic
Set my automatic proxy config URL to my companies wpad.dat.
Click on 'apply system wide'

Note that /etc/environment still contains 'http_proxy="http://goats:8080".
This ends up hosing specific applications that read the proxy from the environment, instead of from wherever GNOME stores this data.

* Regression potential: limited, check that the proxy settings are correctly set and used in both manual and automatic modes

Ubuntu 12.04.1 LTS Precise

gnome-control-center-1:3.4.2-0ubuntu0.8 (from precise-updates)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
Margarita Manterola (marga-9) wrote :

Hi,

The fix is simple, it just implies adding G_DESKTOP_PROXY_MODE_AUTO to the case block where the system proxy is reset. This leads to the same result than Manual->None->Auto leads.

I'm attaching the debdiff for the precise version, will check the raring version next, and if the bug is still present and still the same, create a fix for that one as well.

The attachment "Debdiff containing the fix for the precise version of gnome-control-center" of this bug report has been identified as being a patch in the form of a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Margarita Manterola (marga-9) wrote :

The code in raring is completely different, so even if I don't have a raring box to test it right now, I'm assuming it's unaffected by this bug. The code in quantal, however, is basically the same as in precise. I have prepared a patch based on the quantal version, debdiff attached.

Sebastien Bacher (seb128) wrote :

Thanks Marga, I've sponsored the updates for both precise and quantal

Changed in gnome-control-center (Ubuntu Precise):
status: New → Fix Committed
Changed in gnome-control-center (Ubuntu Quantal):
status: New → Fix Committed
Changed in gnome-control-center (Ubuntu):
importance: Undecided → High
Changed in gnome-control-center (Ubuntu Precise):
importance: Undecided → High
Changed in gnome-control-center (Ubuntu):
importance: High → Low
Changed in gnome-control-center (Ubuntu Precise):
importance: High → Low
Changed in gnome-control-center (Ubuntu Quantal):
importance: Undecided → Low
description: updated
Sebastien Bacher (seb128) wrote :

setting invalid for raring, indeed the code got mostly rewritting in 3.6 and that issue doesn't apply to the current version

Changed in gnome-control-center (Ubuntu):
status: Confirmed → Invalid

Hello Alec, or anyone else affected,

Accepted gnome-control-center into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/gnome-control-center/1:3.4.2-0ubuntu19.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Alec Warner (antarus) wrote :

Fails to verify here. If I select 'Automated' and enter a configuration URL, and then click on 'Apply System Wide' I do not even get a polkit prompt for 'admin' access.

Certainly the http_proxy bit in /etc/environment remains.

Margarita Manterola (marga-9) wrote :

Indeed, the uploaded version doesn't include my change. The uploaded version has the following changelog:

gnome-control-center (1:3.4.2-0ubuntu0.9) precise; urgency=low

  * debian/UbuntuLogo.png: logo was saying 12.04.1 LTS, go back to just
    use "12.04 LTS" to avoid having to keep updating it (lp: #1116801)

 -- Sebastien Bacher <email address hidden> Thu, 07 Feb 2013 17:57:58 +0100

Whereas my patch had the following changelog:

gnome-control-center (1:3.4.2-0ubuntu0.9) precise; urgency=low

  * Added debian/patches/remove-manual-proxy-in-auto.patch to also remove
    the manual proxy setting when in AUTO mode. (LP: #1100587)

 -- Margarita Manterola <email address hidden> Tue, 05 Feb 2013 11:55:06 +0100

I guess the other change was already in the pipeline, but the corresponding fix has not gone in.

Margarita Manterola (marga-9) wrote :

Sorry. My previous message was about the precise package, which doesn't yet include the fix, but that was not what the automated message was asking. I suspect Alec made the same mistake.

The quantal package includes the fix. I had wiped my quantal installation, so I'm re-installing it now to check if the fix verifies in quantal, I expect it will.

Sebastien Bacher (seb128) wrote :

the fix accepted was for quantal, the one for precise is still in the queue (in fact it got reuploaded recently to include another fix):
http://launchpadlibrarian.net/131131330/gnome-control-center_3.4.2-0ubuntu0.10_source.changes

The precise review might take a bit longer since things are currently frozen for 12.04.2 though

Margarita Manterola (marga-9) wrote :

Yes, the package in quantal fixes the issue. Precise is still pending.

Dave Walker (davewalker) wrote :

Hello Alec, or anyone else affected,

Accepted gnome-control-center into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/gnome-control-center/1:3.4.2-0ubuntu0.10 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Sebastien Bacher (seb128) wrote :

Could a SRU team member reject the precise upload? It creates https://bugs.launchpad.net/ubuntu/+source/gnome-control-center/+bug/1136216

The sound capplet fails to load with those errors:
/usr/lib/control-center-1/panels/libsoundnua.so: undefined symbol: gvc_mixer_ui_device_is_output

Not sure why that just started to happening in that version, there is nothing in the diff that should makes a difference on the symbols/linking and diffing the build logs from 0.9 and 0.10 there is this new line

"dpkg-shlibdeps: warning: debian/gnome-control-center/usr/lib/control-center-1/panels/libsoundnua.so contains an unresolvable reference to symbol gvc_mixer_ui_device_is_output: it's probably a plugin."

but nothing in the linker flags changed...

Sebastien Bacher (seb128) wrote :

ok, I found the issue, the diff is buggy, extra lines got added to a new file but the offset of the patch didn't get update which did lead to have the end of file truncated... note for next time: don't try to be too smart about reducing the diff for easier review

I've uploaded a 0ubuntu11 that fixes the bug

Colin Watson (cjwatson) wrote :

Hello Alec, or anyone else affected,

Accepted gnome-control-center into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/gnome-control-center/1:3.4.2-0ubuntu0.11 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Margarita Manterola (marga-9) wrote :

Hi,

I can verify that the provided package fixes the issue. HOWEVER, there seems to be no gnome-control-center-data package, which is a necessary dependency and causes problems when installing.

I checked the build logs, but I couldn't find anything there. Also, the missing package WAS built for i386, but not for the other arches.

I forced dpkg installation and the package seems to work, but the missing dependency is a serious issue.

Margarita Manterola (marga-9) wrote :

Ok, my mistake, I found the -data package, although it was not in the build results. I guess there's something weird going on with those build results, since the package is actually there, and this is probably related with it being an _all package.

I have re-verified and the uploaded package fixes the issue.

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.4.2-0ubuntu0.11

---------------
gnome-control-center (1:3.4.2-0ubuntu0.11) precise; urgency=low

  * Added debian/patches/remove-manual-proxy-in-auto.patch to also remove
    the manual proxy setting when in AUTO mode. (LP: #1100587)

  [ David Henningsson ]
  * debian/patches/96_sound_nua_panel.patch:
    - don't allow to turn bluetooth devices off, or they are dropped from
      the devices list with is no way to turn them back on (lp: #1071561)
 -- Margarita Manterola <email address hidden> Tue, 05 Feb 2013 11:55:06 +0100

Changed in gnome-control-center (Ubuntu Precise):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.4.2-0ubuntu19.1

---------------
gnome-control-center (1:3.4.2-0ubuntu19.1) quantal; urgency=low

  * Added debian/patches/remove-manual-proxy-in-auto.patch to also remove
    the manual proxy setting when in AUTO mode. (LP: #1100587)
 -- Margarita Manterola <email address hidden> Tue, 05 Feb 2013 12:27:20 +0100

Changed in gnome-control-center (Ubuntu Quantal):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers