gnome control center crash when try to open sound settings menu

Bug #1136216 reported by Luigi Agosto on 2013-02-28
44
This bug affects 10 people
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
High
Unassigned
Precise
High
Unassigned

Bug Description

after the last upgrde I tryed to open the sound settings menu from the sound indicator but the gnome control center was opened instead of the sound settings menu.
I have tryed to close it but dont close.
If I try to kill the control center another istance will be open.
I have restart the computer and i have opened the control center from the terminal, and then I have select sound but dont work also. this is what the terminal say:
/usr/lib/control-center-1/panels/libsoundnua.so: undefined symbol: gvc_mixer_ui_device_is_output
Failed to load module: /usr/lib/control-center-1/panels/libsoundnua.so
/usr/lib/control-center-1/panels/libsoundnua.so: undefined symbol: gvc_mixer_ui_device_is_output
Failed to load module: /usr/lib/control-center-1/panels/libsoundnua.so
/usr/lib/control-center-1/panels/libsoundnua.so: undefined symbol: gvc_mixer_ui_device_is_output
Failed to load module: /usr/lib/control-center-1/panels/libsoundnua.so
/usr/lib/control-center-1/panels/libsoundnua.so: undefined symbol: gvc_mixer_ui_device_is_output
Failed to load module: /usr/lib/control-center-1/panels/libsoundnua.so
/usr/lib/control-center-1/panels/libsoundnua.so: undefined symbol: gvc_mixer_ui_device_is_output
Failed to load module: /usr/lib/control-center-1/panels/libsoundnua.so
/usr/lib/control-center-1/panels/libsoundnua.so: undefined symbol: gvc_mixer_ui_device_is_output
Failed to load module: /usr/lib/control-center-1/panels/libsoundnua.so
/usr/lib/control-center-1/panels/libsoundnua.so: undefined symbol: gvc_mixer_ui_device_is_output

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: gnome-control-center 1:3.4.2-0ubuntu0.10
ProcVersionSignature: Ubuntu 3.2.0-38.61-generic 3.2.37
Uname: Linux 3.2.0-38-generic x86_64
ApportVersion: 2.0.1-0ubuntu17.1
Architecture: amd64
Date: Thu Feb 28 19:54:58 2013
InstallationMedia: Ubuntu 12.04.1 LTS "Precise Pangolin" - Release amd64 (20120823.1)
MarkForUpload: True
ProcEnviron:
 PATH=(custom, no user)
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-control-center
UpgradeStatus: No upgrade log present (probably fresh install)
usr_lib_gnome-control-center:
 activity-log-manager-control-center 0.9.4-0ubuntu3.2
 deja-dup 22.0-0ubuntu3
 gnome-bluetooth 3.2.2-0ubuntu5
 indicator-datetime 0.3.94-0ubuntu2

Luigi Agosto (luigi-agosto) wrote :
no longer affects: gnome-control-center
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

thank you for your bug report, can you run "ldd /usr/lib/control-center-1/panels/libsoundnua.so" and add those infos to the bug?

Changed in gnome-control-center (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
Luigi Agosto (luigi-agosto) wrote :
Changed in gnome-control-center (Ubuntu):
status: Incomplete → New
Nicola Jelmorini (jelmorini) wrote :

Same here.
As a workaround I have forced the previous version, 3.4.2-0ubuntu0.09 with Synaptic.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
Ove Risberg (ove-risberg) wrote :

I can confirm that installing gnome-control-center verion 3.4.2-0ubuntu0.9 solves the problem.

Sebastien Bacher (seb128) wrote :

Thanks for the report, seems like an issue with the precise-proposed update:
https://launchpad.net/ubuntu/+source/gnome-control-center/1:3.4.2-0ubuntu0.10

Not sure what's going on there, the diff:
https://launchpadlibrarian.net/131132089/gnome-control-center_1%3A3.4.2-0ubuntu0.9_1%3A3.4.2-0ubuntu0.10.diff.gz

Should lead to anything like that, in any case I'm asking for the update to be rejected

Changed in gnome-control-center (Ubuntu):
importance: Low → High
Changed in gnome-control-center (Ubuntu Precise):
importance: Undecided → High
status: New → Confirmed
Changed in gnome-control-center (Ubuntu):
status: Confirmed → Invalid
kondor (3-reg) wrote :

nm -D -r /usr/lib/control-center-1/panels/libsoundnua.so | grep gvc_mixer_ui_device_is_output

       U gvc_mixer_ui_device_is_output

wrong library linking?

Sebastien Bacher (seb128) wrote :

no, buggy patch update, the diff headers didn't get updated which leaded to truncate the end of the new file, which is where the gvc_mixer_ui_device_is_output() function is defined... I uploaded a 0ubuntu11 which fixes the issue

kondor (3-reg) wrote :

Works again! Thanks a lot.

Luigi Agosto (luigi-agosto) wrote :

I have upgrade just now and I can confirm that works again also here! thank you

Simon Vass (svass) wrote :

Upgrade to 0ubuntu11 fixes it for me also.

Ove Risberg (ove-risberg) wrote :

I can also confirm that 0ubuntu11 solves the problem... thanks for a quick solution to the problem.

Changed in gnome-control-center (Ubuntu Precise):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers