[background]: gnome-control-center crashed with signal 5 in g_settings_set_value()

Bug #1058936 reported by Dan Head
70
This bug affects 8 people
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
Medium
Unassigned

Bug Description

Occurs every time I try and change the theme to "High Contrast". Fresh install of 12.10 beta 2.

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: gnome-control-center 1:3.4.2-0ubuntu16
ProcVersionSignature: Ubuntu 3.5.0-15.23-generic 3.5.4
Uname: Linux 3.5.0-15-generic x86_64
ApportVersion: 2.5.3-0ubuntu1
Architecture: amd64
Date: Sun Sep 30 08:57:22 2012
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/gnome-control-center
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Beta amd64 (20120926)
ProcCmdline: gnome-control-center background
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
Signal: 5
SourcePackage: gnome-control-center
StacktraceTop:
 ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
 g_settings_set_value () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
 ?? () from /usr/lib/control-center-1/panels/libbackground.so
 g_closure_invoke () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: [background]: gnome-control-center crashed with signal 5 in g_settings_set_value()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
usr_lib_gnome-control-center:
 activity-log-manager-control-center 0.9.4-0ubuntu4
 deja-dup 24.0-0ubuntu1
 gnome-control-center-signon 0.0.17-0ubuntu1
 indicator-datetime 12.10.1-0ubuntu1

Revision history for this message
Dan Head (danhead) wrote :
Revision history for this message
Apport retracing service (apport) wrote :

StacktraceTop:
 g_settings_schema_get_value (schema=schema@entry=0x7f51fcf14640, key=key@entry=0x7f51d6f928e9 "ubuntu-overlay-scrollbars") at /build/buildd/glib2.0-2.34.0/./gio/gsettingsschema.c:640
 g_settings_schema_key_init (key=key@entry=0x7fffa3bee740, schema=0x7f51fcf14640, name=name@entry=0x7f51d6f928e9 "ubuntu-overlay-scrollbars") at /build/buildd/glib2.0-2.34.0/./gio/gsettingsschema.c:751
 g_settings_set_value (settings=0x7f51fd07a5e0, key=key@entry=0x7f51d6f928e9 "ubuntu-overlay-scrollbars", value=0x7f51fd2fad00) at /build/buildd/glib2.0-2.34.0/./gio/gsettings.c:1350
 g_settings_set_boolean (settings=<optimized out>, key=key@entry=0x7f51d6f928e9 "ubuntu-overlay-scrollbars", value=value@entry=0) at /build/buildd/glib2.0-2.34.0/./gio/gsettings.c:1815
 theme_selection_changed (combo=0x7f51fd02a410, self=0x7f51fcd605c0) at cc-background-panel.c:1287

Revision history for this message
Apport retracing service (apport) wrote : Stacktrace.txt
Revision history for this message
Apport retracing service (apport) wrote : StacktraceSource.txt
Revision history for this message
Apport retracing service (apport) wrote : ThreadStacktrace.txt
Changed in gnome-control-center (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
visibility: private → public
Changed in gnome-control-center (Ubuntu):
status: Confirmed → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.4.2-0ubuntu17

---------------
gnome-control-center (1:3.4.2-0ubuntu17) quantal; urgency=low

  * debian/patches/04_new_appearance_settings.patch,
    debian/patches/63_normal_scrollbar_in_a11y.patch:
    - Use the current overlay-scrollbar gsettings key (lp: #1058936)
  * debian/patches/97_unity_power_ui.patch:
    - hide indicator setting under GNOME sessions (lp: #1059369)

  [ Didier Roche ]
  * debian/patches/04_new_appearance_settings.patch:
    - remove an unity-2d key which was unconditionnaly set (even if schema not
      installed), provoking a warning.
 -- Sebastien Bacher <email address hidden> Tue, 02 Oct 2012 19:26:48 +0200

Changed in gnome-control-center (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers