Shouldn't animate the panel transition

Bug #1043697 reported by Sebastien Bacher on 2012-08-30
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Online Accounts: GNOME Control Center
High
David King
gnome-control-center-signon (Ubuntu)
High
Unassigned
Quantal
High
Unassigned

Bug Description

The ubuntu-online-account panel is doing animated transition in quantal, please drop that for release:

- it's the only panel doing it which looks inconsistant

(GNOME played with that for 3.6 and dropped it as well: http://git.gnome.org/browse/gnome-control-center/commit/?id=10c00125f4ce4f8fad1c11556f85bfd46c222289)

- it creates issue (cf bug #1040865 about scrollbars not working)

- it adds a depends on clutter to system-settings that we want to avoid where not needed since it creates issue on a range of hardware, the animation is not that important

Related branches

Changed in gnome-control-center-signon (Ubuntu):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-control-center-signon (Ubuntu):
status: New → Confirmed
description: updated
Alberto Mardegan (mardy) wrote :

I'm all in favour of reverting this. :-)
Calum, if you agree, would you please update the UI specs and remove the transition effect?

David King (amigadave) wrote :

I sent Calum an email describing the problems, so just waiting for his confirmation.

David King (amigadave) wrote :

Calum said it is fine to remove this for now, and he will look at it again for the next cycle (13.04).

Changed in online-accounts-gnome-control-center:
status: New → In Progress
assignee: nobody → David King (amigadave)
David King (amigadave) on 2012-08-31
Changed in online-accounts-gnome-control-center:
status: In Progress → Fix Committed
David King (amigadave) on 2012-09-06
Changed in online-accounts-gnome-control-center:
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center-signon - 0.0.14-0ubuntu1

---------------
gnome-control-center-signon (0.0.14-0ubuntu1) quantal; urgency=low

  * New upstream release.
    - removed the clutter based transition, it broke the scrollbar and was
      inconsistent with the other panels (LP: #1043697) (LP: #1043732)
    - Selection style in account type list is inconsistent with the rest
      of Ubuntu (LP: #1043724)
  * debian/control
    - removed clutter build depends
 -- Ken VanDine <email address hidden> Fri, 07 Sep 2012 16:46:35 -0400

Changed in gnome-control-center-signon (Ubuntu Quantal):
status: Confirmed → Fix Released
David King (amigadave) on 2012-09-10
Changed in online-accounts-gnome-control-center:
status: Fix Committed → Fix Released
milestone: none → 0.0.14
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers