can not disable bluetooth in applet menu

Bug #629452 reported by Tormod Volden on 2010-09-03
90
This bug affects 16 people
Affects Status Importance Assigned to Milestone
gnome-bluetooth (Ubuntu)
High
Chris Coulson
Maverick
High
Chris Coulson

Bug Description

Binary package hint: gnome-bluetooth

Similar to bug 436694 but that one is fixed and released so it might be another underlying issue. This Dell Latitude E6500 does not have a hardware bluetooth button, not even on the keyboard. So to turn off bluetooth and save power, I would need to use the "Turn off Bluetooth" action in the bluetooth menu in the indicator applet. The bluetooth USB device would then be unplugged as witnessed by dmesg output. This option is now gone from the menu.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: gnome-bluetooth 2.30.0-1ubuntu3
ProcVersionSignature: Ubuntu 2.6.35-19.28-generic-pae 2.6.35.3
Uname: Linux 2.6.35-19-generic-pae i686
Architecture: i386
Date: Fri Sep 3 13:41:38 2010
ExecutablePath: /usr/bin/bluetooth-properties
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Alpha i386 (20100822)
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: gnome-bluetooth

Tormod Volden (tormodvolden) wrote :
Ryan Hamilton (rthamilt) wrote :

Same here. Not sure if this is a 'bug' or a 'feature' at this point, but it is an extremely important option for me to have since the hardware switch I do have controls both the wireless and the bluetooth adapter together.

auxbuss (launchpad-auxbuss) wrote :

I guess you _could_ call it a feature. A bit like having a car with an engine that you can't ever switch off. Not a very useful feature. I have a rule that says that removing something is not a feature. A "design" choice, but not a feature.

I am in the same situation regarding a shared switch for wireless and bluetooth. I tried blueman, which is a very nice utility, but it crashes a few seconds after using it to deactivate bluetooth. However, I set-up an alias to restart bluetooth when I need it.

  alias startblue='sudo rfkill unblock bluetooth'

Maybe this will work for you.

Jeffrey Baker (jwbaker) wrote :

Let us hope this is a bug and not a design decision.

Changed in gnome-bluetooth (Ubuntu):
status: New → Confirmed
Changed in gnome-bluetooth (Ubuntu Maverick):
importance: Undecided → High
Changed in gnome-bluetooth (Ubuntu Maverick):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
Shiba (shiba89) wrote :

Same here. I have a hardware button for disabling bluetooth and wireless, but I would like to be able to turn only bluetooth off.

cacula (cacula) wrote :

Same here. In Lucid it was possible. Please re-enable. Thank you :-)

Karl Lattimer (karl-qdh) on 2010-09-20
Changed in gnome-bluetooth (Ubuntu Maverick):
assignee: Canonical Desktop Team (canonical-desktop-team) → Karl Lattimer (karl-qdh)
Didier Roche (didrocks) wrote :

thanks Karl, you may want to have a look at the fallback (by killing the service) to see if it still appears upstream.

Karl Lattimer (karl-qdh) on 2010-09-20
Changed in gnome-bluetooth (Ubuntu Maverick):
status: Confirmed → In Progress
Karl Lattimer (karl-qdh) wrote :

After much digging, I've discovered the reason for this is a buggy udev permission for /dev/rfkill which should be mode 0666 it's actually 0600, changing this in theory fixes the bug. although the original problems with visibility are present again.

Chris Coulson (chrisccoulson) wrote :

Thanks for discovering that. So, the udev rule for gnome-bluetooth is actually wrong, and /dev/rfkill doesn't get the ACL's it is supposed to

Changed in gnome-bluetooth (Ubuntu Maverick):
assignee: Karl Lattimer (karl-qdh) → Chris Coulson (chrisccoulson)
Chris Coulson (chrisccoulson) wrote :

Fix is uploaded for this now

Changed in gnome-bluetooth (Ubuntu Maverick):
assignee: Chris Coulson (chrisccoulson) → nobody
milestone: none → ubuntu-10.10
status: In Progress → Fix Committed
assignee: nobody → Chris Coulson (chrisccoulson)
Tormod Volden (tormodvolden) wrote :

Thanks, the updated udev rule makes it work again. However, /lib/udev/rules.d/70-acl.rules explicitly tells not to use TAG+="udev-acl" outside of this file...

Chris Coulson (chrisccoulson) wrote :

I think that's just because it's an internal implementation that's likely to change again in the future. However, the same was true also for ENV{ACL_MANAGE}

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-bluetooth - 2.31.90-0ubuntu2

---------------
gnome-bluetooth (2.31.90-0ubuntu2) maverick; urgency=low

  * Fix LP: #629452 - can not disable bluetooth in applet menu, because no
    ACL's were being set on /dev/rfkill. Fix this by setting
    TAGS+="udev-acl" on this device. Thanks to Karl Lattimer for the
    initial investigation
    - update debian/61-gnome-bluetooth-rfkill.rules
 -- Chris Coulson <email address hidden> Tue, 21 Sep 2010 14:28:06 +0100

Changed in gnome-bluetooth (Ubuntu Maverick):
status: Fix Committed → Fix Released
Torsten Krah (tkrah) wrote :

Don't know how to reopen this bug.
But i did have this option in maverick - but since a week its gone. The optional "disable bluetooth" is gone in the applet and i can't switch it off anymore.
Please reopen it as its there again.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers