gnome-bluetooth cannot use pin = 1234

Bug #551950 reported by KeithG on 2010-03-30
100
This bug affects 22 people
Affects Status Importance Assigned to Milestone
GNOME Bluetooth
Fix Released
Medium
gnome-bluetooth (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: gnome-bluetooth

I have a BT serial port with a pin of 1234. I cannot pair to this device with gnome-bluetooth. Every attempt results in gnome-bluetooth requiring a 6 digit random pin. I was able to pair when I uninstalled gnome-bluetooth and installed bluez-gnome. Bluez-gnome will actually send a 4 digit 1234 pin and connect. I am in the process of setting up the serial port in Ubuntu so that I can communicate with the device. My hope is that this will be fixed in Lucid so that I will not have to go through the text based setup of rfcomm for this device.

In addition, gnome-bluetooth is very reluctant to connect to the PANU served by my phone. It was set up and after a number of tries I was able to exchange PIN numbers and connect. Unfortunately, I was only able to connect to the PANU once. With bluez-gnome, it works all the time every time.

For what it is worth, the OBEX file connection to my Nokia has been very robust under either manager.

My BT dongle reports as this one:
Bus 005 Device 007: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)

Keith

For the pin problem, gnome-bluetooth has the possibly to use a fixed pin during the setup process.
Are you sure you didn't miss it?

For the other problem I don't know but avoid putting several problem in a bug report.

Changed in gnome-bluetooth (Ubuntu):
status: New → Incomplete
KeithG (grider-4) wrote :

Baptiste,

Yes, I did try this and was able to find it. If I selected fixed pin 1234, it accepts that then immediately shows me the 6 digit pin and tells me that it failed to connect. I have found the gnome-bluetooth package to be inconsistent with pairing and repairing. That is except with OBEX file transfer. That works very robustly and consistently with a nokia phone I have used.

I have had much better luck with bluez-gnome in getting to pair and set up reliably my PANU network and to re-pair when the device returns to the vicinity of the computer. I have a hunch that some things were broken with the addition of btusb and not all cases have been repaired.

Another thing that seems to be missing in both Bluez-gnome and gnome-bluetooth is the ability to set up a serial port. In Blueman, I was able to pair then immediately it set up /dev/rfcomm0 for me. I do not see any way of doing this in gnome-bluetooth. If I am missing it or if there is an update, I am willing to try.

The other thing is that I have not been able to pair with the second serial port on the bluetooth device with any package. Blueman allows the first one to be set up, but does not see the second one (probably as it does not advertise itself as SPP). I have been using this under XP for some time and it works fine. I would love to be able to use it under Linux.

Is there a web page describing some of the more esoteric aspects of gnome-bluetooth setup? I mean, if there is a way to query the device to get the info then edit some file to allow consistent operation, I am fine with that. any edits of the /etc/bluetooth files does not seem to do anything useful. I have not been able to find anything consistent on this. "sdpbrowse" does not seem to work, "hciconfig scan" does not see the serial port, either. In fact, it cannot even report back that it sees the BT radio on the device! I am happy and fine with using command line stuff to make this work, but that seems to be either lacking or has changed and I have not been able to find the documentation allowing me to make this connection.

If this really sounds like I have messed something up with all this trial, is there a simple way I can totally remove and reinstall the gnome-bluetooth package to ensure that I have all the files and setup correct?

Thanks!

Keith

fubarbundy (launchpad-mailtic) wrote :

The same issue with a Bluetooth barcode scanner which can only provide a pin to be confirmed by the host and not the other way around.

I select 'fixed pin', with 1234 (or a custom pin), and then most times gnome-bluetooth shows a 6-digit pin to be entered into the device anyway (impossible), followed very shortly by failure to connect.

Occasionally gnome-bluetooth won't show a pin to be confirmed, but fails very quickly anyway.

Changed in gnome-bluetooth (Ubuntu):
status: Incomplete → Confirmed
tz (thomas-mich) wrote :

Same thing. I select 1234 or enter it manually. I verify that the dialog has it by going back in. Instead of using 1234 it displays a random 6 digit pin. It did 1234 ONCE, but I don't know what I did and it isn't repeatable. The last 3 times it gave me the 6 digit pin.

tz (thomas-mich) wrote :

And it includes a stupid startup screen in the wizard with a long, boring, and irrelevant explanation of what is going to happen. You should move it to the screen with the devices or remove it entirely. Also, there is no way back from the wrong pin screen, just cancel. I should be able to get back to the device/pin option screen.

tz (thomas-mich) wrote :

It just worked, but I don't know if it is repeatable - Leave the device off. Go to the stupid "we are going to hold your hand and play nanny while you setup your bluetooth device" screen and hit next. Set the pin option to what is needed and hit ok. Turn the device on.

tz (thomas-mich) wrote :

Continued - turn the device on, wait for it to appear, then select it and click next.

Martin Reiche (grimsrud) wrote :

I can confirm the initial problem from KeithG and that the workaround from tz works for me.

Adi Roiban (adiroiban) wrote :

It looks like the preset pins does not work in gnome bluetooth manager.
I was trying to pair and use a bluetooth headset.

I was able to use it by installing blueman bug #480959

Still, it would be nice if this will work by default in Ubuntu.

I have the same problem in Ubuntu 10.04 and 10.10 beta

Soos Gergely (sogerc1) wrote :

For me tz's workaround does not work.
For a long time the wizard stays on the "connecting" page and then it says "Setting up 'My Phone' failed". And from that point it is a lost cause, there is nothing you can do to set up the device. The only thing that works is to kill blootoothd (started by udev I guess), unplug the BT radio and kill the applet then start it all over again by restarting the applet, reenabling bluetooth and plugging in the radio and then selecting the random pin. Pretty ridiculous.
I have an LG KP 501 Cookie cellphone so fortunately I can use a random pin I just did not want to destroy the pairing of my other computer (I share the same USB-to-BT radio between the two computers so as far as my phone is concerned they are the same device).

Soos Gergely (sogerc1) wrote :

I forgot to mention that I have ubuntu 10.10

Tony Mansson (tony-mansson) wrote :

Issue still present on 12.04.
"Same thing. I select 1234 or enter it manually. I verify that the dialog has it by going back in. Instead of using 1234 it displays a random 6 digit pin."

I am unable to pair with any of two GPS units due to this behaviour. It's 100% repeateble.

peterrus (petorrus) wrote :

13.04 using code 0000. confirmed

tags: added: raring
tags: added: saucy

Please, can anyone report this bug upstream? (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

Changed in gnome-bluetooth (Ubuntu):
importance: Undecided → Medium

Work around is to use command line tools, on 13.04 I used information on the following post. There where tons of reports of this bug with no solution other than editing code and rebuilding.

http://askubuntu.com/questions/187092/bluetooth-from-the-command-line-in-12-04

basically
bluez-simple-agent hci0 11:22:33:44:55:66

replace mac address with your own.
Will prompt for a PIN number.

KeithG (grider-4) wrote :

Still broken in 13.10. You can select special pin, but not continue to pair it. It is a shame this has been broken for so long and such a simple repair. My work around is to use bluetooth manager instead of gnome bluetooth.

Changed in gnome-bluetooth:
importance: Undecided → Unknown
status: New → Unknown
Changed in gnome-bluetooth (Ubuntu):
status: Confirmed → Triaged
Changed in gnome-bluetooth:
importance: Unknown → Medium
status: Unknown → Incomplete
Changed in gnome-bluetooth:
status: Incomplete → New
Changed in gnome-bluetooth:
status: New → Incomplete

Are you still experiencing this bug in any currently supported release?

<https://wiki.ubuntu.com/Releases>

Changed in gnome-bluetooth (Ubuntu):
status: Triaged → Incomplete
Nathan Nathan (naterion) wrote :

Freaking 4 years and this fundamental problem not fixed in 14.04. Another thing: in the Ubuntu Software Center the Bluetooth package contains most of the configuration applets for gnome that are totally unrelated to bluetooth like keyboard settings and desktop fonts, It says it in the description but I thought it was a mistake. That makes no freaking sense. Why the hell is it called bluetooth then?

KeithG (grider-4) wrote :

Sounds like a rewrite is in order. Blueman always works for me. Gnome Bluetooth is pretty well broken, IMO.

KeithG (grider-4) wrote :

Still a problem in 14.04LTS. Had to revert to using bluetooth manager, again. Works every time with bluetooth manager.

Why has this not been addressed?!?!?!?!

KeithG:
> Why has this not been addressed?!?!?!?!

Because we didn't know if this bug was still affecting any currently
supported Ubuntu release till you commented :)

Thank you.

tags: added: trusty
Changed in gnome-bluetooth (Ubuntu):
status: Incomplete → Triaged
Changed in gnome-bluetooth:
status: Incomplete → New
KeithG (grider-4) wrote :

I guess I don't fully get your response. This has been noted as a bug since saucy and has never had a patch or workaround associated with it (other than using bluman instead of gnome-bluetooth). Is there a better bug list for gnome specific problems than here?

Shock (mmiron) wrote :

I've tried tz's workaround and it doesn't work for me. I'm on Ubuntu 14.04 with up to date updates. Highly annoying as every time I want to connect to my phone I have to pair it again (or remember the random 6 digit pin code that gnome-bluetooth insists I use).

Luan Silas (luansilas-sr) wrote :

Same thing on mint 17.2 it takes the same package

Changed in gnome-bluetooth:
status: New → Incomplete

Please:

1. Subscribe to (https://bugzilla.gnome.org/show_bug.cgi?id=734855).
2. Comment there if you are still experiencing this bug.
3. Set this report status back to "confirmed".

Thank you.

Changed in gnome-bluetooth (Ubuntu):
status: Triaged → Incomplete
Eric Johnson (ejohnso49) wrote :

I can also report that in 16.04 LTS that selecting a fixed pin is not an option in the GUI. I originally posted a question on AskUbuntu and found my way here.

AskUbuntu Question: https://askubuntu.com/questions/947255/missing-pin-options-from-bluetooth-pairing-gui

I've attached an image I made combining the two screenshots. The top half is the buggy version missing the options under the Fixed PIN category and the bottom half is the complete and correct version. Unfortunately I do not know what version the good screenshot came from and I don't have enough rep on SO to post a comment to ask.

I will also join the bug report on gnome-bluetooth too.

In (https://bugzilla.gnome.org/show_bug.cgi?id=734855v), developers are asking if you are seing still this bug in the development version of GNOME.

Please subscribe to that bug report, and provide any future info there. Thank you.

Changed in gnome-bluetooth:
status: Incomplete → Expired
Changed in gnome-bluetooth:
status: Expired → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.