Ubuntu

The list of sources could not be read

Reported by Adrián Chaves Fernández on 2007-08-08
12
Affects Status Importance Assigned to Milestone
gnome-app-install (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: update-manager

Could not initialise the package information

An unresolvable problem occurred while initialising the package information.

Please report this bug against the 'update-manager' package and include the following error message:

Error: Opening the cache (E:Malformed line 2 in source list etc/apt/sources.list.d/-main.list (dist parse), E:The list of sources could not be read)

Sebastian Heinlein (glatzor) wrote :

have you edited the sources list file manually with an editor? which Ubuntu version do you use?

Changed in update-manager:
status: New → Incomplete

No, I haven't edited the sources list file.
I have just installed Ubuntu 7.04 on my computer.
Maybe it could help to know that I was looking for a solution at the Ubuntu-es forum, and I found a person with the same error that i had, and something in common with me: We both used the Galician language (Other language of Spain). Maybe the problem is relative to the translation.
(Sorry by my English)

Michael Vogt (mvo) wrote :

Could you please also attach your /etc/apt/sources.list file? And the output of:
$ lsb_relase -a
?

It seems that at least the code in g-a-i that adds repositories needs a closer inspection.

Changed in gnome-app-install:
status: Incomplete → Triaged

If I enter "lsb_relase -a" in the console, that's what appears:

gallaecio@cova:~$ lsb_relase -a
bash: lsb_relase: command not found

Thank's for help, and maybe you should know that if i change the language to spanish (for example), I can access to the "Software fonts" (translation from Galician, sorry if it's not the exact text).

I reported this bug a long time ago (or not so much time), and I don't remember exactly what was the problem. Is it that I can't open the window where I select the type of updates (basic, free software, multiverse, universe...)?

Henrik Nilsen Omma (henrik) wrote :

Gallaecio, The command provided by Michael was misspelled. It should be:

lsb_release -a

Oh! Sure! That's what appears:

gallaecio@cova:~$ lsb_release -a
Traceback (most recent call last):
  File "/usr/bin/lsb_release", line 282, in <module>
    main()
  File "/usr/bin/lsb_release", line 246, in main
    distinfo = get_distro_information()
  File "/usr/bin/lsb_release", line 209, in get_distro_information
    distinfo = guess_debian_release()
  File "/usr/bin/lsb_release", line 163, in guess_debian_release
    rinfo = guess_release_from_apt()
  File "/usr/bin/lsb_release", line 131, in guess_release_from_apt
    releases = parse_apt_policy()
  File "/usr/bin/lsb_release", line 125, in parse_apt_policy
    data.append( (priority, parse_policy_line(bits[1])) )
UnboundLocalError: local variable 'priority' referenced before assignment

Ubuntu sources.list generator at
 http://www.ubuntu-nl.org/source-o-matic/

With this generator you can create your own custom sources.list from various available sources. It takes only two simple steps.

Then, you have to edit the sources list file manually with an editor (e.g. gedit).

If you don't know what to do with a sources.list file, please read https://help.ubuntu.com/community/Repositories/CommandLine

Sorte ;-P

I think that it is a good solution (moitas grazas) and believe that since it is a question of a minor problem, we might give it solved already.
Thank you very much to all.
If the problem with the translation to the Galician persists in the following update (8, I suppose), I will take charge communicating it together with this precedent.
Again, thanks to all.

P.S: I wrote it with a translator, so excuse me by the probables mistakes.

Phillip Susi (psusi) wrote :

This package has been removed from Ubuntu. Closing all related bugs.

Changed in gnome-app-install (Ubuntu):
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers